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INTRODUCTION

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Introducing Authorware 6

Authorware 6 is the leading rich-media authoring tool for creating Web and 
online learning. Authorware integrates graphics, sound, animation, text, and 
video into compelling rich-media learning solutions. 

Authorware is optimized for building e-learning applications. The Authorware 
interface provides a fast and easy environment for creating interactive applications. 
Drag-and-drop icons support rapid application prototyping and development 
without the need for extensive scripting. The flowline provides an intuitive 
representation of the structure of large, highly branched learning applications.

Macromedia Authorware 6 extends the power of the visual interface in 
Authorware by adding the ability to easily synchronize media and events over 
time. The new Media Synchronization feature allows an author to display media 
or trigger any event based on media position in a sound or movie file. Authorware 
has always offered a powerful environment for creating applications driven by user 
interactions. Now, authors can easily coordinate media and events over time using 
a simple, drag-and-drop interface.  

Already capable of delivering applications on multiple platforms, Authorware 6 
streamlines the publishing process with new One-Button Publishing. One-Button 
Publishing integrates and automates all the steps in the process, making it easy 
and efficient. Once publish settings have been defined, an author can deliver an 
application to the Web and for CD with the click of a button. One-Button 
Publishing adds a host of new capabilities including pre-configured HTML 
templates, FTP of files to a server, automatic collection of support files and 
preview in a browser. For large applications involving multiple files, a batch 
publishing option is provided. Whether an author is publishing for CD or the 
Web, one-button publishing delivers dramatic efficiencies in packaging and 
deploying applications.
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Authorware 6 delivers a new level of support for learning and Web standards. 
Built-in functions and variables for data tracking comply with the AICC 
specification for Web-based CMI systems. Authorware tracking features allow 
authors to create e-learning content that integrates with standards-compliant 
learning management systems (LMS). A new metadata editor produces 
SCORM-compliant metadata for use with content repositories. Authorware 6 
also adds new and enhanced support for Web standards, including XML, MP3, 
ActiveX and a new, smaller Web player allowing developers to deliver powerful, 
Web-savvy applications.

Authorware 6 allows you to:

• Extend the expressiveness of e-learning content with new authoring 
capabilities, including the ability to direct events over time.

• Publish projects for the Web or CD-ROM quickly and with one-button ease.

• Deliver powerful e-learning applications that leverage learning and 
Web standards.

Authorware 6 is part of the eLearning studio group of integrated, open, and 
scalable learning tools and technologies. This system provides a complete 
e-learning solution, including the creation, delivery, and management of 
enterprise learning programs.

System requirements

Component Authoring Windows Playback

Processor Pentium with floating-point 
coprocessor

486DX/66 or SX with 
floating-point coprocessor

Memory 16MB minimum
24MB recommended

8MB minimum
12MB recommended

System 
software

Windows 95, Windows 98, 
Windows ME, Windows NT 4.0, 
and Windows NT 2000

Windows 3.1 or later
Windows NT 4.0 or later

Drive 25MB of free disk space and a 
CD-ROM drive

Not applicable
Introduction14



                      
Installing Authorware 6

To install Authorware 6:

1 Put the Authorware 6 CD into your CD-ROM drive.

2 Double-click the Setup icon. 

3 Follow the prompts to customize the installation and select file designations.

When installation is complete, be sure to read the Authorware 6 Read Me file. It 
contains late-breaking information.

If you’re new to Authorware
Authorware is a sophisticated tool that’s both powerful and easy to use. You’ll 
learn the basics quickly. Other things will take you more time to master. This 
checklist will help you find the resources you need to learn everything you need to 
know about using Authorware.

• Use the Macromedia Knowledge Objects.

Knowledge Objects have wizards that lead you through the steps of creating 
projects in Authorware. Launch Authorware, and then select a Knowledge 
Object from the New File dialog box. Drag the other Knowledge Objects you 
need from the Knowledge Objects window.

• Work through the hands-on tutorial.

The tutorial introduces the basics of using Authorware.

• Read Using Authorware 6.

The Authorware 6 manual is the ideal place to find the concepts behind 
Authorware. Don’t overlook the step-by-step tables that tell you where to look 
for information in Authorware Help. Read the chapter “What’s New in 
Authorware 6” on page 19 for new features that have been added to 
Authorware 6. Read Chapter 2, “Authoring Basics” on page 33 to get started.

• Use Authorware Help.

Online help is available directly in Authorware Help. Choose Help > 
Authorware Help. The help system contains procedures, detailed descriptions 
of functions and variables, and reference information.
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• Look at the Show Me examples.

Authorware comes with 80 Show Me examples that not only answer questions 
you may have but also provide flowline logic you can paste into your work. 
Install the Show Me examples on your hard disk for quick access from the Help 
menu (choose Help > Show Me). More Show Me examples are added to the 
Authorware Support Center every month (choose Help > Support Center or 
visit www.macromedia.com/support/authorware).

• Visit the Authorware Support Center.

The Authorware Support Center is a rich source of information about 
Authorware that includes articles by expert users on new features and common 
problems, regular installments of new Show Me examples, and information 
about books and Web sites, user groups and events, and tools and services you 
may need. Go to the Authorware Support Center at  www.macromedia.com/
support/authorware or choose Help > Support Center.

• Join the AWARE list.

The AWARE discussion list is an online forum for discussing Authorware. 
This list is maintained not by Macromedia but by Authorware developers 
worldwide. You can subscribe to the list (you’ll receive around a thousand 
e-mail messages a month), or you can browse the newsgroups 
bit.listserv.authorware and alt.authorware.

To subscribe to the AWARE discussion list, send the following message to 
LISTSERV@LISTSERV.CC.KULEUVEN.AC.BE

SUBSCRIBE AWARE <Your Name>

For example, SUBSCRIBE AWARE Chris Chen

You can remove your name from the list at any time by sending a SIGNOFF 
AWARE or UNSUBSCRIBE AWARE command to the listserv address. For more 
information on the AWARE list, visit www.e-media.nl/aware/manual.html.

• Check the Authorware TechNotes when you have a problem.

If you’re having a problem, chances are that Technical Support has already 
solved the problem for someone else. See the TechNote Index on the 
Authorware Support Center at www.macromedia.com/support/authorware/
technotes.html or choose Help > TechNotes.

• Check the Authorware Discussion Group.

If you’re having a problem and you can’t find the answer in the TechNotes, 
check the Authorware Discussion Group. The discussion group is part of the 
Authorware Support Center at  www.macromedia.com/support/authorware  
or choose Help > Support Center.
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• Buy a book.

Macromedia Press and other publishers publish books by independent authors. 
You may find one or more of them helpful. Macromedia Press books are 
published by Peachpit Press. For information on these, call 800-283-9444 or 
visit www.peachpit.com.

• Join a user group.

Other developers can help you over a lot of hurdles. The best place to meet 
them is at a user group. For a list of user groups, visit the Authorware Support 
Center at  www.macromedia.com/support/authorware  or choose Help > 
Support Center.
Introducing Authorware 6 17
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CHAPTER 1

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
What’s New in Authorware 6

Authorware 6 provides greater extensibility and ease in publishing to the Web. 
It provides all the tools you need to create media-rich, interactive, and trackable 
e-learning applications for delivery on many platforms, including the Web, 
corporate networks, and CDs. 

The following sections give an overview of the new features in Authorware 6.

One-button publishing and other 
enhancements
One-button publishing integrates and automates all the steps in the publishing 
process, making it possible to deliver applications for the Web, CD-ROM or 
corporate network with the click of a button. 

• Package and publish a piece in several formats at the same time. For example, 
in just one step you can publish Authorware packages without runtime (A6R 
file), for the Web Player (AAM file), and a Web page (HTM file).

• Define customizable, reusable publish settings. 

• Automatically identify and collect many of the support files you need for 
publishing a piece, such as Xtras, DLLs, and UCDs).

• FTP files for the Web to your remote server.
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For more information, see “Using one-button publishing to package a piece” on 
page 178.

If you need to publish multiple Authorware pieces, you can use the batch 
publishing feature to publish several pieces in multiple formats at the same time, 
and keep track of all the pieces you need to publish. For more information, see 
Using batch publishing to package a piece in Authorware help.

Although one-button publishing assists in locating the Xtras you have used for a 
file and puts them in the appropriate folder during the publishing process, you 
can also use the new Find Xtras command to locate many of the Xtras that are 
used for a file before you publish it. For more information, see Using the Find 
Xtras command in Authorware Help. 

There have also been some modifications to the Web Packager Command line. 
See Chapter 11, “Streaming, Intranets, and the Web” on page 357.

New Commands menu
In Authorware 6, you can create and add your own custom commands to the new, 
extensible Commands menu. For more information, see “Adding your own 
commands to the Commands menu” on page 182.

Rich text format (RTF) editor and 
knowledge objects
Now you can create rich, reusable content with new authoring capabilities, using a 
new rich text editor. There are two main RTF components in Authorware 6:

• RTF Objects Editor. You can use the RTF Objects Editor to design your 
screens or any other RTF file. Here you can mix and match text, graphics, 
shapes, Authorware variables and expressions, and hot text. See “Using the RTF 
Objects Editor” on page 192.

• RTF Knowledge Objects. You can use RTF Knowledge Objects to display 
external RTF documents inside the Authorware Presentation window. 
Dynamically link to external rich text documents created in the RTF Objects 
Editor so text assets remain easy to update without re-authoring. See “Using 
RTF Knowledge Objects” on page 211.

In addition, there are several new RTF Object functions you can use if you 
load RTFObj.u32. For more information, see Using RTF functions in 
Authorware Help.
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Interface improvements
The Authorware interface has been revised to enhance the flowline, synchronize 
sound and movie icons, and improve screen functionality.

• You can now create a customized icon and store it on the icon palette. See 
Customizing icons in Authorware Help.

• Now it is easy to determine whether an item on the flowline is empty or 
contains information. Empty icons are grey in color. 

• Ten additional colors are available to help you identify your icons on the 
flowline and in the library. See Coloring icons in Authorware help.

• To help you organize your flowline, you can now display a map menu from the 
Window menu or when you right-click on the Design window. Choices 
include: Open Parent Maps, Close Parent Maps, Cascade Map, Cascade All 
Maps, Close All Maps, and Close Window in Authorware Help. 

• Now you can adjust the size of the Functions dialog box and Variables dialog 
box. See “Variables and Functions dialog boxes” on page 314.

Other interface enhancements

The Authorware interface has been enhanced in the following ways:

• When you create a new file, you can select a check box to turn off the option to 
show the New Project dialog box which lets you use Knowledge Objects to 
create a new application or quiz. If you want to use the Project dialog box, you 
can create a new file by choosing File > New > Project. See Creating a new 
project file in Authorware Help.

• The number of recent files displayed when you open a file by choosing File > 
Open > File has been increased to 10.

• A color column has been added to library windows. You can use the color 
palette to add colors to the icons in the library, and you can sort the icons by 
color. See “Using libraries” on page 243.

• When you open a library file by choosing File > Open > Library, the default file 
type is libraries, A6L files, instead of all files.

• The Batch Change dialog box has been changed to start with All and ActiveIf 
selected, instead of Decision and Branching.

• Two commands have been moved to the Windows menu: Close Window and 
Close All Windows.

• New keyboard shortcuts have been added: Control-E displays the Response 
properties dialog window and Ctrl+Alt+M displays the Save as Model menu 
item. See Keyboard Shortcuts in Authorware Help.
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New media features
In addition to the new RTF features, there are two new media features you can use 
in Authorware 6:

• Direct events over time by synchronizing the display of media and other events 
with time-based media. Media Synchronization allows Authorware Sound and 
Movie icons to trigger any event based on media position in an audio or video 
file. See Media Synchronization in Authorware Help.

• With Authorware 6, you can add MP3 sound to your piece. See “Creating and 
integrating sound” on page 225.

Calculation window enhancements
Several improvements have been made to the Calculation window. Now you can 
change calculation preferences; insert a symbol, divider line, or message box; and 
view the ASCII value of the selected character in a function or variable. See 
“Using the Calculation window” on page 310.

Performance tracking enhancements

PWInt.x32 Xtra

Several changes have been made to the PWInt.x32 Xtra. The PWInt.x32 Xtra 
now supports IsCourseChanged, IsLibraryChanged, CMISetAICCVersion and 
CMIGetAICCVersion functions. In addition, the CMI support in Authorware no 
longer requires a version sent from the CMI system. ExitAU is now sent with 
CMIFinish. See “CMI variables and functions” on page 349.

Assessment question knowledge objects

The Hot Spot, Hot Object, True/False, Single Choice, and Multiple Choice 
assessment question knowledge objects have been updated to allow for the import 
and export of question content stored in XML files that conform to the IMS 
Question Test Interoperability (QTI) version 1.1 standard. This allows you to 
export a question to an XML file and import an XML file. See “QTI Assessment 
Knowledge Objects” on page 338.
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Web technology enhancements
Now you can leverage standard Web technologies in your Authorware 
applications:

• Extend your application with nearly any ActiveX control using 
communications that support extended properties and methods of ActiveX 
controls. See “ActiveX controls” on page 334.

• The XMLParser Xtra allows Authorware pieces to read, parse, and make use of 
the contents of XML documents. Create dynamic, data-driven applications by 
importing external data stored in Web-standard XML files. See “The 
XMLParser Xtra” on page 335.

• You can track student activity with enhanced data tracking capabilities with 
SCO Metadata Editor. The Department of Defense Advanced Distributed 
Learning (ADL) initiative has developed common guidelines for the 
development, delivery, and management of learning. The Shareable 
Courseware Object Reference Model (SCORM) is a reference model for a set 
of interrelated guidelines for reusability, accessibility, durability, and inter 
operability. This is accomplished by the use of very structured packaging 
guidelines, or metadata. The SCO Metadata Editor now provides the metadata 
with your package that conforms to  ADL-SCORM specifications. For more 
information see “SCO Metadata Editor” on page 338.

• The Authorware Web Player, which downloads Authorware 6 content over the 
Web, is 40% smaller. 

New properties, functions, and variables
Many new properties, functions, and variables are provided with Authorware 6. 
Over 100 new properties are now available to the GetIconProperty and 
SetIconProperty functions. For complete details, see System functions in 
Authorware Help.
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New functions

The following functions have been added to Authorware 6. For complete details, 
seeSystem functions in Authorware Help.

Function Description

GetExternalMedia 
(IconID@ 
“IconTitle”/ 
LibraryID)

Returns full list of external media associated wih the node or 
the library. This function returns an empty list when used on 
packaged files.
Each property list represents a single piece of external 
media. Display and interaction icons can have more than one 
of these. The list contains the IconID, the IconTitle, a 
Boolean value to indicate whether the media is linked by 
literal (Literal=true) or by expression 
(Literal=false), the path if the item is a literal, and the file 
name. If the item is linked by an expression, then the path is 
empty and the expression comes in the file name spot; that’s 
the way it is stored in the IconID.

GetFunctionList 
(Category)

Returns a property list with information about the functions 
within the specified category.

GetLibraryInfo() Returns a linear list of all libraries currently associated with 
the current course file. The list also includes library files 
currently open, whether they are linked to the course or not. 
This function only operates on unpackaged files.

GetPasteHand() Returns the IconID of icon on the flowline closest to the 
Paste Hand. If the IconID is positive, then the paste hand is 
before the icon. If the IconID is negative, then the paste 
hand is after the icon. If the value returned is 0, then the paste 
hand is on the tool palette. This function only operates on 
unpackaged files.

GetSelectedIcons() Returns a linear list describing the selected icons in the front 
map. Values returned include the Icon Title, Icon ID, 
and Icon Type. 

GetVariableList 
(Category)

Returns a property list with information about the variables 
within the specified category.

GroupIcons() Groups the selected icons. The selection is maintained after 
grouping. This function only operates on unpackaged files.

OpenFile 
("filename")

Opens the specified course file. If "filename" is omitted, a 
new untitled file is created. If the file specified cannot be 
found, a new file is created with the specified title. Sets 
IOStatus and IOMessage. Returns a value of TRUE if 
successful. This function does nothing unless called via the 
CallTarget function on an unpackaged target file.

OpenLibrary 
("filename")

Opens the specified course library file. Returns the value of 
IOStatus. This function only operates on unpackaged files.
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PackageFile(“Output
File”,Runtime, 
ResolveLinksAtRun¬
time, 
PackLibsInternal, 
PackMediaInternal, 
UseDefaultNames, 
[LibraryLocations])

Packages the currently open course file. Returns the value of 
IOStatus. This function does nothing unles called via the 
CallTarget function on an unpackaged file. Values include 
the following:
Output file=name of the output file to create
Runtime 0=None, 1=16 bit, 2=32 bit. 
ResolveLinksAtRuntime, TRUE / FALSE. 
PackLibsInternal, TRUE / FALSE. 
PackMediaInternal, TRUE / FALSE. 
UseDefaultNames, TRUE / FALSE
Library Locations, (if libraries are packaged externally) 
List of the LibraryId and location of packaged exernal 
libraries.

PackageLibrary(Libr
aryID,”OutputFile”, 
ReferencedOnly, 
UseDefaultName, 
PackMediaInternal) 

Packages the specified library file. The library specified must 
be connected with the current course. Returns the value of 
IOStatus. Use GetLibraryInfo to obtain the 
LibraryIDs for each library. 

SaveLibrary(Library
ID, ["New 
Filename"])

Saves the specified content library file. If "New filename" 
is provided, the library is saved to the new file and the original 
file is left intact. The course file will be marked as "Changed" 
during this process. Returns the value of IOStatus. This 
function works on unpackaged files only.

SetHotObject(iconId 
for response, 
iconID for object)

Sets the currently active object for the response. This 
function works both at Runtime and Authoring time. Since 
the value is not stored when set through this function, use 
SetIconProperty for design time changes that are 
stored in the file.

SetMotionObject¬
(iconId for 
response, iconID¬ 
for object)

Sets the currently active object for the response. This 
function works both at Runtime and Authoring time. Since 
the value is not stored when set through this function, use 
SetIconProperty for design time changes that are 
stored in the file.

SetTargetObject¬
(iconId for 
response, iconID¬ 
for object)

Sets the currently active object for the response. This 
function works both at Runtime and Authoring time. Since 
the value is not stored when set through this function, use 
SetIconProperty for design time changes that are 
stored in the file.

UngroupIcons() Ungroups the selected icons. Ungrouping icons that are not 
grouped maps (as well as empty maps) deletes the icon. The 
selection is maintained after ungrouping. This function only 
operates on unpackaged files.

Function Description
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Icon colors for Get, Set, and Batch edit property functions

There are now 16 colors available for icons for the Get, Set, and Batch edit 
property functions.

SetFileProperty and GetFileProperty

The following properties can now be set and retrieved with SetFileProperty 
and GetFileProperty.

Open properties

Properties for the GetIconProperty and SetIconProperty previously available 
only through the batch edit feature are now available in listed properties. Three 
properties excluded from this are Button, Cursor, and Display Mode.

The following are the new properties available for GetIconProperty and 
SetIconProperty.

Property Possible values Description

awIconCount Any number Reports the number of icons in the piece just 
as it is listed in the File property dialog box.

awPackDefaultNames T
F

Packages using default names 

awPackLibInternal T
F

Packages libraries internally

awPackMediaInternal T
F

Packages external media internally

awPackRunLink T
F

Resolves links at run time

awPackRuntime #none 
#run16 
#run32

Indicates by symbol which run time to include

Authorware name Property Icons Possible value

Active if True #awActiveIf Any icon that is a 
response to an 
interaction

Numeric value; 
expression that 
resolves to a 
numeric value

Affected Area #awAffectedArea Interaction, display, 
Xtra, erase, context 
(framework)

#entireWindow, 
#changingAreaOnly
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Anti-alias #awAntialias Display, interaction A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Auto Match #awAutoMatch A conditional 
response to an 
interaction

#off, #whenTrue, 
#onFalseToTrue

Base X #awBaseX Motion, display, 
interaction, movie, 
Xtra

Numeric value; 
expression that 
resolves to a 
numeric value

Base Y #awBaseY Motion, display, 
interaction, movie, 
Xtra

Numeric value; 
expression that 
resolves to a 
numeric value

Branching #awBranching Decision #sequentially, 
#randomToUnused
Path, 
#randomToAnyPath, 
#toCalculatedPath

Calculated nav 
expression

#awCalcExpr Navigation Expression that 
resolves to an icon ID

Calculated path #awCalcPath Decision Numeric value;  
expression that 
resolves to a 
numeric value

CMI Score #awCMIScore Interaction Numeric value; 
expression that 
resolves to a 
numeric value

CMI Weight #awCMIWeight Interaction Numeric value; 
expression that 
resolves to a 
numeric value

Destination X #awDestX Motion, display, 
interaction, movie, 
Xtra

Numeric value;  
expression that 
resolves to a 
numeric value

Destination Y #awDestY Motion, display, 
interaction, movie, 
Xtra

Numeric value;  
expression that 
resolves to a 
numeric value

Direct to screen #awDirectToScreen Display, movie, Xtra, 
interaction

A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Authorware name Property Icons Possible value
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Display Duration #awDisplayDuration Display, interaction, 
context 
(framework), Xtra

Numeric value; 
expression that 
resolves to a numeric 
value. Used with 
Erase and deals with 
transition of Erase 
process.

Display Smoothness #awDisplaySmooth¬
ness

Display, interaction Numeric value; 
expression that 
resolves to a numeric 
value. Used with 
Erase and deals with 
transition of Erase 
process.

End X #awEndX Motion, display, 
interaction, movie, 
Xtra

Numeric value;  
expression that 
resolves to a 
numeric value

End Y #awEndY Motion, display, 
interaction, movie, 
Xtra

Numeric value;  
expression that 
resolves to a 
numeric value

Erase Content #awEraseContent Any icon whose 
parent is a decision 
icon

#beforeNextEntry, 
#uponExit, 
#dontErase

Erase Duration #awEraseDuration Erase, interaction Numeric value;  
expression that 
resolves to a 
numeric value

Erase Previous 
Content

#awErasePrevious Display, movie, Xtra, 
interaction

A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Erase Smoothness #awEraseSmooth
ness

Erase, interaction Numeric value;  
expression that 
resolves to a numeric 
value

Highlight on match #awHighlightOn
Match

A hot-spot or 
hot-object response

A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Icon Color #awIconColor Any icon #white, #yellow, 
#pink, #green, #red, 
#blue, #brightred, 
#brightblue, 
#brightgreen, 
#fushcia, #purple, 
#orange, #gray, 
#brown, #cyan, #teal

Authorware name Property Icons Possible value
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Icon Description #awIconDesc Any icon

Icon Modified Date #awModTime Any icon

Icon Size #awIconSize Any icon

Initial X #awInitialX Display, interaction, 
movie, Xtra

Numeric value; 
expression that 
resolves to a 
numeric value

Initial Y #awInitialY Display, interaction, 
movie, Xtra

Numeric value;  
expression that 
resolves to a 
numeric value

Interaction branching #awIntBranching Any icon that is a 
response to an 
interaction

#tryAgain, 
#exitInteraction, 
#continue, #return

Interruption #awInterruption Any icon that is a 
response to an 
interaction

#continueTiming, 
#pauseResumeOn
Return, 
#pauseRestartOn
Return, 
#pauseRestartIf
Running

Judge Status #awJudgeStatus Any icon that is a 
response to an 
interaction

#notJudged, 
#correctResponse, 
#wrongResponse

Layer #awLayer Display, movie, Xtra, 
interaction, motion

Numeric value; 
expression that 
resolves to a 
numeric value

Location X #awLocationX Any icon that is a 
response to an 
interaction

Numeric value;  
expression that 
resolves to a 
numeric value

Location Y #awLocationY Any icon that is a 
response to an 
interaction

Numeric value;  
expression that 
resolves to a 
numeric value

Mark on match #awMarkOnMatch A hot-spot response A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Match #awMatch A hot-spot or 
hot-object response

#singleClick, 
#doubleClick, 
#cursorInArea

Authorware name Property Icons Possible value
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Movable #awMovable Display, movie, 
interaction, Xtra

#never, #onScreen, 
#onPath, #inArea, 
#anywhere

Pause before 
branching

#awPauseBefore
Branch

Decision A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Perpetual #awPerpetual Any icon that is a 
response to an 
interaction

A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Prevent Automatic 
Erase

#awPreventErase Display, movie, Xtra, 
interaction

A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Prevent Cross Fade #awPreventFade Erase A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Repeat #awRepeat Decision #dontRepeat, 
#untilAllPathsUsed, 
#fixedNumberOfTim
es, 
#untilClickKeypress, 
#untilTrue

Repeat Condition #awRepeat
Condition

Any icon whose 
parent is a decision 
icon

Numeric value;  
expression that 
resolves to a 
numeric value

Reset paths on entry #awResetPathsOn
Entry

Decision A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Show countdown #awShow
Countdown

Wait A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Show Button #awShowWait
Button

Wait A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Size X #awSizeX Any icon that is a 
response to an 
interaction

Numeric value;  
expression that 
resolves to a 
numeric value

Size Y #awSizeY Any icon that is a 
response to an 
interaction

Numeric value;  
expression that 
resolves to a 
numeric value

Authorware name Property Icons Possible value
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New variables

The following are the new variables in Authorware 6. For complete details, see 
System variables in Authorware Help. 

Time Limit #awTimeLimit Decision, motion, 
wait, or any icon that 
is a response to an 
interaction

Numeric value; 
expression that 
resolves to a 
numeric value

Concurrency #awTiming Sound, video (the 
old one), movie, 
motion

#waitUntilDone, 
#concurrent, 
#perpetual

Track Interaction #awTrackInteraction Interaction A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Update variables #awUpdateVars Display, interaction A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Wait for mouse click #awWaitClick Wait A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Wait for keypress #awWaitKeypress Wait A Boolean value: 
True/False or 1/0 , 
True = 1, False = 0

Sprite Icon Type #awXtraType Sprite 

Variable Description

LastObject¬
ClickedID

The LastObjectClickedID variable contains the IconID of the 
last object the user clicked. When the user clicks an object, both 
LastObjectClickedID and ObjectClickedID contain the 
same value. However, if the user then clicks the Presentation 
window background instead of an object, ObjectClickedID 
contains an empty (null) value, while LastObjectClickedID still 
contains the IconID of the display the user clicked earlier.

ObjectClickedID The ObjectClickedID variable contains the IconID of the 
object the user clicked. When the user clicks an object, both 
ObjectClickedID and LastObjectClickedID contain the 
same value. However, if the user then clicks the Presentation 
window background instead of an object, ObjectClickedID 
contains an empty (null) value, while LastObjectClickedID still 
contains the IconID of the display the user clicked earlier.

ObjectMovedID The ObjectMovedID variable contains the IconID of the last 
display icon the user moved, even if it didn’t match a response icon.

Authorware name Property Icons Possible value
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Authoring Basics

Multimedia piece is a broad term that includes many types of communication. 
For example, an intranet-based training course, an interactive kiosk, an online 
magazine, and a computer simulation of industrial equipment are all multimedia 
pieces. Their common multimedia trait is the ability to orchestrate media 
objects—such as graphics, sound, digital movies, or a set of instructions—in 
response to changing conditions such as the user’s choices and the amount of 
time that passes.

The assembling of multimedia into a functioning piece is known as authoring.

Icon-based authoring
The best introduction to icon-based authoring is the Authorware tutorial in 
Chapter 3 “Tutorial” on page 57. If you’ve skipped it, the information in the first 
few pages of this chapter will get you started on your own. Be sure to see 
“Authoring—step-by-step procedures” on page 36 for the topics in Authorware 6 
Help that explain how to use icons.

With Authorware you construct, or author, a multimedia piece by assembling 
icons on a flowline. The flowline organizes the icons and determines the sequence 
in which Authorware runs them.

Icons contain the contents of a piece. Different types of icons contain different 
types of objects, such as graphics, text, sound, digital movies, or a set of 
instructions. The arrangement of icons forms the logic of a piece—its structure 
or architecture. The logic of a piece gives the piece shape and makes it work a 
certain way.
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In Authorware, you drag icons from the icon palette. The icon palette is like a 
bottomless well. You can drag up to 16,000 icons from the icon palette into a 
single file, but it is best to create smaller modular pieces, which are much easier 
to work with.

The flowline appears in the Design window. That’s where you arrange the icons 
and construct the logic of the piece. The icons’ order on the flowline determines 
the order in which events take place when the piece runs.

When you run a piece, it appears in the Presentation window. As you build a 
piece, you use the Presentation window to lay out text, graphics, buttons, and all 
the other visual elements that make up the piece.

Running the piece

As you author, you can run the piece to check how images appear and whether 
interactivity works the way you want. Use the Control menu and the Authorware 
Control Panel to run or step through your piece. Use the start and stop flags to 
test a specific segment of the piece.

The stages of authoring
Authoring a multimedia piece generally follows the traditional development 
process of analysis, design, development, evaluation, and distribution.

Analysis

Before you start using Authorware, conduct an analysis to determine what the piece 
you’re creating needs to do. The analysis you make will differ depending on the type 
of solution that you are providing. Who is the intended audience? What objectives 
must be met? How timely must the information be? What environment will users 
be in when they use the piece? If you’re developing a kiosk that will be situated in a 
noisy shopping mall, you may decide against using sounds in your piece.

Next, think about how you’ll distribute the piece and the kinds of computers that 
the target audience has. For more things to consider before you begin designing 
your piece, see “Distributing your piece” on page 172.

Design

Before you develop the navigational structure of your piece, make a prototype of 
the screen design and identify all of the content elements for your piece.
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Create storyboards and prototypes Create storyboards for the project and design a 
few sample screens to work out in detail exactly what you want to achieve. 
Authorware is ideal for creating prototypes. You can draw basic shapes to represent 
elements on the screen and later import finished graphics into the piece. A 
prototype should convey the idea of how a piece will work. Be careful not to 
spend too much time on visual details for the prototype: If the design needs to 
change later, you will have created graphics that won’t be used.

Identify and gather content When professional developers identify and gather their 
content, they create what’s known as an asset list—a list of every sound, graphic, 
movie, and object used in a piece. You should do the same. Authorware excels at 
integrating text, graphics, sound, and digital movies. Although you can create 
some text and graphics with Authorware tools, you’ll get the best results with 
applications designed specifically for creating the type of media you want to 
include. For example, use Macromedia Director for digital movies and animations.

Use the Authorware media libraries and external content features as much as 
possible. They let you store content externally and reuse and reference the icons, 
saving disk space and making it easier to update applications.

Be sure that your computer and all end users’ computers have the equipment 
needed to play sound and video.

Development

Now you’re ready to build full functionality into the piece, which is best done 
module by module. You’ll need to import content, apply transition and motion 
effects, create navigation structures and interactions, and develop data variables.

Look for ways to set up logic so you can save it as a model and reuse it. Remember 
that you can switch from Authorware to external applications—for example, to let 
the user enter numbers in a real spreadsheet or save results in a text file. Run and 
test the piece regularly as it is being built.

Evaluation

When you think your application works the way you want it to, test it just as 
software companies test applications—on real users.

Testing and fine-tuning Run the files and make adjustments to the content and 
the interactions. You may need to make changes to the files to obtain the best 
performance on slower computers. It’s important to allow ample time for this 
stage; designing interactions is considerably more complicated than creating a 
linear presentation. 

Review In this stage of testing you make sure the project works as designed. You 
may need to go back to the development stage, or you may need to simply fine-
tune some details.
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Distribution

When you’re ready to distribute your piece, package it. You can use one-button 
publishing to package it in multiple formats at the same time. If you’re developing 
commercial applications, make sure your distribution is in accordance with the 
license agreement. The packaged file doesn’t contain all the information needed to 
change the application, so be sure to archive the original Authorware file.

If you’re developing a piece for the Internet or for a corporate intranet, you can 
use one-button publishing to create the HTML page where you want to embed 
the piece, and then put all the files on your Web server. Run at least one test with 
each browser that will be used to view the piece, such as Netscape Navigator or 
Internet Explorer, to make sure the piece downloads and runs properly.

Authoring—step-by-step procedures
The steps involved in authoring a multimedia piece are presented in the 
following table.  

What you can do In Authorware Help, see

Create a new file Creating a new project file

Use a Knowledge Object in a file Choosing a Knowledge Object for a new file, 
Adding a Knowledge Object to a file

Open a file Opening a file

Build a piece Building a piece

Set up icon properties Modifying icon properties

Edit an icon Editing an icon

Add text Working with text

Add images , Importing a graphic, 
Pasting a graphic, 
Drawing graphics

Display the content of several 
icons in the Presentation window 
at the same time

Displaying the content of several icons

Create effects when you display 
or erase images

Choosing a transition

Move objects across the 
Presentation window

Using the motion icon

Add sound Working with sound
Linking to external files
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The toolbar
Authorware’s toolbar provides quick access to some of the most frequently used 
menu commands. Use the View menu to show or hide the toolbar. 

To find out what a button does, position the pointer over it. A description of the 
button appears after a few seconds. 

Add digital movies Working with digital movies, 
Linking to external files

Play video Working with video

Group icons Grouping and moving icons

Move icons from one part of the 
flowline to another

Grouping and moving icons

Reuse content Using libraries

Create interactivity Ways to interact

Track a user’s performance Tracking performance, Using Knowledge Track to set 
up a course

Track information Using a variable, Creating a variable

Set up paging and 
navigation structures

Ways of directing the flow, Paging structures—quick 
and easy user control

Add functions to a piece Using a system function

Extend Authorware’s functionality Using scripting Xtra functions, Loading a DLL custom 
function, Using an ActiveX control

Reuse flowline structures Using a model

Test a piece Running and pausing a piece

Use the Authorware 
Control Panel

Using the Control Panel

Save a file Saving a file

Package a piece for distribution Packaging an Authorware piece, Using one-button 
publishing to package a piece

Process a piece to play it over 
the Web

Getting a piece ready for the Web

What you can do In Authorware Help, see
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Icon basics
The following table describes what each icon does:  

Display icon Displays text and graphics on the screen. See “Working with 
text” on page 186 and “Working with images and graphic 
objects” on page 218.

Motion icon Moves an object along a path or to a specific point. You can 
restrict where an object can move. See “Using the motion 
icon” on page 303.

Erase icon Erases any or all objects from the screen when they are no 
longer needed. See “Setting up an erase icon” on page 41.

Wait icon Adds pauses with or without onscreen buttons that let users 
decide when to continue. See “Setting up a wait icon” on 
page 41.

Navigate icon Sets up automatic or user-controlled navigation in a 
hypermedia framework. See “Setting up a navigate icon” on 
page 42.

Framework icon Used to lay out a hypermedia framework, a structure of text, 
graphics, sound, animation, and data that users can navigate 
through. See “Setting up a framework icon” on page 42.

Decision icon Sets up various paths Authorware can take depending on 
conditions and events. See “Setting up a decision icon” on 
page 43 and “Decision structures—directing the flow 
automatically” on page 277.

Interaction icon Gives users a variety of ways to make choices, such as 
clicking buttons or hot spots. Evaluates a user’s actions. “If 
you do nothing more than present text, graphics, animation, 
video, and sound to users, you’re creating the equivalent of a 
television commercial. At best, it will entertain and inform; at 
worst, users will ignore it. It’s a passive, one-way form of 
communication.” on page 247 See “Setting up an 
interaction icon” on page 43.

Calculation icon Updates values in variables. Executes functions that affect 
what the piece does. See “Setting up a calculation icon” on 
page 44 and “Where you can use variables, functions, 
expressions, and scripts” on page 308.

Map icon Simplifies and organizes the flowline by grouping it into 
smaller segments. See “Setting up a map icon” on page 44.
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Some icons share common traits:

• Display, digital movie, and video icons display objects in the Presentation 
window. Interaction icons can display objects along with objects in other icons.

• Motion and erase icons affect icons that display content.

• Digital movie and sound icons can be synchronized with the contents 
of display icons. For more information, see Media Sychronization in 
Authorware Help.

• Framework, decision, interaction, and calculation icons control the piece’s 
branching and navigation.

• Map icons contain groups of other icons. Each map can be opened to display 
its segment of the flowline in its own Design window.

• Sprite icons add special functionality to Authorware through sprite Xtras. 
Sprite icons come from the Insert menu. See Using a sprite Xtra in 
Authorware Help.

Digital movie icon Plays Macromedia Director 5 and earlier, AVI, MOV, FLC, 
MPEG, and QuickTime 2 digital movies. You will need to use 
the QuickTime Xtra to import QuickTime 3 or later movies. 
See “Setting up a digital movie icon” on page 45 and 
“Working with digital movies” on page 228.

Sound icon Includes music, narration, or sound effects in a piece. See 
“Setting up a sound icon” on page 46 and “Working with 
sound” on page 224.

Video icon Includes still images, sound, or animation from videodisc. 
See “Setting up a video icon” on page 46 and “Working with 
video” on page 233.

Start and stop flags Speed up development by letting you test segments of the 
flowline as you create them. (The start and stop flags are 
usually used together.) See Running and pausing a piece in 
Authorware Help.

Icon color palette Organize icons by color-coding them. See  Coloring Icons in 
Authorware Help.
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Inserting an icon

Drag an icon from the icon palette to the place on the flowline where you 
want to insert it. Authorware adds the icon to the flowline where you release 
the mouse button.

Setting up icons

See the topic for the specific type of icon you want to set up:

• “Setting up a display icon” on page 41

• “Setting up a motion icon” on page 41

• “Setting up an erase icon” on page 41

• “Setting up a wait icon” on page 41

• “Setting up a navigate icon” on page 42

• “Setting up a framework icon” on page 42

• “Setting up a decision icon” on page 43

• “Setting up an interaction icon” on page 43

• “Setting up a calculation icon” on page 44

• “Setting up a map icon” on page 44

• “Setting up a digital movie icon” on page 45

• “Setting up a sound icon” on page 46

• “Setting up a video icon” on page 46

• “Setting up a sprite icon” on page 47

• “Using Knowledge Objects” on page 50
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Setting up a display icon

Use the display icon to display text and graphics. Drag a display icon onto the 
flowline and then add graphics and text to it in the Presentation window.

To add contents to a display icon’s Presentation window, use the Toolbox to draw 
objects, use the File > Import command to import images, or drag and drop text 
or graphics files into the display icon.

To modify the display and layout of a display icon, select the icon in the flowline and 
choose Modify > Icon > Properties. The Display Icon Properties dialog box appears.

To keep previously displayed items in the Presentation window when you open a 
display icon, hold down the Shift key while you double-click the icon.

Setting up a motion icon

Use motion icons to move display objects from one location on the screen 
to another.

First, place a display icon on the flowline. Next, place a motion icon after it. Then 
define the motion of the display objects in the Motion Icon Properties dialog box. 
All the display objects in that icon move together. You can also move movies 
playing on the screen this way.

Double-click the motion icon in the Design window to open the Motion Icon 
Properties dialog box. Here you can set type of motion, timing, and other options. 
You can also preview the type of motion you’ve set up by clicking the Preview 
button in the dialog box.

Setting up an erase icon

Use the erase icon to erase any icon that’s currently displayed. You can erase the 
objects displayed by the display, interaction, framework, and movie icons.

When you erase an icon, you erase all its contents. For example, if a display icon 
contains three graphic objects, Authorware erases all three objects. If you want to 
erase just one of those objects, place it in a separate display icon, so it appears as a 
separate object in the Presentation window. 

To open the Erase Icon Properties dialog box, double-click the erase icon.

Setting up a wait icon

Use the wait icon to pause the piece for a specified amount of time or until the 
user presses a key or clicks the mouse.

Double-click the wait icon to open the Wait Icon Properties dialog box, then enter 
the property options.

When synchronizing sounds within a piece, don’t use the wait icon. See 
“Synchronizing audio, video, and graphics” on page 226.
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Setting up a navigate icon

Icons attached to framework icons are called pages. You can use navigate icons 
to create links that jump to specific pages in a framework. When Authorware 
encounters a navigate icon, it goes to the page you set up as a destination. This 
is called a navigation link.

When you define a navigation link, you define the type of destination, such as going 
forward or backward a page, jumping to a page, searching for text, or jumping to 
the first or last page of a framework. Double-click a navigate icon to open the 
Navigate Icon Properties dialog box, where you can select destination options.

You can use navigate icons in two ways:

• Automatic navigation places a navigate icon anywhere on the flowline. When 
Authorware encounters the navigate icon, it automatically executes the link and 
goes to the destination page. 

• Navigation controlled by the user Attaches one or more navigate icons to an 
interaction icon to create a navigation framework. The interaction icon can be 
on the main flowline or in the entry pane of a framework icon. For each 
navigate icon you attach to an interaction icon, you can set up a navigation 
control (such as a button) that takes the user to a destination page. 

For more information about navigation frameworks, see “Frameworks in depth” 
on page 284. 

You can also use navigation styles to set up hyperlinks by creating hot text. 
When the user clicks the hot text, Authorware executes the hyperlink and goes 
to a destination. For more information, see Setting up a navigation link in 
Authorware Help.

Setting up a framework icon

The framework icon provides an easy way to set up navigation in an Authorware 
piece. A set of navigation controls is built into the framework icon so that users 
can move among the icons you’ve attached to it.

An icon attached to a framework icon is called a page. A page isn’t limited to a 
display icon containing text and graphics. It can also be a digital movie, a sound, 
or an animation. In fact, if you use a map icon, you can make the page as complex 
as you want. It can contain an interaction, a decision, another framework icon 
with its own navigation structure, or any combination of icons you want to 
arrange on the flowline.

Use the Framework window to set up icons that Authorware executes when 
entering or exiting a navigation framework.
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Setting up a decision icon

You set up a decision structure by attaching icons to a decision icon. When 
Authorware encounters a decision structure, it branches to a path according to the 
criteria you’ve defined.

When you set up a decision structure, you can define the following settings:

• The Repeat setting determines how many times Authorware loops through 
the decision icon.

• The Branch setting determines which icon Authorware branches to. 

Double-click the decision icon to open the Decision Icon Properties dialog box 
and define these settings.

Setting up an interaction icon

You use interaction icons to set up interaction structures that consist of an 
interaction icon with result icons attached to it. Each result icon corresponds to a 
response that the user can make, such as clicking a button or entering text, or to 
an event, such as the number of tries the user made.

When Authorware encounters an interaction icon, it displays any text and graphic 
elements it finds, including buttons, hot spots, text entry fields, and so on, defined 
by the response type symbols. Authorware then halts and waits for a response 
from the user. When a user responds, Authorware sends the response along the 
interaction flowline to see if it matches any of the target responses. If a match is 
found, Authorware branches to or executes the specified result icon.

You set up the responses you’re looking for in the Response Type dialog box. Here 
you determine the user’s response or the event by defining each result icon as a 
particular response type. When the user makes a response or the event occurs, 
Authorware branches to the corresponding result icon and displays its contents. 

You set the characteristics of the interaction display using the Interaction Icon 
Properties dialog box. Here you can specify display options, such as layer level, 
transition, positioning, and when objects are erased.

Double-click an interaction icon on the flowline to open the Presentation window 
to edit the display contents.
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Setting up a calculation icon

Use calculation icons to execute expressions and scripts that change values in 
variables or that perform calculations in a piece. Insert calculation icons at any 
point on the flowline or attach them to other icons.

To create an expression for a calculation icon, double-click the icon to open the 
Calculation window. You can then enter expressions and scripts for if...then 
statements and repeat loops in the window. You can also insert comments to 
describe the expression. See Chapter 9, “Using Variables, Functions, Xtras, 
and More” on page 307.

Authorware usually executes all the statements in a calculation icon and then exits 
the icon. You can force Authorware to exit calculation icons by entering an Exit 
statement in an expression. If the calculation icon is attached to another icon, that 
icon is executed normally.

In most cases, it’s a matter of preference whether to place a calculation icon before 
another icon or whether to attach it. However, if you attach a calculation to a 
decision or interaction icon, Authorware executes the calculation repeatedly if the 
icon uses Try Again branching. If the calculation icon is placed before a decision 
or interaction icon, Authorware executes it only once.

While Authorware executes a calculation icon, no other processing takes place and 
Authorware doesn’t respond to mouse clicks or key presses. For calculation icons 
that contain relatively simple calculations, this delay is imperceptible. However, 
calculation icons that contain complex repeat loops take longer to execute and 
may cause a noticeable delay.

Setting up a map icon

You can use map icons to group a sequence of icons. By grouping icons in map 
icons, you can organize your piece into convenient modules. This gives you a clear 
overview of how the piece will work, no matter how many icons it contains. Place 
map icons anywhere on the flowline and attach them to interaction icons, decision 
icons, or framework icons. You can place map icons within other map icons.

Each map icon has its own flowline. Double-click a map icon to open it. A level 
caption appears in the upper right corner.

When Authorware encounters a map icon, it executes the map’s icons in the order 
in which they appear on the flowline. When it finishes executing the last icon, 
Authorware exits the map icon and executes the next icon on the main flowline.

If the map icon is attached to an interaction icon, Authorware executes the entire 
contents of the map icon before branching to the next result icon. Authorware 
also executes the entire contents of the map icon when it is a path attached to a 
decision icon or pages attached to a framework icon.
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To group icons into a map icon, the icons must be next to one another on the 
flowline. To create a map icon, select the icons, choose Modify > Group, and 
name the resulting map icon. To redisplay (or ungroup) the icons in a map icon, 
select the map icon and choose Modify > Ungroup.

If you attach a calculation icon to a map icon and then ungroup the map icon later, 
Authorware attaches the calculation icon to the first icon that was within the group.

Setting up a digital movie icon

You can use digital movie icons to import digital movies created by other 
applications. (To import QuickTime 3 or later movies, use the QuickTime Xtra.)

You use the Digital Movie Icon Properties dialog box to control the movie’s 
properties, such as its positioning, the number of times it is played, and the speed 
at which it is played. 

A digital movie can be stored internally or externally, depending on the type of movie.

• Internally stored movies are stored in the Authorware file, increasing the size of 
the file. You can use erase transitions with internally stored movies.

• Externally stored movies are not stored in the Authorware file. You can’t use 
erase transitions with externally stored QuickTime, MPEG, or AVI movies. 
To use an erase transition on other types of external movies, select the Prevent 
Crossfade option in the Erase Icon Properties dialog box.

You must keep externally stored movies where Authorware can open them when it 
encounters movie icons on the flowline. You must distribute the files for externally 
stored movies along with your packaged Authorware piece. 

Authorware and the Authorware run-time application (Runa6w16.exe and 
Runa6w32.exe) look for external movies in the directories set in the Search Path 
field of the File Properties dialog box, or in the SearchPath variable, or in the 
external file name stored in the Movie Icons Properties dialog box. 

To preview a movie, select the digital movie icon, choose Modify > Icon > 
Properties, and use the playback controls to run the movie.

Note: Because movie icons are branching icons, they cannot be direct children of 
Interaction, Decision, or Framework icons. You can, however, place a map icon next to the 
interaction, decision, or framework icon, then place the movie icon inside the map icon.
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Setting up a sound icon

Use sound icons to play sounds in your Authorware pieces. You can import 
sounds and store them internally in a file, or store them externally and link them 
to your piece. Like other files, you can also drag and drop sound files onto the 
flowline of your piece.

You can play a loaded sound without opening the sound icon. Click the sound 
icon with the right mouse button or press Ctrl+Alt as you click the sound icon. 
Authorware plays the sound.

Note: Because sound icons are branching icons, they cannot be direct children of 
interaction, decision, or framework icons. You can, however, place a map icon next to the 
interaction, decision, or framework icon, then place the sound icon inside the map icon.

To play sounds on Windows computers, users need Windows version 3.1 or later 
and an audio card. For more information, consult your Windows documentation.

Setting up a video icon

Use the video icon to include a video clip from a videodisc player in an Authorware 
piece. To play the video, connect a videodisc player to your computer and then 
place a video icon in the Authorware file where you want the sequence to play.

Specify overlay drivers and players by choosing File > Preferences. For more 
information about those options, see Preferences in Authorware Help.

Incorporating video displays in Authorware

You can incorporate video into Authorware in two ways:

• Use an external monitor. Simply connect the video device to the computer and 
to the monitor. No special video overlay hardware is required.

• Install a video overlay card. If you install an overlay card in your computer, you 
can display video on the same screen that displays the rest of your Authorware 
piece, so that you can integrate video sequences into the piece. For example, 
you might play video on one part of the screen while you ask the user questions 
about it on another part of the screen. 

To use this option, a video overlay card must be installed in each computer on 
which the piece will run and the video player must be connected to the overlay 
card and the computer's serial port. You also need to select other options, such as 
where the video will play on the screen.
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Setting up a sprite icon

A sprite is a functional element such as a 3D object, a Macromedia Flash 
animation, an HTML browser window, or a pop-up menu. Sprite Xtras make it 
possible to incorporate such sprites into an Authorware piece. When you place a 
sprite Xtra file in the Xtras folder and then start Authorware, the Xtra file adds a 
command to the Insert menu. For example, the QuickDraw 3D Xtra adds the 
command ThreeD to the Insert menu.

Each sprite Xtra has both a menu category and a name. The menu category 
appears on the Insert menu, and the name appears on the submenu. In the case 
of the QuickDraw 3D Xtra, its menu category is ThreeD, and its name is 
QuickDraw 3D Model.

To incorporate a sprite into an Authorware piece, position the Paste Hand on the 
flowline where you want the sprite to appear, then choose the Xtra you want from 
its submenu. Authorware displays a dialog box that lets you choose the sprite you 
want, then inserts it on the flowline in a sprite icon. When you run the piece, the 
sprite appears in the Presentation window.

Tips for working with icons

Here are tips for working with icons more efficiently.

Naming icons Give each icon in the flowline a meaningful name. If you’re working 
in a team, this makes the logic much clearer for others looking at the piece. As a 
piece grows in complexity, or when you need to modify the flowline, icon names 
that describe the modules or the actual icons are invaluable.

Selecting more than one icon You can drag a selection rectangle around several 
icons on the flowline to select them. The Cut or Copy command will then apply 
to all the selected icons. You can also apply the Group command to several 
selected icons to place them all in a single map icon.

Rearranging icons You can rearrange icons by dragging them. When cutting and 
pasting icons, Authorware inserts them at the Paste Hand.

Embedding and linking content You can embed or link content directly to the 
flowline by using the File > Import command. Authorware looks at the file type and 
automatically places the correct type of icon (sound, display, or digital movie) at the 
Paste Hand. The Link to File option is available from the Import dialog box. 
Linking to a file stores the file separately from the Authorware file. For more 
information on linking files, see “Creating and incorporating content” on page 184. 

Using the drag-and-drop feature You can use the drag-and-drop feature to quickly 
import content into your piece. For example, you can drag files (movies, sound, 
images, and text) from the Windows Explorer onto the flowline. You can also drag 
images and text directly onto a display icon. Press the Shift key as you drag to link 
content, rather than embed it. 
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You can drag several files onto an interaction icon, making each file the result 
of a response. Or drag several files to a framework icon so each becomes a page. 
Drag files to a decision icon and each becomes a path. Drag files to the flowline 
and they’re arranged one after another. Authorware automatically inserts the 
appropriate icon for each type of file in the flowline.

Editing icon properties Each icon has attributes and options associated with it, 
which together are known as the icon’s properties. The options available depend on 
the type of icon. For example, the display icon’s properties include name, size, 
layout, transition, and layer. See  Modifying Icon Properties in Authorware Help.

Image properties The display icon can contain more than one image. Each 
imported or linked image has its own Properties dialog box with options for 
transparency, foreground and background colors, positioning, scaling, and 
cropping. Select an image and then choose Modify > Image Properties to view 
the Properties dialog box for the selected image.

Grouping icons You can group several related icons on a flowline into a map. This 
helps organize your information and makes it easier to find. See Grouping and 
moving icons in Authorware Help.

Coloring icons You can use a color-coding scheme for icons on the flowline or in 
the library simply by selecting the icon then selecting a color from the color 
palette. See Coloring icons in Authorware Help.

Media sychronization You can place icons to the right of sound or movie icons, in 
much the same way you set up decision icons. The icons placed to the right of 
another icon are called child icons. In addition, you can set those child icons to 
trigger based on the media position or number of seconds from when the media 
starts playing. See Media Synchronization in Authorware Help.

Customizing icons If the icons on the icon palette are not set up with the options 
you most commonly use, you can create your own customized icons and drag 
them back to the icon palette. These become the default when you select an icon 
from the icon palette. See Customizing icons in Authorware Help.

Editing an icon
You can edit an icon by double-clicking it.

When you open and edit icons that display their contents on the screen (such as 
the display, digital movie, or video icons) the Presentation window opens as well.

The toolbox appears when a display or interaction icon is open for editing in 
the Presentation window. The tools that are available depend on the type of 
icon that is open.

For display, digital movie, sound and video icons, and displays within interaction 
icons, the Modify menu provides more options. The menu items available are the 
ones that can be applied to the type of icon that is currently active.
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For motion and erase icons, the Presentation window also shows the contents of 
their associated icon or icons.

The Presentation window doesn’t appear when icons that don’t use it, such as 
navigate, wait, and calculation icons, are opened for editing. Instead, Authorware 
opens the corresponding options dialog box or window.

Editing multiple icons

Use the Change Properties command to simultaneously change one or more 
properties common to the icons you’ve selected. For example, use Change 
Properties to change the time limit and to show a countdown clock for all the 
interactions in a file.

To edit multiple icons:

1 Select the group of icons you want to modify. 

2 Select Edit > Change Properties. 

3 In the dialog box, choose a category, then a property, then the setting you want. 
Repeat the process to change as many settings as you want.

4 Click OK. 

To apply the same settings to a different selection of icons, choose Edit > 
Change Properties Again.

Displaying the content of several icons

To display the content of more than one icon:

1 Double-click the first icon to open it.

2 Shift-double-click subsequent icons.

To open a set of neighboring icons:

1 Run the segment that contains the icons.

2 Shift-double-click the icons that you want to edit.
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Displaying the Design window

To display the Design window containing the current icon, do one of the following: 

• Select View > Current Icon.

• Press 0 on numeric keypad.

To display a Design window by name:

Choose Window > Design > Design window name. 

The main Design window has the same name as the file. Other Design windows 
have the same name as the map icon they correspond to. 

Using Knowledge Objects
Knowledge Objects can help increase your productivity with Authorware 6. Each 
Knowledge Object has an icon and a wizard. You incorporate a Knowledge Object 
into your own project by dragging its icon from the Knowledge Objects window. 
Some Knowledge Objects are automatically added to your file by other 
Knowledge Objects or by the New File dialog box. You can edit each Knowledge 
Object’s properties with its wizard.

To use Knowledge Objects, you should have a basic understanding of Authorware 
icons and the flowline. Knowledge Objects developed by Macromedia have 
introduction screens that describe the Knowledge Object and online help screens 
that provide detailed instructions for specific tasks.

It’s important to save your work before inserting Knowledge Object icons and 
launching Knowledge Objects. This is because many Knowledge Objects 
(especially those that use external media and UCDs) rely on pathnames relative to 
the current file’s location. Additionally, saving your work creates backup versions 
to which you can revert if necessary.

Choosing a Knowledge Object for a new file

To choose a Knowledge Object for a new file:

1 Choose File > New > File.

2 Select a Knowledge Object in the New File dialog box, then click OK. 

The Knowledge Object is added to your file automatically.

3 Set the options in the wizard. When you’re finished, click Done.
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Adding a Knowledge Object to a file

To add a Knowledge Object to a file:

1 Choose File > Save to save your file.

2 If the Knowledge Object window isn’t open, choose Window > 
Knowledge Objects.

3 Drag a Knowledge Object icon from the Knowledge Objects window 
to the flowline.

Knowledge Objects are grouped by category. Use the Category pop-up menu in 
the Knowledge Objects window to view a specific group. Choose All to view all 
of the available Knowledge Objects. For information on adding Knowledge 
Objects to the Knowledge Objects window, see “Displaying Knowledge 
Objects in the Knowledge Objects window” on page 374.

4 Double-click the Knowledge Object icon to launch the wizard. 

5 Set the options in the wizard. When you’re finished, click Done.

If you need to make changes, double-click the Knowledge Object icon to run 
the wizard again.

Authorware Knowledge Objects
Authorware 6 includes many Knowledge Objects that you can use right away. 
Knowledge Objects developed by Macromedia are organized into the 
following categories:

• “Assessment Knowledge Objects” on page 52

• “File Knowledge Objects” on page 53

• “Interface Components Knowledge Objects” on page 53

• “Internet Knowledge Objects” on page 54

• “New File Knowledge Objects” on page 52

• “RTF Objects Knowledge Objects” on page 54

Knowledge Objects created by independent developers are also available for use 
with Authorware 6. See Chapter 12, “Creating Knowledge Objects” on page 373.
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New File Knowledge Objects

The Application and Quiz Knowledge Objects are available when you first start 
Authorware to create a new file. Use them as the starting point for training, 
presentations, testing, courseware, and other custom applications.

Application Knowledge Object

The Application Knowledge Object provides navigation for sections, pages, and 
quizzes. Select from a variety of layout, delivery, user interface, and other options. 
You can customize this template with your own content for a particular discipline 
or instructional strategy.

Quiz Knowledge Object

The Quiz Knowledge Object is a basic testing shell that sets global parameters for 
the following types of exercises:

Multiple Choice is a standard question type with multiple distractors. The user can 
select all the answers that apply to the question.

Single Choice is similar to the Multiple Choice exercise. The user selects one 
possible answer for the question.

True/False is a subset of the Single Choice exercise type with only two distractors.

Short Text is a standard fill-in-the-blank question type.

Drag and Drop is a standard exercise type for matching and ordering exercises.

Hot Object is an exercise type for identification and exploration exercises that 
require users to click on an object in the Presentation window.

Hot Spot is an exercise type for identification and exploration exercises that 
require users to click on a particular area in an image.

The exercises are available with the stand-alone Quiz Knowledge Object or as part 
of a quiz in the Application Knowledge Object. You can also add each component 
separately by selecting an Assessment Knowledge Object (see “Assessment 
Knowledge Objects” on page 52).

Assessment Knowledge Objects

These Knowledge Objects work in conjunction with the Assessment Login and 
Scoring Knowledge Objects. 

Drag and Drop Question is a standard exercise type for matching and ordering 
exercises.

Hot Object Question is an exercise type for identification and exploration exercises 
that require users to click on an object in the Presentation window.

Hot Spot Question is an exercise type for identification and exploration exercises 
that require users to click on a particular area in an image.
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Login implements the login sequence and storage type to facilitate score recording 
for Assessment Questions in Assessment Scoring.

Multiple Choice Question is a standard question type with multiple distractors. 
The user can select all the answers that apply to the question.

Scoring implements score accumulation, display and recording for Assessment 
Questions.

Single Choice Question is similar to the Multiple Choice exercise. The user selects 
one possible answer for the question.

Short Answer Question is a standard fill-in-the-blank question type.

True/False Question is a subset of the Single Choice exercise type with only 
two distractors.

Note: The Hot Spot, Hot Object, True/False, Single Choice, and Multiple Choice 
Assessment Knowledge Objects allow for the import and export of question content 
stored in XML files that conform to the IMS Question Test Interoperability (QTI) version 1.1 
standard. This allows you to export a question to an XML file and import an XML file. See 
“QTI Assessment Knowledge Objects” on page 338.

File Knowledge Objects

Add/Remove Font Resource loads a font file into memory so that Authorware can 
draw text using the font.

Copy File copies one or more files into a directory.

Find CD Drive locates the CD-ROM drive on the computer running your piece.

Jump to Authorware File jumps to other Authorware files from the current piece.

Read INI Value reads a value from a Windows INI file. 

Set File Attribute sets the system attributes (such as read-only) of external files.

Write INI Value writes a value to a Windows INI file.

Interface Components Knowledge Objects

The following Knowledge Objects let users interact with your piece more 
effectively. Use them as components of your own interface design.

Browse Folder Dialog Box displays a Windows-style dialog box for browsing and 
selecting directories.

Checkboxes displays a set of check box selection controls in your piece.

Message Box displays a Windows-style message or alert dialog box.

Move Cursor changes the location of the mouse pointer.
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Movie Controller displays standard play, pause, stop, rewind, and fast-forward 
controls for video and audio files.

Open File Dialog Box displays a dialog box for selecting a file to open.

Open File Dialog displays a dialog box for selecting a file to open. Stores the 
absolute path to the selected file in a variable.

Radio Buttons displays a set of radio-button selection controls in your piece.

Save File Dialog Box displays a dialog box for specifying a folder and file name.

Set Window Caption changes the text in the Presentation window title bar.

Slider displays a horizontal or vertical slider control in your piece.

Windows Control displays a common Windows Control. See “About Windows 
Control Knowledge Objects” on page 397.

Windows Control Get Property retrieves a Windows Control property value. See 
“About Windows Control Knowledge Objects” on page 397.Windows Control Set 

Property modifies a Windows Control property value. See “About Windows 
Control Knowledge Objects” on page 397.

Internet Knowledge Objects

Authorware Web Player Security sets trusting and nontrusting options for the 
Authorware Web Player. 

Launch Default Browser launches the specified URL with the system’s default 
Web browser.

Send E-mail sends a standard e-mail message within your piece.

RTF Objects Knowledge Objects

After you have created an RTF file using the RTF Objects Editor, you can add it 
to the flowline and edit how it functions on the flowline using Authorware RTF 
Knowledge Objects. For information about how to create an RTF file using the 
RTF Objects Editor, see “Using the RTF Objects Editor” on page 192.

Create RTF Object creates a new RTF Object ID in the Authorware Presentation 
window. It takes your RTF document and input and returns an RTF Object ID. 
Use this ID in all other RTF Knowledge Objects to identify your RTF Object. See 
Creating an RTF Object Knowledge Object in Authorware Help.

Save RTF Object exports a previously created RTF Knowledge Object to a new 
RTF document or graphic after it has been preprocessed, meaning that embedded 
variables have been replaced and external media has been imported. See 
“Exporting an RTF Object Knowledge Object” on page 212.
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Show or Hide RTF Object makes a previously created RTF Object visible or 
invisible during run time. See “Using the Show or Hide RTF Object Knowledge 
Object” on page 212.

Get RTF Object Text Range locates a specified text string and returns the position 
of that text string in an RTF Object. See “Using the Get RTF Object Text Range 
Knowledge Object” on page 213.

Insert RTF Object Hot Text Interaction creates an interaction linked to an RTF file 
and a specified number of responses. See “Inserting an RTF Object Hot Text 
Interaction Knowledge Object” on page 213.

Search RTF Object locates a specified text string and returns the position of that 
text string in an RTF file. See “Searching for text in an RTF Object Knowledge 
Object” on page 213.
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Tutorial

Macromedia Authorware 6.0 provides a powerful environment for creating and 
presenting interactive information. Authorware basic features let you develop 
presentations quickly and easily, while advanced features offer greater authoring 
control. You can foster a sensory experience for your users by incorporating 
interactions and rich media, such as Macromedia Flash files and MP3 audio, into 
your Authorware presentations. 

By completing this tutorial you’ll develop the Authorware skills necessary to create 
interactive training. When you finish creating the training, you’ll use one-button 
publishing to play your piece on the Web and prepare it for distribution on a CD.

Specifically, you will learn how to do the following:

• Analyze a completed Authorware piece and set up a new file

• Create a navigational structure using the flowline and icons

• Add multimedia to a piece, including graphics, sound, Flash movie clips, 
and animation

• Add user interactions

• Import an RTF file while maintaining formatting and a paging structure

• Add models to streamline authoring

• Use and modify Knowledge Objects to create an interactive quiz

• Package the completed piece using one-button publishing

The estimated time it takes to complete each section of the tutorial is noted at the 
beginning of the section.
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Tutorial structure
This tutorial consists of seven parts: 

• Analyze the completed tutorial

• Add graphics, sound, and a button to a new piece

• Add a main menu and navigation

• Import an RTF file

• Use models to streamline authoring

• Use Knowledge Objects to create a quiz

• Publish your piece with one-button publishing

The tutorial is designed so that you can complete it sequentially, or you can 
complete just the lessons in which you’re most interested.

Note: If you do complete the tutorial out of sequence, note that the later lessons assume 
that you’ve mastered the skills and understand the concepts introduced in earlier lessons.

What you should know

Although this tutorial is designed for beginning Authorware users, before 
completing it we recommend that you complete the Introduction to Authorware 
module—an interactive lesson, created in Authorware. You’ll find the module by 
choosing Help > Welcome. Next, click the Authorware Basics link and look for 
Module 2: Introduction to Authorware.

To promote a greater understanding of the tutorial, be sure you’re comfortable 
with the concepts presented in the module before starting this tutorial.

Analyze the completed tutorial
You can play the completed version of Introduction to Photography to better 
understand what your piece will look like when it’s finished. Additionally, by 
viewing the completed piece in the authoring environment, you’ll see the 
relationship between icons and the presentation of information.

This section of the tutorial takes approximately 10 minutes to complete.
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Objectives
After analyzing the completed tutorial, you will know the following:

• How the sequence of icons determines the flow and logic of the piece

• How to restart a piece

• How your completed piece will look

View the completed tutorial
Before you start to work on your own Authorware file, view the final version of 
the tutorial to see how your completed file should appear.

1 Start Authorware. In the New Project dialog box, click None.

2 Choose File > Open > File and select Camera6.a6p from the Tutorial folder 
within your Authorware 6 application folder. Then click Open.

If a message appears warning that the file is locked, click OK. 

The Presentation window appears, which displays the piece. The design 
window, which might be partially obscured by the Presentation window, 
displays the flowline for Camera6.a6p. The flowline includes several different 
types of icons, which you’ll learn more about as you complete this tutorial.

Design windowFlowline

Presentation windowIcon palette
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Navigate through the finished file

When you play a piece, you can use the controls in the Presentation window just 
as your user would.

1 Click the Continue button in the lower right corner. 

The items on the introductory screen fade away and the Main Menu for the 
piece appears. 

2 Select each choice from the Main Menu. You are first introduced to camera 
terminology. You can then test your knowledge about the parts of a camera. 
The Take Some Pictures segment lets you actually adjust camera settings and 
see how those settings affect a photograph. Last, you can take a quiz about 
camera parts.

3 In general, notice the order in which things happen. Pay attention to the 
various types of content, choices, and user interactions.

4 In the Design window, double-click the Introduction map icon to view the 
icons contained within.
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Icons can contain content or other icons. You create an application in Authorware 
by dragging icons from the icon palette onto the flowline. The order in which you 
place icons on the flowline corresponds to the order of events that take place when 
a user runs the application.

Some icons, like the design icon, require content such as graphics. Others, like the 
navigation icon, require you to specify certain settings. If, during playback, 
Authorware comes to an icon that requires additional specifications, the piece 
pauses and a Properties dialog box for that icon appears. Once you specify the 
settings, the piece resumes playing.

Restart the completed tutorial

When you restart a piece, Authorware follows the instructions at the top of the 
flowline and continues to execute them sequentially.

To restart your piece, do one of the following:

• Choose Control > Restart.

• Select Window > Panels > Control Panel and click Restart.

You can move the Control Panel to a convenient location on the screen.

1 When you finish viewing the file, you can either keep it open for reference, or 
close it by choosing File > Close. 

If you’ve made any changes to the document, don’t save them when you close 
the file.

Note: If you choose to keep the file open, you must launch a second instance of 
Authorware to continue the tutorial.

PauseRestart

Play

Stop
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Add graphics, sound, and a button to a new 
piece
The goal of an introductory sequence is to gain the attention of your audience: 
invite them in, and make them want more. To capture and maintain attention, 
you can rely on the Authorware tools for adding graphics, text, and sound. 

This section of the tutorial takes approximately 30 minutes to complete. 

Objectives
After opening a new file and creating the introductory sequence, you will know 
how to do the following:

• Select the size and background for the Presentation window

• Group icons on a flowline

• Create and edit text, select fonts and styles, and set margins

• Import external files

• Add audio

• Control pacing with wait icons

• Create and position a Continue button

• Erase content and add transitions

Create a new piece
Begin by opening a new file.

1 Choose File > New > File.

The New Project dialog box appears, listing Knowledge Objects you can use 
when you build a piece. 
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2 Click None; you’ll use Knowledge Objects later in the tutorial.

The Design window is where you organize how the piece is structured. The label 
Level 1 in the upper right corner of the Design window indicates that this flowline 
shows the overall arrangement of the piece.

3 To save and name the piece, select File > Save. In the File Name text box, 
type Camera.

4 Browse to your Authorware 6 application folder and save the file in the 
Tutorial folder. 

Authorware appends the A6P extension to the file name, which indicates this 
is an Authorware 6 file.

Note: As you complete the tutorial, remember to save your work frequently. 
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Set properties for the Presentation window 
You can set file properties that determine the appearance of the Presentation 
window, such as the size of the window and whether or not a title bar and menu 
will be included.

Size the Presentation window

When selecting the appropriate screen size for the Presentation window, specify a 
size no larger than the smallest monitor that you anticipate your audience will use. 
If you specify a larger size, part of the window might get cut off on the user’s 
machine. For this tutorial, you’ll select a 640 x 480 window, a size designed for 
most standard monitors.

1 Select Modify > File > Properties.

The File Properties dialog box appears. The settings you enter here affect the 
entire piece. 

2 In the Size pop-up menu, verify that 640 x 480 (VGA, Mac13”) is selected. 

Specify window options

The piece that you’ll create does not require a menu bar, which includes a File 
menu with the Quit command, or a title bar, so you will specify that these items 
not be included. Additionally, you will configure the Presentation window to 
appear centered on the user’s screen.
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1 Deselect Title Bar and Menu Bar.

2 Select Center on Screen, then click OK.

Create a title page
A title page in your piece serves the same purpose as a title page in a book—it 
indicates what the piece is about and motivates the user to learn more.

1 To create the title page, drag a display icon, used to display text and graphics, 
from the icon palette to the flowline. 

2 To name the icon, type the word Title while the icon is still selected.
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3 Double-click the Title display icon.

Authorware displays the Presentation window the way you configured it in the 
File Properties dialog box. The Presentation window is the workspace where 
you place graphics, text, and other visible objects. Additionally, as you learned 
when you analyzed the completed tutorial, in Play mode the Presentation 
window lets you interact with the piece as a user would. 

A toolbox also appears, containing tools for creating text and graphics 
specifically for the Title display icon. The name of the opened icon appears in 
the title bar of the toolbox.

Note: To organize your onscreen work area, you can drag the toolbox, dialog boxes, and 
windows to reposition them.

Create text using the toolbox

You’ll create the text object that will be a title for the piece.

1 In the toolbox, select the Text tool.

Text tool
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2 To change the default font, choose Text > Font. Select Arial if it appears on a 
list of fonts; otherwise, select Other and select Arial from the pop-up menu. 
Then click OK. 

Choosing a font without text selected changes the default font. All text that you 
create in this file will default to the font you selected.

3 In the Presentation window, click toward the upper left corner (exact 
placement isn’t necessary; you’ll align the text later), and type The World of 
35mm Photography. 

The line above the text shows the margin width. 

Note: While completing the tutorial, you may find it useful to undo your most recent 
change by choosing Edit > Undo.

4 To change the size of the text, select the entire line of text and choose 
Text > Size > 14.
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5 To make the text margin narrower, click the small square margin handle (not 
the dark triangle) at the right end of the margin line, and drag it toward the end 
of the word Photography. 

6 To make the text stand out against any color background, verify that it’s still 
selected and choose Window > Inspectors > Modes. Select Inverse from the 
modes palette.

With Inverse, text automatically appears light against dark backgrounds and 
dark against light backgrounds.

7 Close the modes palette and choose Control > Restart to play the piece from 
the beginning of the flowline.

Note: As you complete the tutorial, remember to save your work frequently.

Margin handle
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Add a graphic background
Adding a consistent background is a way of creating continuity within a piece. 
Icons for the background are stored in a library. Libraries are separate files that 
store content—such as text, graphics, sounds, and digital movies—in library 
icons. You can link a library to your piece to use the content within the library. 

Open a library

Using libraries has several advantages: you can use the same library icon repeatedly 
without increasing the size of your Authorware file, and any changes made to the 
library file automatically update all library icons in your piece. 

You’ll use a library icon to create the background for your piece’s title page.

1 Choose File > Open > Library. Within your Authorware application folder, 
browse to the Tutorial folder, select the Graphics.a6l file, and then click Open.

The library contains several icons created for use in this tutorial.

2 If the Design window is not visible, choose Window > Design > Camera.a6p. 

3 Drag the Title Background display icon from the library to the flowline above 
the Title icon.

When you place an icon from a library onto the flowline, the icon’s title appears 
in italics. 

4 To view the piece in the Presentation window, choose Control > Restart. Then 
choose Control > Pause.

Because you selected the Inverse mode for the text you created, it appears as a 
contrasting color against the blue background.
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5 In the Presentation window, drag the text that you typed to align it under the 
Title Background text.

Pausing play, and then positioning objects in the Presentation window, is a 
common authoring and design technique that you’ll use repeatedly.

6 When you finish viewing the piece, choose File > Save.

If you’re asked if you want to save the changes you’ve made to the library 
file, click Yes.

Import graphics

In addition to storing objects in the library, you can use the import feature to 
embed or link to files. When you embed a file, it’s stored in your Authorware 
piece. When you link to the file, Authorware stores the path to the file, but the file 
remains external. Linking to external content allows you to change the content 
and have those changes reflected in your piece without having to import the 
content again. When you publish your piece, Authorware automatically includes 
the linked external files. You’ll now link to a graphic of a camera for the title page. 
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1 Return to the flowline.

Note: If your monitor is small or configured in such a way that you cannot have the 
Presentation window open while viewing the Design window, then you’ll need to close 
the Presentation window by choosing Control > Stop throughout the tutorial, whenever 
necessary. To view the Presentation window from the point in the flowline where you left 
off, choose Control > Play.

2 On the flowline, Shift-double-click the Title display icon to open it.

The Title icon contains only the text you created. If you just double-clicked the 
icon, you would display just the title text. By holding Shift as you double-click, 
you also display the objects displayed last.

3 Choose File > Import.

4 In the Import Which File dialog box, browse within your Authorware 6 
application folder to Tutorial/Assets and select Camera1.png. 

5 Select Link To File, and then click Import.

Note: If, during the tutorial, you wish to view a list of external files linked to your piece 
along with their paths, you can choose Window > External Media Browser.

6 Drag the camera to the approximate location shown in the following 
illustration:
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7 With the graphic still selected, choose Window > Inspectors > Modes and 
select Alpha.

The graphic includes an alpha channel—an effect that creates variable 
transparency in an image, which lets you blend the image with images behind 
it. Upon import, the alpha channel is maintained, and it becomes visible when 
you select the Alpha mode. 

Note: As you complete the tutorial, remember to save your work frequently. 

Add Sound
You can link sound to your piece while also specifying how you want the sound 
to play. Authorware supports a variety of sound formats, including MP3 digital 
audio files.

1 Drag a sound icon from the icon palette to the flowline, placing it below the 
Title display icon. 
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2 Name the sound icon Camera Sound, and double-click it.

3 In the Sound Icon Properties dialog box, click Import and browse within 
your Authorware 6 application folder to Tutorial/Assets, then double-click 
Camera.mp3.

4 In the Sound Icon Properties dialog box, click the Timing tab. In the 
Concurrency pop-up menu, select Concurrent. 

When the Concurrency setting is Wait Until Done, the sound file plays 
completely before advancing to the next icon on the flowline. When 
Concurrent is selected, once the sound begins to play, Authorware immediately 
advances to the next icon down the flowline.

5 In the Play pop-up menu, verify that Fixed Number of Times appears.

6 In the text box below, type 2 for the number of times the sound will play.

7 Click the Play button to hear the sound based on the settings that you 
specified, and then click OK.

8 Restart and pause the piece by choosing Control > Restart and then 
Control > Pause.

Play
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Add a Continue button
Pacing is essential in creating an engaging presentation, and pauses offer an 
effective way of controlling the pace. You can use the Authorware wait icons to 
stop the presentation until the user decides to continue. 

With the Authorware standard Continue button, you’ll set up a pause as a first 
step in creating a transition to the Main Menu.

1 Add a wait icon after the Camera Sound icon on the flowline, and name the 
icon Continue. 

2 Double-click the icon to open the Wait Icon Properties dialog box. 

3 Deselect Key Press, verify that Show Button is selected, and click OK.

When the Key Press option is selected, pressing any key is the equivalent of 
clicking the Continue button. When the Key Press option is turned off, the 
user must click the Continue button to proceed through the piece.
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4 Restart the piece. When the Continue button appears, click it.

Position the Continue button

1 Choose Control > Restart. You can also press 1 on the numeric keypad. 

The Num Lock function on the numeric keypad must be turned off for the 
shortcut to work.

2 Pause the piece by choosing Control > Pause, or press 2 on the numeric keypad.

3 Drag the Continue button to the lower right corner of the 
Presentation window.

4 Close the Presentation window by choosing Control > Stop, or press 0 on the 
numeric keypad.
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Erase content and add transitions
As Authorware plays icons in sequence down the flowline, it displays the contents 
of each icon in addition to the contents of the previous icons. You can use erase 
icons to specify that certain icons do not play.

You’ll add a transition to erase the title page when the user clicks Continue.

1 Drag an erase icon to the flowline and place it below the wait icon.

The erase icon removes the contents of one or more icons—primarily display 
icons—from the screen.

2 Name the erase icon Erase Title Page. 

3 Double-click the Erase icon. 

The Erase Icon Properties dialog box appears.

You can control the way an item is erased by selecting the transition type. 
For example, you can make an item disappear quickly or gradually fade away.

4 On the Erase tab, select the Ellipsis (...) button to the right of the 
Transition text box. 

5 In the Erase Transition dialog box, verify that [Internal] is selected in the 
Categories column.

Internal transitions do not require Xtras—external plug-ins that offer 
additional functionality. 

6 In the Transitions column, scroll up and select Fade Out.
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7 Verify that .5 appears in the Duration text box and click OK.

Duration indicates the number of seconds the transition will take. 

8 To select what you want to erase, click the Icons tab in the Erase Icon 
Properties dialog box and verify that Icons to Erase is selected.

9 In the Presentation window, click the camera graphic. 

The camera, as well as the text that you typed (because they are both part of the 
same icon), fade out. In the Erase Icon Properties dialog box, the Title icon 
appears in the list of icons to erase. Although you are erasing just one icon here, 
Authorware lets you create a list of icons to erase.

10 To preview the transition, click the Preview button in the Erase Icon Properties 
dialog box. When you finish previewing the effect, click OK.

Note: As you complete the tutorial, remember to save your work frequently.

Test your work

1 Choose Control > Restart to restart the piece, and click the Continue button 
to see the entire introductory sequence. 

2 Choose Control > Stop.
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Group icons into a map icon
To organize icons in the Design window, you’ll group them into a map icon. Map 
icons can hold any number of other icons, including other map icons. They’re 
ideal for grouping your piece into logical sections, so it’s easy to see the entire 
structure at a glance. This is especially important for large pieces.

1 Click slightly above and to the left of the first icon on the flowline and drag the 
pointer to select all the icons on the flowline. Choose Modify > Group.

2 In the flowline, name the resulting map icon Introduction.

Color icons
You can change the color of icons to serve a variety of purposes: you might add 
color to icons that still require content, for example, or you might make all icons 
that comprise a segment a specific color.

For the tutorial, you’ll change the color of the Introduction map icon to make the 
level 1 flowline more visible as you work with multiple Design windows. As you 
complete the tutorial, you can use a strategy to color icons that you determine will 
suit your needs.

1 Verify that the Introduction map icon is still selected.

2 On the icon panel, select orange from the icon color boxes. 

Add a main menu and navigation
You’ll now build an interaction that serves as a main menu. You can continue 
using the Camera.a6p file you created in the previous section, or you can open the 
Camera2.a6p file included in the Tutorial subfolder of your Authorware 6 
application folder.

If you do open the Camera2.a6p start file, immediately choose File > Save As and 
save the file with a new name to maintain an unmodified version for future use.

This section of the tutorial takes approximately 45 minutes to complete. 
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Objectives
After adding a main menu and navigation, you will know how to do the following:

• Create a menu with hot spots

• Insert map icons as structural placeholders

• Create a framework to ensure consistency

• Use a calculation icon to end a session

• Use the Quit function

Add graphics to the segment
1 If the Design window is not open, choose Window > Design, and then 

choose the name of the file in which you’re working (either Camera.a6p 
or Camera2.a6p).

2 On the flowline, add a map icon after the Introduction icon and name it 
Main Menu.

3 Double-click the Main Menu map icon to open it. 

When you open the map icon, the label in the upper right corner of the Main 
Menu flowline window says Level 2, indicating that this flowline is a subset of 
the Level 1 flowline. 
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4 Drag the Lesson Title Background icon from the library to the 
Main Menu flowline.

5 On the Main Menu flowline, add a display icon below Lesson Title 
Background and name it Lesson Title, then double-click the Lesson Title 
icon to open it.

6 To import the camera graphic for this segment, choose File > Import and 
Browse within your Authorware 6 application folder to Tutorial/Assets. 

7 Select Camera2.png, and then select Link to File and click Import. 

For the moment, it doesn’t matter where, in the Presentation window, the 
camera graphic appears.

8 With the graphic still selected, use the modes palette to select Alpha. (If the 
modes palette is not open, choose Window > Inspectors > Modes). 
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Align objects in the Presentation window
Once you’ve created and imported objects appearing in the Presentation window, 
you’re ready to start and pause your piece to adjust how the objects are aligned.

Use flags to view segments of your piece

As your file grows, you’ll often find it more efficient to run specific segments of 
your piece rather than running the entire piece from the beginning of the flowline. 
You can use start and stop flags to run just the section on which you’re working.

1 From the icon palette, drag a start flag to the beginning of the Main Menu flowline.

2 To restart the piece from the start flag, do one of the following:

• Choose Control > Restart from Flag.

• Click the Restart from Flag button on the toolbar. 

Align the graphics

1 Pause the piece. 

2 In the Presentation window, verify that the Lesson Title Background dark 
rectangle appears in the correct location, as shown in the following illustration. 
Drag the camera graphic to the approximate location shown in the following 
illustration:

Note: In addition to dragging an object in the Presentation window to place it, you can 
use the arrow keys on your keyboard to “nudge” a selected object one pixel at a time in 
the direction of the arrow.
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Add menu items
Menus provide both a point of departure and a point of return for your user. By 
using interaction and navigation icons, you can easily create a branching flowline 
that allows a user to follow nonlinear sequences, and a navigational structure that 
includes hot spots the user can click to go to another segment.

1 On the Main Menu flowline, add an interaction icon below Lesson Title and 
name it Select a Topic. 

An interaction icon not only lets users interact with a piece; it also behaves like 
a display icon by showing graphics and text in the Presentation window.

You’ll attach icons to this interaction that comprise the Main Menu. 

2 Double-click the Select a Topic icon to open it, and select the Text tool from 
the toolbox.

3 In an earlier section, you changed the default text to Arial. Use the Text menu 
to verify that Arial is still the selected font. For the text size, choose 14 point, 
and choose Bold for the style.

4 If the modes palette isn’t open, choose Window > Inspectors > Modes. Select 
Inverse and close the modes palette.

5 Click near the upper left corner of the Presentation window and type Main 
Menu, then press Enter three times.

6 Choose Text > Size and select 10 point. 

7 In the Presentation window, type 1. Photographic Terminology, then press 
Enter twice.

8 Type 2. Parts of a Camera, and again press Enter twice.
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9 Type 3. Take Some Pictures, and press Enter twice.

10 Type 4. Camera Quiz.

11 Click the square text margin handle (not the dark triangle) at the right end of 
the margin line, and drag it toward the end of the word Terminology.

Set the navigational structure
You’ve defined the graphic and text elements for your main menu.You’re now 
ready to define the response: the action the user takes. Later in the tutorial, you’ll 
define the result of that action. For menu items, the expected response is that the 
user clicks the menu text. The result is that the linked text takes the user to the 
corresponding segment.

1 On the Main Menu flowline, place a navigate icon to the right of the Select a 
Topic icon. 

2 In the Response Type dialog box, select Hot Spot, and click OK.

The Response Type dialog box lets you select how your user will interact 
with an object.
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3 On the Main Menu flowline, name the unlinked navigate icon Navigate to 
Terminology.

4 On the Main Menu flowline, double-click the response symbol above the 
Navigate to Terminology icon.

The response symbol offers access to the Response Properties dialog box, where 
you can configure settings for the response type.

5 On the Hot Spot tab of the Response Properties dialog box, in the Size text 
boxes, specify 196 for the pixel width of the hot spot (under the X) and 30 for 
the pixel height (under the Y). 

You do not need to enter values in the Location text boxes, because you will set 
the location of the hot spots directly in the Presentation window.

6 In the Keys text box, type 1.

The 1 indicates that the user can either type 1 or click the hot spot to select the 
first menu item.

7 Select Highlight on Match.

This causes the selection to highlight when the user clicks it.

8 To display a pointing finger when the user rolls over the hot spot, click the 
Ellipsis (...) button to the right of the Cursor text box. In the Cursors dialog 
box, scroll down and double-click the pointing finger. 

The Response symbol is above the icon
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9 On the Response Properties dialog box, click OK.

Add and configure the remaining navigation icons

1 Place another navigation icon on the Main Menu flowline to the right of the 
Navigate to Terminology icon, and name it Navigate to Parts of Camera.

2 Double-click the response symbol above the Navigate to Parts of Camera icon. 
On the Hot Spot tab, type 2 in the Keys text box. Then click OK.

The settings you specified for the Navigate to Terminology hot spot are now 
the default response type settings, including the pointing finger cursor.

3 Place two more navigation icons to the right of the others, and name them 
Navigate to Take Pictures and Navigate to Quiz, respectively. 
Tutorial 85



4 Double-click the response symbol for Navigate to Take Pictures, type 3 in the 
Keys text box, then click OK.

5 Double-click the response symbol for Navigate to Quiz, type 4 in the Keys text 
box, then click OK.

Place hot spots on the Main Menu

You can view the hot spot areas in the Presentation window, and place them over 
the text that you wish to link.

1 Choose Control > Restart from Flag, then choose Control > Pause.

2 Taking care to avoid dragging the sizing handles, drag the menu text within the 
Lesson Title Background shaded rectangle to place it, as shown in the following 
illustration:
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3 Drag each of the four hot spots to their corresponding menu selections.

For example, drag the Navigate to Terminology hot spot object to the text that 
reads 1. Photograhic Terminology.

Although you have the hot spots in place, they are not yet linked to other 
segments in your piece. As you complete a segment, such as adding photographic 
terminology or the camera quiz, you’ll link it to the Main Menu.

Create a master framework
You can use framework icons to further define the navigation structure. When you 
set up a framework, you specify what appears on each page attached to the 
framework icon. The master framework that you’ll create will include a Menu 
button, Quit button, and a background that appears on every page after the 
introductory segment.

1 Drag a framework icon to the Level 1 flowline, below the Introduction icon, 
and name it Master Framework. 

2 Drag the Main Menu icon to the right of the Master Framework icon.
Tutorial 87



3 Double-click the Master Framework icon to open its flowline.

The Master Framework flowline is divided into two panes: the Entry pane on 
top, and the Exit pane on the bottom. The icons in the Entry pane are default 
navigation controls.

4 To delete the default icons, select the Gray Navigation Panel icon and Shift-
Click the Navigation Hyperlinks interaction icon, then press Delete.

5 When the alert appears, click Select All Attached Icons.

6 Drag the Title Background icon from the library to the Master Framework 
flowline.

7 Drag an interaction icon from the icon palette to the Master Framework flowline, 
place it below the Title Background icon, and name it Global Navigation.

Add a Menu button
A menu button in your piece gives users the option of returning to the Main 
Menu at any point after playing the introduction. 

1 Drag a map icon to the right of the Global Navigation icon on the Master 
Framework flowline.

2 In the Response Type dialog box, verify that Button is selected, and click OK.
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3 On the Master Framework flowline, name the map icon Menu.

4 Double-click the Menu response symbol. Click Buttons and verify that the 
button with the description Standard Windows Button System is selected. 
Click OK.

5 In the Response Properties dialog box, click the Ellipsis (...) button to the right 
of the Cursor text box. Select the pointing finger in the Cursors dialog box. 
Then click OK.

6 In the Response Properties dialog box, click OK.

Add the navigation for the Menu button

You’ll now specify that the Menu button return users to the Main Menu.

1 On the Master Framework flowline, double-click the Menu map icon.

2 Drag a navigate icon to the Menu flowline, and name it Navigate to Main Menu.

3 Double-click the Navigate to Main Menu icon. In the Navigate Icon Properties 
dialog box, verify that Anywhere appears in the Destination pop-up menu and 
Master Framework in the Framework pop-up menu.
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4 In the Page list, select Main Menu, and then click OK to link the Menu button 
to the Main Menu.

5 Close the Menu flowline.

Add a Quit button
Once your users enter an application, you don’t want them to feel trapped within. 
A Quit button offers users a way of exiting the application or, if they’ve clicked the 
button in error, a way of returning to the Main Menu.

1 On the Master Framework flowline, add a map icon to the right of the Menu 
icon, and name it Quit.

2 Double-click the Quit icon. Add an interaction icon to the Quit flowline and 
name it Exit the Program.
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3 Double-click the Exit the Program icon. Select the Text tool in the toolbox and 
type, anywhere in the Presentation window, Are you sure you want to exit the 
Camera Tutorial?

The user will see this text after clicking the Quit button and will then have the 
option of clicking a Yes or No button.

4 If the modes palette is not open, choose Window > Inspectors > Modes. Verify 
that Inverse is selected, then close the modes palette.

5 Choose Control > Stop or press 0 on the numeric keypad to close the 
Presentation window. 

As you learned earlier in the tutorial, the Num Lock function on the numeric 
keypad must be turned off for the shortcut to work.

Add a Yes response

Users who want to quit will click a Yes button, which you’ll configure to exit the piece.

1 On the Quit flowline, place a map icon to the right of the interaction icon. In 
the Response Type dialog box, verify that Button is selected, and click OK.

2 Name the map icon Yes, and double-click its response symbol. 

3 On the Button tab of the Response Properties dialog box, click the Ellipsis (...) 
button to the right of the Cursor text box. In the Cursors dialog box, select the 
pointing finger, then click OK. 

4 In the Response Properties dialog box, again click OK.
Tutorial 91



5 On the Quit flowline, double-click the Yes icon. Add a calculation icon to the 
Yes flowline and name it Quit. 

One of the purposes of a calculation icon is to execute a function.

6 Double-click the Quit icon to display the Calculation window. 

7 To specify the function to add to the Quit icon, choose Window > Functions. 
Verify that All appears in the Category pop-up menu.

8 In the scrolling list below the Category pop-up menu, scroll down and 
click Quit. Read the description for the function, which appears in the 
Description text box.

9 Click the Paste button, then click Done.
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10 In the calculation window, select the text within the parentheses that says 
option and type 1. 

The 1 option, as described in the Functions dialog box, quits Authorware.

11 Close the calculation window. When the alert appears, press Enter.

12 Close the Yes flowline.

Add a No response

Users who don’t want to quit will click a No button, which you’ll configure to 
return them to the Main Menu.

1 On the Quit flowline, place a map icon to the right of the Yes map icon and 
name it No.

The same button style and pointing finger cursor that you selected for the Yes 
button are still selected; you do not need to open the Response Properties 
dialog box as you did for the Yes button.

2 Double-click the No icon to open the No Flowline. Add a navigate icon to the 
No flowline and name it Main Menu. Then close the No flowline.
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Place the buttons
1 On the Master Framework flowline, double-click the Global Navigation 

interaction icon. Drag and use the keyboard arrow keys to place the buttons 
side by side in the upper right corner of the Presentation window.

2 Choose Control > Restart from Flag.

3 Click the Quit button and pause the piece.
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4 Drag the Yes and No buttons to the lower edge of the Lesson Title 
Background rectangle. 

5 Double-click the text Are you sure you want to exit the Camera Tutorial? In the 
toolbox, select the Text tool. Click the Are you sure you want to exit the Camera 
Tutorial? text and drag the right margin handle to the left to make the margin 
narrower, so that the text will fit inside the Lesson Title Background rectangle.

6 In the toolbox, select the Pointer tool. Drag the text and place it above the Yes 
and No buttons.

7 Choose Control > Play to start the piece from where you left off, and click No.

Because you haven’t specified where the No button should take users, the 
Navigation Properties dialog box appears.
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8 In the Navigation Properties dialog box, under Page, select Main Menu, which 
is where you want users to go upon clicking the No button. Then click OK.

9 Authorware takes you to the Main Menu. Pause the piece and close the Master 
Framework flowline.

Note: As you complete the tutorial, remember to save your work frequently.

Import an RTF File
Now that you’ve created a framework and navigational structure for your piece, 
you’re ready to add content. First, you’ll create the terminology section by 
importing text and graphics from an external RTF file.

When importing the file, Authorware can preserve formatting information such as 
bold text, italics, and page breaks. Additionally, Authorware creates the icon 
structure and imports the content into the icons in a single step. As you complete 
the tutorial, you’ll find the way Authorware handles RTF files convenient for 
importing five pages—just imagine how valuable the feature would be if you were 
importing 50 pages. 

To complete this section, you can continue using the file you created in the 
previous section, or you can open the Camera3.a6p file included in the Tutorial 
subfolder of your Authorware 6 application folder.

If you do open the Camera3.a6p start file, immediately save the file with a new 
name to maintain an unmodified version for future use.

This section of the tutorial takes approximately 45 minutes to complete.
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Objectives
After you complete this section, you will know how to do the following:

• Use the RTF Objects Editor to edit an external RTF file

• Import an external RTF file into your Authorware piece

• Align and erase text blocks in the Presentation window that comprise a series 
of sequential pages

Create a terminology segment
You’ll begin by adding the background and a graphic to a map icon. 

1 On the Level 1 flowline, add a map icon to the right of the Main Menu icon, 
and name it Terminology.

2 Double-click the Terminology map icon and drag the Lesson Title Background 
icon from the library to the Terminology flowline.

3 Place a display icon below the Lesson Title Background icon and name it Camera.
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4 Double-click the Camera icon. Choose File > Import and browse to the 
Tutorial/Assets folder within your Authorware 6 application folder. Select 
Camera_top.png and click Import.

5 To view the alpha transparency in the image, choose Window > Inspectors > 
Modes, and select Alpha.

6 Drag the camera graphic to the lower right area of the Presentation window, as 
shown in the following illustration:

7 In the toolbox, select the Text tool. Click toward the upper left corner in 
the Presentation window (don’t worry about precise placement) and type 
Terminology. 

8 In the Presentation window, select the text. Use the Text menu to verify that the 
text is Arial. Make the text 14 point plain style. 

9 In the modes palette, select Inverse. 

Edit an external file with the RTF Objects 
Editor
The RTF Objects Editor lets you create Rich Text Format documents that include 
formatted text, graphics, and other objects. Using the RTF Objects Editor, you can 
create RTF documents and easily insert the documents into an Authorware piece. 

Additionally, users unfamiliar with Authorware can create RTF files independent 
of Authorware for inclusion in an Authorware piece. Many of the features in the 
Authorware RTF Objects Editor are similar to those found in word-processing 
applications. In the RTF files, You can include any of the following objects:

• Text (including linked text), graphics, and shapes

• Authorware variables and expressions
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• Flash and QuickTime movies

• PowerPoint presentations 

• Any other ActiveX objects

1 Choose Commands > RTF Objects Editor. 

2 In the RTF Objects Editor, choose File > Open Document.

3 Browse to the Tutorial/Assets folder within your Authorware 6 application 
folder and open Terminology.rtf.

Change text formats

With the RTF Objects editor, you can quickly change the format of a file. You’ll 
format the heading for three sections to make the text bold.

1 Select the Lens heading text and click the Bold button.

2 Repeat step 1 to add boldface to the Aperture ring heading and the Shutter 
Release heading.

Note: The RTF file contains page breaks, which do not appear in the editor, after 
each definition. When you import the file, Authorware creates a new display icon at 
each page break.

3 To save your changes to the RTF file, in the RTF Objects Editor choose File > 
Save As. Name the new file Terminology_edited and save it within Tutorial/
Assets, in your Authorware 6 application folder. Exit the editor by choosing 
File > Exit.

By saving the file with a new name, you maintain an unedited version of the 
RTF file for future use.
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Import the RTF file
Now that you’ve finished editing the RTF file, you’re ready to import it into your 
Authorware piece.

1 On the Terminology flowline, add a display icon below the Camera display 
icon, and name it Term.

2 Double-click the Term icon and choose File > Import. Browse to the Tutorial/
Assets folder within your Authorware 6 application folder and select 
Terminology_edited.rtf.

3 Select Link to File and click Import.

When you link to the file, you can edit the RTF file without having to 
reimport the file.

4 In the RTF Import dialog box, verify that Create New Display Icon and 
Standard are selected, and click OK.

On the Terminology flowline, Authorware creates a display icon for each term, 
using the page breaks in the RTF file to determine how the terms are divided.
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Rename the terms

The icons Authorware added to the Terminology flowline follow a numerical 
naming convention. The icon after Term is called Term 2, next is Term 3, and so 
on. To make the names more meaningful, so they indicate the part of the camera 
that the text describes, you’ll rename the terminology icons.

1 On the Terminology flowline, select the Term icon and rename it Lens.

2 Select the Term 2 icon and rename it Aperture Ring.

3 Rename the Term 3 icon Shutter Release.

4 Rename the Term 4 icon Shutter Speed Indicator.

5 Rename the Term 5 icon Film Advance Lever. 

Align the text
After importing text from RTF files into your piece, you can edit and align it as if 
you had created the text directly in Authorware. The Text tool in the toolbox lets 
you adjust the margin size, and you can use the Pointer tool to place the text block.

1 On the Terminology flowline, double-click the Lens icon.

2 In the toolbox, select the Text tool. 
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3 Click the text in the Presentation window and slide the right square margin 
handle to the left to make the margin narrower, so that the text will fit within 
the Lesson Title Background dark rectangle. (The first line of the definition 
should wrap at the word to.)

4 Select the Pointer tool in the toolbox, and use it to drag the text to the 
approximate location where it appears in the following illustration.

5 If the modes palette is not open, choose Windows > Inspectors > Modes. 
Select Inverse.

6 Return to the Terminology flowline and double-click the Aperture Ring icon.
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7 In the Presentation window, again use the Text tool to decrease the margin size, 
and use the Pointer tool to move the text to the approximate area where it 
should appear:

8 In the modes palette, select Inverse.

9 On the Terminology flowline, double-click the Shutter Release icon, and repeat 
steps 7 and 8 to decrease the margin, place the text, and make the text inverse.

10 On the Terminology flowline, double-click the Shutter Speed Indicator icon, 
and again repeat steps 7 and 8.

11 On the Terminology flowline, double-click the Film Advance Lever icon, and 
(you guessed correctly) repeat steps 7 and 8.

Add wait and erase icons

If you left the terms on the Terminology flowline as they are currently configured, 
Authorware would play them stacked on top of each other. To ensure that only 
one term plays at a time, you’ll add wait and erase icons for each term in the 
flowline except the last.

1 On the Terminology flowline, add a wait icon after the Lens icon and name 
it Continue.

2 Double-click the Continue icon. In the Wait Icon Properties dialog box, verify 
that Key Press and Show Button are selected. Verify that Mouse Click is not 
selected, and click OK.
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3 On the Terminology flowline, add an erase icon after the Continue icon and 
name it Erase Term.

4 Click the Continue icon, and Shift-click the Erase Term icon to add it to 
the selection.

5 Choose Edit > Copy.

Note: To copy the icons, you can also use the keyboard shortcut Control+C.

6 On the Terminology flowline, click after the Aperture Ring icon to move the 
Paste Hand to that location, and choose Edit > Paste (or press Control+V).

Copies of the Continue and Erase Term icons are pasted on the flowline.

7 Paste copies of the Continue and Erase Term icons after the Shutter Release 
icon and the Shutter Speed Indicator icon (but not after the Film Advance 
Lever icon).
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Align and erase objects
You’re now ready to create and align objects for each term in the Presentation 
window, then specify the objects to erase when the user clicks Continue.

1 Add a start flag to the beginning of the Terminology flowline and choose 
Control > Restart from Flag. Then choose Control > Pause.

Note: If the start flag is missing from the icon palette, click the area on the palette where 
it should be to create a new start flag.

2 Move the objects in the Presentation window, as necessary, to better align them.

3 Double-click the lens text to display its toolbox. Select the Rectangle tool.

4 If the modes palette is not open, choose Window > Inspectors > Modes. 
Select Inverse.

5 In the Presentation window, drag the mouse pointer to draw a rectangle around 
the camera lens.

6 Choose Control > Play and click the Continue button.
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7 In the Icons tab of the Erase Icon Properties dialog box, verify that Icons to 
Erase is selected. In the Presentation window, click the text so that the Lens 
icon appears on the list of icons to erase. Then click OK.

8 Choose Control > Pause and align the objects on the screen, as necessary.

9 Double-click the Aperture Ring text to display its toolbox. Select the Rectangle 
tool and draw a rectangle around the camera’s aperture ring. 

Inverse mode should still be selected in the modes palette.

10 Choose Control > Play and click the Continue button.

11 In the Presentation window, click the Aperture Ring text so that the Aperture 
Ring icon appears in the list of icons to erase in the Erase Icon Properties dialog 
box. Then click OK.
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Configure the Shutter Release page

You’ll follow steps similar to the previous steps to align and create objects for the 
Shutter Release term.

1 Choose Control > Pause and align the objects on the screen, as necessary.

2 Double-click the Shutter Release text to display its toolbox. Select the 
Rectangle tool and draw a rectangle around the camera’s shutter release.

3 In the modes palette, verify that Inverse is selected. 

4 Choose Control > Play and click the Continue button.

5 In the Presentation window, click the Shutter Release text so that the Shutter 
Release icon appears in the list of icons to erase. Then click OK.

Configure the Shutter speed indicator page

The shutter speed indicator page also needs alignment and a graphic object.

1 Choose Control > Pause and align the objects on the screen, as necessary.

2 Double-click the Shutter Speed Indicator text to display its toolbox. Select the 
Rectangle tool and draw a rectangle around the camera’s shutter speed indicator.
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3 In the modes palette, verify that Inverse is selected.

4 Choose Control > Play and click the Continue button.

5 In the Presentation window, click the Shutter Speed Indicator text so that the 
Shutter Speed Indicator icon appears in the list of icons to erase. Then click OK.

Configure the Film Advance Lever Page

By now, you can probably guess what steps you need to complete for the Film 
Advance Lever Page.

1 Choose Control > Pause and align the objects on the screen, as necessary.

2 Double-click the Film Advance Lever text to display its toolbox. Select the 
Rectangle tool and draw a rectangle around the camera’s film advance lever.
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Add a Flash movie
You can import a Flash movie for the lens term that uses animation to demonstrate 
how light enters the camera lens. Authorware lets you scale the dimensions of the 
movie upon import. Additionally, you can use the Sprite Icon Properties dialog box 
to specify a mode, such as transparent or inverse, for the movie.

1 On the Terminology flowline, click below the Lens icon so that the Paste Hand 
appears there.

2 Choose Insert > Media > Flash.

3 In the Flash Asset Properties dialog box, click Browse. In the Open Shockwave 
Flash Movie dialog box, browse to the Tutorial/Assets folder within your 
Authorware 6 folder and double-click Camera_lens.swf.

4 In the Flash Asset Properties dialog box, verify that Linked, Image, Sound, and 
Loop are selected as playback options.

You are specifying that the movie will be linked rather than embedded, that 
the image is included, and that the movie, upon reaching the end, loops to 
the beginning.

5 In the Scale text box, type 75 for the movie to appear 75 percent of its original 
size. Click OK.
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6 On the Terminology flowline, double-click the Flash icon to open the Sprite 
Icon Properties dialog box. Click the Display tab. From the Mode pop-up 
menu, select Transparent. Click OK.

7 Choose Control > Restart from Flag, then pause the piece. In the Presentation 
window, drag the Flash movie and place it under the Lens definition.

You might need to move the Lens text up. 

Erase the Flash movie by modifying properties

The Flash movie should appear with the Lens term only. To specify this, you’ll 
add the movie to the list of icons to erase when the user clicks Continue from 
the lens page.

Note: Anytime you wish to modify an icon’s properties, you can simply double-click the icon.
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1 On the Terminology flowline, double-click the first Erase Term icon that 
appears after the Flash icon.

The Erase Icon Properties dialog box appears.

2 In the Presentation window, click the Flash movie.

On the Icons tab of the Erase Icon Properties dialog box, the Flash icon appears 
in the list of icons to ease.

3 Click OK to close the dialog box.

Organize the flowline
To follow the recommended practice of organizing your icons within logical 
groups, you’ll create maps on the Terminology flowline for each of the five terms.

1 Drag to select the Lens and Flash icons as well as the Continue and Erase Term 
icons that appear immediately after.

2 Choose Modify > Group and name the map icon Lens Term.
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3 Select the Aperture Ring icon as well as the wait and erase icons that are next on the 
flowline, and choose Modify > Group. Name the map icon Aperture Ring Term.

4 Select the Shutter Release icon as well as the wait and erase icons that are next 
on the flowline, and choose Modify > Group. Name the map icon Shutter 
Release Term.

5 Select the Shutter Speed Indicator icon as well as the wait and erase icons that 
are next on the flowline, and choose Modify > Group. Name the map icon 
Shutter Speed Term.

6 The Film Advance Lever icon does not require a wait or erase icon, since 
it displays the last of the terms. Still, for consistency, select it and choose 
Modify > Group to create a map icon. Name it Film Advance Term.
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Link the photographic terminology to the 
Main Menu
Now that you’ve included the terminology in your piece, you can link it to the 
Main Menu.

1 Choose Control > Restart and click the Continue button.

2 When the Main Menu appears, click 1. Photographic Terminology.

Because you haven’t defined the link for the hot spot, the Navigate Icon 
Properties dialog box appears.

3 The Page field includes a list of icons to which you can navigate: the Main 
Menu and the Terminology map icons. You want the hot spot to take users to 
the terminology; click the Terminology icon, and click OK.

The Lens definition appears in the Presentation window.

4 Close the Terminology flowline.

5 Click the Continue button to view all the terms.

Note: As you complete the tutorial, remember to save your work frequently.

Use models to streamline authoring
A model contains one or more icons together with their branching structures. 
Models are built with Authorware and saved in separate files that can be shared 
among developers. You can load models into your Authorware file, where they’ll 
be available for you to insert anywhere in an application you’re building. As you’ll 
see in this section, models can save you time and effort.

You’ll now load and paste two existing models that contain icons for two of 
your menu topics. 

To complete this section, you can continue using the file you created in the 
previous section, or you can open the Camera4.a6p file included in the Tutorial 
subfolder of your Authorware 6 application folder.
Tutorial 113



If you do open the Camera4.a6p start file, immediately save the file with a new 
name to maintain an unmodified version for future use.

This section of the tutorial takes approximately 15 minutes to complete. 

Objectives
After completing this section, you will know the following:

• What models are and how to add them to your Authorware piece

• The benefits of using models

Add models
You can access models for this tutorial through the Knowledge Objects window.

1 Go to the Level 1 flowline.

2 If the Knowledge Objects window is not open, choose Window > 
Knowledge Objects.

Icons in the Knowledge Objects window are sorted in alphabetical order. To see 
the description of an icon, click it. 

3 In the Category pop-up menu, select Tutorial.

4 Select the CameraParts map icon and drag it to the flowline to the right of the 
Terminology map icon.
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5 Select the TakePictures map icon and drag it to the flowline to the right of the 
CameraParts map icon.

Link models to the Main Menu
Once your models are in place, you can link them to the Main Menu just as you 
did for other segments in your piece that branch from the Main Menu.

1 Choose Control > Restart. In the Introductory segment, click the 
Continue button.

2 On the Main Menu page, click 2. Parts of a Camera.

3 In the Navigate Icon Properties dialog box, click Parts of a Camera in the list of 
pages, to link and navigate to that icon. Click OK.
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4 Authorware takes you to the Parts of a Camera page. Click the Menu button.

5 When you return to the Main Menu, click 3. Take Some Pictures.

6 In the Navigate Icon Properties dialog box, select Take Some Pictures to link 
and navigate to that icon. Click OK.

You’ve now linked the two models to the Main Menu.

Note: As you complete the tutorial, remember to save your work frequently.
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Test the Models

Now that you’ve added two segments, you’ll play and test them.

1 Restart your piece. After the Introductory segment, click Continue.

2 On the Main Menu, click 2. Parts of a Camera, then test each question by 
answering it.

To further understand the interactions, see how the segment reacts when 
you give both correct and incorrect answers, and click the Hint button for 
some questions.

3 When you finish testing the Parts of a Camera segment, click the Menu button 
to return to the Main Menu.

4 Click 3. Take Some Pictures.

5 Follow the instructions in the Presentation window to adjust the aperture and 
shutter speed indicator, then click the shutter release button. Try doing this 
with several combinations of aperture and shutter speed settings.

6 When you’ve finished taking pictures, choose Control > Stop.

7 On the Level 1 flowline, double-click the Parts of a Camera icon to open 
its flowline.

8 Examine the flowline to understand more about the authoring involved 
in creating this model. When you finish viewing the Parts of a Camera 
flowline, close it.

Use Knowledge Objects to create a quiz
A Knowledge Object is a prebuilt packet of logic, encapsulated in a model, that 
you insert into an Authorware piece. Unlike the models that you used in the 
previous section, however, Knowledge Objects include wizards that automate 
setting up and modifying content.

Knowledge Objects are powerful productivity tools that benefit both 
inexperienced and experienced developers. They offer a way of accomplishing 
common tasks easily and efficiently, as well as a way to automate repetitive tasks.

You’ll use the Quiz Knowledge Object to set up a scorable quiz about the parts 
of a camera.

To complete this section, you can continue using the file you created in the 
previous section, or you can open the Camera5.a6p file included in the Tutorial/
Assets folder within your Authorware 6 application folder.

If you do open the Camera5.a6p start file, immediately save the file with a new 
name to maintain an unmodified version for future use.

This section of the tutorial takes approximately 1 1/2 hours to complete.
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Objectives
After you complete this section, you will know how to do the following:

• Add a Knowledge Object to the flowline

• Use a Knowledge Object to determine scoring options for a quiz

• Specify quiz design

• Import graphics for the quiz

• Add interactive quiz questions

• Modify styles and icons that comprise the Knowledge Object

• View quiz data

Add icons and graphics for the quiz
Before using the Knowledge Object, you’ll add icons and title text for the segment.

1 On the level 1 flowline, add a map icon to the right of the Take Some Pictures 
icon and name it Camera Quiz.

2 Double-click the Camera Quiz map icon. Add a display icon to the Camera 
Quiz flowline and name it Quiz Text.
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3 Double-click the Quiz Text icon. Select the Text tool and type Camera Quiz 
toward the upper left corner of the Presentation window. Text placement 
doesn’t need to be precise.

4 In the Presentation window, select the text. Use the Text menu to verify that the 
text is Arial. Make the text 14 point plain style. 

5 If the modes palette is not open, select Window > Inspectors > Modes. Select 
Inverse if it’s not already selected. Close the modes palette.

6 Place a start flag at the beginning of the Camera Quiz flowline. Restart the 
piece from the flag, and arrange the Camera Quiz text under the Introduction 
to Photography text.
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Specify Knowledge Object Settings
The first part of using the Quiz Knowledge Object involves determining the quiz 
setup, such as the login options, the way in which the quiz is scored, and the 
generic feedback that should appear in the quiz. A wizard in the Knowledge 
Object greatly simplifies this process.

1 If the Knowledge Objects window is not open, choose Window > Knowledge 
Objects. In the Category pop-up menu, select (All).

2 In the list of Knowledge Objects, scroll down to the Quiz Knowledge Object. 
Drag the Quiz Knowledge Object icon to the end of the Camera Quiz flowline.

In addition to adding the Knowledge Object to the flowline, Authorware adds 
a framework icon.

Specify the Screen size and quiz media path

You’ll specify that the screen size of the quiz is the same as the rest of your piece. 
You’ll also see the path where Authorware stores your quiz results.

1 Read the first page of the wizard, then click Next.

2 For screen size, verify that 640 x 480 is selected.

3 Along the bottom of the window, you see a text box that displays where 
Authorware will store the Knowledge Object quiz media. You’ll accept the 
default location shown. Click Next.

Determine the layout style

The Knowledge Object includes several templates, including graphic objects, that 
you can select.

1 In the Select a Layout list, click each selection to preview it.
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2 Select 3 Educational as the layout, then click Next.

Create default quiz options

You can now determine how you want the quiz and questions to be displayed.

1 Review the default settings.

Note: The Distractor Tag determines how to number or letter multiple-choice options.

2 When you finish reviewing the settings, click Next.

Set login options

You’ll configure the quiz to let users enter their names to log in. Authorware 
saves user login data in a DAT file, which you’ll learn about later in this section 
of the tutorial.

1 Select Show Login Screen at Start.

2 Deselect the following options:

• Ask for User ID

• Ask for Password

• Limit User to # Tries Before Quitting
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3 To determine where Authorware will store the quiz results, refer to the path in 
the Records Directory text box. Make of note of this path, because you will 
need it to find the data files the quiz will generate. Click Next.

Specify data tracking options

Data tracking options let your further define how you’ll track user information. 
For the tutorial, you’ll store the information in a text file. Note, however, that you 
also have options to store information in an Open Database Connectivity 
(ODBC) database, a common standard for connecting to a database, and an 
AICC compliant learning management system (LMS). For more information 
about both options, see “Connecting with databases” on page 356 and “Using 
Knowledge Track to set up a course” on page 348.

• Verify that Track User Progress and Report To is selected, as well as Text file, 
and click Next.

Add scoring options for questions 

The quiz Knowledge Object lets you determine when and how the user 
receives feedback.

1 Select Judge User Response Immediately.

The user will know immediately if the selected choice is correct or incorrect. 
The Display Check Answer Button option requires that the user click a button 
before receiving feedback.
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2 Verify that User Must Answer Question to Continue and Show Feedback After 
Question Is Judged are selected.

3 Verify that 70 is in the Passing Score % text box, and click Next.

Specify generic feedback

Generic feedback lets you specify default feedback—responses users see when they 
answer questions. You can override the default settings for individual questions.

Positive feedback lets you determine what should appear when the user answers a 
question correctly.

1 To specify positive feedback, verify that Positive is selected.

The Enter the Generic Feedback Statement text box displays the text that 
appears when a user correctly answers a question. 

2 Click the Delete Feedback button twice, so that the only positive feedback text 
that remains is That’s right.
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3 To specify the text that should appear when a user incorrectly answers a 
question, select Negative.

4 Click the Delete Feedback button twice, so that the only negative feedback text 
that remains is Sorry, that’s the wrong answer, and then click Next.

Add a question to the quiz
Now that you’ve determined how the text will appear and specified quiz settings, 
your ready to add the four questions that will comprise the quiz.

Add a single-choice question

Single-choice questions are a common multiple-choice format: a question with 
one correct answer.

1 In the Quiz Knowledge Object: Add Questions window, click Single Choice.
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2 In the Enter or Modify Question Title text box, type Question 1. Then click 
Run Wizard.

Import graphics for a quiz question

You’ll import a graphic of a camera for this quiz question.

1 In the Preview Window, click the sample question text so that it appears in the 
Edit Window.

2 Click Import Media. In the Import Media dialog box, browse to the Tutorial/
Assets folder within your Authorware 6 application folder and select Lens.png, 
then click Open.

3 If a message appears asking for permission to copy the file, click Yes.
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Note: You’ll adjust the location of the graphics included in the quiz when you play the 
quiz for the first time.

Use the set up wizard
The Setup Question window includes a Preview Window that lets you see how 
your questions and answers are organized. A minus sign before an answer indicates 
that the response is incorrect. A plus sign indicates a correct response.

Buttons on the right side of the window let you import media and add new 
answers, which you can specify as either correct or incorrect.

1 In the Edit Window, replace the sample text with What is the name of the 
adjustable diaphragm that controls the amount of light entering the camera? 
Press Enter.
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2 In the Preview Window, click the word distractor. Use the Edit Window to 
replace it with the word Shutter, and press Enter.

3 In the Preview Window, click the definition text under Shutter. Use the Edit 
Window to change the text to No, the shutter controls how much light enters 
the camera based on how long it stays open. Try again.

4 In the Preview Window, click the word hint and select Right Answer.

The minus sign beside the word hint in the Preview Window changes to a plus 
sign, which indicates this will be a correct answer.

5 Use the Edit Window to change the word hint to Aperture, and press Enter.

6 In the Preview Window, click the text under Aperture. Use the Edit Window to 
change the text to Yes! The adjustable diaphragm is called the aperture.

Finish adding choices and responses

You’ll follow steps similar to the steps you just completed to finish adding choices 
and responses to Question 1.

1 In the Preview Window, select the word feedback. Select Wrong Answer.

2 Use the Edit Window to change the text to Shutter Release, and press Enter.

3 In the Preview Window, click the text under Shutter Release. Use the edit 
window to change the text to No. Pressing the shutter release button opens 
the shutter to let light pass through the lens and expose the film. Try again. 
Then press Enter.

4 To add a final answer, verify that Wrong Answer is selected, and click 
Add Choice.

5 In the Preview Window, click <Place choice here>. Use the Edit Window to 
change the text to Lens, and press Enter.

6 In the Preview Window, click <generic feedback>. Use the Edit Window to 
change the text to No. The lens is used to focus light on the film. Try again. 
Press Enter.

7 To exit the wizard for the first quiz question, click Done.
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Add a true/false question
You’ll add a question that lets the user choose either True (the correct choice) or 
False.

1 Click True/False.

2 In the Enter or Modify Question Title text box, type Question 2. Then click 
Run Wizard.

3 To import a graphic for this question, click the first line of text in the Preview 
window, then click Import Media. 

4 In the Import Media dialog box, browse to Tutorial/Assets within your 
Authorware 6 application folder and select Lens.png, then click Open.

5 Use the Edit Window to change the sample question text to The higher the 
aperture setting, the more light passes through the lens. Press Enter.

6 In the Preview Window, click True and select Right Answer.

7 Click the text under True. Use the Edit Window to replace the text with Yes. 
The higher you set the aperture setting, the more light passes through the 
lens. Press Enter.

8 In the Preview Window, click the text under False. Use the Edit Window to 
replace the text with No. The higher you set the aperture setting, the more 
light passes through the lens. Press Enter.

9 To complete the question and exit the wizard, click Done.
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Add a hot spot question
You’ll add hot spots over a camera graphic to let the user answer a question by 
clicking a hot spot.

1 Click Hot Spot.

2 In the Enter or Modify Question Title text box, type Question 3. Then click 
Run Wizard.

3 To import a graphic for this question, click the first line of text in the Preview 
window and click Import Media. In the Import Media dialog box, browse to 
Tutorial/Assets within your Authorware 6 application folder and select Camera 
Top.png, then click Open.

4 If a message appears asking permission to copy the file, click Yes.

5 Use the Edit Window to change the sample question text to Click the part of 
the camera you would press to take a picture.

6 Click the Add Hotspot button three times, so that five hot spot responses 
appear in the Preview Window.

Each response in the list includes the number of the hot spot and the 
coordinates for the hot spot on one line, and on the next line, the text that 
appears when the user clicks the hot spot.

For now, you don’t need to be concerned with the hot spot coordinates. You 
will adjust where the hot spots appear after creating the hot spot text.
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Modify the hot spot response text

Now you’ll create the text that appears when the user clicks the corresponding 
hot spot.

1 In the Preview Window, click the text in the second line of hot spot 1. Use the 
Edit Window to change it to Yes! Pressing the shutter release button opens the 
shutter to let light pass through the lens and expose the film. Press Enter.

2 In the Preview Window, click the text in the second line of hot spot 2. Use the 
Edit Window to change it to No. This is the lens. It is used to focus light on 
the film. Please try again. Press Enter.

3 In the Preview Window, click the text in the second line of hot spot 3. Use the 
Edit Window to change it to No, this is the aperture ring, which adjusts the 
amount of light that passes through the lens. Try again. Press Enter.

4 In the Preview Window, click the text in the second line of hot spot 4. Use the 
Edit Window to change it to No, that’s not the correct part of the camera. Try 
clicking another part. Press Enter.

5 In the Preview Window, click the text in the second line of hot spot 5. Use the 
Edit Window to change it to No, that’s not the correct part of the camera. Try 
clicking another part. Press Enter.

6 When you finish changing the hot spot text, the window should look like the 
following illustration:
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Modify hot spots

Once you’ve determined that number of hot spots and the response text, you can 
place where the hot spots should appear over the camera graphic.

1 Click Modify Hotspot.

2 If necessary, drag the camera graphic up and toward the right edge of the 
window, as shown in the following illustration. 

Graphic placement on this Knowledge Object window will be the same as on 
the Presentation window.

3 Drag hot spot 1 to place it over the shutter release button on the camera, as 
shown in the following illustration.
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4 Drag hot spot 2 to the lens, and use the sizing handles to enlarge the hot spot 
so that it covers the lens area in front of the aperture ring.

5 Drag hot spot 3 to the aperture ring, and resize it to cover the aperture ring.
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6 Drag and resize hot spots number 4 and 5, so they appear as in the following 
illustration:

7 Click Done to complete placing the hot spots, then click Done again to 
complete Question 3.

Add a multiple-choice question
You’ll now add a multiple-choice question that has two correct answers.

1 In the Quiz window, click Multiple Choice.

2 In the Enter or Modify a Question Title text box, type Question 4. 
Click Run Wizard.

3 In the Preview Window, click the sample question text. Use the Edit Window 
to change it to What parts of a camera affect the amount of light that passes 
through the lens? (Select all parts that apply.) Press Enter.

4 In the Preview Window, click Auckland. The minus sign indicates this is an 
incorrect choice. Click Right Answer to make it a correct choice.

5 Use the Edit Window to change Auckland to Shutter speed, and press Enter.

6 In the Preview Window, click the text under Shutter speed and use the Edit 
Window to change it to Yes. The shutter speed indicates what fraction of a 
second the shutter will be open and how much light will pass through the 
lens. Press Enter.
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7 In the Preview Window, click Perth. Then click Wrong Answer.

8 Use the Edit Window to change Perth to Film advance lever, and press Enter.

9 In the Preview Window, click the text under Film advance lever and use the 
Edit Window to change it to No. The film advance lever advances the film 
one frame so you can take a new picture. Press Enter.

Complete the question

Now that you know the procedure to select text in the Preview Window and modify 
it in the Edit Window, change the text for the remaining choices, as follows.

1 Verify that the third choice is a right answer, as indicated by the plus sign. 
Change Sydney to Aperture, and change the line of text immediately following 
to Yes. It adjusts the amount of light that passes through the lens. The higher 
the setting, the more light passes through the lens.

2 Verify that the fourth choice is an incorrect answer, as indicated by the minus sign. 
Change Vienna to Film counter, and change the line of text immediately 
following to No. The film counter indicates how many pictures have been taken.

3 To complete the question, click Done.
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Finish using the Knowledge Object
You’ll now reorder the quiz questions so that they appear in sequence.

1 In the Click an Item in the List to Modify It pane, click Question 2. Click the 
Move Question up arrow twice, so that Question 2 appears after Question 1.

2 Click Question 3, and then click the Move Question up arrow once, to place 
the question before Question 4.

3 To finish using the Knowledge Object, click Done. Then refer to the Camera 
Quiz flowline to view the icons Authorware has added.

Link the quiz
Once you finish using the Knowledge Object, you can link it to the main menu. 

1 Restart the piece, and click Continue to go to the Main Menu.

2 In the Main Menu, click Camera Quiz. In the Navigate Icon Properties dialog 
box, select Camera Quiz, and click OK.

You’ve linked the Main Menu to the quiz.
Tutorial 135



Change quiz graphic objects
The quiz background in the Knowledge Object template that you selected, as you 
might have noticed, looks nothing like the background in other segments in your 
Authorware piece. You can simply delete the quiz background to reveal the Title 
Background underneath.

1 Pause the piece and double-click toward the edge of the Presentation window 
to see the Quiz Background and its graphics toolbox. Press Delete.

2 In the Presentation window, double-click the logon dialog box so that it is the 
only object selected—the text and text boxes should not be selected—and press 
Delete. (You might need to click away from the dialog box, then click it again).
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Import a graphic for the Quiz Background display icon

The Quiz Background display icon is now without content; you’ll import a 
background graphic for the icon.

1 On the Camera Quiz flowline, double-click the Quiz framework icon.

2 On the Quiz flowline, double-click the Quiz Background display icon.

3 Choose File > Import. Browse to the Tutorial/Assets folder within your 
Authorware 6 application folder and import QuizBackground.png.

4 In the modes palette, select Alpha.

5 Place a start flag at the top of the Quiz flowline, and choose Control > Restart 
from Flag. Pause the piece and align the Quiz Background against the lower left 
corner of the Presentation window.

6 Press the Up Arrow key six times to move the background up 6 pixels. Press the 
Right Arrow key eight times to move the background 8 pixels to the right.
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Import the camera graphic

You’ll import a graphic of a camera.

1 On the Quiz flowline, double-click the Login display icon. 

2 On the Login flowline, double-click the first display icon, named Display. On 
the Display flowline, double-click the Logon Dialog display icon.

3 In the Presentation window, all of the objects on the page are selected. Press Delete.

4 Choose File > Import and import Camera1.png from your Tutorial/Assets 
folder within your Authorware 6 application folder.

5 If the modes palette is not open, choose Window > Inspectors > Modes. Select 
Alpha from the modes palette, then close the palette.

6 Drag the camera toward the lower right edge of the window.

7 Close the Display flowline.
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Modify Styles
In Authorware, you can assign styles—text attributes such as font type, size, and 
color—to text fields. Once styles are established, you can easily modify them to 
update entire blocks of text. The benefits of using styles will now become apparent 
as you modify styles rather than change individual text areas in the quiz.

1 Choose Text > Define Styles.

2 In the Define Styles dialog box, select General Text Heading - edu from the list 
of styles. In the Font Style pop-up menu, verify that Arial is selected.

3 In the Font Size pop-up menu, select 9 as the point size.

4 Verify that Text Color is selected. Click the Text Color box. In the Text Color 
palette, select white and then click OK.

5 Change each of the following styles to Arial text. Additionally, repeat steps 3 
and 4 to change the following styles to 9 point white Arial text:

• Normal

• Page Number edu

• wzDistractor

• wzFeedback

• wzQuestionStem

6 Change the wzDistractorHilite style to 9 point yellow Arial text.

7 When you’ve finished changing the styles in the Define Styles dialog box, 
click Done.
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Delete login objects
You’ll configure the quiz to have the user enter a first and last name, but no middle 
name. Additionally, you will delete text and graphic objects for the name fields 
while keeping the text entry fields.

1 On the Quiz flowline, go to the Login flowline.

2 On the Login flowline, select the Middle Name map icon, then press Delete.

3 On the Login flowline, double-click the First Name map icon.

4 On the First Name flowline, double-click the First Name interaction icon. In 
the Presentation window, select the text First Name. Take care to verify that the 
text is the only object selected in the Presentation window, and press Delete.

Align objects to enter a first name

1 In the Presentation window, double-click the First Name text entry field. In the 
Interaction Text Field Properties dialog box, click the Text tab and select 
Opaque from the Mode pop-up menu. Then click OK.

The text field will now appear white against the dark blue background.

2 Choose Control > Restart from flag, then pause the piece.

3 In the Presentation window, double-click the text Enter you First Name and 
press Enter.

4 Choose Text > Alignment > Left to change the alignment from centered.
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5 Use the Pointer tool in the toolbox to make the text margins narrower and to 
place the text within the borders of the Quiz Background rectangle.

6 Select the First Name text entry field and drag it under the Enter your First 
Name...text. Use the sizing handles to make the text field fit within the Quiz 
Background border, as shown in the following illustration.

7 Choose Control > Play and type your first name in the text field. Press Enter, 
and then pause the piece.

8 Close the First Name flowline.
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Align objects to enter a last name

After entering a first name, the user enters a last name. You’ll align the objects for 
the last name now.

1 On the Login flowline, double-click the Last Name map icon.

2 On the Last Name flowline, double-click the Last Name interaction icon.

3 In the Presentation window, select the Last Name text, verify that no other 
objects are selected, and press Delete.

4 Double-click the Last Name text entry field. On the Text tab of the Interaction 
Text Field Properties dialog box, select Opaque from the Mode pop-up menu. 
Then click OK.

5 Choose Control > Restart from Flag. Again type your first name in the text 
entry field and press Enter. 

6 Pause the piece and drag the Last Name text entry field over the First Name 
text entry field. Resize the Last Name text entry field so that the two fields are 
approximately the same size.

7 Double-click the text that reads Enter your Last Name and press Enter.

8 Choose Text > Alignment > Left. Use the Pointer tool in the toolbox to drag 
the text above the text entry field. Decrease the margin so the text fits within 
the Quiz Background borders.
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9 Choose Control > Play and type your last name in the text field, then press 
Enter. Pause the piece.

Align objects to submit your name data

As you learned from using the Knowledge Object wizard, Authorware saves quiz 
data, including login information. Users logging on for the first time can click a 
sign-on button, which adds their data to a userinfo.dat file. You’ll align the objects 
that let the user sign on.

1 In the Presentation window, double-click the text that reads, Your name is not 
in the roster. Would you like to sign on?

2 Use the Pointer tool to resize the text margin and place it to the lower portion 
of the Quiz Background, as shown in the following illustration: 
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Replace buttons

The current buttons in the quiz don’t match the look of your piece. You’ll change 
the buttons to a more consistent style.

1 Double-click the Retype Name button. In the Response Properties dialog box, 
rename the button Restart.

Note: The Retype Name button is configured to go to the beginning of the piece. The 
beginning of the tutorial is the introductory sequence rather than the logon window.

2 Click Buttons. Scroll down the list and select the Standard Windows 3.1 
System button. 

3 Click OK to close the Buttons dialog box, then click OK again in the Response 
Properties dialog box.

4 In the Presentation window, double-click the Quit button. In the top text box, 
select the Quit text and type Exit Quiz to rename the button.

5 Click Buttons and select the Standard Windows 3.1 System button. 

6 Click OK to close the Buttons dialog box, then click OK again on the 
Response Properties dialog box.
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7 In the Presentation window, double-click the Sign-on button and repeat steps 5 
and 6 to select a Standard Windows 3.1 System button.

8 Drag the buttons to the lower left area of the Presentation window, in the order 
shown in the following illustration:

Note: You can also align the buttons using the arrow keys on your keyboard to move the 
buttons one pixel at a time in the direction of the arrow.

9 Play the piece. In the Presentation window, click Sign-on, then pause the piece.

Now that Authorware has captured your login data, if you log in to the quiz 
again with the same information, Authorware retrieves the data from the DAT 
file and bypasses the message that indicates your name is not in the roster.
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Modify the Quiz design
You’ll continue to modify content within the Knowledge Object to create 
continuity between the quiz and the rest of your piece.

Design Question 1

Question 1, if you recall from the Knowledge Object wizard, is a multiple-choice 
question with one correct answer. You’ll arrange the objects that comprise the 
question.

1 In the Presentation window, select only the text that reads Quiz, Question 1 
and delete it.

2 Select the Quiz Navigation object and delete it.

3 Drag the Previous Page and Next Page buttons to the lower right area of the 
Quiz Background.

4 Move the Question 1 of 4 text to the lower right area of the Quiz Background, 
above the Previous and Next Page buttons.

Quiz Navigation 
object

Next page

Quit
Previous page
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5 In the Presentation window, double-click the orange Quit button. In the 
Response Properties dialog box, change the name of the button to Finish and 
click Buttons. Select the Standard Windows System 3.1 button. Click OK in 
both dialog boxes.

6 In the Presentation window, drag the sizing handles on the Finish button to 
make the button larger.

7 Drag the Finish button to the lower left edge of the quiz background.

8 Select the lens graphic. Go to the modes palette and select Alpha. Drag the 
lens graphic to reposition it in the lower right area of the Presentation window, 
as necessary. 
Tutorial 147



9 Double-click the question text. Using the Pointer tool, decrease the size of the 
margins and move the text to the Quiz Background.

Arrange choices and responses

After arranging the choices, you’ll also arrange the response text.

1 In the Presentation window, double-click the text A. Shutter.

The text, because it is variable text, might change. .
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2 Control-Shift-click to select the three remaining choices. Drag the choices 
under the question, so they appear indented.

3 Choose Control > Play and click the first choice in the Presentation window. 
Pause the piece.

4 Double-click the feedback text that appears.

5 Use the Pointer tool in the toolbox to decrease the margin size and to move the 
feedback text to the area underneath the choices.

6 Choose Control > Play and click the second choice in the Presentation window.

7 Verify that the positive feedback appears in the same area as the negative 
feedback, and click the Next Page button, then pause the piece.
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Design Question 2

You’ll now arrange the objects that comprise Question 2—the True/False question.

1 Double-click the camera lens graphic and select Alpha from the modes 
palette. If necessary, reposition the graphic in the lower right corner of the 
Presentation window.

2 Double-click the question text. Use the Pointer tool to decrease the size of the 
margin and move the text within the area of the quiz background.

3 Double-click True, then use Control-Shift-click to add the second False choice 
to the selection. Drag the choice text to the Quiz Background area, indented 
underneath the question. 

As with Question 1, when you select the variable text, it might change.
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4 Play the piece and click the second False choice. Double-click the response text 
and use the Pointer tool to decrease the response text margin size, and to place 
the text within the lower area of the quiz background.

5 Play the piece and click True. Verify that the response text appears in the correct 
location and click the Next Page button, then pause the piece.

Design Question 3

Question 3, the hot spot question, requires you to implement steps similar to 
those you used for the previous questions to display the alpha transparency for the 
graphic, and to resize and align the text areas.

1 In the Presentation window, double-click the camera graphic. In the modes 
palette, select Alpha.
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2 Double-click the question text. Use the Pointer tool to decrease the size of the 
margin and to drag the text to the top area of the quiz background.

3 Choose Control > Play, and click the left side of the camera to click a hot spot 
that displays a negative response.

4 Taking care to not click over a hot spot, double-click the response text. Use the 
Pointer tool to decrease the size of the margin and to drag the text to the lower 
area of the quiz background.

5 Play the piece and click the shutter release on the camera to verify that the positive 
response appears correctly. Click the Next Page button, then pause the piece.

Design Question 4

For the last of the questions, multiple choice with two correct answers, you’ll 
arrange text and modify a button that lets the user check the answer.

1 In the Presentation window, double-click the question text. Use the Pointer 
tool to decrease the size of the margin and move the text within the top area of 
the quiz background.

2 Double-click A. Shutter speed, then use Control-Shift-click to select the remaining 
choices. Drag the choices under the question, within the quiz background.

Remember that the variable text might change when you select it.

3 Double-click the Check Answer button. In the Response Properties dialog box, 
click Buttons. In the Buttons dialog box, select the Standard Windows System 
3.1 Button. Click OK in both dialog boxes to close them.
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4 In the Presentation window, select just the Check Answer button and drag it 
underneath the choices.

5 Choose Control > Play and click any of the choices to view the response text. 

6 Pause the piece, then double-click the response text to open the toolbox.

7 Use the Pointer tool to resize the response text margin, and move the response 
text underneath the Check Answer button.

8 Play the piece again, then select another choice. Click the Check Answer 
button, then pause the piece.
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Design the Finish response

During the course of taking the quiz, the user can click the Finish button to exit 
the quiz before completing it, while saving quiz data up until that point. You’ll 
follow steps similar to those you’ve completed thus far to delete and rearrange 
objects that were part of the template you selected, and change the buttons.

1 On the Quiz flowline, double-click the Finish map icon.

2 On the Finish flowline, double-click the Are You Sure interaction icon.

3 In the Presentation window, select the Finish background, then delete it.

4 Place a start flag at the top of the Finish flowline, and restart the piece 
from the flag.
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5 Pause the piece. Select and delete the small black text that reads Finish (not the 
larger white text that reads Finish).

Double-click the text that reads Are you sure you want to quit the program?

Select the rectangle tool in the graphics toolbox and draw a rectangle around 
the Finish title text and the Yes, No and Close Window buttons.

6 Double-click the Yes button. In the Response Properties dialog box, click 
Buttons and Choose the Standard Windows 3.1 System button. Click OK in 
both dialog boxes.

Finish text
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7 Repeat step 6 to change the No button to a Standard Windows 3.1 System button.

8 Choose Control > Play, and click No.

Complete the quiz 

To complete the quiz, you only need to test your work and change a Quit button 
to match the style of other buttons used in the piece.

1 Restart your piece. After the introductory sequence, click Continue. On the 
Main Menu, click Camera Quiz.

2 Log in, using the same name that you used before. You should bypass the 
sign-on message.

3 Answer the four questions, then click the Next Page button to view the 
quiz results.

The Quiz Summary, which displays the quiz results, is now visible. 

4 Choose Control > Pause and double-click the Quit button.

5 In the Response Properties dialog box, click Buttons. Select the Standard 
Windows 3.1 System button, then click OK in both dialog boxes.

6 Choose Control > Play and click Quit. 

You’ve completed the steps to use and modify a Knowledge Object to add a quiz 
to your piece.
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Limit when a button is active
If, while taking the quiz again, you click the Menu button on the Presentation 
window, you’ll see that the application takes you to the Quiz Summary rather 
than the Main Menu. Selecting the Menu button while in the quiz forces the 
application to exit the quiz framework. Part of this exit process involves a quit 
routine that displays the summary. To avoid this unexpected and undesirable 
result, you’ll limit when the Menu button is active, making it disappear when 
users take the quiz.

Use an Active If condition

You can add a condition to a button that indicates when the button should be active.

1 On the level 1 flowline, double-click the Master Framework icon.

2 On the Master Framework flowline, double-click the Menu response symbol.

3 In the Response Properties dialog box, go to the Response tab. In the Active If 
text box, type CurrentPageID@"Quiz"=0.

You are telling the application that the Menu button should be active only if 
the current page ID is not that of the quiz.
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Hide an inactive button

In the same Response Properties dialog box where you added the Active If condition 
to the Menu button, you can specify that an inactive button is not visible.

1 In the Response properties dialog box, click the Button tab.

2 Click Hide When Inactive, then click OK.

Now when your users take the quiz, they will not see the Menu button.

View quiz data
Authorware saves quiz data in a file named quiz.dat. Data for users logging on to 
the quiz is saved in a file named userinfo.dat. You can find both files in the default 
location that you noted when you configured the login options for the quiz 
Knowledge Object. The path to the data depends on your operating system, such 
as C:\\Windows\AW6_DATA\. The DAT files are within a numbered folder.

Open the files with a text application, such as Notepad.

Following, is an example of the data contained in the quiz.dat file:

 The userinfo.dat file saves data about the date the user began the quiz, the date 
the user completed it, and logon data.
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Publish your piece with one-button 
publishing
The final procedure for developing your Authorware piece involves publishing it 
for a CD or the Web. The one-button publishing feature of Authorware 6 takes a 
potentially complicated process and lets you implement it in one simple step. 
Before you publish your piece, however, take a look at the default publish settings 
that determine how Authorware publishes the file.

To complete this section, you can continue using the file you created in the 
previous section, or you can open the Camera6.a6p file included in the Tutorial 
subfolder of your Authorware 6 application folder.

This section of the tutorial takes approximately 15 minutes to complete.

Objectives
After you complete this section, you will know how to do the following:

• View publish settings to understand how Authorware 6 publishes your piece

• Use one-button publishing to publish your piece for the Web or a CD

• View your published file in a Web browser
Tutorial 159



View publish settings
The Publish Settings dialog box lets you view and modify the way in which 
Authorware publishes your files. 

1 After saving your file, choose File > Publish > Publish Settings.

Authorware takes a moment to scan the flowline.

On the Formats tab of the One Button Publishing dialog box, the default 
settings include options to publish for a CD, for the Authorware Web Player, 
and embedded in an HTML file.

2 The Publish for CD, LAN, Local HDD, and Publish for Web text boxes 
indicate where Authorware will save published files. 

The published piece for the Web Player will have the AAM extension, and 
Authorware also creates an HTM file to play the piece on the Web.
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3 Click the Package tab to see that Authorware, by default, packages external 
libraries and media internally.

4 Click the Files tab to see the files Authorware will include in the published 
package, along with the source location, destination, and description. The blue 
symbol with two squares and a line indicates a valid (not broken) link.

5 When you finish viewing the publish settings, click OK.

Although you can publish the piece from the Publish Settings dialog box, you’ll 
exit the dialog box to use the Publish command.
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Use one-button publishing
Publishing your piece is as simple as invoking a single command.

1 Choose File > Publish > Publish.

Authorware begins to publish your piece as specified in the Publish Settings 
dialog box.

2 When the One Button Publishing Completed dialog box appears, click OK.

3 To view your piece in a Web page, browse to your Tutorial folder within your 
Authorware 6 application folder. You’ll find a folder that Authorware created 
during the publishing process named Published Files. Open it, then open the 
Web folder.

Within the Web folder, you’ll find an HTM file (the exact file name is 
dependent on the name in which you saved your A6P file; for example, if 
your original source file were named Camera.a6p, the file name would be 
Camera.htm). 

The HTM file includes OBJECT and EMBED tags to play your packaged 
Authorware file, which has the AAM extension.

4 Open the HTM file in a Web browser to play your published piece.

The next steps
In this tutorial you have learned many of the techniques you’ll use when creating 
Authorware applications, including the following:

• Analyzing a completed Authorware piece and setting up a new file

• Creating a navigational structure using the flowline and icons

• Adding multimedia to a piece, including graphics, sound, Flash movie clips, 
and animation 

• Adding user interactions

• Importing an RTF file while maintaining formatting and a paging structure

• Adding models to streamline authoring

• Using and modifying Knowledge Objects to create an interactive quiz

• Packaging the completed piece using one-button publishing

To learn more about Authorware features, note that the Using Authorware 6 
manual includes in-depth information on the topics covered in the tutorial. It also 
includes a chapter on tips and tricks. Additionally, be sure to visit the award-
winning Macromedia Support Center, at www.macromedia.com,  for technical 
notes, tutorials, articles, and sample files.
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Working with Authorware

Good authoring practice

The typical Authorware piece is complex, with many components to keep track 
of. To be successful in authoring, you need to organize your work.

Set up file properties first Before you start building a piece, take a look at the File 
Properties dialog box. Choose Modify > File > Properties.

You use the File Properties dialog box to set many overall options for the piece. It’s 
important to set file properties first, because changes you make to file setup may 
affect the playback and interaction of the piece. You can change the file properties 
later if you need to.

The File Properties dialog box includes the following options:

• Background color for the Presentation window

• Chroma key color

• The size of the Presentation window

• Whether the Presentation window has a menu bar, title bar, or task bar

• The default Wait button

• The transition when a user returns to the file

• Which folder Authorware searches for external files

• Whether to run the piece from the beginning or from where the user left off
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Break up the flowline into manageable sections By placing groups of related icons in 
map icons, you can organize your work into logical chunks of related material. 
Grouping icons helps you understand how all the icons in the piece affect each other. 
Grouping also helps you locate the source of problems if things don’t work right.

Create a naming scheme Descriptive names help both you and anyone else 
who’s working on or troubleshooting your piece. Develop a naming scheme for 
all icon names, variable names, keywords, and file names (both Authorware files 
and external content files). The names should be consistent and descriptive, have 
a clear pattern, and indicate what an icon is for, what a variable does, or what 
a file contains. 

One naming scheme is to prefix all your variable names with a letter that 
corresponds to the icon in which it is used. (To improve readability, use the 
underscore character after the prefix.) This scheme lets you easily identify the type 
of icon the variable is used in and alphabetically groups the variables in the 
Variables window. Another naming scheme is to suffix media files with numbers 
that indicate the latest revisions.

Use keywords When you’re searching for an icon you’ve created, the text it 
contains provides an easy way to identify it. In a multimedia piece, however, 
information is available in forms other than text—digitized sounds and music, 
voice-overs, animations, digital movies, and video recordings, to name just a few. 
To make any kind of icon easy to find, assign a keyword to it.

Think about rhythm and pace Most people are sophisticated viewers. They’re used 
to films and television shows in which something is always happening. To keep 
users engaged, avoid dead spots when you’re jumping between files or loading 
external media. The danger of dead spots is even greater if you’re using “distant” 
media. Downloading the segments of a Web-packaged piece over the Internet—or 
even reading external content from a server connected over a local area network—
can be slowed noticeably by network traffic. Design your projects so that long 
downloads and data transfers aren’t necessary. And orchestrate the flow of 
information so there’s always something to engage a user’s attention when 
downloads and data transfers are happening.

Comment your work The reason you assembled icons or assigned a value in the 
piece may not be obvious to someone who works on the piece after you. It might 
not even be obvious to you after a few weeks pass. Be sure to describe what 
important variables do and how complex interactions work. Comments on the 
flowline and in calculation windows save time and clarify your work. Place brief 
comments in icon titles and more detailed comments in calculation icons.
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Save your work frequently Frequently saving your work and creating backup files 
will spare you the frustration of losing valuable time if something goes wrong. 
With Authorware you can save file revisions in one of the following ways:

• File > Save saves the revised file by replacing the older file of the same name.

• File > Save As gives the revised version a different file name and leaves the 
original file intact.

• File > Save And Compact gives the revised version a different file name and 
compacts it to minimize disk space. The compacted version returns to its 
uncompacted size when you reopen the file. 

Run the piece frequently as you author It’s usually easier to identify a problem 
shortly after you introduce it. Studying a few steps at a time helps you focus on 
where the problem might be. If there’s a problem in an area that ran correctly 
before you added and edited some icons, the new icons are almost certainly 
involved in the problem. If you run your piece frequently, you can easily narrow 
any problem down to the small number of icons you worked with since you last 
ran the piece. Use start and stop flags to focus on specific sections. Use the 
Authorware Control Panel to trace the progress of Authorware down the flowline.

Test the piece on a range of computers Run the packaged piece on all the types of 
computers that you expect users to have. The piece can behave very differently on 
different computers. For example, the speed may be slower, noticeable pauses may 
occur when objects are loaded into memory, or colors may be undesirable when 
the piece runs on a computer that uses a lower color depth. If users will be 
running the piece in Windows 2000 NT, you should test the piece in Windows 
2000 NT.

Back up and archive Always back up files before you package a piece. At the end 
of a project, create an archive of all the project files and store it in a safe place. Two 
sets of archive files are best. You can use high-capacity Zip drives or recordable 
CDs to archive your project.

Good authoring practice—step-by-step procedures

What you can do In Authorware Help, see

Set up file properties first Creating a new project file

Break up the flowline into 
manageable sections

Grouping and moving icons

Create a naming scheme 
for variables

Creating a variable

Use keywords to help identify icons Assigning a keyword to a page

Comment your work Using comments
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Troubleshooting methods
Good authoring practice helps avoid problems in the first place, but no piece 
works exactly as planned the first time. That’s a basic fact of authoring. 

You’ll always need to make revisions and adjustments. Although it’s impossible to 
predict every problem that could arise, you can rely on basic troubleshooting 
techniques to detect and solve problems.

Authorware does exactly what you tell it to, but it doesn’t always do what you 
expect. When something unexpected happens, it doesn’t mean that the software 
has a bug. Most likely, something in the icons’ order or the way they’re set up 
produced the unexpected result.

The following troubleshooting methods can help you identify a problem. 
You’ll probably want to refer to these examples as your understanding of 
Authorware increases. 

Determine which section has the problem

Most pieces are too large and complex to analyze completely from beginning to 
end. Fortunately it’s rarely necessary to analyze a piece as a whole; the area in 
which the problem occurs is usually easy to narrow down. Here are some examples 
of reasonable approaches to common situations:

• If clicking a button produces the wrong result, look at the interaction that 
contains the button.

• If a display icon doesn’t appear, check its position on the flowline. It may be 
positioned after a wait icon that prevents Authorware from running it or before 
an erase icon that erases the image before you can see it.

• If a decision icon produces an unintended result, check the values that you used 
to control branching.

You can save time by using the start and stop flags to restrict the portion of the 
flowline that you run. If a problem doesn’t occur when you run a section 
between start and stop flags, the problem is probably related to an icon outside 
the section you ran.

Save your work Saving a file

Use start and stop flags to focus on 
specific sections

Running and pausing a piece

Step through a piece Using the Control Panel

Test your piece Using the Control Panel, Troubleshooting methods

What you can do In Authorware Help, see
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Think through the problem section

When a section of the flowline doesn’t do what you want, first try to trace the 
flowline’s behavior in your head. That often helps you find the problem. 

Connections between icons aren’t always apparent from looking at one section of 
the flowline. Use Modify > Icon > Connections to list all the connections to and 
from an icon. From the list you can go to the icon on the flowline that is at either 
end of the connection. If the selected icon is a framework icon or a map icon, you 
can also show connections between icons within that structure.

Check the icon settings

Check each icon’s properties to make sure they’re set correctly. For example, a 
display icon might appear in a layer that hides it from view. You can remove the 
icon from the flowline and then run the section to see if the problem persists. If 
the problem goes away when the icon is removed, the problem may be in the 
icon’s settings.

Figure out where the flow goes

Problems often occur because Authorware follows the flowline differently than 
you expected. For example, a response type has different results for continue and 
try-again branching.

The Authorware Control Panel window displays a list of icons in the order that 
Authorware encounters them.

Check variables and functions

Analyze the values related to variables and the usage of functions to see how the 
values change as the piece runs. They may do the wrong thing or change at the 
wrong time. See Variables, functions, and expressions to make sure you 
understand how variables, functions, and expressions work.

See System variables and System functions in Authorware Help to make sure 
you’ve set up the variables and functions correctly. If you’re using them correctly 
but the problem persists, track the values related to the variable. There are two 
ways to track what happens to variables as the piece runs:

• Display the variable on the screen, so you can see its value as Authorware 
proceeds down the flowline. 

• Use the Trace function to display the variable’s value in the Authorware 
Control Panel window. For more information, see the entry for the Trace 
function in System functions in Authorware Help.
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Make changes one at a time

Don’t be afraid to change things in the piece to see if a change eliminates the 
problem or gives a result that points to the problem. At the same time, don’t trade 
one problem for another. Change elements one at a time and change them back if 
the problem isn’t fixed. If you make many changes before solving a problem, you 
might lose sight of the original problem and possibly introduce new problems.

Re-create the section

If you haven’t found the problem, try re-creating the section from scratch in 
a new file. Don’t copy and paste icons from the old flowline: that might just 
copy the problem.

By re-creating the section, you reconstruct the logic at its most basic level and 
verify that Authorware is working as you expect. If the section that you re-create 
still doesn’t work properly, chances are there’s something wrong in the logic for 
the section.

If the section that you re-create works properly, compare that section to the 
original piece to see where they differ. You can also copy the section into 
the original piece to see whether that corrects the problem.

Troubleshooting—step-by-step procedures

What you can do In Authorware Help, see

Find an icon’s connections Icon > Connections

Check an icon’s properties Setting up icons

Check the flow Using the Control Panel

Step through a piece Using the Control Panel, Trace (function)

Display a variable on the screen Displaying variable information onscreen

Check the list of common problems Troubleshooting methods

Check the TechNotes on 
Macromedia’s Web site

Help > TechNotes
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Setting up file structures

File structures

In addition to the Authorware file that contains the flowline with the icons you’ve 
arranged on it, Authorware typically uses several other files when it runs a piece. 
These may include:

• Libraries linked to the piece

• Linked external files such as digital movies or sound files

• User records

• Any drivers that the piece requires

• Any custom function files that the piece requires

When running a piece, Authorware searches through specified folders in a set 
order until it finds these files. It is critical to make sure that files are in a folder that 
Authorware searches.

Default search path

When Authorware runs a piece, it must be able to find the additional files, such as 
the libraries and drivers that it requires. Authorware does this by searching a series 
of folders. Placing files in one of these folders is the simplest way to make sure that 
Authorware finds them.

Authorware searches directories for files in the following order:

• The directory where the file was located when you first loaded it. (When the 
piece is packaged or the file is moved, Authorware no longer finds the file 
unless you tell it the file’s new location.)

• The directory where the piece is located

• The directory that contains Authorware or the Authorware run-time 
application (Runa6w16.exe or Runa6w32.exe), whichever is currently running

• The Windows directory

• The Windows System directory
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Specifying file locations

You might want to put files in places other than the default folders. For example, 
to make the piece available to a group of people, rather than store separate copies 
of all the files on each local computer, you could make them available from a 
server. In these cases, you must tell Authorware which folder contains the file and 
where to find it. You can do this by specifying folders in the following places:

• In the Search Path field of the File Properties dialog box, specify folders that 
Authorware always searches after the piece starts.

• In the variable SearchPath, specify folders that Authorware searches in 
addition to the folders listed in the Search Path field. Because Authorware 
searches folders listed in the variable SearchPath only after the piece has 
started, don’t include folders that you want Authorware to search for libraries. 
Libraries must be opened when the piece opens, so it is best to list their folders 
in the Search Path field in the File Properties dialog box.

When a piece is packaged, Authorware loses track of where external files were 
located when you loaded them. You must use one of the methods just described to 
make sure a packaged piece finds external files when it runs.

You can specify folders and files by their names—delimited by backward 
slashes(\), forward slashes(/), or colons(:).

If you specify partial pathnames that don’t include the root, Authorware interprets 
the path as a subfolder of the folder for the current piece. However, placing a path 
delimiter (\, /, or :) before the partial pathname causes it to move up one level. 

For example, if the folder for the current piece is C:\A6w\Myfolder and the 
default search path is set to Library\Media;Data\, Authorware interprets the 
search path as C:\A6w\Myfolder\Library\Media and C:A6w\Myfolder\Data. 
However, Authorware interprets the search path \Library\Media;\Data\ as 
C:\A6w\Library\Media and C:\A6w\Data.

It’s possible that you have set up a search path correctly, but that for some reason 
the file or folder is missing from its proper location. Use the FileType function to 
check whether a file or folder is where you expect it to be.

See also

“Specifying where Authorware searches for files” on page 172
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User records

Users often want to explore a piece part way and later return to where they left off. 
Authorware lets users do this by recording data about the current condition of the 
piece when the user quits a session. The information is saved in a separate file, 
called a user record.

Authorware creates user records whenever it runs a piece that has Resume selected in 
the On Return option of the File Properties dialog box. It retrieves the values in the 
user records file to determine what the location on the flowline and current custom 
variable values were when the user quit or Authorware jumped out of the file. 

When you distribute packaged files that have Resume set in the File Properties 
dialog box, be sure to reserve enough space for the user records folder on the user’s 
hard disk. The amount of space needed depends on the number of files, the 
number and contents of custom variables, and the number and type of objects 
appearing in the Presentation window when the records are saved. 

Typically, you should reserve about 100K for the user records folder. Authorware 
automatically allocates space in the records folder for each file.

Location of user records

Authorware creates a user records file whenever Resume is selected in the On 
Return option of the File Properties dialog box. It retrieves the values in the user 
records file to determine where the user was when they quit last. The default 
folder for user records is A6w_data, which is in the Windows folder.

If this folder doesn’t exist on the user’s computer, Authorware automatically 
creates it when the user first runs an Authorware piece. Each user record receives a 
file name that consists of the first eight characters of the piece’s file name and the 
extension REC.

Changing the records folder

You can change the location of the records folder for several reasons:

• To route users to different files in a modular piece and still retain their 
individual records

• To set up separate records folders for individual users when multiple users work 
with the same piece

• To relocate records to another disk (often necessary when you are running on a 
network)

If user records are write-protected, Authorware is prevented from updating records 
as the piece runs. This commonly occurs because the user doesn’t have access 
privileges to the folder. It’s a good idea to check whether the user record is 
write-protected by trying to write a text file to the folder that contains user records.
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You will need to use either functions or variables to change the records folder 
location:

• Specify the folder in the variable RecordsLocation. 

By default, Authorware sets the records folder to A6w_data in the 
Windows folder.

• Specify the new records folder in the last argument of the JumpFile or 
JumpFileReturn function. 

Specifying where Authorware searches for files

You can change the default location where Authorware searches for files.

To specify where Authorware searches for files:

1 Choose Modify > File > Properties.

2 Click the Interaction tab.

3 In the Search Path field, specify the location of external files.

If you don’t specify a drive in the path, Authorware defines the path relative to the 
location of the Authorware file. 

To specify multiple search paths, separate the names with semicolons. For 
example, the following path searches the root level of a hard drive named Main 
and then searches the A6W directory of a mounted file server named Group:

Main\; Group\A6W

Distributing your piece
After you have completed your Authorware piece, you will need to package it in a 
format that can be used by the audience who will be running it.

You can distribute your work in several ways: on disk, on CD, over a network, or 
on the Web. Authorware needs only to see an accessible disk; it makes no 
distinction between a local hard drive, a removable disk, or a network server.

Before you start to author your work, you need to decide which distribution 
medium to use—disk, CD, or network (intranet or Internet)—and where to 
include the run-time application. The choice will depend on the size of your files, 
the type of computers the piece will be played on, and the terms of your 
Authorware License Agreement.

The point of creating pieces is to distribute them. When you distribute an 
Authorware piece, you provide users with a packaged or Web-packaged piece—
a separate version that users can run but not edit.
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Always design for the least capable system your piece will run on. If you’ve 
designed your piece with 16-bit sound, it won’t be of much use to someone with 
an 8-bit sound card. 

Here are just some of the requirements you should consider:

• Which operating systems will the piece be delivered on?

• What are the size and color capability of users’ monitors?

• How much RAM and hard disk space do they have?

• Are there any other hardware requirements, such as sound cards for Windows 
computers, CD drives, or videodisc players?

• Do you need to provide installation instructions, Read Me files, or an 
installer program?

• If you’re delivering over a network, which Web browsers and specific browser 
plug-ins, such as Authorware Web Player and ActiveX, will your audience need?

If your piece contains libraries, you’ll need to set the library search path for each 
distributed piece so that Authorware knows where to look for the libraries (see 
Packaging a library in Authorware Help).

Choosing a distribution medium
You can distribute your work in several ways: on disk, on CD, or over a local area 
network, a corporate intranet, or the Internet. You can create CD-Web hybrids 
that contain an Authorware piece but receive updated information over a network. 

Authorware needs only to see an accessible disk; it makes no distinction 
between a local hard disk, a removable disk, or a network server. The 
best approach depends on your particular situation and requirements.

Delivering on CD or disk

CD A single CD can store up to 740MB of data. The popularity of CD-ROM 
drives and CD mastering devices makes this a good choice for many types of 
multimedia delivery. 

Other removable disks Many other types of removable disks are available—from 
3.5-inch disks to cartridges that can hold a gigabyte of information. Make sure 
your users have the appropriate disk drive to read the delivery medium you choose. 

If your file won’t fit on one disk, you can divide the file into portions so that it 
can fit on several disks. In this case, include an installation program to make it 
convenient for users to install the piece.
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Delivering across networks

Network delivery—local area, intranet, or Internet—has the advantages of being 
accessible and flexible. You can easily revise files, and users can run the piece at their 
convenience. You can track the progress and results of everyone who runs the piece.

Local area network You can distribute a piece over a local area network when your 
users’ computers are all connected to the same network. The piece can be stored 
on a hard disk attached to the server or on the server itself. Users save disk space 
on their local computers because many of the external files, such as libraries, 
remain on the server.

The server doesn’t have to be the same platform as the users’ computers, as long as 
the local computers can mount it. For example, a Windows computer can obtain 
files from a UNIX server as long as it can mount the server.

Internet or intranet Delivery over the Internet or a company intranet has the 
advantages of being timely and responsive to change and of eliminating the cost 
of producing and distributing disks or CDs.

The main limitation of Internet or intranet delivery is the data transmission speed 
of users’ computers and the network that carries your piece. Design your piece 
with the benefits of the Internet in mind—interactivity, discussion, and access to 
other resources—and try to keep large images and movies at a minimum. See 
Chapter 11, “Streaming, Intranets, and the Web” on page 357 for more 
information on delivering your piece over corporate intranets and the Internet.

Using a combination of disk and network delivery

CD–Web hybrids offer a way of combining disk and network delivery. A CD–
Web hybrid contains links to files over a network. For example, you can store all 
the media files for a piece on a CD and have questions for the piece stored on a 
Web server so you can easily update or change them.

Optimizing file size

Here are a few techniques for optimizing how files fit onto the distribution 
medium you choose:

• Break the piece into several parts so that portions of it can load at a time. It’s a 
good idea to plan ways to make a file modular while authoring it, rather than 
waiting until you’re ready to package it.

• Package some files to a hard drive.

• Use a compression utility such as WinZip to compress your media files, and 
provide an installer to expand the files.
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Packaging an Authorware piece
Packaging a piece converts it to the format that you distribute. You don’t need 
Authorware to run a packaged piece, but you do need a run-time application to 
play it. The run-time application can be distributed separately from the piece, or it 
can be part of the packaged piece. 

Options for packaging a piece

Authorware provides three basic options for packaging a piece:

• One-button publishing provides a comprehensive tool for publishing and 
distributing a piece and all its related components in one step. This is the tool 
of choice in almost all publishing situations, including publishing to a 
CD-ROM and publishing to the Web. The comprehensive settings provide 
almost every publishing option you need. When you initiate the one-button 
publishing process, Authorware automatically scans your piece and finds the 
files you need to publish for each medium. See “Using one-button publishing 
to package a piece” on page 178 and Using batch publishing to package a piece 
in Authorware Help.

• Web-packaging a piece provides a way to publish a piece when there are special 
circumstances. It is used to distribute pieces over the Web.

• Packaging a piece is rarely needed. It is used to distribute pieces over a LAN 
or CD-ROM.

The Authorware run-time application

In Windows, there are two versions of the run-time application: Runa6w16.exe 
(for Windows 3.1) and Runa6w32.exe (for Windows 95, Windows 98, Windows 
NT, and Windows 2000). You can find the run-time application files in the 
Authorware program folder.

If you package a piece with the run-time application, the piece is a completely 
self-contained application. But sometimes you want to keep the run-time 
application separate. For example, if you have a lot of packaged files that are 
part of one project, all of them can use the same run-time application if it’s 
not packaged. Also, a piece packaged with the run-time application is not 
cross-platform. 
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Do two things before you package a piece:

1 Make a copy of the piece. Once a piece is packaged, its structure can’t be 
examined and its media can’t be copied or edited (the flowline and icons are no 
longer accessible). Make sure you keep a copy of the unpackaged version of the 
files in case you need to make changes to the piece.

2 Make sure you have all the additional files that the piece requires, such as Xtras 
and DLLs, and that you follow the license agreements related to them.

Packaging libraries

When packaging an Authorware piece that contains icons linked to a library file, 
you must provide the packaged library also. The packaged library must be 
available to each computer that runs the packaged piece.

The run-time application reads libraries, but doesn’t write to them. This means 
that libraries can be shared by more than one piece at a time over a network. 

You can provide the library by packaging it within the piece or you can package it 
and provide it separately. Packaging and providing a piece separately avoids 
duplicating the library’s content and saves disk space. However, you must make 
sure the library is available on the computer that runs the piece.

If you are using one-button publishing, you have the option of packaging your 
libraries internally, in which case they do not have to be distributed with the piece. 
However, if you do not package your libraries internally, you will need to set up 
publishing settings for each library, as well as the piece.

Libraries are searched for before a piece opens. The information in the content 
search path can’t be read until the file opens, so the content search path doesn’t 
help in finding library files (it does help with movies and such). The only way the 
library is found is by changing the search path in the A6w.ini file, putting the file 
in the same location as the packaged piece, or putting the file in the exact same 
location it was in when it was packaged.

When you package libraries separately, store packaged library files in the same 
folder as the piece. Putting packaged libraries in this location ensures that the run-
time application can find them. If the run-time application can’t find a library file 
when opening the piece, a standard dialog box appears that asks the user to locate 
the library file. 

When a link between an icon and the library it’s linked with is broken, the icon’s 
contents do not appear. However, Authorware still presents the icons and takes into 
account all other information about the icon, such as option settings and attached 
calculations. Even though no contents are displayed, variables can be affected.
Chapter 4176



Packaging a piece—step-by-step 
procedures 

Getting a piece ready for the Web
After you’ve completed a piece you can package it for delivery over the World 
Wide Web. To package a piece for the Web, use one-button publishing—it 
segments and compresses the file to make downloading faster. You can also use 
one-button publishing to set up how external files (libraries, Xtras, digital movies, 
and so on) are downloaded. 

You must embed the Web-packaged piece in an HTML page. You must also 
configure a Web server and put the Web-packaged piece and all its external 
files there. This is all done with one-button publishing.

Users of a Web-packaged piece must have the Authorware Web Player to run it. 
You can supply the player with the piece, or users can download it from the 
Macromedia Web site.

See Chapter 11, “Streaming, Intranets, and the Web” on page 357 for more 
information on delivering an Authorware piece over the Internet or a corporate, 
government, or educational intranet.

What you can do In Authorware 6 Help, see

Determine which files need to 
be published

Determining which files you need to distribute

Package a piece Using one-button publishing to package a piece, 
Using batch publishing to package a piece

Republish a piece that has 
previously been published

Repackaging a piece

Package external media files 
internally

Packaging linked media internally

Package a library Packaging a library

Package a piece and its 
libraries separately

Packaging a piece and its libraries separately

Package a piece for the Web Getting a piece ready for the Web, 
Getting ready for the Web—step-by-step procedures

Add ADL-SCORM metadata 
to a piece

SCO Metadata Editor

Locate missing Xtras Using the Find Xtras command
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Getting ready for the Web—step-by-step procedures

Using one-button publishing to package a 
piece
You can streamline the publishing and packaging process by using the Publish 
command in the File menu. It provides a way for you to find most of the Xtras, 
libraries, and DLLs you have used, and package and publish several versions of a 
single Authorware piece in one step.

For example, for a single Authorware piece, you can publish Authorware packages 
without run time (A6R file), for the Web Player (AAM file), and for a Web page 
(HTM file) by simply choosing one command.

The first time you use one-button publishing for a piece, you should look at the 
publishing settings to be sure you have set it up to publish your piece in the way 
you want to. After you have published the piece the first time, the settings you 
have selected remain, and you can republish it by simply using the command 
File > Publish > Publish. In most cases, you can produce exactly the published 
files you want using one-button publishing; however, you can also publish pieces 
without changing the default settings. However, you can also review each of the 
settings and customize them as needed. You can then save your customized 
publishing settings, so you do not have to reenter them if you need to package 
and publish your files again.

What you can do In Authorware Help, see

Package a piece for the Web Publishing for the Authorware Web Player, Publishing 
to a Web page

Publish remotely to an FTP site Publishing remotely

Republish your piece Repackaging a piece

Combine map files for different 
player versions

Combining map files for different player versions

Play a Director movie in 
a Web-packaged piece

Playing Director movies in Web-packaged pieces

Tune the performance of 
a Web-packaged piece

Performance tips for Web-packaged pieces

Configure the Web server On your server, Configuring your server

Add a Web-packaged piece 
to a Web page

Publishing to a Web page

Set up a Web page for 
non-streaming browsers

Publishing for the Authorware Web Player
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Setting up one-button publishing settings

The default settings for one-button publishing are the following:

• Without Runtime publishes a packaged A6R file.

• For Web Player publishes an AAM file that can be launched with the 
Authorware Web Player.

• Web Page publishes an HTML file.

You can select from the following one-button publishing settings for CD, LAN, 
and Local HDD:

• With Runtime publishes an executable EXE file. (This is not a default setting. 
To select it, see “Setting up one-button publishing settings” on page 179.)

• Without Runtime publishes a packaged A6R file (this is a default setting).

You can also select from the following settings for distribution over the Web:

• For Web Player publishes an AAM file that can be launched with the 
Authorware Web Player (this is a default setting).

• Web Page publishes an HTML file (this is a default setting).  
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Determining which files you need to 
distribute
A piece typically consists of not only the Authorware file that contains the flowline 
but also external files, Xtras, scripting Xtras, and DLLs that the Authorware file 
may use. To run properly, a packaged piece requires that these external files be 
available. If they aren’t already available on the computer running the packaged 
piece, you must provide them.

Which files a packaged piece requires depends on the piece’s components and the 
platform it runs on. You might need to include the following files in addition to 
the Authorware A6P file that contains the flowline:

• Xtras for each media type used. Include the Xtras that are required by 
Authorware to process any graphic or sound format as well as Xtras for any 
specific formats. For example, if you use GIF, include GIFIMP.x32 . For details, 
see the following topics in Authorware Help: 

Files you need to distribute for images

Files you need to distribute for sounds

Files you need to distribute for movies

Files you need to distribute for Director movies

Files you need to distribute with animated GIFs

• Linked files, such as linked graphics, external sounds, and Director, 
QuickTime 2.0 for Windows, or Video for Windows movies. 

• Authorware drivers and system-level drivers for components such as 
QuickTime 2.0 for Windows,  for Windows, video overlay, and videodisc 
players. For details, see the following topics in Authorware Help:

Files you need to distribute for movies

Other files you may need to distribute

• Fonts, when you want to make sure the piece has a specific font that might not 
be available on users’ computers. For details, see Distributing text fonts in 
Authorware Help.

• Installation and decompression programs for packages that you have 
compressed.
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• External software modules that the piece uses, such as Xtras, ActiveX controls, 
UCDs, and DLLs. For details, see the following topics in Authorware Help:

Distributing Xtras

Distributing the Macromedia Control Xtra for ActiveX

Distributing UCDs and DLLs

Distributing an Authorware piece that uses a database

Commands menu
The extensible Commands menu is new in Authorware 6. It contains several 
built-in commands, including the following:

• Find Xtras. This is used to assist in locating the Xtras that are used for an 
Authorware piece and copy them all to the same folder. For more information, 
see Using the Find Xtras command in Authorware Help.

• RTF Objects Editor. This is used to create an edit RTF objects without leaving 
Authorware and includes enhancements not found in other RTF editors, such 
as the ability to add images, paste in Authorware expressions, and create your 
own graphics. For more information, see “Using the RTF Objects Editor” on 
page 192.

• SCO Metadata editor. The Department of Defense Advanced Distributed 
Learning (ADL) initiative has developed common guidelines for the 
development, delivery, and management of learning. The Shareable 
Courseware Object Reference Model (SCORM) is a reference model for a 
set of interrelated guidelines for resuability, accessibility, durability, and 
interoperability. This is accomplished by the use of very structured packaging 
guidelines, or metadata. The SCO Metadata editor now provides the metadata 
with your package that conforms to  ADL-SCORM specifications. For more 
information see “SCO Metadata Editor” on page 338.

You can also create your own commands and add them to the Commands menu. 
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Adding your own commands to the 
Commands menu
When you start Authorware, it populates the Commands menu with the names of 
all the EXE and A6R files located in the Commands folder in the Authorware 
program directory. 

You can add any kind of executable (EXE) file to the Commands menu. You do 
not have to create it using Authorware. However, only Authorware EXE, A6R, or 
A6P files, or files built with an SDK like the Delphi SDK (included on the 
Authorware CD), will be able to communicate with Authorware.

The behavior of the items in the Commands menu is similar to that of the 
Authorware Knowledge Objects. When you select a command, another instance 
of Authorware is launched that runs the command. The Commands menu uses 
the same CallTarget protocol, and the commands are modal. 

This means you cannot access the original instance of Authorware until the 
command is completed or stopped. Only one command can be executed at a 
time. When the command completes, control is returned to the Authorware 
application. For instructions on how to do this, see Adding your own commands 
to the Commands menu in Authorware Help.
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Working with Content

An Authorware piece is made up of logic and content. Logic—the way you 
arrange and structure icons on the flowline—defines how a piece works. 
Content—text, graphics, movies, and so on—communicates the information in a 
piece and gives the piece its look and feel.

This chapter describes how to work with content as you develop an Authorware 
piece, create and integrate media into a piece, and make the most of the media. 
It includes cross-references to instructions on using text, graphics, animation, 
sound, and video.

You can use several types of media in Authorware:

• Text

• Graphics (backgrounds, photos, drawings, diagrams, borders, buttons)

• Digital movies (Director movies, Flash movies, animated GIFS, 
QuickTime 2 movies, Video for Windows movies, PICS)

• Sound (music, voice-overs, sound effects)

• Video (from a videodisc player)

• Other media (Flash, animated GIFs, Quicktime 3 and 4 formats)
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Creating and incorporating content
You can use Authorware to create some content (for example, text and simple 
graphic objects). However, most content is created outside Authorware using 
specific media editors. Media editors are sophisticated applications for creating 
and modifying digital media. 

Using Xtras and OLE to include content

Authorware can also be extended through the use of Xtras to include other types 
of content, such as QuickDraw 3D objects. Xtras are plug-ins that let you add 
functional elements to the Presentation window. For example, with the 
Macromedia Control Xtra for ActiveX you can embed elements such as Web 
browsers, calendars, and user interface controls in an Authorware piece.

In Windows, you can use object linking and embedding (OLE) to embed such 
elements as functioning spreadsheets and charts in an Authorware piece.

Embedding and linking content
Once you’ve created content in a media editor, you need to import it into 
Authorware, either by embedding or by linking. If you embed a file, the actual file 
data is stored in the Authorware piece. If you link to a file, the only data stored in 
Authorware is the file’s name and location. For information on specific 
procedures, see “Embedding and linking content—step-by-step procedures” on 
page 185.

With externally linked media, if you need to change content—for example, by 
shortening a sound file—you simply change the original file. As long as the file has 
the same name and the same location, Authorware automatically includes the 
change when the piece is played. You can link content over a network or across the 
Internet. If you edit content frequently in the application you used to create it, 
linking to external media files is an efficient way to update changes.

Although linking helps keep your piece small, it also means that you end up with 
lots of separate files to distribute. Linked media files in different locations can be 
tricky to manage. The External Media Browser helps you manage these files. See 
“Using external content and the External Media Browser” on page 241.

With embedded media, the content becomes part of your Authorware piece; it is 
no longer linked to the program that created it. Embedded media is harder to 
update. To change sound, for example, you must open the original sound file, 
make the changes, and then reimport the file into Authorware. On the other 
hand, using embedded media makes file management easier: Although the size of 
the piece increases because the media files are all contained within it, you need to 
distribute fewer files.
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If you use the same media elements over and over in a piece, you can collect them 
in libraries. For more information, see “External content, libraries, and models” 
on page 238.

Embedding and linking content—step-by-
step procedures

What you can do In Authorware Help, see

Import text Creating and integrating text

Import graphics Importing a graphic, Linking to external files

Import sound files Importing a sound, Linking to external files

Import digital movies Importing a digital movie, Linking to external files

Export embedded media Exporting embedded content

Check the links to all 
external files

External Media Browser—step-by-step procedures

Fix a broken link Fixing a link to an external file

Edit a link Editing the link to an external file

Change a link to a different file Linking to a different external file

Define a link with a variable 
or an expression instead of a 
literal path

Defining a link with an expression, 
External content, libraries, and models

Relink to a file after changing 
its format

Relinking to a file after changing its format

Set up a relative path in place of 
an absolute path

External Media Browser—step-by-step procedures
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Working with text
Text in a piece can be used for headings, questions, prompts, button labels, and 
simple directions—or as the main feature of pieces such as tutorials, help systems, 
language training, interactive books, reference titles, and so on. For more 
information, see“Text—step-by-step procedures” on page 191.

You can do the following things with text:

Display text and move text on the screen Use the Text tool to edit text and create 
short text segments such as questions, comments, and headings. If you already 
have large portions of text created in a word processor or editor, you can import 
the text in rich text format, which retains style information, then edit the text in 
Authorware. You can change the font, size, and style of text and assign predefined 
text styles by using the Text menu, or you can add interest by applying transition 
effects or by moving text along a path or across the screen like a banner.

Use hypertext and hot text Hypertext is text that users click to navigate from one 
part of a piece to another. Hot text is like a hot spot on a hot object: Authorware 
reacts in some predefined way when users click it.

Let users enter text Or move text objects as part of an interaction. For example, 
you can create an interaction that lets users correctly label objects. 

You can store text that users enter and set up Authorware so it automatically 
makes decisions based on the data that users enter. Highly interactive pieces and 
pieces with instant feedback use this feature. 

Send text to and retrieve it from a database You might build a front end to a Web 
site that looks up customer records and displays the information inside 
Authorware. You can have the WriteExtFile function create a record of a student’s 
performance in a quiz. Or you can use the Authorware Open Database 
Connectivity (ODBC) capabilities and Structured Query Language (SQL) 
commands to set up an interface to something such as a referral agency database 
that lists members, their specialties, and their current availability.

Guidelines for creating and integrating text
Here are some issues that may affect decisions you make about text:

• Not all computers have the same fonts available. If you can’t make sure that the 
fonts you want to use will get installed on users’ computers, stick with standard 
system fonts.

• Downloading fonts to Windows computers is clumsy. Although you can 
use Authorware Web Packager to download the custom fonts that a 
Web-packaged piece needs, Windows users need to restart their computers 
before the fonts become available. If you don’t know which fonts Windows 
users have, it’s best to stick with system fonts.
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• You can use the Add/Remove Font Resource Knowledge Object to help install 
and remove fonts. This Knowledge Objects adds a font resource to a user’s 
system by copying the TrueType font you specify to the system director, then 
loading the font. Before your piece ends, you can use another Add/Remove 
Font Resource Knowledge Object to remove the font resource from the user’s 
system memory.

• Bitmap text doesn’t require text fonts. If you want text with a special look—
such as a logo—you can use a bitmap image rather than a text object. Then the 
text will look the same on all platforms. On the other hand, bitmaps are more 
difficult to edit, and they use more disk space than editable text objects.

Creating and integrating text
There are four ways to create text and integrate it into an Authorware piece. 

Use the RTF Objects Editor to create media-rich RTF documents within 
Authorware. You can add images, your own graphics, special formatting, 
hyperlinks, and paste Authorware expressions directly into the RTF Object. You 
then use an RTF Knowledge Object to include it on the flowline. See “Using the 
RTF Objects Editor” on page 192.

Creating text within Authorware is a good choice for prototyping, last-minute 
editing, and short discrete bits of text such as prompts and help messages.

To create or edit text within Authorware, open a display icon or an interaction 
icon and use the Text tool. 

Click in the Presentation window with the Text tool to get the insertion 
cursor. Click again to create additional text objects. Each text object can be 
positioned and sized independently of the others.

During editing, a paragraph ruler appears above the text. It has small triangles 
indicating indent markers and small boxes indicating the text box margins. Click 
the paragraph ruler to create tab stops; you can drag them to adjust them. Indents 
apply only to the selected paragraph. Use indented paragraphs to simulate text 
wrapping around objects. 

Importing text is good for long passages of text that appear over many pages and 
for text that requires specific paragraph formatting, such as hanging indents.

Create text in a word processor and save it in rich text format (RTF). Use the 
File > Import command in Authorware to bring the text into a display icon. You 
can then use the Authorware text editing features (text styles or the Text tool and 
Text menu) to give the text its final form.

RTF text retains all formatting except for headers, footers, footnotes, tables, and 
columns. Those elements appear as regular paragraph text.
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If the text contains page breaks, you can choose whether it is treated as one 
page or as separate display icons. You can create a text object with or without 
scroll bars.

Pasting text is another quick way of getting text into your Authorware piece. If 
you set up paragraph styles in a word processor and you need to add properly 
formatted text to Authorware, you can create it quickly in a word processor and 
then copy and paste it into Authorware. For example, an outline would retain all 
its styles and indents.

Open the document that you want to paste from, select the text to be pasted, and 
copy it to the Clipboard. 

Dragging and dropping a text file directly from your desktop and dropping it on 
the flowline automatically embeds it in a display icon. Authorware also gives you 
the option of displaying the text in the file in a scrolling field or of creating a 
separate display icon for each page of text in the file. It’s a great way to set up a 
paging structure.

Making the most of text
Here are some ways to use text efficiently and creatively.

Paging or scrolling? If you have a block of text that won’t fit on a single screen, 
you have the option of making a scrolling text window or placing the text in 
another page. With Authorware it’s easy to do either. 

From a user’s point of view, scrolling through text is fine when only a few lines 
don’t fit on the screen. However, scrolling through many screens can be tiring 
for the eyes.

If you think the best solution is a paging structure where users click a button to 
advance to the next page, you can use the framework icon to quickly create a book 
metaphor. Be sure to let users know how many pages of text are to come—or 
number the pages so users will know where they are. 

Assigning text styles You may want to assign specific text attributes—font, size, 
style, color, even interactivity—to text. Text styles make text easy to read, indicate 
its purpose, and look attractive. To conveniently format and update entire portions 
of text, define text styles so you can quickly apply sets of specific text attributes.

Styles help you make text formatting consistent throughout a piece, regardless of 
the text’s source. Modifying a text style’s attributes automatically updates the 
attributes for any text assigned that particular text style.
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Searching for text Not only can you search for text as you are authoring (choose 
Edit > Find), but users can search for text as the piece is running. Authorware has 
a built-in search feature to accommodate searches within the entire piece or within 
the current framework. To set up a text search, use the navigate icon and set the 
destination to Search. Users can search for words or keywords assigned to icons. 
See “Search—allowing users to search for a page” on page 292 for more details.

Controlling text with variables and functions
Authorware has a set of variables and functions designed especially for working 
with text. The following tables list the variables and functions and give a brief 
description of each.

For more information about the variables in the following table, see System 
variables in Authorware Help. 

Variable Description

CapsLock CapsLock is TRUE if the Caps Lock key is currently on.

CharCount Contains the number of characters the user typed in 
response to a text interaction.

EntryText Contains the text of the user’s last response in the 
last interaction.

ForceCaps When set to TRUE, all text the user types in the current 
interaction display is converted to uppercase letters.

HotTextClicked Contains the hot text that a user has clicked.

PresetEntry Text assigned to this variable appears automatically in a 
text-entry field during presentation.

WordClicked Contains the word the user clicked in a text object.

WordCount Contains the number of words the user enters in a 
text-entry interaction.
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For more information about the functions in the following table, see System 
variables in Authorware Help.

Function Description

Capitalize Returns the string that results from capitalizing the first 
character of every word in the string.

Char Returns the character, number, symbol, or key name that 
corresponds to the ASCII code or key name you specify.

CharCount Returns a count of the number of characters, including 
spaces, found in a string.

Code Returns the ASCII code that corresponds to the character, 
number, symbol, or key name you specify.

DeleteLine Returns the string that results from deleting a line in a string.

Eval Makes it possible to evaluate expressions at run time, based 
on information the user enters.

EvalAssign Interprets an assignment operation in a text string as if it 
were a literal assignment operation.

Find Searches a text string for the text you’re looking for.

GetLine Retrieves a specific line from a text string.

GetNumber Returns a numeric value from a series of values in a string.

GetWord Returns the nth word from a string.

InsertLine Inserts a line in a string and returns the result.

LineCount Returns the number of lines in a string.

LowerCase Converts all the uppercase letters in a string to lowercase 
letters and returns the result.

MapChars Maps the characters in a string from the values for one 
platform to the values for the other.

NumCount Returns the count of numbers in a string.

Reduce Eliminates repeated characters and returns the result.

RepeatString Duplicates a string a given number of times and returns 
the result.

Replace Replaces one text segment with another in a string and 
returns the result.

ReplaceLine Replaces one line in a string with another line and returns 
the result.

ReplaceString Replaces a portion of string with new text and returns 
the result.
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Text—step-by-step procedures

ReplaceWord Replaces one word in a string with another word and returns 
the result.

RFind Searches a string and returns the position of the last match 
it finds.

String Converts data into a string.

Strip Removes one or more characters from a string and returns 
the results.

SubStr Returns a portion of a string.

UpperCase Converts all the lowercase letters in a string to uppercase 
and returns the results.

WordCount Returns the number of words in a string.

What you can do In Authorware Help, see

Add text to the 
Presentation window

Working with text

Import text Importing text

Paste text Pasting text or graphics

Align text Changing the font, size, style, or alignment of text

Anti-alias text Anti-aliasing text

Set the font, size, or style 
of text

Changing the font, size, style, or alignment of text

Define text styles Defining text styles

Create a style based on 
the current format of a 
block of text

Creating a text style from an existing format

Create hypertext Creating a hot text style, Navigating with hot text, Show Me: 
Hot Text

Apply text styles Applying text styles

Modify text styles Modifying text styles

Change margins Setting paragraph attributes

Set tabs Setting paragraph attributes

Function Description
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Using the RTF Objects Editor
The RTF Objects Editor is a powerful tool that lets you create full-featured 
screens external to Authorware and have them show in the Authorware 
Presentation window. 

In order to use the features provided with the RTF Objects Editor, you will need 
to use the Create RTF Object Knowledge Object instead of importing the RTF 
document into a display icon. See Creating an RTF Object Knowledge Object in 
Authorware Help.

Note: You can also use any simple word processing program, like Word Pad, to create 
RTF documents. However, you cannot import graphics, draw your own graphics, or paste 
Authorware expressions into the files.

Definitions

In order to understand how the RTF Objects Editor and RTF Knowledge Objects 
work, it is important to be clear about the terminology.

RTF document An external RTF document created by the RTF Objects Editor, an 
Authorware variable containing RTF codes, or a memo field from a database 
containing RTF codes.

RTF Objects Editor The application you launch from the Authorware Commands 
menu which creates RTF documents.

RTF Object An Authorware display object created by either the Create RTF 
Object Knowledge Object or the rtfCreate() function. An RTF Object is 
transparent and responds to Authorware erase issues, such as before next entry, 
after next entry, and on exit. Multiple instances are supported. You can use the 
Authorware erase and motion icons on an RTF Object, and you can export an 
RTF Object to a graphic.

Indent a paragraph Setting paragraph attributes

Align paragraphs Setting paragraph attributes

Let users enter text Setting up a text-entry field

Set the style of the 
text the user enters

Setting the style of user-entered text

Check spelling and 
add dictionaries

Spelling

Find and change words Find

Apply transitions to text Choosing a transition

What you can do In Authorware Help, see
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An RTF document is preprocessed before it is turned into an RTF Object. During 
this preprocessing phase, RTFObj.u32 replaces embedded variables and 
expressions and imports external text and graphics.

RTF Knowledge Objects The Knowledge Objects that allow you to create and 
manipulate RTF Objects in the Authorware Presentation window. Do not confuse 
an RTF Object with an RTF Knowledge Object. An RTF Object is a display 
object, and an RTF Knowledge Object is the Knowledge Object that creates and 
manipulates the RTF Object. 

Several examples are provided in the RTF.a6p Show Me located in the Authorware 
program directory folder ShowMe/RTF. 

Features

The following are some of the things you can do using the RTF Objects Editor. 
You can seamlessly include these features in your own Authorware applications.

• Provide non-Authorware developers with the ability to create screens. They’ll 
be able to mix and position text, graphics, and other objects and then easily see 
the results inside the Authorware Presentation window. This helps you to 
streamline production work, letting Authorware developers concentrate on the 
code while other professionals focus on creating your screens.

• Give users the ability to vertically scroll large graphics (or graphics mixed with 
text and other objects).

• Create external text and format it any way you like. Mix boldface, underlines, 
italics, colors, and fonts in any combination you want. If you’ve ever tried to 
use external text before, you’ll really appreciate this feature.

• Create many different polygon shapes not available inside Authorware. 

• Use Rich Text Format files. You can either embed them or link them to other 
files, so that inside Authorware you are always showing the latest version.

• Easily insert the current date and time in a variety of formats.

• Embed any Authorware variables and expressions you want. Authorware 
evaluates them just as it would if those variables and expressions had been 
entered directly in the Authorware Presentation window.

• Print anything you’ve prepared with the RTF Objects Editor. This means users 
can print anything that you show them through the RTF Objects Editor: a 
lesson to review offline, a certificate of achievement, or anything you want.
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Opening the RTF Objects Editor

The RTF Objects Editor lets you create rich documents that include formatted 
text, graphics, and other objects. A non-Authorware user can use it to set up your 
materials completely outside of Authorware, then easily insert those materials in 
the Presentation window. Many of the options in the RTF Objects Editor are 
similar to those in word processors. You can include any of the following objects:

• Text

• Graphics

• Shapes

• Page breaks

• Authorware variables and expressions

• Hot text

Using the RTF Objects Editor, you can open RTF documents and memo fields in 
Microsoft Access databases and edit them using the RTF Objects Editor features.

To open the RTF Objects Editor:

Choose Commands > RTF Objects Editor. 

The RTF Objects Editor toolbar

The RTF Objects Editor toolbar contains standard Windows buttons. It also 
includes several specialized buttons. For information on specific buttons, see 
“Managing files with the RTF Objects Editor” on page 195 and “Editing files 
with the RTF Objects Editor” on page 199. 
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Managing files with the RTF Objects Editor
To create new files and open and close existing files, you can use the commands in 
the RTF Objects Editor’s File menu. You can also use buttons in the RTF Objects 
Editor toolbar or keyboard commands for most menu selections.

Opening a new RTF document

When you open a new file, if another RTF document is open, it will be closed first.

To open a new RTF document:

1 Choose Commands > RTF Objects Editor.

2 In the RTF Objects Editor, do one of the following: 

• Choose File > New.

• Click the New Document button in the toolbar.

• Press Control+N.

Opening an existing RTF document

You can also open an existing RTF document.

To open an existing RTF document:

1 In the RTF Objects Editor, do one of the following:

• Choose File > Open Document.

• Click the Open Document button in the toolbar.

• Press Control+O.

A list of RTF documents in the current directory is displayed.

2 Select the file you want to open.
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Opening a database

You can open an existing Microsoft Access database and view or edit the values in 
memo fields. The only values you can access are those in memo fields.

You can use the RTF Objects Editor to store RTF information in a database. This 
is useful because you can store multiple RTF documents in separate database 
fields, yet deliver a single database with your piece. Otherwise, you would have to 
deliver multiple RTF documents. 

This feature also gives you all the power and capabilities of a database. For 
example, the Authorware developer could store an entire product catalog in a 
database, along with a description and a picture of each product. Authorware can 
be used to browse the database by displaying the previous record, next record, and 
so on. Storing RTF in database memo fields provides these advantages:

• It makes the product catalog more colorful and interesting for the user.

• It makes building a database browser easier, because the Authorware developer 
can simply retrieve the fields for the current record and does not need to open 
external RTF documents in addition to reading the database fields.

To open a Microsoft Access database:

1 In the RTF Objects Editor, do one of the following:

• Choose File > Open Database.

• Click the Open Database button in the toolbar.

• Press Control+D.

2 Select the MS Access Database MDB file you want to open.

The Select Database Table/Field/Record dialog box is displayed.
Chapter 5196



3 Highlight a table to select it. 

If a memo field exists in the table, it is displayed in the Memo Field section. 
The value of the memo field is displayed in the Memo Value section. Reference 
fields for the memo field are displayed in the Reference field section. 

Note: You can edit only the records (references) in memo fields.

4 Select a reference field from the Reference Field section.

The Reference fields contain the values for individual records in the database.

5 Do one of the following:

• To edit a value in a reference field, use the arrows or the slider bar to scroll 
through the values in the reference field. Display the value you want to edit, 
then click OK to return to the RTF Objects Editor window and edit it. 

• To insert an image, click OK to return to the RTF Objects Editor window. 
Select Insert > Image from the RTF Objects Editor menu.  Select an image, 
then click OK.

When you save the file, the value in the field is updated.

Opening a previously opened RTF document

You can select from a list of the last four opened RTF documents to quickly open 
a file you have been using.

To open a previously opened RTF document:

1 In the RTF Objects Editor, choose File > Reopen.

A list of previously opened files is displayed.

2 Select the file you want to open. 

Saving an RTF document

You can save an RTF document using the same name, which updates the existing 
file, or you can save a file with a new name, which creates a new file.

To save an RTF document, do one of the following in the RTF Objects Editor:

• To save a file using the same name, choose File > Save, click the Save button in 
the toolbar, or press Control+S.

• To save a file with a new name or location, choose File > Save As. Enter the new 
location and file name.
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Printing an RTF document

You can print the RTF document that is currently open.

To print an RTF document:

1 In the RTF Objects Editor, do one of the following:

• Choose File > Print.

• Click the Print button in the toolbar.

• Press Control+P.

The Print Setup dialog box is displayed. 

2 Set the print options as desired.

3 Click OK.

Exiting the RTF Objects Editor

To return to the Authorware Design or Presentation window, you need to close 
the RTF Objects Editor.

To exit the RTF Objects Editor:

1 In the RTF Objects Editor, do one of the following:

• Choose File > Exit.

• Click the Exit button on the toolbar.

• Press Alt+F4.

2 If you have not previously saved your file, you are prompted to do so. Click Yes 
to save your file.

You are returned to the Authorware Presentation or Design window.
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Editing files with the RTF Objects Editor
You can use the commands in the Edit menu within the RTF Objects Editor as 
you would the editor in any word processor to select, copy, cut, and paste text 
and objects.

Undoing the last action 

You can return your file to the state it was in before your last action.

To undo the last action, do one of the following in the RTF Objects Editor:

• Choose Edit > Undo.

• Click the Undo button in the toolbar.

• Press Control+U.

The file is returned to its previous state.

Redoing the last action

If you have used Undo, Redo will repeat the undone action.

To redo the last action that you undid, do one of the following in the RTF Objects 
Editor:

• Choose Edit > Redo.

• Click the Redo button in the toolbar.

• Press Control+Y.

The file is returned to the state it was in before you used Undo. 

Deleting text or graphics

You can delete the currently selected item from a file and copy it to the Clipboard.

To delete text or a graphic and save a copy to the Clipboard:

1 In the RTF Objects Editor, select the text or graphic.

2 Do one of the following:

• Choose Edit > Cut.

• Click the Cut button in the toolbar.

• Press Control+X.

The selection is deleted from the current location and copied to the Clipboard. 
You can then paste it into a new location.
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Copying text or graphics

You can copy the currently selected item to the Clipboard.

To copy text or a graphic to the Clipboard:

1 In the RTF Objects Editor, select the text or graphic.

2 Do one of the following:

• Choose Edit > Copy.

• Click the Copy button in the toolbar.

• Press Control+C.

The selection is copied from its current location to the Clipboard. You can then 
paste a copy into a new location.

Pasting text or graphics

You can paste the contents of the Clipboard at the current insertion point.

To paste material on the Clipboard to a new location:

1 In the RTF Objects Editor, select and cut or copy the text or graphic.

2 Place the insertion point in the new location.

3 Do one of the following:

• Choose Edit > Paste.

• Click the Paste button in the toolbar.

• Press Control+V.

The text or graphic is pasted from the Clipboard to the new location. It 
remains in the Clipboard and can be pasted again at another location.

Using the Paste Special command

To choose from different formats to use when pasting the current Clipboard 
contents at the insertion point, you use the Paste Special command. This 
command allows you to paste text only from an e-mail or another document, 
without font, color, or other formatting information.

To paste special text or formats:

1 Select and cut or copy the text or graphic.

2 Place the insertion point in the new location.

3 In the RTF Objects Editor, choose Edit > Paste Special.
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4 Select one of the special options (depending on the source):

• Select Picture if the selection is a graphic.

• Select Rich Text Format to paste an RTF document with objects.

• Select Rich Text Format Without Objects to paste an RTF document 
without objects.

• Select Unformatted Text to paste only text, with no formatting.

5 Select other options as needed:

• Select Paste Link to paste a link to an existing file.

• Select Display as Icon to display the pasted item as an icon.

6 Click OK.

The text or graphic is pasted from the Clipboard to the new location. It 
remains in the Clipboard and can be pasted again in another location.

Searching for and replacing text in the RTF 
Objects Editor
Using the RTF Objects Editor Search menu, you can perform standard search and 
replace operations.

Searching for text

You can use the RTF Objects Editor to search for any occurrence of text.

To locate text in a document:

1 In the RTF Objects Editor, place the insertion point at the place in the file 
where you want to begin your search.

2 Select the text you want to find.

3 Do one of the following:

• Choose Search > Find.

• Click the Find button in the toolbar.

• Press Control+F.

The Find dialog box is displayed. If you selected text in step 1, the Find What 
text box text box displays the text you selected. 

4 If you did not select text or want to find other text, type it in the text box.
Working with Content 201



5 If you want, select the following options:

• Select Match Whole Word Only to match only the entire word in the Find 
What text box. 

• Select Match Case to match the word only when it is in the same case as that in 
the Find What text box. 

• Select either Up or Down to specify the direction for the search. 

6 Click Find Next to locate the next occurrence of the text in the direction 
you selected.

The RTF Objects Editor searches through the file from the insertion point.

7 Continue clicking Find Next until you have found all the text you want, then 
click Cancel.

8 To repeat the last Find or Search operation, choose Search > Search Again.

Replacing text

You can use the RTF Objects Editor to search for and replace occurrences of text.

To replace text in a document:

1 In the RTF Objects Editor, place the insertion point at the place in the file you 
want to begin to replace text.

2 If you want, select the text you want to replace.

3 Choose Search > Replace. 

The Find and Replace dialog box is displayed. If you selected text in step 2, the 
Find What text box displays the text you selected. 

4 If you did not select text or you want to find other text, type it in the text box.

5 In the Replace With text box, enter the text you want to substitute for the 
found text.

6 If you want, select the following options:

• Select Match Whole Word Only to match only the entire word in the Find 
What text box. 

• Select Match Case to match the word only when it is in the same case as that in 
the Find What text box. 

• Select either Up or Down to specify the direction for the search. 
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7 Do one of the following:

• Click Find Next to locate the next occurrence of the text in the direction 
you selected.

• Click Replace to replace the first occurrence of the Find What text with the 
Replace With text.

• Click Replace All to replace all occurrences of the Find What text with the 
Replace With text.

The RTF Objects Editor searches through the file from the insertion point.

8 Continue clicking the desired buttons until you have replaced all the text you 
want, then click Cancel.

9 To repeat the last Find or Search operation, choose Search > Search Again.

Changing view options in the RTF Objects 
Editor
You can select the toolbars you want displayed in the RTF Objects Editor screen, 
including the main toolbar, Format bar, ruler, and Status bar. The default is to 
display all toolbars.

Toolbar
Ruler

Status Bar

Format Bar
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To change the display of toolbars:

1 In the RTF Objects Editor, choose View. 

A list appears showing the toolbars you can display. A check mark precedes 
those toolbars that are displayed.

2 Click each toolbar to select or deselect it, until you have selected the toolbars 
you want to display.

When you return to the RTF Objects Editor, the selected toolbars are displayed.

Inserting files and graphics using the RTF 
Objects Editor
You can use the RTF Objects Editor to insert graphics and files directly into your 
RTF documents.

Inserting a file or image into an RTF document

You can embed or link to an external text (TXT) file, Rich Text Form (RTF) file, 
or Knowledge Display (KDD) file. You can also embed or link to an external 
image file, including BMP, JPG, WMF, or EMF formats.

To insert a file or image in an RTF document:

1 Use the RTF Objects Editor to open a file.

2 In the open RTF document, place the insertion point at the location where you 
want to insert the file.

3 If you are inserting a file, choose Insert > File or click the Insert File button on 
the toolbar. 

If you are inserting an image, choose Insert > Image or click the Insert Image 
button on the toolbar.

4 Select the type of file you want to insert.

5 Select the path and name of the file.

6 Select one of the following options:

• Import File copies the current information from the file into the open RTF 
document. If changes are made to the imported file after insertion, they are not 
reflected in the RTF document.

• Link File copies the location of the file into the open RTF document. Every 
time the RTF document is opened, the linked file is copied into the RTF 
document. If changes are made to the linked file, they are reflected in the 
RTF document.
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7 If you selected Link File in step 5, select a path option:

• Absolute (Full Path) looks for the linked file at the exact location (including 
drive) specified. For example, if you select c:/rtflink for the location of the file, 
the RTF Objects Editor will always look for the file at that location.

• Relative to File Location looks for the linked file in a location relative to where 
the RTF document is currently located. For example, if you select c:/rtflink for 
the location of the file, but you move the RTF document to the D drive, the 
RTF Objects Editor will look for the file at d:/rtflink.

8 If you are inserting an image, select the Image Preview option you want to use 
to review the file:

• Normal displays a preview of the image at its normal size and location.

• Center displays a preview of the image at its normal size, centered in the Image 
Preview box.

• Stretch displays a preview of the image stretched to fill the Image Preview box.

9 Click OK to insert the file or image.

Inserting a shape in an RTF document

You can create a shape in an RTF document, such as a circle, square, or rectangle, 
and format it in several ways. This is useful when you use the RTF Objects Editor 
to create a user interface.

To insert a shape in an RTF document:

1 Use the RTF Objects Editor to open an RTF document, or start a new file.

2 Place the insertion point at the location where you want to insert the shape.

3 Choose Insert > Shape or click the Insert Shape button on the toolbar.

The Insert Shape dialog box appears.
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4 Select the shape you want to insert.

5 Change the Inside Brush settings as needed to determine the fill for the shape.

As you change the settings, you see the result in the Shape section of the 
dialog box.

6 Change the Outside Border settings as needed to determine the color, line 
width, and line style of the border defining the shape.

7 Click OK.

The shape is inserted into your RTF document.

Inserting a symbol in an RTF document

You can choose and insert a character from any installed font in your RTF 
document. It’s a good idea to use commonly installed fonts, because the end 
user must also have the font installed in order to see the symbol displayed. 

To insert a symbol in an RTF document:

1 Use the RTF Objects Editor to open an RTF document.

2 Place the insertion point at the location where you want to insert the symbol.

3 Choose Insert > Symbol or click the Insert Symbol button on the toolbar. 

The Insert Symbol dialog box displays.

4 Change the font as needed.

5 Click the symbol, then click OK to insert it.

Inserting a hyperlink (hot text) in an RTF document

You can insert an Authorware hypertext link, hot text, into an RTF document. 
When you insert Hot Text into the RTF document, all that is inserted is a 
HPYERLINK tag. This doesn’t do anything unless the RTF document is displayed 
inside Authorware using either the Create RTF Object Knowledge Object or the 
rtfDisplay function). This parses the RTF document, and the HPYERLINK tags 
are removed. 

Internally, RTFObj.u32 remembers the hyperlink positions. You can use this and 
turn the hyperlinks into something active by either inserting the RTF Hot Text 
Knowledge Object or using the rtfGetLinkCount, rtfGetLinkCoor, 
rtfGetLinkText, and rtfGetLinkCode functions in a calculation icon. See 
“Using RTF functions” on page 214 and “Inserting an RTF Object Hot Text 
Interaction Knowledge Object” on page 213.
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To insert a hyperlink in an RTF document: 

1 Use the RTF Objects Editor to open an RTF document.

2 Place the insertion point at the location where you want to insert the hyperlink.

3 Choose Insert > Hot Text or click the Insert Hot Text button on the toolbar.

4 In the  LinkText field, enter the text for the hyperlink. For example, if you want 
the user to click on the words "Go to demonstration", you would enter Go to 
demonstration.

5 In the Link Code field, enter the link code or icon title. For example, if you 
want to link to an icon titled "Demonstration", you would enter 
Demonstration in the Link Code field.

6 Select Underline Hot Text if you would like the hot text underlined.

7 Click OK. 

The hot text is inserted in the RTF document as a hypertext link.

8 The hypertext link will not be active until you insert an Insert RTF Object Hot 
Text Interaction on the flowline. See “Inserting an RTF Object Hot Text 
Interaction Knowledge Object” on page 213.

Inserting a page break in an RTF document

When you create a Create RTF Object Knowledge Object for an RTF document, 
Authorware creates your RTF Object from the StartPage to the EndPage, reading 
the <page break> tags. The default is to create an object containing all pages. 
However, if you want to create an RTF Object starting on page 2, you could enter 
2 as the start page and the RTF Object would be created starting at page 2. See 
“Creating an RTF Object Knowledge Object” on page 212.
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To insert a page break in an RTF document: 

1 Use the RTF Objects Editor to open an RTF document.

2 Place the insertion point at the location where you want the page break.

3 Choose Insert > Page Break or click the Insert Page Break button on the toolbar.

The code <Page Break> appears in the RTF document.

Inserting the date and time in an RTF document

You can insert the date and time in an RTF document, using the Authorware 
built-in variables.

To insert the date and time in an RTF document: 

1 Use the RTF Objects Editor to open an RTF document.

2 Place the insertion point at the location where you want to insert the date and 
time.

3 Choose Insert > Date and Time or click the Insert Date and Time button on 
the toolbar.

4 Select the format for the date and time.

5 Click OK.

The date and time are inserted in the file.

Inserting an Authorware expression in an RTF document

You can insert an Authorware expression in an RTF document. The expression 
will be executed like any other Authorware expression.

When you insert the expression, the parameters are empty, meaning that default 
parameters for each function and variable will be used. You can override the 
defaults by entering the parameters you want to use for the expression.
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To insert an Authorware expression in an RTF document:

1 Use the RTF Objects Editor to open an RTF document.

2 Place the insertion point at the location where you want to insert the 
Authorware expression.

3 Choose Insert > Authorware Expression or click the Insert Authorware 
Expression button on the toolbar.

4 Select either Functions or Variables.

5 To shorten the list of choices, select the appropriate category.

• Function categories are All, Character, CMI, Decision, File, Framework, 
General, Graphics, Icons, Jump, List, Math, Network, OLE, Platform, Target, 
Time, Video, and [Untitled].

• Variable categories are All, CMI, Decision, File, Framework, General, 
Graphics, Icons, Interaction, Network, Time, Video, and [Untitled].

6 Select the expression, then click the Insert button.

The selected expression displays at the bottom of the Insert Authorware 
Expression dialog box.

7 Click OK.

The expression is inserted in the RTF object.
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Changing formats with the RTF Objects 
Editor
You can use the Format menu in the RTF Objects Editor to change character and 
paragraphic formatting.

Changing character formatting in your document

You can use the RTF Objects Editor to change character attributes such as font, 
size, and color. 

To change character attributes: 

1 Use the RTF Objects Editor to open an RTF document.

2 Select the text you want to change.

3 Choose Format > Fonts.

4 Select the desired font.

5 Set parameters as desired for Font Style, Size, Effects (Strikeout or Underline), 
Color, and Script.

6 Click OK.

Changing paragraph formats

You can use the RTF Objects Editor to change paragraph attributes such as 
indentation, alignment, and spacing. 

To change paragraph alignment:

1 Use the RTF Objects Editor to open an RTF document.

2 Select the paragraph or paragraphs you want to format.

3 Choose Format > Paragraph.

4 Select parameters as desired for Indentation, Alignment, and Spacing.

5 Click OK.
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Adding or changing tab stops

You can use the RTF Objects Editor to add, change, and delete tab stops for 
selected paragraphs. 

To add or change tab stops:

1 Use the RTF Objects Editor to open an RTF document.

2 Select Format > Tabs.

The Tabs dialog box displays.

3 In the text box at the top of the Tabs dialog box, type a value or use the arrows 
to select the position for the tab stop.

4 Click Add.

The tab stop is displayed at the bottom of the Tabs dialog box.

5 Repeat steps 4 and 5 to add additional tab stops.

6 Click Set to set the tabs.

7 To clear a tab, highlight it and click Clear.

8 When you are finished, click OK.

Using RTF Knowledge Objects
After you have created an RTF document using the RTF Objects Editor, you can 
add it to the flowline and edit how it functions on the flowline using Authorware 
RTF Knowledge Objects. 

You can use RTF Knowledge Objects in the following ways:

• Use the Create RTF Object Knowledge Object to create a new RTF Object ID 
variable, which is used in all the other RTF Knowledge Objects to identify an 
RTF document. See Creating an RTF Object Knowledge Object in 
Authorware Help.

• Use the Save RTF Object Knowledge Object to export a previously created 
RTF Knowledge Object to an RTF document or graphic. See Exporting an 
RTF Object Knowledge Object in Authorware Help.

• Use the Show or Hide RTF Object Knowledge Object to display or hide an 
RTF Object Knowledge Object when it is running. See Using the Show or 
Hide RTF Object Knowledge Object in Authorware Help.

• Use the Get RTF Object Text Range Knowledge Object to display the text in a 
specific range of an RTF document. See Using the Get RTF Object Text Range 
Knowledge Object in Authorware Help.
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• Use the Insert RTF Object Hot Text Interaction Knowledge Object to create an 
Interaction linked to an RTF document and a specified number of responses. 
See Inserting an RTF Object Hot Text Interaction Knowledge Object in 
Authorware Help.

• Use the Search RTF Object Knowledge Object to find a specified text string 
and return the position of that text string in an RTF document. See Searching 
for text in a RTF Object Knowledge Object in Authorware Help.

Creating an RTF Object Knowledge Object

After you have created an RTF document using the RTF Objects Editor, you use 
the Create RTF Object Knowledge Object to provide an RTF Object ID variable 
name for the RTF document so that you can import it into your Authorware 
piece.

Note: Do not import an RTF document created using the RTF Objects Editor into a 
display icon. If you do, the RTF document will not be able to access the RTF Objects Editor 
features you used to create or edit the file, such as imported graphics, Authorware 
expressions, or special formatting.

Exporting an RTF Object Knowledge Object

The Save RTF Object Knowledge Object exports a previously created RTF 
Object to a new RTF document or a graphic after it has been pre-processed. The 
RTF object to be exported must have been created using the Create RTF Object 
Knowledge Object.

Using the Show or Hide RTF Object Knowledge Object

The Show or Hide RTF Object Knowledge Object shows or hides an existing 
RTF object that has been previously created using the Create RTF Object 
Knowledge Object. Basically this does the same thing as the Show RTF Object 
option in the Create RTF Object Knowledge Object (see the procedure under 
Creating an RTF Object Knowledge Object in Authorware Help). The difference 
is when the object is made visible or invisible.

The Show RTF Object option in the Create RTF Object Knowledge Object 
allows you to make the RTF Object visible or invisible at creation time. The Show 
or Hide RTF Object Knowledge Object allows you to make the RTF Object 
visible or invisible during the execution of the piece, for example, at run time 
when a specific condition is met. 

You might want to start off with an invisible object and then make it visible later 
when it is actually needed. Alternately, you might want to start off with a visible 
object and later hide it. See Creating an RTF Object Knowledge Object in 
Authorware Help.
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Using the Get RTF Object Text Range Knowledge Object

The Get RTF Object Text Range Knowledge Object returns a specified range of 
text for an existing RTF object that has been previously created using the Create 
RTF Object Knowledge Object.

Inserting an RTF Object Hot Text Interaction Knowledge 
Object

The RTF Object Hot Text Interaction Knowledge Object inserts an interaction 
icon in the flowline with hot spot responses for your RTF object. These responses 
interact with the hot text in your RTF document. See Inserting a hyperlink (hot 
text) in an RTF document in Authorware Help.

The hot spot responses created by the RTF Object Hot Text Interaction 
Knowledge Object use the rtfGetLinkCoor function to position themselves over 
the hyperlinks. When the user clicks a hot spot response, meaning when the user 
clicks an RTF object hyperlink, the Knowledge Object navigates to the 
IconTitle associated with the hyperlink. This is what is returned by the 
rtfGetLinkCode function. See “RTF functions” on page 215.

However, what you associate with the hyperlink in the RTF Objects Editor 
doesn’t have to be an IconTitle. It could be something completely different. 
Basically, rtfGetLinkText returns the visible portion of the hyperlink, and 
rtfGetLinkCode returns the invisible portion of the hyperlink. The RTF Object 
Hot Text Interaction Knowledge Object assumes the invisible portion is an 
IconTitle and navigates to that IconTitle. However, you can modify what is 
inserted by the RTF Object Hot Text Interaction Knowledge Object, or bypass that 
Knowledge Object altogether, using the rtfGetLink functions in a calculation 
icon, and do something completely different when the user clicks a hyperlink.

By default, the RTF Object Hot Text Interaction Knowledge Object navigates to 
an icon, because in practice, this is what most of the users want it to do. That is 
why the RTF Objects Editor suggests associating an IconTitle with the hot text 
when inserting a hyperlink into the document. 

Searching for text in an RTF Object Knowledge Object

You can use the Search RTF Object Knowledge Object to search for specific text in 
an RTF object that was created with the Create RTF Object Knowledge Object.
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Using RTF functions
If you are an experienced Authorware developer, instead of using RTF Knowledge 
Objects, you can use the underlying RTF functions by themselves. Before you can 
use them, you need to load RTFObj.u32, which contains the RTF functions.

To load RTF functions:

1 Choose Window > Functions > Load.

The Functions dialog box is displayed.

2 Select the category [untitled].

3 Click the Load button.

The Load Functions dialog box is displayed.

4 Select RTFObj.u32, then click Open.

The Custom Functions in RTFObj.u32 window is displayed, listing all 
RTFObj.u32 functions.

5 To see a description of a function, click it.

6 Select the functions you want to load, then click Load.

The RTF functions are loaded.
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RTF functions

When you load the RTF functions, you can use the following functions with 
RTF objects.

Function Syntax Description

rtfCreate Id := 
rtfCreate(Left, 
Top, Width, 
Height, 
"Source", 
Scrolling, 
Prevent¬
AutomaticErase, 
StartPage, 
EndPage)

This function creates an RTF object with the 
specified Width and Height on your screen 
at point (Left, Top) and then reads the 
RTF document identified by "Source".
If StartPage and EndPage are supplied, 
then this function reads the pages from 
StartPage to EndPage. Otherwise it reads 
all pages.
This function returns the RTF object Id if 
successful; otherwise it returns 0.
Note: This function does not show the object. 
If you want to display the object in the 
Authorware Presentation window, you need 
to call rtfShow() explicitly.

rtfErase Result := 
rtfErase(Id)

This function erases the RTF object identified 
by Id.
This function returns 1 (TRUE) if successful; 
otherwise it returns 0 (FALSE).

rtfFindText Result := 
rtfFindText(Id, 
StartPos, 
"TextOrPhrase")

This function searches a given range in the 
RTF object identified by Id for some specific 
text or a phrase.
Use this function to search a range of text in 
an RTF object for some specific text or a 
phrase. Only the text in the range starting at 
the position StartPos will be searched.
This function returns the position of the text 
or phrase, where 0 is the position of the first 
character in the RTF object. If the text or 
phrase does not appear in the indicated 
range, this function returns -1.

rtfGetCurrent¬
Printer

Result := 
rtfGetCurrent¬
Printer()

This function returns the position of the 
currently selected printer in the list of 
installed printers, with the first printer 
having a value of 1.
Note: the list of installed printers is returned 
by the rtfGetPrinterNames() function.

rtfGetLinkCode Result := 
rtfGetLink¬
Code(Id, Num)

This function returns the code of the 
hyperlink identified by Num in the RTF object 
identified by Id.
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rtfGetLinkCoor Result := 
rtfGetLinkCoor¬
(Id, Num)

This function returns the coordinates of the 
hyperlink identified by Num in the RTF object 
identified by Id.
Coordinates are relative to the Authorware 
Presentation window. The return value is a 
property list that looks like this: 
[#Left:20, #Top:10, #Width:120, 
#Height:21]
Note: If the RTF object is not visible, this 
function returns an empty property list.

rtfGetLinkCount Result := 
rtfGetLink¬
Count(Id)

This function returns the number of 
hyperlinks found in the RTF object 
identified by Id.

rtfGetLinkText Result := 
rtfGetLinkText¬
(Id, Num)

This function returns the text of the 
hyperlink identified by Num in the RTF 
object identified by Id.

rtfGet¬
Orientation

Result := 
rtfGet¬
Orientation()

This function returns the currently selected 
printer orientation:
0: Your RTF document prints vertically on 
the page (default).
1: Your RTF document prints horizontally 
on the page.

rtfGetPageCount Result := 
rtfGetPage¬
Count("Source")

This function returns the number of pages in 
the RTF document identified by "Source".

rtfGetPrinter¬
Names

Result := 
rtfGetPrinter¬
Names()

This function returns a list of all printers 
installed in Windows.

rtfGetTextRange Result := 
rtfGetText¬
Range(Id, 
StartPos, 
EndPos)

This function returns the text between 
StartPos and EndPos for the RTF 
object identified by Id.

rtfHide Result := 
rtfHide(Id)

This function hides the RTF object 
identified by Id.
This function returns 1 (TRUE) if successful; 
otherwise it returns 0 (FALSE).

rtfLineFromPos Result := 
rtfLineFrom¬
Pos(Id, 
Position)

This function returns the whole line where the 
specified linear character position appears 
for the RTF object identified by Id.

Function Syntax Description
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rtfPrint Result := 
rtfPrint¬
("Source", 
MarginLeft, 
MarginTop, 
MarginRight, 
MarginBottom, 
StartPage, 
EndPage)

This function prints the RTF document 
identified by "Source".
Margin parameters specify the dimensions, in 
1/1000 inches, of the page size used when 
printing your RTF document.
If StartPage and EndPage are supplied, 
then this function prints the pages from 
StartPage to EndPage; otherwise it prints 
all pages.
This function returns 1 (TRUE) if successful, 
otherwise 0 (FALSE).

rtfSave Result := 
rtfSave¬
(Id, FileType, 
"FileName")

This function exports the RTF object 
identified by Id to the file specified by 
"FileName".
FileType can be one of these:
0: RTF
1: BMP
2: JPG
3: GIF
This function returns 1 (TRUE) if successful; 
otherwise it returns 0 (FALSE).

rtfSetCurrent¬
Printer

Result := 
rtfSetCurrent¬
Printer(Index)

This function sets the currently selected 
printer.
Index is the printer referenced by its position 
in the list of installed printers, with the first 
printer having a value of 1.
Note: The list of installed printers is returned 
by the rtfGetPrinterNames() function.
This function returns 1 (TRUE) if successful; 
otherwise it returns 0 (FALSE).

rtfSet¬
Orientation

Result := 
rtfSet¬
Orientation¬
(Orientation)

This function determines if your RTF 
document prints vertically or horizontally on a 
page.
These are the possible values for Orientation:
0: Your RTF document prints vertically on the 
page (default).
1: Your RTF document prints horizontally on 
the page.
This function returns 1 (TRUE) if successful; 
otherwise it returns 0 (FALSE).

rtfShow Result := 
rtfShow(Id)

This function displays the RTF object 
identified by Id.
This function returns 1 (TRUE) if successful; 
otherwise it returns 0 (FALSE).

Function Syntax Description
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When you publish a piece that contains RTF objects for the Web, you can either 
add the RTF documents to the map file or choose to publish them separately. 
Whichever option you choose, the RTF documents do need to be available on 
your remote server.

When using NetLocation() to open and load your RTF documents, 
RTFObj.u32 does not require your RTF documents to be in the map file because 
RTFObj.u32 includes a built-in HTTP client and can stream the RTF documents 
without the map file. When using FileLocation to open your RTF documents, 
you do need to add the RTF documents to the map file.

Note: The Create RTF Object Knowledge Object uses NetLocation(), and therefore 
doesn’t require your RTF documents in the map file.

Working with images and graphic objects
The Authorware graphics tools are best used for prototyping and creating simple 
graphic elements. For more sophisticated graphics you should use a program other 
than Authorware. Often the graphics that you want to use already exist—for 
example, a set of engineering schematics, a collection of digitized photographs, or 
archives of historical documents saved on a CD. At other times you will need the 
power of a graphics application such as Fireworks to create and edit images before 
you bring them into Authorware. See “Creating and integrating images and 
graphics” on page 219 for a list of compatible image file formats.

Graphics are placed in display or interaction icons. These icons can hold many 
graphic objects. You can layer objects and give them various transparency modes. 
You can group several objects together and treat them as a single object.

Things to consider

Before you start working with images and graphic objects, ask yourself the 
following questions: “What is the minimum bit depth I can use?” and “What is 
the minimum bitmap resolution I can use?”

Bit depth If your graphics will be downloaded from the Internet, keep the bit 
depth to a minimum. A minimum bit depth keeps file sizes small. Saving graphics 
at a color depth of 8 bits or less improves performance significantly.

Bitmap resolution Most graphics applications let you create bitmaps up to 
300 dots per inch (dpi). High resolution such as that is useful for print media, 
but on the screen most of the information is lost, since monitors usually display 
around 72 to 96 dpi. 

Import graphics at 72 dpi. If you import at a higher or lower resolution, 
Authorware resizes the graphic. For example, if you import a graphic at 144 dpi, 
the graphic appears at half its normal size.
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Creating and integrating images and 
graphics
There are several ways to create graphics and integrate them into Authorware. You 
can use the toolbox to draw graphics, you can import graphics that were created in 
another application, and you can link to graphics files. You can also cut and paste 
or drag and drop graphics. 

Using the toolbox The toolbox appears when you open a display or interaction 
icon for editing. Use tools in the toolbox to draw, resize, and rearrange graphics in 
the Presentation window.

Use this tool To do this

Pointer Select and move objects in the Presentation window. 
Click an object to select it. Shift-click to select several 
objects. Drag the center of a filled object to move it. Drag a 
handle on a selected object to resize it.

Text tool Create and edit text. 
Click in the Presentation window to create a new text 
object. Click an existing text object to open it for editing. 
Type in an open text object to edit text.

Straight Line tool Draw horizontal, vertical, or 45° lines. 
Click the start point and drag to draw a line. The line snaps to 
a horizontal, vertical, or 45° position.

Diagonal Line tool Draw a line between any two points. 
Click the start point and drag to draw the line.

Oval tool Draw an ellipse. 
Click and drag to draw an oval; click and Shift-drag to 
draw a circle.

Rectangle tool Draw a rectangle. 
Click and drag to draw a rectangle; click and Shift-drag to 
draw a square.

Rounded Rectangle tool Draw a rectangle with rounded corners. 
Drag the control point that is inside the object to adjust the 
bevel of the corners.

Polygon tool Draw irregular polygons or multiline objects. 
Click to create the polygon’s corners; double-click 
the last point to complete the polygon. Drag points 
to modify the line.
Working with Content 219



Importing images You can import the following types of images:

BMP, EMF (Extended Metafile), GIF, JPEG, LRG (xRes), PICT, PNG (Portable 
Network Graphics), PSD or PS3 (Photoshop), TIFF, TGA (Truevision Targa), 
and WMF (Windows Metafile). 

Note: To import or play back or view PICT images in Windows, you must have 
QuickTime 2.0 for Windows installed.

You can preview images before you import them. Once you import an image, 
choose Modify > Image > Properties to set the mode (transparent, inverse, and so 
on), set the background and foreground colors, and view information about the 
image (file size, file format, and color depth).

Linking to an external image When you select Import, the Import dialog box gives 
you the option to Link to File. Authorware retains the original file format 
information, rather than converting to BMP or DIB format. Together with the 
External Media Browser, the Link to File option enables you to manage, edit, and 
substitute images in their original format.

For the advantages and disadvantages of linking to files, see “Embedding and 
linking content” on page 184.

Making the most of images and graphics
Use Window > Inspectors to set the lines, fills, modes, and colors of objects that 
you create within Authorware. The modes palette also applies to imported 
graphics and some digital movie formats. There are six modes: opaque, matted, 
transparent, inverse, erase, and alpha. There are some movie formats that always 
play in opaque mode, such as AVI. 

Positioning graphics

In Authorware, there are several ways to position graphics and digital movies:

• Enter values (or variables) in the Layout tab of the Properties dialog box

• Drag objects with the pointer

• Align one or more objects along their top, bottom, left, or right edges; align 
them horizontally or vertically relative to the center of each object; or align 
them so they are equally spaced horizontally or vertically or both

• Display a grid and constrain the movement of objects to the grid

• Group several objects to maintain their relative positions as you drag them 
or to apply an attribute, or for any other reason you might want to treat them 
as a group

To help position graphics in the Presentation window, you can view objects in 
preceding display icons. 
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Layering objects

When you arrange several text or graphics objects in a single display icon, some of 
the objects may overlap. The same thing can happen when you display text and 
graphics from several different display icons on the screen at the same time. The 
overlap may cause a problem—for example, a background may hide the text that’s 
supposed to appear in front of it. 

Inside a single display icon Authorware arranges objects from back to front in the 
order in which you create or import them. To rearrange their order, use the Bring 
to Front and Send to Back commands. 

In the Presentation window, Authorware arranges objects from back to front in 
the order in which the icons that contain them appear on the flowline. To move 
an object to the front or the back—without moving the icon that contains it—use 
the icon’s Layer setting. 

The Layer setting is especially flexible because you can use a variable or expression 
instead of a number for the setting. With a variable or expression, the order in 
which objects appear in the Presentation window can change dynamically. For 
example, you can use variables to set the layering of an object relative to 
another object.

Layer setting
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Controlling images with variables and 
functions
Authorware has a set of variables and functions designed especially for working 
with images. The following tables list the variables and functions and give a brief 
description of each.

For more information about the variables in the following table, see System 
variables in Authorware Help. 

For more information about the functions in the following table, see System 
functions in Authorware Help.  

Variable Description

DirectToScreen Draws an image directly to the screen.

DisplayHeight Contains the height of an image.

DisplayLeft Contains the distance between the left end of an object 
and the left edge of the Presentation window.

DisplayTop Contains the distance between the top of the objects 
and the top edge of the Presentation window.

DisplayWidth Contains the width of an object.

DisplayX Contains the distance from the center of the objects to 
the left edge of the Presentation window.

DisplayY Contains the distance from the center of the objects to 
the top of the Presentation window.

LastX, LastY Contain the last X and Y coordinates drawn by a 
graphics function.

Layer Contains the layer number of the current screen object.

Function Description

Box Draws a box on the screen.

Circle Draws a circle on the screen.

DrawBox Allows the user to draw a box.

DrawCircle Allows the user to draw an oval.

DrawLine Allows the user to draw a line.

Line Draws a line on the screen.

Overlapping Returns a value of TRUE if the graphic objects in the 
icons you specify overlap.
Chapter 5222



Graphics—step-by-step procedures

RGB Combines the red, green, and blue values into a single 
color value.

SetFill Sets the current fill style for drawing functions.

SetFrame Sets the current frame style for drawing functions.

SetLine Sets the line style for drawing functions.

SetMode Sets the current mode for drawing functions.

SetPalette Loads a palette and sets it as the current palette for the 
Presentation window.

What you can do In Authorware Help, see

Import a graphic Importing a graphic, 
Linking to external files

Preview a graphics file Importing a graphic

Drag and drop graphics Drag and drop feature in Authorware

Draw a graphic Drawing graphics

Cut and paste graphics Pasting a graphic

Apply a mode, color, fill, or 
line width

Mode, color, fill, and line width

Blend a graphic’s alpha 
channel with the background

Displaying a graphic’s alpha channel

Align graphics Arranging graphics

Control order in which images 
appear in front of other images

Placing objects in front of other objects

View graphics in preceding 
display icons

Displaying the content of several icons

Crop a graphic Cropping a graphic

Scale a graphic Scaling a graphic

Use a custom color palette Using custom color palettes

Move a graphic across the 
Presentation window

Using the motion icon, 
Making objects move

Function Description
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Working with sound
Sound can be a valuable component of a piece. It can provide information as a 
narration, enhance the mood of a scene, provide a transition between scenes, or be 
the focus of the entire piece.

Sound is contained in a sound icon. The sound icon’s position on the flowline 
establishes when the sound plays. The Sound Icon Properties dialog box lets you 
specify which sound to play and the way it plays. 

Guidelines for using sound

Follow these guidelines when you use sound in your Authorware piece:

• It’s easier to edit the sound to begin and end where you want before you import 
it. This is because you must use Authorware functions to specify starting and 
stopping points of a segment in a sound file, unlike digital movies, from which 
Authorware can easily select a range of frames.

• Because sound icons are branching icons, they cannot be direct children of 
Interaction, Decision, or Framework icons. You can, however, place a map icon 
next to the interaction, decision, or framework icon, then place the sound icon 
inside the map icon.

• Make sure each sound has been recorded at a sampling rate that will give you 
the sound quality you need for the particular use. The higher the sampling rate 
of a sound, the better the sound quality but the larger the sound file. For 
example, music CDs are sampled at 44 kHz, voice-overs may be sampled at 
22 kHz, and short sound effects may need no more than 11 kHz. If you’re 
delivering the piece containing the sound over the Web, save the sound at an 
8-bit sample size and at a sample rate of no more than 11 kHz. Smaller sample 
rates, such as 5 kHz or 7 kHz, may also be sufficient.

Use a special effect to display 
or erase a graphic

Choosing a transition

Use a graphic as a button Setting up a hot object,
Hot Object Interactions

Synchronize graphics 
with sound

Media Synchronization
SyncPoint, SyncWait functions
Show Me: A/V Synchronization

Let the user create graphics DrawBox, DrawCircle, and DrawLine functions

Use libraries to 
organize graphics

Using libraries

What you can do In Authorware Help, see
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• Mono sounds are significantly smaller than stereo sounds. Unless you 
require stereo for some specific purpose, always save your sounds as mono 
to save disk space.

• Compress sounds using Shockwave Audio (SWA), MP3, Voxware (VOX), 
or ADPCM compression.

• Make sure users’ computers have sound cards. A computer that has no sound 
card can play a piece that includes sound, but the sound itself won’t play.

• For 16-bit sounds, make sure users’ computers have sound cards capable of 
playing 16-bit sounds.

File formats for sounds

Authorware supports the following sound file formats: AIFF, MP3, PCM, 
SWA,VOX, and WAVE.

Creating and integrating sound
Shockwave Audio is a technology that makes sounds smaller and plays them faster 
off disk or over the Internet. Shockwave Audio can compress sounds up to a ratio 
of 176-to-1. It also makes them streamable—meaning that they can begin playing 
before they’re completely loaded into memory. Use Director to create sound files 
in Shockwave Audio (SWA) format. The higher the bit rate you choose for the 
compression setting, the better the quality of the sound will be. However, some bit 
rates are too high for certain Internet access methods. For instance, 16 Kbps, the 
equivalent of monaural FM radio quality, works for 28.8 Kbps modems, but 
higher bit rates do not.

You can also convert WAV files to SWA files in Authorware. Choose Xtras > 
Other > Convert WAV to SWA.

Voxware achieves even greater compression for voice-only audio files. When you’re 
creating simple voice-overs or narration—without music, sound effects, or any 
background noise—record the audio as a WAVE file, then convert it to 
the Voxware format (VOX).

If you use an MP3 sound file, be sure to distribute the AWMP3.x32 Xtra with the 
file. There is a limit on the types of MP3 files that Authorware will play. If a file is 
allowed to change bit rates and go from mono to stereo or stereo to mono, there 
may be a significant change in bit rates. This is a fairly rare condition in most 
MP3 files, but it is possible. If it turns out that the change in the bit rate is 
significant enough to throw off the algorithm that imports an MP3 file, then it is 
possible there will be playback problems with the sound.
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The best compression technique and the best compression ratio to use depend on 
the relative importance of conserving memory and retaining sound quality. Use 
your judgment. When memory is adequate and high sound quality is the priority, 
a lower compression ratio or no compression at all is a better choice.

Always make a copy of the original sound before you compress it. After a sound is 
compressed, you can’t decompress it. You can only change the compression rate by 
reloading the sound and selecting a different compression rate.

You can import sounds into Authorware by dragging sound files onto the flowline. 
Authorware creates a sound icon for you. When the sound icon is open, you can 
preview the sound, choose how fast it plays, set the conditions under which it 
plays, and set the number of times it repeats.

Synchronizing audio, video, and graphics
Synchronizing multimedia components must be done carefully. Animation, video, 
and sound each require a certain length of time to play—time that can vary from 
computer to computer. When you play these components together, making sure 
they start and stop at the right time in relation to each other is crucial to creating 
a smooth piece. Synchronizing sound with motion or video usually requires 
repeated testing to determine how long each component takes to play, where any 
noticeable pauses occur when a component is loaded into memory, and the start 
and stop points for each component. 

You can place icons to the right of sound or movie icons, creating a child icon. In 
addition, you can set those child icons to trigger based on the media position or 
number of seconds from when the media starts playing. See Media Sychronization 
in Authorware Help.

Another way to present sound and graphics together is to combine them in a 
digital movie. This guarantees that the sound and image remain synchronized. 
It also offers better performance than running a sound icon concurrently with 
another icon.

A common technique in a presentation is to display text and graphics 
synchronized with key points in an audio track containing voice-over 
narration. You can synchronize sounds with visuals by using the SyncPoint 
and SyncWait functions.

You can also use the MediaPosition variable for synchronization with digital 
movies such as QuickTime or Video for Windows.

Choose Help > Show Me, and then launch A/V Synchronization to see an 
example of synchronizing sounds with graphics.
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Media Synchronization
If you place an icon to the right of a sound or movie icon, it becomes a child icon 
of the sound or movie icon. You can set child icons to trigger based on the media 
position or number of elapsed seconds from when the media starts playing. 

Note: Because sound and movie icons are branching icons themselves, they cannot be 
direct children of Interaction, Decision, or Framework icons.

Controlling sound with variables and 
functions
You can control sound in your Authorware piece through the use of the following 
variables and functions. For complete details on how to use the variables and 
functions, see System variables overview and System functions overview in 
Authorware Help.

Variables

For more information about the variables in the following table, see System 
variables overview in Authorware Help. 

Variable Description

Contains the length of the movie, sound, or video icon 
you specify. Sound icons return 1000ths of seconds.

MediaPlaying Determines whether a specific digital movie is playing.

MediaPosition Tells you the current position of the sound icon.

MediaRate Contains the rate for the movie, sound, or video icon 
you specify. 

SoundPlaying Contains the value of TRUE if a sound is playing.
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Functions

For more information about the functions in the following table, see System 
Functions in Authorware Help.  

Sound—step-by-step procedures

Working with digital movies
Digital movies are more than animation and synchronized sound. By adding 
the ability to select and play specific frames and conserve space through 
compression, you can:

• Include digital movies created outside Authorware

• Simulate equipment and processes, such as a sprouting seed, readings on a 
gauge, or varying degrees of rotation for an object

• Compress graphics or sound used in a piece

Function Description

MediaPause Pauses a movie, sound, or video.

MediaPlay Plays a specific digital movie, sound, or video. When the 
digital movie is already playing, it is reset to its starting 
frame and plays from the beginning.

MediaSeek Sets the position for the movie, sound, or video icon.

What you can do In Authorware Help, see

Compress a voice audio file Compressing voice audio files

Import a sound Importing a sound, Linking to external files

Preview a sound Previewing a sound

Set the speed at which a 
sound plays

Changing a sound’s speed

Set the number of times a 
sound plays

Setting how many times a sound repeats

Integrate a sound with other 
things that are happening

Creating and integrating sound

Synchronize sounds 
with graphics

Synchronizing audio, video, and graphics
Media Synchronization
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Authorware gives you added options and possibilities by playing digital movies in 
response to the conditions you choose. You can play the digital movies when cued 
by the flowline, when a variable reaches some value, or when the user takes a 
specific action. By using integers or variables to specify frames, you can play a 
selected sequence of frames. For specific procedures, see “Digital movies—
step-by-step procedures” on page 232.

You can use the Shockwave control for ActiveX to play Director Shockwave 
movies.For information about using ActiveX controls, see Using an ActiveX 
control in Authorware Help.

Things to consider

Some types of digital movies are always embedded in Authorware; others must be 
treated as external linked files.

• PICS, FLC/FLI/CEL, and DIB sequence movies are always embedded.

• Director, QuickTime, MPEG, and AVI movies are always external linked files.

Whether the digital movie is embedded or external affects what you must do 
before delivering it to users.

External digital movies must have the appropriate drivers available and be in the 
proper format for the platform they play on. For a list of the drivers you must 
include with each type of digital movie, see “Determining which files you need to 
distribute” on page 180.

Digital movie file formats

Authorware supports the following digital movie file formats:

• Director

• Video for Windows (AVI)

• QuickTime for Windows (MOV)

• FLC/FLI/CEL

• MPEG (when played with a 100% MCI-compliant MPEG card)

• DIB /BMP sequences
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Creating and integrating digital movies
Digital movies are created outside Authorware in applications such as 
Macromedia Director. Integrating a digital movie into your piece involves placing 
a digital movie icon in the appropriate place on the flowline, opening the digital 
movie icon, and selecting a digital movie file. When the digital movie icon is 
open, you can also preview the movie, choose how fast it plays, and set the 
number of time it repeats.

To quickly import digital movies, you can drag and drop movies from the desktop 
into the flowline. Use the Shift key when dragging to link to the movie rather than 
embedding it.

Because movie icons are branching icons, they cannot be direct children of 
Interaction, Decision, or Framework icons. You can, however, place a map icon 
next to the interaction, decision, or framework icon, then place the movie icon 
inside the map icon.

Making the most of digital movies
Authorware provides you with several ways to use digital movies efficiently 
and creatively. For information on procedures, see “Digital movies—step-by-step 
procedures” on page 232.

Using motion with movies You can use the motion icon with digital movies to 
move the movie around the screen. For example, you may have an animation of a 
bird that moves its wings as if it were flying. You can move the bird along a path to 
simulate the bird flying across the screen.

Playing a range of frames Authorware can play a range of selected frames from a 
digital movie. The range can be different segments of a digital movie that play at 
different times, such as different segments from a 360-degree view from the top of 
Mount Kilimanjaro, or a few frames from a digital movie that simulates turning a 
knob to different positions. You can identify frames by frame numbers, or you can 
use variables or other expressions. Using variables or other expressions gives you 
the flexibility to select different frames at different times, depending on conditions 
in the piece. 

The digital movie can loop continuously, play a set number of times, or play until 
some specific condition occurs. Use the Movie Icon Properties dialog box to 
specify the timing and number of times a digital movie plays.

Retaining Director interactivity Unlike QuickTime and Video for Windows 
movies, Macromedia Director movies are noted for interactivity—the ability to 
interpret and respond to the user, the computer, or external input. If you already 
have a Director movie that you want to include in Authorware or if you find that 
a Director movie can accomplish a task better than Authorware (Director excels in 
animation and sound), then you will want to take advantage of the ability of 
Authorware to retain Director interactivity.
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Saving Director movies as QuickTime movies If you save a Director movie as a 
QuickTime movie, you don’t need all the Director driver files and your movie will 
be much more compact. To save a Director movie as a QuickTime movie, create a 
movie in Director (without interactivity) and convert it to QuickTime.

Turning sound off in digital movies Suppose you want to use a digital movie’s 
animation but not its sound. You can use the Audio On option to specify whether 
a digital movie’s sound plays along with the animation. 

Seeing objects behind PICS and FLC/FLI movies For PICS and FLC/FLI movies, 
you can change the layer that the movie appears in. For example, you might want 
to keep the contents of a previous icon on top and have the contents of 
subsequent icons appear behind it. You can set the movie’s Layer attribute to make 
the movie appear in front of or behind other objects regardless of the movie’s place 
on the flowline. 

You might want to let other objects show through. For PICS, FLC/FLI/CEL, and 
DIB/BMP sequence movies in an Authorware piece, you can do this by applying 
different modes to the movie. The modes work much the same way as the modes 
on the modes palette. 

Variables and functions for digital movies
Authorware has several variables and functions that track what a digital movie is 
doing so that you can respond accordingly. The following tables list the variables 
and functions and give a brief description of each.

For more information about the variables in the following table, see System 
Variables in Authorware Help.

Variable Description

MediaPlaying Determines whether a specific digital movie is playing.

MediaPosition Tells you the current frame number in a digital movie.

MediaLength Tells you the total number of frames in a digital movie.

MediaRate Contains the rate for the movie, sound, or video icon 
you specify. 
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For more information about the functions in the following table, see System 
Functions in Authorware Help.

Digital movies—step-by-step procedures

Function Description

GetMovieInstance Provides a value that serves as an identifier for an instance 
of a QuickTime 2 or AVI movie within Authorware.

MediaPause Pauses a movie, sound, or video.

MediaPlay Plays a specific digital movie, sound, or video. When the 
digital movie is already playing, it is reset to its starting 
frame and plays from the beginning.

MediaSeek Sets the position for the movie, sound, or video icon.

What you can do In Authorware Help, see

Import a movie Importing a digital movie

Preview a movie Previewing a digital movie

Play a range of frames Playing a range of frames in digital movies

Set a movie’s playback speed Digital Movie Icon Properties

Set whether a movie plays in 
front of or behind other images

Specifying a PICS/FLC/FLI/CEL and DIB sequence 
movie’s layer

Make a movie’s background 
transparent

Seeing objects behind PICS/FLC/FLI/CEL and DIB 
sequence movies

Turn off the movie’s sound Turning off sound in digital movies

Play a sound-only movie Digital Movie Icon Properties

Set the number of times a 
movie plays

Setting how many times a digital movie plays

Integrate a movie with other 
things that are happening

Digital Movie Icon Properties

Position a movie in the 
Presentation window

Digital Movie Icon Properties

Allow users to move the 
movie image

Digital Movie Icon Properties

Retain Director interactivity Allowing Director interactivity
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 Working with video
Videodisc is an excellent source of high-quality images and sound. Training 
applications where television-quality video is crucial—for example, surgery 
training in hospitals—can be created by using video within Authorware. You 
can set up Authorware to automatically jump to a certain frame in response to 
choices students make or conditions you set, and you can give students playback 
controls so they can view the video at their own pace and can rewind or replay 
sections if necessary.

Using the variables and functions related to the video icon, you can control the 
video in ways that the Video Icon Properties dialog box alone can’t. For example, 
you can have more precise control over which frame plays, detect whether video is 
started or finished and instruct the piece to respond accordingly, and send 
instructions to the video player. For information on how to set up video controls, 
see “Video—step-by-step procedures” on page 236.

Things to consider

To play a segment of video from a videodisc or videotape player, you need the 
following components:

• The source material on videodisc 

• A videodisc player connected to the computer

• A place for the image to appear—either an external monitor or a computer that 
contains a video overlay card

You need to specify the video controls in the File > Preferences dialog box.

Let users control the playback 
of a movie

Letting users control QuickTime movies

See objects behind PICS and 
FLC/FLI movies

Displaying digital movies in front of other objects

What you can do In Authorware Help, see
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Creating and integrating video
Setting up Authorware for video is a four-step process: setting up the hardware, 
setting up Authorware, creating an overlay display, and associating the display 
icon with a video icon. For information on specific procedures, see “Video—step-
by-step procedures” on page 236.

Integrating video

Once you are set up for video, you can set the playback conditions in the Video 
Icon Properties dialog box. The options include:

• The segment’s beginning and ending frames.

• How fast the video plays—slow motion, backward, and so on.

• Which audio channels play (for bilingual tracks or voice-overs).

• Whether to provide an onscreen controller that lets users control the video. You 
may want to allow users to review sections freely in some parts of the course but 
withhold control of the video during a quiz.

• When to freeze the video, so that at the end of a segment Authorware displays a 
frame rather than a blank screen.

• Whether to display frame numbers. In a process tutorial you may want to refer 
to what’s happening in specific frames (for example, each stage in the 
development of a fertilized cell).

• Conditions to stop playing video. A video segment can repeat until a student 
answers a question about it.

Making the most of video
If you have a video overlay card, you can use the chroma key for special effects—for 
example, showing the video inside large bold text, within a special shape, or with a 
soft edge around it. The chroma key is a certain color that you define through 
which the video will play. Areas in the chroma key color are replaced by video.

For information on specific procedures, see “Video—step-by-step procedures” on 
page 236.
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Controlling video with variables and 
functions
The functions and variables related to video can give you control of the video in 
ways that the Video Icon Properties dialog box alone can’t. For example, you can 
more precisely control which frame plays; detect whether video is starting or 
finishing and instruct the piece to respond accordingly; and send instructions to 
the video player. The following tables list the variables and functions and give a 
brief description of each.

Variables

For more information about the variables in the following table, see System 
Variables in Authorware Help. 

Functions

For more information about the functions in the following table, see System 
Functions in Authorware Help. 

Variable Description

MediaLength Contains the length of the video icon you specify. 
Sound icons return 1000ths of seconds.

MediaPlaying Determines whether a video clip is playing.

MediaPosition Tells you the current position of the sound icon.

MediaRate Contains the rate for the movie, sound, or video icon 
you specify. 

VideoDone Is TRUE if the current video sequence is finished playing.

VideoFrame Contains the number of the current video frame being 
played by an attached video device.

VideoResponding Is TRUE when communication is established with the 
selected video device.

Function Description

MediaPause Pauses a movie, sound, or video.

MediaPlay Plays a specific digital movie, sound, or video. When the 
digital movie is already playing, it is reset to its starting 
frame and plays from the beginning.

MediaSeek Sets the position for the movie, sound, or video icon.
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Video—step-by-step procedures

VideoChromaKey Determines the chroma key color for the video 
overlay device.

VideoDisplay Turns the video display on and off.

VideoPause Pauses the video at the current frame.

VideoPlay Plays the video to the frame number you specify at the 
current speed.

VideoSeek Moves the video to the frame you specify.

VideoSend Sends a character string to the video player, pauses 
Authorware for the amount of time you specify, and 
returns a response from the video device.

VideoSound Controls the sound for a video sequence.

VideoSpeed Sets the speed for the next video sequence to 
be played.

VideoStep Moves the video sequence backward or forward by 
a single frame. 

VideoText Shows text using the character generator in the 
videodisc player. (Not all videodisc players support 
this function.)

What you can do In Authorware Help, see

Set up Authorware for video Setting up your computer for video

Create an overlay display Assigning an area for video overlay

Associate a display icon with a 
video icon

Assigning an area for video overlay

Choose a chroma key Assigning an area for video overlay

Preview a video segment Previewing a video segment

Select the segment you 
want to play 

Selecting which video segment to play

Turn the video image off Turning video image and sound on and off

Turn the video sound off Turning video image and sound on and off

Function Description
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Managing content
Creating content is one of the most time-consuming aspects of any project. 
Although it’s never easy to manage the content you’ve created, if you do it 
efficiently you will not only save time, you will end up with a much more effective 
and professional product.

Here are some benefits of managing content properly:

• You can use the same content more than once without having to duplicate 
the content. 

• You can make content easy to integrate and update, especially if you’ve used an 
element such as a graphic or a sound file over and over.

• If you build a flowline structure that solves a common problem or standardizes 
some functionality—such as a set of custom navigation controls—you can use 
the structure again elsewhere without have to re-create it. 

• You can set up a project so that different team members can share content and 
flowline structures. 

• Content can be easy to update and maintain even after the project has been 
distributed. For example, you can make new content available over an intranet.

Authorware makes all these things possible through the use of external content, 
the External Media Browser, media libraries, and models.

Provide users with a control panel Providing a controller

Step a video when a certain 
condition occurs

Turning video off

What you can do In Authorware Help, see
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External content, libraries, and models
Authorware has four tools that help you manage content.

External content If you link a file to Authorware, the only data Authorware stores 
is the file’s name and its location. The content remains in the file, stored outside 
Authorware. The great advantage of external content is that it’s easy to update 
both during development and after a project has been distributed. For example, 
you can turn over a packaged project to a client, and the client—without using 
Authorware—can update the content just by replacing an external content file 
with a newer version. Or you can distribute a piece that links to essential but 
ephemeral content—say, satellite photos of weather systems—over the Internet. 
As long as the name of the file and its location don’t change, you don’t need 
anything to the Authorware piece that the file is linked to.

Keep in mind, though, that file names and locations can’t change once you 
distribute a project. You need to make sure that all the external content files get 
distributed with the project and installed in the right place or that they get set 
up correctly on the right Web server. Managing external content wisely means 
knowing when you need its flexibility and when it may well be more trouble 
than it’s worth.

The External Media Browser During the development phase of a project, the 
External Media Browser makes managing external files easy. It has two major 
strengths: It lets you edit the pathnames to external files, either individually or 
in groups, and it lets you define the location of external content with variables 
and expressions.

At the start of a project you might plan to keep all the external media in a single 
folder. Later you might decide to place sound, movie, and graphics files in separate 
folders. You can select all the files in any of the groups in the External Media 
Browser and, in a single step, change the path to every file in the group.

You can use variables and expressions as paths to change the content of a piece 
on the fly. Suppose you’re creating an information kiosk for a public place such 
as an airport. The use of external sound files makes the information easy to 
update, and variables make it possible for users to get the information in the 
language they choose.
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Media libraries A media library is a special Authorware file that contains a 
collection of individual icons and their content. Library files are different from 
Authorware flowline files. Libraries have no flowline and no icon structures—just 
individual icons.

With libraries you can use the same content repeatedly without duplicating it.

Libraries are very much like external content in one way: When you use content 
that’s in a library, the Authorware file stores only a link to the content, not the 
content itself. What distinguishes a library is that it can contain many different 
pieces of content, not just one. Because libraries contain icons and not just raw 
media, they can also contain icon properties; external content files can’t contain 
external properties. For example, to set the start and end frames of a digital movie 
with a variable, set up the variable in the library. If you were using an external 
content file you’d have to do it each time you use the movie. Unlike external content 
files, libraries can be packaged—which means that they’re much easier to distribute.

Libraries and external content aren’t mutually exclusive. You can link an icon in a 
library to an external media file as easily as you can link an icon on the flowline to 
one. The result is the best of both worlds: the content is easy to update, and you 
have the convenience of setting up the icon properties you want to use just once.

Another advantage of libraries is that they’re a convenient development tool for a 
project team. Once you set up a library, you can place it on a server so that the 
entire team has access to its contents.

Flowline file

Library file
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Models A model is a flowline segment—a sequence of icons you’ve copied from 
the flowline and saved. You can’t open a model directly, but you can reproduce a 
copy of the icon structure it contains by dragging the model from the Knowledge 
Objects window to the flowline. 

Use models to save and reuse structures you’ve constructed. For example, instead 
of re-creating a complex interaction, you can just save it as a model. Then you can 
paste it into any piece you want, and add the text, graphics, and other media that 
will tailor it to its new context. 

Models are unlike both libraries and external content: they’re not a way of saving 
space. Each time you paste a model on the flowline, you add the complete set of 
icons that the model contains. But because models are just segments of the 
flowline, there’s no reason you can’t link icons in a model to external content files 
or to library icons—as long as the external files and libraries are available to the 
files you paste the model into.

If you include a Knowledge Object icon in a model, you can turn the model into 
a Knowledge Object—a packet of logic with its own wizard interface. See Chapter 
12, “Creating Knowledge Objects” on page 373.

Model file
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Using external content and the External 
Media Browser
The great advantage of external media is its flexibility: You can update it as often 
as you want—even after an Authorware piece has been packaged—without having 
to make any change to Authorware. Its only drawback is that it requires careful 
and conscientious management. For every piece of external content in your piece, 
there’s a file you need to keep track of. The External Media Browser can help 
you manage external content both during development and when you distribute 
a project. For information on specific procedures, see “External Media Browser—
step-by-step procedures” on page 242.

Managing external content during development

During development, the External Media Browser provides you with a list of all 
the external content that’s linked to a file. The browser shows you the name of 
each external content file, the path to its location, the icon it’s linked to, and 
whether the link is intact. If you move external content files from one folder to 
another, you can use the browser to update the paths to the files, either 
individually or in groups. You can also use the browser to repair links that 
have been broken.

Using the External Media Browser to prepare for distribution

The External Media Browser makes it easier for you to manage the distribution of 
external content by letting you change absolute paths to relative paths. An absolute 
path is the complete path to a file, starting with the hard disk where it’s located. 
Using absolute paths can be problematic. The absolute path to a file on your 
computer often won’t match the absolute path to the same file once it’s installed on 
a user’s computer—which means that every time Authorware needs to use the file, 
it will ask the user to find it. A relative path, on the other hand, is just part of the 
path to a file, but it always starts from a known reference point: the folder where 
the Authorware piece is located. As a result, Authorware can find the file without 
knowing the file’s absolute location—and without asking the user to locate it.

The External Media Browser also makes it easier to manage files once you’ve 
distributed them by allowing you to locate them with a variable or expression. If 
you use a variable or expression to identify the external media file for Authorware, 
you can switch files on the fly. For example, you might substitute a voice-over in 
one language for a voice-over in another.
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Key features

When you’re trying to decide how best to use external media, keep these key 
features of both external content files and the External Media Browser in mind:

• You can update external content files anytime, even after you’ve packaged an 
Authorware piece.

• External content files aren’t packaged. You can’t prevent users from 
copying them.

• You can use the External Media Browser to change the paths to external 
content files or to repair broken links.

• You can use the External Media Browser to set relative paths or to locate files 
with variables or expressions.

External Media Browser—step-by-step 
procedures

What you can do In Authorware Help, see

Check the links to all external files Using external content and the External 
Media Browser

Fix a broken link Fixing a link to an external file

Edit a link Editing the link to an external file

Change a link to a different file Linking to a different external file

Define a link with a variable or an 
expression instead of a literal path

Defining a link with an expression, 
External content, libraries, and models

Relink to a file after you change its format Relinking to a file after changing its format
Chapter 5242



Using libraries
A media library is a special Authorware file that contains a collection of individual 
icons and their content. You can place display, calculation, digital movie, sound, 
and interaction icons (but not interaction structures) in a library. For information 
on specific procedures, see “Libraries—step-by-step procedures” on page 244.

To use a library icon, drag it to the flowline. The icon that appears on the flowline 
represents a link to the icon and its content in the library. 

The titles of icons linked to a library are displayed in italics.

Authorware doesn’t actually make a copy of the library icon or its content, it just 
displays a duplicate image of the icon. The content remains in the library.

Any changes you make to the content of a library icon—for example, adding text 
or replacing the image there with a different one—are reflected everywhere you 
use the icon in every file you link to the library.

To organize icons in the library window you can color them, by selecting an icon, 
then selecting a color from the color palette. You can also sort the icons in the 
library window by clicking on any of the headings: Link, Color, Icon, Title, or Date.

You can link up to 17 libraries to a piece, and you can have as many as 20 library 
files open at the same time. (There’s an advantage to being able to have more 
libraries open than you can link to a piece: You can copy icons from the unlinked 
libraries to the libraries you do want to link to.) Authorware lets you link more 
than one library to a piece so that you can use libraries to organize content. For 
example, you might want to put text, graphics, sound, and digital movies all in 
separate libraries. Or if you’re working on a project that’s going to be distributed 
in several languages, each language can be in a separate library.

Note: Don’t confuse the button library with a media library. The button library contains only 
button components, and it’s always part of a course file.
Working with Content 243



Library key features

When you’re trying to decide how best to use media libraries, keep these key 
features in mind:

• With libraries you can use the same content more than once without 
duplicating it.

• The Authorware file stores only a link to the content, not the content itself.

• You can embed or link content to an icon in a library.

• Unlike an external media file, a library can contain more than one piece 
of content.

• A library icon can contain icon properties, not just content.

• A library can be packaged, which makes it easy to distribute. But once it’s 
packaged, its content can’t be edited.

• You can link as many as 17 libraries to a file.

• An entire team can use a library at the same time.

Libraries—step-by-step procedures

What you can do In Authorware Help, see

Create a library Creating, opening, saving, and 
closing a library

Add icons to a library Adding icons to a library

Use an icon library in a piece Using an icon from a library

Delete an icon from a library Deleting an icon from a library

Paste a library icon into a piece rather 
than linking to it

Cutting, copying, and pasting library icons

Update the link to an icon in a library Updating an icon linked to a library

Identify links to library icons Identifying links to library icons

Fix a broken link Fixing broken library links

Locate the library an icon is linked to Identifying links to library icons

List the icons linked to a library Identifying links to library icons

List broken and unbroken links Identifying links to library icons

Package a piece and its libraries separately Packaging a piece and its libraries separately

Package a library Packaging a library
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Using models
A model is a flowline segment—a sequence of icons you’ve copied and saved. A 
model gives you a much more efficient and reliable way of duplicating a structure 
than just copying the icons to the Clipboard and immediately pasting them to 
another location. With a model, you save the structure permanently, so you can 
use it wherever you want, whenever you want, without returning to the original 
file where you created it. For information on specific procedures, see “Models—
step-by-step procedures” on page 246.

Models are much more powerful than library icons or external media files because 
they contain chunks of functionality, not just content. For example, you can store 
a single interaction icon in a library, but to save an entire interaction structure, 
you need to turn it into a model. Unlike library icons or external media files, 
models aren’t links to anything. Each time you add a model to the flowline, you’re 
duplicating the content of the model in its entirety. As a result, you don’t save any 
disk space by using a model. On the other hand, you can change the structure of 
the duplicate content to tailor it to the particular context. Changing the structure 
after you’ve pasted it into a piece has no effect on the model itself.

Models are easy to create and use. To create a model, select the segment of the 
flowline you want to copy and save it in a model. Put the model file in the 
Knowledge Objects folder (it’s in the same folder as Authorware). Models in the 
Knowledge Object folder appear in the Knowledge Objects window. To use the 
model, drag it from the Knowledge Objects window to the flowline.

Standardizing and sharing elements

Models provide a great way to standardize elements such as buttons and text styles 
or to share standard components among the members of a development team.

For example, if you want to use the same set of buttons in more than one file, 
create an interaction that contains all the buttons and then turn the interaction 
into a model. Drag the model into any piece where you want to use the buttons, 
save the piece, and then delete the interaction. The buttons remain available in the 
button library.

If you want to share buttons and text styles among the members of a development 
team, follow a similar process: Create an interaction with the buttons and use all 
the text styles in a display icon. Save both as a model and distribute the model to 
everyone on the team. Any team member can then paste the model into a file, save 
it, and then delete the interaction and the display icon. The buttons will remain in 
the button library and the text styles will appear both on the styles palette and in 
the Define Styles dialog box.
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Add a Knowledge Object icon to a model, and you can create a Knowledge 
Object—a model with an wizard interface. For example, if you’re creating a course 
with many multiple choice questions, you can create a template interaction and a 
wizard that allows anyone—even a novice Authorware user—to enter text for and 
set up a specific interaction. 

Model key features

When you’re trying to decide how best to use models, keep these key 
features in mind:

• Models let you create a permanent copy of a chunk of functionality.

• The copy of the model you add to the flowline isn’t linked to the model; 
it’s a duplicate.

• Changing the icons contained in the model after you add them to the flowline 
has no effect on the model.

• Models can contain library icons or linked external content—as long as the 
libraries or external files are available to the file you paste the model into.

• A development team can use the same set of models to standardize their work.

The complexity of the structure you’re copying is another factor in determining 
whether a model is a useful solution. If the structure is simple, it may be just as 
easy to re-create it each time you want to use it. If the structure is complex, it may 
take longer to work out how to modify it than to build a structure tailored to the 
context in which you want to use it. 

In cases where you can easily reuse the functionality you’ve created, it makes good 
sense to use a model.

Models—step-by-step procedures

What you can do In Authorware Help, see

Create a model Creating a model

Use a model Using a model

Convert a model from an earlier version 
of Authorware

Converting a model
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Creating Interactions

If you do nothing more than present text, graphics, animation, video, and sound 
to users, you’re creating the equivalent of a television commercial. At best, it will 
entertain and inform; at worst, users will ignore it. It’s a passive, one-way form of 
communication.

Interactive multimedia holds the key to active, two-way communication. Each 
interaction provides an opportunity for the user to respond to the program or to 
other users. You can record and evaluate each response, and you can control which 
part of the piece the user goes to depending on the response.

You can tailor a multimedia piece to the unique needs of each user. Users can also 
control the information presented to them. They can navigate through the piece, 
set the pace, try out procedures, take tests, play games, get further information, 
and track their own progress. At the same time, you can record information about 
users: which paths they take, the time they take to respond, the results of tests, 
what information they receive, and much more.

Authorware makes it easy to create a wide variety of interactions with buttons, hot 
spots, hot objects, hot text, pop-up menus, text-entry fields, and more.
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The components of an interaction
Imagine a common computer interaction: A user starts an application, and a list 
of topics appears on the screen. The user clicks a button to choose a topic. The 
application branches to the segment the user has chosen. 

These are the basic components of any interaction: a way to interact (a button), a 
response (a click), and a result (the application branches).

A way of interacting There are many different ways to allow users to interact. You 
can set up buttons for them to click, menus for them to choose from, fields where 
they can enter text. You can let them click a country on a map to find out more 
about it or click a word in a passage of text to see its definition. You can wait for 
them to press a single key to move a pointer around the screen. You can test their 
knowledge of human anatomy by having them assemble the bones of the skeleton.

When you design an interaction, always choose the most efficient way of 
interacting. For example, it’s easier for users to point to a country and click it than 
to type the name of the country in a text box. But it’s quicker for most users to 
type their name in a text box than to spell it out by clicking letters on the screen.

A response The response is the action the user takes.

The way you set up an interaction prompts users to respond in a certain way. If 
you set up a button, you expect users to click it. If you set up a text box, you 
expect them to type something in it. But users don’t always do what you expect. 
Suppose you’ve set up a multiple-choice question with answers that are numbered 
1, 2, and 3. Most users may click an answer, but others may type 1, 2, or 3. Some 
may do nothing at all.

Any response that you anticipate a user might make is called a target response. In 
a multiple-choice question, the right answer is a target response, but so are all the 
wrong answers. Good design also means anticipating even inappropriate actions, 
such as typing a number rather than clicking an answer, or doing nothing at all; it 
means treating the inappropriate actions as target responses and reacting to them.

The result The result of an interaction is whatever you set up Authorware to do in 
response to a user’s action. You might display simple feedback on a wrong answer 
and a prompt to try again. Or you might launch a Web browser and start 
downloading information over the Internet. The result of an interaction can be 
anything Authorware can do.
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How an interaction works
In Authorware the structure of an interaction looks like this: 

Take a look at the four main components: the interaction icon, the response type 
symbol, the result icon, and the result path. Notice that you can have more than 
one response type symbol–result icon pair attached to an interaction icon.

To create an interaction, you drag an interaction icon to the flowline and use it as 
the foundation of the interaction structure. You build the structure by attaching 
icons to the interaction icon. Each icon you attach is called a result icon. For each 
result icon you set up a response type symbol. The response type symbol gives 
users a way to interact, and it defines the target response that directs the flow 
down the result path to the result icon. The result path also determines where 
Authorware goes when it leaves the result icon.

The interaction icon The interaction icon works in part like a display icon: It 
displays the buttons, menus, text-entry fields, and other elements that allow users 
to respond to an interaction. You also use it to:

• Display text and graphics that you want to appear throughout an interaction

• Control such things as whether Authorware displays the text and graphics with 
a transition, where it positions them, which layer it places them in, and when it 
erases them

• Set whether Authorware erases the screen at the end of an interaction and 
whether it uses a transition

Most important, however, the interaction icon monitors the actions of the 
user and sends that information to the response type symbols attached to it.

Response type symbol

Result path

A map icon used as a 
result icon

Interaction icon
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The response type symbol The response type symbol gives users a way to interact. 
The response type symbol you choose tells the interaction icon whether to display 
a button, a menu, a text-entry field, or some other element.

Response types and the symbols associated with them

Sometimes you may want to interact not just with users but with circumstances 
and events. So Authorware provides two other ways to use the response type 
symbol. One is to use it to track and react to circumstances that are part of the 
interaction. For example, you can set up a response type symbol to keep track of 
time and to react if a user doesn’t respond within some limit you set. You can also 
use the response type symbol to track and react to events produced by other 
components embedded in an Authorware piece, such as an ActiveX pop-up menu 
or calendar control. For example, you can set up a response type symbol that 
reacts when the date changes.

Once you’ve set up a response type symbol to allow a user (or a circumstance or an 
event) to interact with Authorware, you use the response type symbol to define 
the target response. Sometimes that’s easy (the target response for a button, for 
instance, is a user’s clicking it). Sometimes it’s much more difficult than it might 
seem. Consider, for example, a text-entry field. Suppose you want a user to 
respond to a question by typing the correct answer. How do you treat a word that’s 
misspelled (sattellite, instead of satellite), or a synonym (moon, instead of satellite), 
or an extra word such as a or the, or an answer that’s so wrong it’s impossible to 
predict? What if you want a number and a user types text? How do you deal with 
all the numbers that are too large or too small? Authorware has a way of dealing 
with all those possibilities, but it means anticipating them and setting up target 
responses to handle them.
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As you can guess, most interaction icons have more than one response type 
symbol attached to them. In some cases the response type symbols represent 
nothing more than options—the choices on a menu, for example. In other cases 
they represent correct and incorrect answers. For that reason, you also use the 
response type symbol to indicate whether a user’s response is right or wrong.

Two final things you do with the response type symbol are related to the result 
icon: You use it to tell Authorware when to erase any text or graphics displayed 
by the result icon and to direct the flow after Authorware leaves the result icon.

The result icon The content of the result icon—the icon that’s attached to the 
response type symbol—determines what happens when Authorware detects the 
response type symbol’s target response. You can use any icon on the palette as the 
result icon, but it’s best to use a map icon because it’s the most flexible. You can 
add and remove icons from a map icon easily as you construct the result of 
the interaction.

The result path The result path determines where the flow is directed after 
Authorware exits the result icon. Typically, you direct the flow to the next response 
type symbol, back to the interaction icon, or out of the interaction to the next 
icon on the flowline.

Tracing the flow through an interaction
When you’re setting up an interaction, you’ll find it useful to be able to trace the 
flow though the interaction structure. If you keep in mind both the structure of 
the interaction and the way control flows through the structure, it will help you 
organize the interaction, make sure it’s complete, and figure out what’s wrong with 
it if it doesn’t work as you expect.For information on specific procedures, see 
“Setting up an interaction—step-by-step procedures” on page 255.
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Waiting for a response When Authorware encounters an interaction icon, it 
displays any text and graphic elements it finds there as well as any buttons, hot 
spots, text-entry fields, and so on defined by the response type symbols. It then 
halts and waits for a response from a user. 

Each response type symbol corresponds to a button.

Checking for a match When a user responds, Authorware sends the response along 
the interaction flowline to see whether it matches any of the target responses 
you’ve set up. 
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Each target response, you’ll remember, is contained in a separate response type 
symbol. Each response type symbol acts like a switch. If the user’s response doesn’t 
match the target response in the response type symbol, the switch stays open, and 
Authorware sends the response along the flowline to the next response type symbol.

When a user’s response matches a target response, the switch closes and directs the 
flow along the path you’ve set up for that response.

The flow follows the path to the result icon, where the contents of the icon 
determine what happens next.

Some target responses are triggered by circumstances rather than a user’s action. If 
you’ve set up a response type symbol to impose a time limit on an interaction, as 
soon as the time you’ve set elapses, the switch closes, and Authorware sends the 
flow down the interaction flowline. When it reaches the time limit response type 
symbol, the switch directs it to the result icon that’s attached.

Leaving the result icon When the flow leaves the result icon, the result path 
determines where it goes next. As mentioned earlier, you can choose to direct the 
flow to the next response type symbol, back to the interaction icon, or out of the 
interaction to the next icon on the flowline.  

Try againContinue to the 
next symbol
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The result path you choose and the position of the result icon it’s attached to can 
affect whether or not an interaction works. For example, look at the interaction in 
the following illustration. The result path that the author has chosen for the first 
response type symbol prevents the flow from ever getting to any of the other 
response type symbols.  

One way to solve the problem is to change the result path so that it goes on to the 
next response type rather than back to the interaction icon. 

Another way to solve the problem is to make the response type symbol the last one 
in the structure instead of the first. 

Back to the beginning If the user’s response doesn’t match any of the target 
responses in any of the response type symbols, the flow simply returns to the 
interaction icon, where Authorware waits for another response from the user.  

The flow never gets past the first response symbol.

The flow continues to the next symbol.

The response symbol is now the last one in the structure.
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Often it’s a good idea to have a catchall target response at the end of an interaction 
so that it’s impossible for a user to respond without getting some feedback. For 
example, if you set up a multiple-choice question in which users are supposed to 
click the right answer, you can set up a catchall hot spot that covers the entire 
screen. If users click anything other than one of the answers, they’ll trigger the hot 
spot. You can give them feedback and then use the result path to take them back 
to the interaction icon.

Ways to interact
You can give users any of five different ways to interact:

• Click a button, a hot spot, or a hot object

• Choose an item from a pull-down menu

• Enter text

• Press a key

• Drag an object to a target

You can also track and react to the following circumstances during an interaction:

• The number of tries a user has made

• The amount of time that has elapsed since the interaction began

• Any condition that can be true or false

Finally, you can track and react to events produced by components such as 
ActiveX controls embedded in an Authorware piece. 

Each of these ways of interacting is easy to set up with a response type symbol.  

Setting up an interaction—step-by-step 
procedures  

What you can do In Authorware Help, see

Set up a button Setting up a button, 
Buttons, radio buttons, and check boxes 

Create a pull-down menu Setting up a pull-down menu, 
Pull-down menus

Create a hot spot Setting up a hot spot, 
Hot spot interactions
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Buttons, radio buttons, and check boxes
Buttons provide one of the clearest and simplest ways for a user to respond. You 
can also use the button response type to set up radio buttons and check boxes.  

• Use standard buttons when you want the result of a choice a user makes to take 
effect immediately. Examples are navigation controls, choices on a menu 
screen, and Help and Quit buttons.

• Use radio buttons for mutually exclusive options. For example, if you’re 
creating a training course that displays text in more than one language, use 
radio buttons to let users select the language they will use.

Create a hot object Setting up a hot object, 
Hot object interactions

Respond to a single key Waiting for a keypress, 
Keypress interactions

Create a text-entry field Setting up a text-entry field, 
Show Me: Free Form Text, 
Show Me: Short Text Interaction

Create hot text Setting up hot text

Create a drag-and-drop interaction Letting users drag an object,
Target area interactions

Limit the number of tries a user has to 
choose a correct answer

Limiting the number of tries, 
Time limit interactions

Limit the time a user has to respond Putting a time limit on an interaction, 
Time limit interactions

React to circumstances that surround 
the interaction

Reacting to special conditions

Respond to events from sprite Xtras, 
scripting Xtras, and ActiveX controls

Setting up an event response, 
Show Me: Using ActiveX

Add text or graphics to an interaction icon Adding text or graphics to an interaction icon

What you can do In Authorware Help, see

Standard 
button

Radio buttons Check boxes
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• Use check boxes for options that aren’t mutually exclusive. For example, if 
you’re creating a kiosk with travel information, use check boxes to allow users 
to select one or all of the activities they’re interested in.

To create the type of button you want to use, you need to set up a button response 
type symbol and then select either a button, a check box, or a radio button from 
the Button Library dialog box. If you create a check box or radio button, you can 
use the system variable Checked to find out whether the check box or radio 
button has been selected.

Button library

The Authorware button library (Window > Buttons) contains standard system 
buttons, check boxes, and radio buttons for use in setting up a button response 
type symbol. The button library is just as useful if you’re using custom buttons. 
Assemble the custom buttons in the Button Editor, and they’re instantly available 
in the button library.

Button Editor

Use the Button Editor (Window > Buttons > Add) to create, edit, and globally 
update custom buttons. In Authorware, a custom button is a complete set of 
graphics and sounds that represent each of the button’s states. 

A button can have eight different states—four normal and four checked states, 
indicating that a button has been clicked, or a check box or radio button has been 
selected. Each state can look different and have a different sound associated with 
it. You can also show or hide the button’s label in each state.

The four normal button states are as follows:

• The button is ready to be clicked.

• The cursor is over the button.

• The cursor is over the button and the mouse button is down.

• The button is deactivated (unavailable). 

Creating a custom button is straightforward. For each of the button’s states, you 
import a graphic and sound and select a setting to show or hide the button’s label. 
If you don’t want a different graphic and sound for each state, Authorware 
automatically uses a graphic and sound you’ve already imported; or you can 
choose no graphic or sound at all. Before you start, create the graphic or select the 
clip art image you want to use for each of the button’s states. You can create a 
sound or select a clip sound for each state, too.
Creating Interactions 257



Buttons—step-by-step procedures

Pull-down menus
Pull-down menus are ideal for providing users with options without taking up 
space on the screen. For information on specific procedures, see “Pull-down 
menus—step-by-step procedures” on page 259.

They’re best for options that you want to be available to users over a period of 
time while they’re engaged in some activity, rather than for options that you want 
to display at a decision point where a user must make a choice. As a consequence, 
pull-down menus are usually “perpetual” interactions—interactions that are 
always active in the background no matter what you’re doing. For information 
about perpetual interactions, see Perpetuals—interactions that are always active in 
Authorware Help.

What you can do In Authorware Help, see

Set up a button Setting up a button
Show Me: Button Interactions

Adjust the size and position of a button Resizing or repositioning a button quickly, 
Resizing or repositioning a button precisely

Use a custom button, check box, 
or radio button

Selecting a check box, a radio button, or a 
custom button

Provide a key that a user can press instead 
of clicking the button

Assigning a shortcut key to a button

Make a button active in the background Setting up a button that’s always available

Make a button active only under 
certain conditions

Limiting when a button is active

Hide or dim a button when it’s not active Hiding or dimming an inactive button

Make a button the default Making one button the default

Mark a button as a right or wrong answer Marking a response right or wrong

Limit the time a user has to click the 
correct button

Putting a time limit on an interaction

Limit the number of tries a user has to click 
the correct button

Limiting the number of tries

Create or edit a custom button Creating a custom button, Editing a 
custom button

Create a collection of custom buttons Creating a custom button collection
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If you assign shortcut commands to the items on a pull-down menu, Authorware 
automatically displays the shortcuts on the menu—just as in any standard 
Windows application.

When you create a pull-down menu interaction, Authorware uses the title you 
give the interaction icon as the title of the pull-down menu. It uses the title of 
each result icon as the name of each item in the menu.

Although all the items in a pull-down menu interaction are usually pull-down 
menu responses, they don’t have to be. For example, you might include a time 
limit response type symbol that prompts users to make a selection from the menu 
if they haven’t done so after a set amount of time passes.

Pull-down menus—step-by-step procedures

What you can do In Authorware Help, see

Create a pull-down menu Setting up a pull–down menu,
Pull–down menus

Dim a menu item Disabling a menu item

Set up the menu to always be available, 
even when users are engaged in some 
other activity

Setting up a pull–down menu that’s always 
available

Add a separator between groups of 
menu items

Adding a separator between groups of 
menu items

Provide a key that a user can press instead 
of selecting a menu item

Assigning a shortcut key to a menu item, 
Assigning a hot key to a menu item

Disable a menu item Disabling a menu item

Mark a menu item as a right or wrong choice Marking a response right or wrong

Limit the number of tries a user has to select 
a given menu item

Limiting the number of tries

Limit the time a user has to select a 
menu item

Putting a time limit on an interaction
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Hot spot interactions
You can make any rectangular area on the screen a hot spot. The area doesn’t have 
to be a discrete graphic, as do buttons and hot objects. That means you can turn 
an image that’s part of a background into a hot spot without editing out the 
background that surrounds it. Hot spots are also ideal for setting up catchall areas. 
A catchall area—usually a hot spot as big as the entire Presentation window—lets 
you respond to users when they click near, not on, the buttons or hot spots you’ve 
set up for them to interact with. For specific procedures, see “Hot spots—step-by-
step procedures” on page 260.

Hot spots—step-by-step procedures

What you can do In Authorware Help, see

Create a hot spot Setting up a hot spot

Adjust the size and position of a hot spot Resizing or repositioning a hot spot quickly,
Resizing or repositioning a hot spot 
precisely

Provide a key that a user can press instead 
of clicking a hot spot

Assigning a shortcut key to a hot spot

Set up a hot spot so it’s always available Setting up a hot spot that’s always available

Make a hot spot active only under 
certain conditions

Limiting when a hot spot is active

Use a custom cursor whenever the pointer 
is over a hot spot

Selecting a custom cursor for a hot spot

Highlight the area that the hot spot encloses 
when a user clicks the hot spot

Highlighting a hot spot

Set whether you want a user to select a hot 
spot by clicking it, double-clicking it, or just 
placing the cursor over it

Clicking, double–clicking, or rolling over a 
hot spot

Mark a hot spot as a right or wrong choice Marking a response right or wrong

Limit the time a user has to click the correct 
hot spot 

Putting a time limit on an interaction

Limit the number of tries a user has to click 
the correct hot spot

Limiting the number of tries

Respond to mouse clicks that aren’t over 
a hot spot

Setting up a catchall hot spot
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Hot object interactions
Although a hot object has to be discrete from its background, it doesn’t, like a hot 
spot, have to be rectangular. Making an object hot can be a much more efficient 
way of making an object interactive than drawing a hot spot over it. It’s especially 
useful if the object isn’t rectangular and you want the area that’s interactive to 
correspond to the object exactly—for example, if you want each country on a map 
to act as a button. It’s also useful if you’re moving an object around the screen and 
you want it to remain interactive no matter where it’s located.

The most important rule to remember when you’re setting up a hot object is to 
make sure that the object is in a display icon by itself. Authorware actually makes 
the contents of the entire display icon hot. So if there are several objects in the 
same display icon, they all become hot and they all react the same way.

For specific procedures, see “Hot objects—step-by-step procedures” on page 261.

Hot objects—step-by-step procedures

What you can do In Authorware Help, see

Create a hot object Setting up a hot object

Set up a catchall area around the hot object Setting up a catchall hot spot

Provide a key that a user can press instead 
of clicking the hot object

Assigning a shortcut key to a hot object

Set up the hot object so it’s available when 
the user is engaged in other activities

Setting up a hot object that’s always 
available

Make an object hot only under 
certain conditions

Limiting when a hot object is active

Use a custom cursor whenever the pointer 
is over the object

Selecting a custom cursor for a hot object

Highlight the object when a user clicks it Highlighting a hot object

Set whether you want a user to trigger the 
hot object by clicking it, double-clicking it, 
or just placing the cursor over it

Clicking, double–clicking, or rolling over 
a hot object

Mark a hot object as a right or wrong choice Marking a response right or wrong

Limit the time a user has to click the 
correct object 

Putting a time limit on an interaction

Limit the number of tries a user has to click 
the correct object 

Limiting the number of tries
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Keypress interactions
Sometimes the easiest way for a user to do something is to press a single key. For 
example, if you set up a screen with several text-entry fields on it, the easiest way 
to get from one field to another is to press the Tab key. You can use a keypress 
response type symbol to make that possible.

You can set up a keypress response type symbol to react to a single key or to a 
key combination such as Control-A. You can also set up a single keypress response 
type symbol to react to several different keys or key combinations (although it 
can react to only one key or key combination at a time). And you can set up a 
keypress response type symbol to respond to any key at all, no matter which one 
a user presses. For specific procedures, see “Keypress responses—step-by-step 
procedures” on page 262.

Make sure you don’t try to use the keypress response type symbol to do things 
other response type symbols are designed to do. For example, don’t use a keypress 
response type symbol to set up an optional key for a button, hot spot, hot object, 
or pull-down menu item. Each of those response type symbols has a field in its 
options dialog box in which you can define an optional key. And don’t use the 
keypress response type symbol when you want a user to enter text in a field. To do 
that, you use a text entry response type symbol.

Keypress responses—step-by-step 
procedures

What you can do In Authorware Help, see

Respond to a single key Waiting for a keypress 
Show Me: Keypress Interactions

Make a keypress interaction inactive 
under certain conditions

Limiting when a keypress symbol is active
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Text entry interactions
To create a text field where a user can enter text, you set up a text-entry 
interaction. See “Text entry—step-by-step procedures” on page 263 for 
information on specific procedures.

Because there’s such a broad range of possibilities to anticipate when you’re 
allowing users to enter text, Authorware provides considerable flexibility in 
determining what constitutes a match. For example, you can use wild cards to 
allow variations in spelling. In fact, you can use wild cards to accept any entry at 
all. You can also accept different words or phrases that mean the same thing, and 
you can have Authorware ignore capitalization, extra punctuation, spaces, extra 
words, or word order.

A text-entry interaction works slightly differently from, say, a button interaction. 
If you add five button response type symbols to an interaction icon, you get five 
buttons on the screen. But a text-entry interaction has only one text-entry field, 
no matter how many text-entry response type symbols you attach to the 
interaction icon. That’s because no matter how many target responses you set up, 
a user makes only one entry at a time. If you want to set up several different pieces 
of information—such as a name and a password—you need to create two separate 
interactions, one for the name and one for the password.

Authorware lets you evaluate the text a user enters immediately with a text-entry 
response type symbol, and automatically stores anything a user enters in the 
variable EntryText. You can transfer the text in EntryText into a custom 
variable, then use the information in any way you want—display it on the screen, 
save it in a file, or write it to a database. 

Text entry—step-by-step procedures

What you can do In Authorware Help, see

Create a text entry field Setting up a text–entry field
Show Me: Free Form Text
Hot text interactions

Adjust the size and position of a 
text-entry field

Resizing or repositioning a text-entry 
field quickly
Resizing or repositioning a text-entry 
field precisely

Define default text for a text-entry field Defining the default for a text field

Limit the number of characters a user 
can enter

Limiting the length of a text entry field

Change the key a user presses to indicate 
he or she has finished the entry

Changing the entry key
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Target area interactions
You can create interesting interactions by letting a user drag an object to a target 
area. For example, you can ask the user to create a map by dragging countries to 
their proper location; to assemble a machine by dragging its parts to fit together; 
to trace the flow of a process by arranging each stage in the correct sequence; or to 
reconstruct history by lining up events in the order in which they actually 
happened. You can also create an interaction that gives a user the freedom to 
landscape a garden or rearrange the furniture in a room. You use the Authorware 
target area response type for these interactions.

For each target area response type symbol you attach to an interaction icon, 
Authorware displays a target area on the screen. You then drag the object to 
connect with the target area to its proper place onscreen. Authorware moves the 
target area to the location you’ve indicated. 

Treat an entry as complete as soon as a user 
has entered a certain number of characters

Accepting a user’s entry automatically

Ignore an entry if a user presses Enter 
without entering any text

Ignoring empty text entries

Hide the triangular marker that indicates a 
text-entry field

Hiding the triangular text-entry field marker

Limit the number of words a user needs to 
match to accept the entry

Limiting the number of words a user needs 
to match

Accept several words entered over several 
tries as a match for the given response

Accepting words on subsequent tries

Use wild cards to allow variations Text-entry rules

Handle and evaluate numbers Handling numerical entries

Match any text Text Entry tab (Text Entry Response 
Properties)

Select a font, style, and size for the text 
a user enters

Setting the style of user-entered text

Mark target text as the right or wrong choice Marking a response right or wrong

Limit the number of tries a user has to enter 
the right answer

Limiting the number of tries

Limit the time a user has to enter the 
right answer

Putting a time limit on an interaction

What you can do In Authorware Help, see
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Target areas—step-by-step procedures

Tries limit—limiting users’ attempts
When you set up an interaction that has a right answer, you don’t have to choose 
between giving users one chance to get it right and allowing them to try over and 
over again until they answer correctly. You can use the tries limit response type 
symbol to limit users to any number of tries.

You can also use the response type symbol to give users feedback after each wrong 
answer and still let them try again. For example, if a user has three tries to get a 
question right, you could set a tries limit response to display the message “Two 
tries left” after the first wrong answer. After another wrong answer, you could set a 
second tries limit response to display the message “This is your last chance.” Even 
better, you could give them feedback that could help them figure out what the 
right answer is. 

What you can do In Authorware Help, see

Create a target area interaction Letting users drag an object, 
Target area interactions

Adjust the size and position of a 
target area

Resizing or repositioning a target area quickly
Resizing or repositioning a target area 
precisely

Set up a target area so it’s always available 
in the background

Setting up a target area that’s always 
available

Make a target area active only under 
certain conditions

Limiting when a target area is active

Mark a match as right or wrong Marking a response right or wrong

Limit the time a user has to drag an object 
to the correct target

Putting a time limit on an interaction

Limit the number of tries a user has to drag 
an object to the correct target area

Limiting the number of tries

Set up a safety net to catch objects that 
aren’t dragged to a target area

Setting up a safety net

Freeze an object you’ve made movable Freezing an object you’ve made movable

Set boundaries for an object 
that’s movable

Setting boundaries for an object that’s 
movable
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Where you position the tries limit response type symbol in the interaction 
flowline lets you orchestrate the feedback connected to the tries limit symbol and 
the feedback connected to the other response type symbols. For example, to 
display the feedback connected to the tries limit response type symbol, you’d 
position the tries limit symbol to the right of the other symbols, like this:

If you want the feedback connected to the tries limit response type symbol to 
replace the feedback for the wrong answer, you’d position the tries limit symbol to 
the left of the other symbols, like this: 

Authorware not only uses the tries limit response type to keep track of the number 
of tries a user has made, it also records the number in the system variable Tries. For 
information on using Tries, see Chapter 15, System Variables in Authorware Help.

Tries limit—step-by-step procedures

What you can do In Authorware Help, see

Limit the number of tries a user has to 
enter the right answer

Limiting the number of tries, 
Tries limit—step-by-step procedures

Use the system variable Tries Tries

Mark a match as right or wrong Marking a response right or wrong

Tries limit symbol

Tries limit symbol
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Time limit interactions
You can use the time limit response to limit the amount of time a user has to 
answer a question. You can also use the time limit response to warn users that their 
time is almost up and to prompt them to respond if they haven’t done so after a 
certain length of time.

When you use a time limit response in an interaction, Authorware uses the system 
variable TimeRemaining to record the amount of time that’s left. Authorware 
also records in the system variable TimeInInteraction the amount of time a 
user has spent in an interaction (even if you haven’t used a time limit response in 
the interaction). 

Time limit—step-by-step procedures

Conditional interactions
Conditional responses are useful to make something happen when some special 
condition is true. Many variables and expressions that can be true can be used as 
the target condition for a conditional response. 

For example, you may want to check whether the Caps Lock key is down 
before a user enters text. Or if users have a limited amount of time to complete 
an entire section of a course, you may want to tell them at the beginning of an 
interaction how much time they have left. Or you may want to skip an interaction 
entirely if something is true—for example, if a user has already answered another 
question correctly.

You can use more than one conditional symbol in an interaction to handle 
different conditions.

What you can do In Authorware Help, see

Limit the time a user has to enter the 
right answer

Putting a time limit on an interaction
Time limit interactions

Show the amount of time remaining Displaying a countdown clock

Restart the time limit for each try a 
user makes

Restarting the time limit

Make the time limit inactive under 
certain conditions

Limiting when a time is active
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The Automatic setting

The Automatic setting is a special feature of the conditional response type. It 
allows a conditional response to react to the target condition in an interaction 
without the need for a user to respond to the interaction at all. For example, you’d 
use the Automatic setting to tell Authorware to skip an interaction entirely if a 
user has already answered another question correctly.

Examples of conditional responses

There’s no limit to the ways you can use conditional responses in interactions. Here 
are a few examples to help you understand the range of situations open to you.

Using a logical variable to check a specific condition

Suppose you want to make sure that the Caps Lock key isn’t on when users enter 
information in a certain text-entry field. You’d set up an interaction that looked 
like this:

In the Condition field of the Conditional Response Properties dialog box, type:

CapsLock

CapsLock is a logical variable. It’s true when the Caps Lock key is on and false 
when the key is off. When the key is on, the target condition is true, so the 
conditional symbol directs Authorware to the result icon attached to the symbol. 
The result icon displays a message that tells the user to turn the Caps Lock key off.

Screening out unwanted entries in a text field

Suppose you’ve set up a text-entry field where you know that entering any number 
(as in a name field) or entering any text (as in a social security or telephone 
number field) is a mistake. You can use a conditional response and one of two 
system variables (NumCount or WordCount) to catch the mistake and ask the user 
to reenter the information. 
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Providing feedback for entries in a text field

Suppose you want to ask students the question “How many neutrons are there in 
an atom of Uranium 238?” You want to create a text-entry interaction for their 
response. The easiest way to set up the interaction is like this:

The target response for the first conditional symbol is any entry that’s less 
than 146. The target response for the second conditional symbol is the correct 
answer, 146. The target response for the third conditional symbol is any entry 
that’s greater than 146. The asterisk that’s used as the target response for the 
text-entry response is a wild card that accepts any entry.

Providing feedback after all the correct items have been 
selected

Suppose you set up an interaction in which you ask students to select the three 
primary colors out of six that are displayed on the screen. To set up the structure 
of the interaction so that students remain in the interaction until they’ve selected 
all the correct colors, you use a conditional response type and the system variable 
AllCorrectMatched. 
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Setting up a condition that’s always true

Suppose you’ve set up a menu, and you want to play the same sound no matter 
which of the menu items users select. One way to do that is to include a sound 
icon in the result icon attached to each response type symbol. An easier way is to 
attach the sound icon to a conditional response type and set up a target condition 
that’s always true. The structure of the interaction looks like this:

By placing the conditional symbol first and selecting Continue as its branching 
option, you make sure that whenever a user makes a choice, Authorware plays the 
sound, returns to the interaction flowline, and proceeds to the response type 
symbol that matches the option the user has selected.

Conditional responses—step-by-step 
procedures

Events and senders
Sprite Xtras, scripting Xtras, and ActiveX controls can send events. An event is 
something that happens. Some events are the result of a user’s action. For example 
the Microsoft Calendar ActiveX control tracks where a user clicks on the calendar 
and sends an event each time that happens. Other events are produced by a sprite, 
script, or control on its own. The Microsoft Web Browser control, for example, 
sends an event when it starts to download information from the Web and another 
when the download is complete.

What you can do In Authorware Help, see

React to circumstances that surround 
the interaction

Reacting to special conditions

Set up a conditional response symbol so 
it’s always active in the background

Setting up a conditional response that’s always 
available

Set automatic matching Conditional Response Properties

Mark a match as right or wrong Marking a response right or wrong

Continue to the 
next symbol
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Sprites, scripts, or controls that produce events are called senders. You can use an 
event response type symbol to track a user’s interaction with a sender and respond 
to it just as if the user were interacting with a button, hot spot, or text entry field 
you’d set up. You can also set up an interaction to respond to events that a sender 
generates on its own.

The Event Response Properties dialog box lists all the senders that you’ve 
incorporated into an Authorware piece and all the events that each one can 
generate. All you have to do to set up an event response type symbol is to select 
the events you want it to track. 

Events—step-by-step procedures

Perpetual interactions—step-by-step 
procedures

What you can do In Authorware Help, see

Respond to events from sprite Xtras, 
scripting Xtras, and ActiveX controls

Setting up an event response, 
ActiveX controls

Make an event response symbol active 
only under certain conditions

Limiting when an event response is active

Set up an event response symbol so 
it’s always active in the background

Setting up an event response that’s always 
available

Mark a match as right or wrong Marking a response right or wrong

What you can do In Authorware Help, see

Make a button  active in the background Setting up a button that’s always available

Set up a hot spot so it’s always available Setting up a hot spot that’s always available

Set up the hot object so it’s available when 
the user is engaged in other activities

Setting up a hot object that’s 
always available

Set up the menu to always be available, 
even when the user is engaged in some 
other activity

Setting up a pull-down menu that’s 
always available

Set up a target area so it’s always available 
in the background

Setting up a target area that’s 
always available

Set up a conditional response symbol so it’s 
always active in the background

Setting up a conditional response that’s 
always available
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Limiting when a choice is active
At times you may want a particular element in an interaction—say, a button or 
an item on a pull-down menu—to be available only under certain circumstances. 
To do that, you use the Active If field in the Response Properties dialog box 
(Modify > Icon > Response). Enter the condition under which you want the 
element to be available, and Authorware will make it active whenever the 
condition is true. 

Limiting when a choice is active—step-by-
step procedures

Set up an event response symbol so it’s 
always active in the background

Setting up an event response that’s 
always available

Turn off a perpetual Turning off a perpetual

Turn off a perpetual hot spot Turning off a hot spot perpetual

Make a perpetual inactive Making a perpetual inactive

What you can do In Authorware Help, see

Make a button active only under 
certain conditions

Limiting when a button is active

Make a hot spot active only under 
certain conditions

Limiting when a hot spot is active

Make an object hot only under 
certain conditions

Limiting when a hot object is active

Dim a menu item Disabling a menu item

Make a keypress interaction inactive 
under certain conditions

Limiting when a keypress symbol is active

Make a target area active only under 
certain conditions

Limiting when a target area is active

Make the time limit inactive under 
certain conditions

Limiting when a time limit is active

Make an event response symbol active only 
under certain conditions

Limiting when an event response is active

What you can do In Authorware Help, see
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Directing the Flow

The flowline provides a clear image of how Authorware operates at its most basic 
level: It moves forward from icon to icon along a single path.

You’ll find that you soon want to move beyond the most basic level. For example, 
if you’re working on a project with many pages of text, you’ll want to let users page 
backward as well as forward, jump back to pages they’ve already read, and even 
search for pages that cover a particular topic. Or you may want users to be able to 
jump to a glossary or a help system without losing their place. If you’re setting up 
a training course, you may want Authorware to branch automatically to a 
particular section based on the results of a pretest. In any kind of project you’re 
working on, if you find yourself setting up the same sequence of icons over and 
over, you can set up a subroutine and have Authorware jump to it whenever you 
need to use it.

Authorware gives you the flexibility to do all those things with its framework, 
navigate, and decision icons.
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Ways of directing the flow
As you get into the details of directing the flow through an Authorware piece, 
you’ll find that keeping a few key distinctions in mind will prove helpful.

User control versus automatic control

There are two ways to control the flow through a piece:

• You can let users direct the flow. For example, you can provide Next, 
Previous, and Search buttons to let users navigate through pages of text.

• You can have Authorware direct the flow automatically based on some specific 
circumstance. In a training course, for example, Authorware might branch 
automatically to a particular section based on the results of a pretest.

Structures that let users direct the flow are called navigation structures. Structures 
that direct the flow automatically are called decision structures.

Following a path versus jumping around

In many cases, directing the flow in Authorware is just a matter of channeling it 
down one path or another. That’s the case with interaction icons and decision 
icons. The flow never leaves the flowline; it simply follows one branch rather 
than another.

Examples of paths
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In other cases, directing the flow means setting up Authorware to jump from one 
place to another on the flowline. You set up jumps with navigate and framework 
icons. You can place a navigate icon anywhere in a file, but it can direct the flow 
only to an icon that’s attached to a framework icon.

The best place to use navigate icons is within framework structures. Inside a 
framework structure you can jump around as much as you like.

The flow within a file versus the flow between files

A project that you’re working on may be made up of several files, each containing 
a different segment. If so, you need to be able to direct the flow from one file 
to another.

Directing the flow from one file to another is different from directing the flow 
from one icon to another within a single file. You can’t use the navigate icon to 
jump from one file to another. Instead, you need to use one of the JumpFile 
functions (see “Using Variables, Functions, Xtras, and More” on page 307). 

The flow and the Internet

If you’re designing an Authorware piece to run over the Internet, remember 
that downloading data over the Internet takes longer than reading the same 
data from a local hard disk. The strategies you choose to direct the flow may 
need to be different.
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Navigate, framework, interaction, and decision icons

Don’t think of the navigate, framework, interaction, and decision icons as mutually 
exclusive ways of directing the flow. They are all useful in various combinations to 
achieve the kind of control you want. For example, the framework icon has built 
into it an interaction icon with a series of navigate icons attached to it. Those 
navigate icons are the framework icon’s standard navigation controls.

You could also use a navigate icon—or even an entire framework structure—at the 
end of each path in a decision structure.

In designing ways to control the flow through an Authorware piece, keep in mind 
what each of the icons does:

• Interaction icon lets users choose a branch.

• Decision icon chooses a branch automatically.

• Navigate icon jumps the flow from one place to another.

• Framework icon contains the destinations the navigate icon can jump to.
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Decision structures—directing the flow 
automatically
A decision structure is made up of a decision icon and one or more paths that are 
attached to it. When the flow reaches the decision icon, the decision icon 
automatically directs the flow down one of the paths, based on the settings you’ve 
selected for the icon.

Suppose, for example, that you’re creating a training course for customer service 
representatives. Some of the people taking the course are current employees 
brushing up on department policies, some are new employees unfamiliar with the 
system, and some are seasonal workers who may have learned the system last year 
but haven’t used it since then. Because the backgrounds of the people taking the 
course are so varied, you decide to create a pretest to determine where each user 
should start.

At the beginning of the course, Authorware presents each user with the pretest 
and then encounters a decision structure on the flowline.

The decision structure tells Authorware which path to follow based on the user’s 
score. That’s the essence of a decision structure: The path Authorware follows is 
neither predetermined nor decided by the user. Instead, the path is determined 
automatically by Authorware when it reaches the decision structure.

Types of branching
The decision icon gives you four different types of branching to choose from:

Decision icon Type of branching

Sequential

Random to any path
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Sequential branching
Sequential branching works like this: Each time Authorware passes through a 
decision structure it takes a different path, starting with the one on the left. The 
second time it passes through the structure, it takes the second path; the third 
time, it takes the third path, and so on.

The introduction to this section described how you can use a decision icon to 
evaluate a pretest and take the path to the part of a course where it’s appropriate 
for a user to start. You can also use a decision icon to present a pretest.

You set up the decision structure so that each path presents one of 10 questions 
in the quiz.

You attach a calculation to the decision icon and, to keep track of the number of 
questions a user has answered, enter this expression in the Calculation window:

counter := counter+1

The expression adds 1 to the custom variable counter each time Authorware 
passes through the decision structure.

Random to only an unused path

To a path determined by a calculation

Decision icon Type of branching

Second

First Third
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In the Decision Options dialog box, you select Until True as the Repeat option 
and enter this expression:

PercentWrong>30 | counter=10

The first expression, PercentWrong>30, tells Authorware to continue repeating 
the decision structure until the user has answered more than 30 percent of the 
questions wrong. The second expression, counter=10, tells Authorware to 
continue repeating the decision structure until the user has answered all the 
questions. The “or” (|) bar between the two tells Authorware to repeat the 
decision structure until either expression is true.

Because you’ve set the decision icon to branch sequentially, each time Authorware 
passes through the decision structure it moves one path to the right. If you don’t 
include an expression to tell Authorware when to stop repeating the decision 
structure, when it reaches the last path it returns to the left-most path and starts 
over again.

The Reset Path On Entry option affects what Authorware does if it leaves the 
decision structure and then returns to it later. If Reset Path On Entry is selected, 
Authorware starts over again with the first path. If it isn’t selected, Authorware 
remembers which path it followed the last time it passed through the decision 
structure and moves one path to the right.

Random branching
There are two ways to set up random branching in a decision structure. You can 
have Authorware select any path at random, regardless of whether it’s selected the 
path before, or you can have Authorware select randomly only from the paths it 
hasn’t yet taken.

For example, you could set up the pretest described in the previous procedure so 
that Authorware selects randomly from the questions it hasn’t yet presented a user. 
Everything else about the decision structure would be the same except that you’d 
select Randomly To Unused Path rather than Sequentially as the Branch option.

Randomly To Unused Path also comes in handy if you need to test a student a 
second time on the same material. You’d set up each question so that it has two 
or more versions, depending on the number of times a student is allowed to 
retake the test.

If you leave Reset Path On Entry deselected, Authorware remembers which 
version of the question it has already presented. The next time it passes through 
the decision structure, it presents a different version.
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Branching based on a variable or 
expression
You can use the value of a variable or expression to determine which path in a 
decision structure Authorware follows.

Authorware numbers the icons attached to a decision icon from left to right, 
starting with 1.

If a variable’s value is 1, Authorware branches to the first icon; if the variable 
equals 2, it branches to the second icon. If the value of a variable isn’t a whole 
number, Authorware ignores the decimal part of a value; it considers 0.75 equal to 
0 and 4.25 equal to 4. Notice that Authorware doesn’t round the value to the 
nearest whole number—it simply drops the decimal part of the value. If a value is 
less than 1 or larger than the number of icons attached to the decision icon, 
Authorware bypasses all the attached icons and moves to the icon that follows the 
decision icon on the flowline, regardless of which Repeat option you’ve selected.

If you want something to happen only when a certain condition is true, use a 
logical variable or a conditional expression. If the variable or expression is true, 
Authorware treats it as if it’s equal to 1 and branches to the first icon attached to 
the decision icon. If the variable or expression is false, Authorware treats it as if it’s 
equal to 0, bypasses the icon attached to the decision icon, and moves to the icon 
following the decision icon on the flowline. For an example, see “Branching based 
on a conditional expression” on page 281.

Branching based on a calculation

Suppose, for example, that you’re setting up the training course described in 
Decision structures (see “Decision structures—directing the flow automatically” 
on page 277).

At the beginning of the course, Authorware presents each user with the pretest and 
then encounters a decision structure on the flowline. For example, to evaluate the 
results of the pretest, you’d set up the Decision Icon Properties dialog box like this:
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Remember, if the value of a variable or an expression isn’t a whole number, 
Authorware ignores the decimal part of the value.

The calculation in the dialog box divides those who take the pretest into three 
groups. As shown in the following table, the lowest third take the first path, the 
middle third take the second path, and the highest third take the third path. 

Branching based on a conditional expression

You can use a conditional expression when you want something to happen only 
if a condition is true. Suppose you have text interactions in a piece that are 
case-sensitive and you want to make sure at the beginning of the application 
that Caps Lock isn’t down. You can use the system variable CapsLock to find out. 
CapsLock is true if Caps Lock is down, false if it’s up.

You’d set up a decision structure to display a message to the user if Caps Lock is 
down. The decision structure has only one path.

If CapsLock is true, Authorware branches to the display icon attached to the 
decision icon; if CapsLock is false, Authorware bypasses the decision structure 
entirely.

To have Authorware check the value of CapsLock, you insert the variable into the 
To Calculated Path field.

You can also set up branching based on a variable or expression.

Percent Correct (PercentCorrect/34)+1 Path

25 1.74 1

33 1.97 1

34 2 2

50 2.47 2

67 2.97 2

68 2 3

100 2.94 3
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Decision structures—step-by-step 
procedures

Paging structures—quick and easy user 
control
A paging structure is any navigation structure that uses a book or index card 
metaphor. A paging structure usually consists of pages of text and has navigation 
controls that let users go to the next or the previous page, look up and jump to a 
page they’ve already read, and sometimes search for a word or a topic and jump to 
the page where it’s located.

Paging structures are the easiest type of navigation structure to create in 
Authorware. Once you’ve saved the content in a rich text format (RTF) file, all 
you need to do is drag a framework icon to the flowline, and then drag the RTF 
file to the framework icon. Authorware creates a display icon for each page in the 
RTF file, attaches the display icons to the framework icon, and provides a 
ready-to-use set of navigation controls. The results aren’t elegant, but they’re quick 
and serviceable—and it’s a great way to get started or to prototype a project.

The navigation controls built into the framework icon give users these options:

• Move to the next or previous page

• Move to the first or last page in the paging structure

• Jump back to the last page they’ve read

• Display a list of the pages they’ve read

• Search for a word, phrase, or keyword

• Exit the paging structure

What you can do In Authorware Help, see

Branch sequentially to a series of paths Setting up sequential branching

Branch randomly to a series of paths Setting up a decision path

Branch randomly to only to the paths 
that haven’t already been used

Random branching

Branch based on the value of a variable 
or an expression

Branching based on a variable or 
expression
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Although any icon attached to a framework icon is called a page, a page doesn’t 
have to be a screen full of text. It can be a graphic, an animation, a digital movie, a 
sound—or even a map icon containing a complex sequence of icons. For example, 
you could use a paging structure to create an annotated version of Chopin’s 
waltzes. Each page might contain a recording of one of the waltzes accompanied 
by a commentary on the music. You could use a paging structure to show how 
editing changes a film. For example, you could use the first page to show an 
unedited scene, the second to show the scene after it’s been cut, the third to show 
with special effects, the fourth with sound effects, the fifth with music, and so on.

By the way, if you drag a group of movie files or a group of sound files—or even a 
group of movie, sound, graphic, and text files—to a framework icon, Authorware 
places each of them in its appropriate icon and arranges them as pages attached to 
the framework icon.

Paging structures—step-by-step procedures

What you can do In Authorware Help, see

Set up a paging structure Setting up a paging structure

Set up a paging structure a page at a time Setting up pages one at a time

Import text into a paging structure from an 
RTF file

Importing text into a framework

Reposition the default navigation controls Repositioning the navigation controls

Choose a transition effect between pages Setting up page transitions

Disable Previous and Next buttons so piece 
doesn’t go from last page to first or from first 
to last

Preventing wraparound paging, 
Going to the next, previous, first, or 
last page

Change the way a navigation control works Changing where a navigation control 
takes a user

Change the look of a navigation control or 
the sound it makes 

Changing a navigation control’s graphic 
or sound

Provide a key that a user can press instead 
of clicking a navigation control

Assigning a shortcut key to a button

Make a navigation control active only under 
certain conditions

Limiting when a button is active

Hide or dim a navigation control when 
it’s not active

Hiding or dimming an inactive button

Make a navigation control the default Making one button the default
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Frameworks in depth
Navigation structures let users select the path they want to take through a piece. 
Most navigation in Authorware is handled with the navigate and framework 
icons. The two icons work hand in hand.

The navigate icon takes Authorware from one place on the flowline to another 
place that’s inside a framework icon.

A navigate icon can be on the flowline outside a framework, but the destination it 
directs Authorware to must be inside a framework.

The navigate icon is much more sophisticated and flexible than the Authorware 
GoTo function. You can use the navigate icon to do the following:

• Go to any specific icon inside a framework

• Go to an icon just by identifying its location relative to the current icon (for 
example, the next icon or the previous one)

Add or delete a default navigation control Adding or deleting a default navigation 
control

Create custom navigation controls Creating custom navigation controls

Save navigation controls as a model Saving navigation controls as a model

Replace the default navigation controls 
with a model

Replacing the default navigation controls 
with a model

Remove the default navigation controls 
from the framework icon permanently

Eliminating the default navigation controls

Create new default navigation controls Creating new default navigation controls

What you can do In Authorware Help, see

The Navigate icon takes 
Authorware from one place 
on the flowline...

...to another place that’s 
inside the Framework icon.
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• Return to the last icon a user looked at

• Display a list of all the icons a user looked at recently

• Display a dialog box that a user can use to search for an icon and then go to it

You can place a navigate icon anywhere on the flowline or use it anywhere you’d 
use any other icon: inside a map icon, attached to a decision or interaction icon, 
or attached to a framework.

A navigate icon’s destination must be a page attached to a framework. You can’t 
select an icon on the main flowline as the destination. Its destination can be a page 
attached to a different framework, but not attached to a framework that’s in a 
different file. If you nest one framework inside another, you can select a page 
attached to the nested framework as the destination of a navigate icon; but if you 
attach a map icon to a framework, you can’t select a specific icon inside the map as 
the destination.

How the framework icon works
The framework icon sets up an environment designed to make creating navigation 
easy. The elements of the environment appear in the framework window.

The environment has three components: the framework window, a set of default 
navigation controls, and the icons attached to the framework icon. (Any icon 
attached directly to a framework icon is called a page ID.)

The framework window has two parts: an entry pane and an exit pane.

Framework icon

Pages

Framework window
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The framework environment works like this: When Authorware enters the 
framework, it first goes to the flowline in the framework window’s entry pane.

The icons in the entry pane affect every page that’s attached to the framework 
icon. For example, if you set up a display icon in the entry pane to display a 
background, the background appears on every page. The default navigation 
controls are part of the entry pane, so they appear on every page as well.

Authorware goes to the flowline inside the entry pane whenever it enters the 
framework—no matter where it’s headed. If Authorware is coming from 
somewhere outside the framework directly to, say, the third icon attached to 
the framework, it still goes to the flowline inside the entry pane first. That’s how 
Authorware makes sure that the environment you set up in the entry pane affects 
every page in the framework, no matter what order they’re displayed in.

Before Authorware exits the framework, it does two things:

• It returns to the framework window and goes to the flowline in the exit pane.

Anything you set up there happens each time Authorware leaves the 
framework. For example, if you want to change the value of a variable each 
time a user exits the framework, you’d set up a calculation icon in the exit 
pane to do that.

• It erases everything in the entry pane and in any page in the framework.

This includes any buttons you’ve set up as perpetual. In short, it returns 
everything to the way it was when it entered the framework.

Entry pane

Exit pane

Default navigation controls
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The framework’s navigation controls
The Authorware default navigation controls work well for most common 
navigation structures.

Although, it’s easy to change the controls or to replace them entirely with a set of 
custom controls. Just open up the framework window and edit the navigation 
control’s interaction—or delete the interaction and create a new one.

You can even make a set of custom controls a permanent part of the framework 
icon. The framework icon—and the default navigation controls inside it—are 
contained in a model named Framewrk.a6d that’s in the same folder as 
Authorware. If you want to make a custom set of controls a permanent part of the 
framework icon, replace the current model with a model that contains a 
framework icon with the new navigation controls inside it.

You can customize the framework icon model even further if you want. For 
example, if you use a layout template to lay out the screen, you can include it in 
the model, and it will appear on every page you attach to the framework icon.

Nesting navigation frameworks
Although any icon attached directly to a framework icon is called a page, a page 
doesn’t have to be just a screen full of text. It can be a digital movie icon, a sound 
icon, or even a map icon containing another framework.

Nesting one framework inside another is a good way of structuring material and 
providing users with quick access to the information they’re interested in.

Go to last page viewed

List pages user has viewed

Exit navigation framework

Display Find dialog box

Go to first page

Go to previous page

Go to next page

Go to last page
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For example, imagine an electronic version of a book. One way to set it up is to 
use a single framework icon with a display icon attached for every page in the 
book. A better way to organize the piece is to create a framework in which each 
page is a map icon containing an entire chapter and then to nest inside each map 
icon another framework in which each page is a page of text.

With the piece organized that way, users can jump directly from the beginning of 
one chapter to the beginning of the next. They don’t have to page through all of 
one chapter to get to the next.

Things to consider about navigation 
structures
Here are some things to think about when you’re designing navigation:

• Are you designing the piece to run over the Internet?

If so, remember that downloading data over the Internet takes longer than 
reading the same data from a local hard disk. Consider your overall navigation 
design carefully.

• What navigation controls do you need?

If the default navigation controls aren’t what you want, change them or create a 
set of custom controls.

• How should the content be structured?

If the information you want to present is too deep for a single framework, 
consider a nested structure. Modify the navigation controls to make it easy for 
users to get where they want as quickly as possible.
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• Are any text or graphic elements common to everything inside the 
navigation framework?

If so, set those elements up in the entry pane of the framework icon.

• Is there anything you want Authorware to do every time users enter the 
navigation framework?

For example, do you want Authorware to set the value of a variable whenever 
users enter the navigation framework? If so, set it up to happen in the entry pane.

• Is there anything you want Authorware to do every time users exit the 
navigation framework?

If so, set it up to happen in the exit pane.

Navigation structures—step-by-step 
procedures

What you can do In Authorware Help, see

Set up a navigation framework Setting up a navigation framework

Set up a framework’s entry and exit panes Setting up a framework’s entry and 
exit panes

Import text into a paging structure from 
an RTF file

Importing text into a framework

Reposition the default navigation controls Repositioning the navigation controls

Choose a transition effect between pages Setting up page transitions

Disable Previous and Next buttons so piece 
doesn’t go from last page to the first or from 
first to last

Preventing wraparound paging,
Paging structures—step-by-step 
procedures

Change the way a navigation control works Changing where a navigation control 
takes a user

Change the look of a navigation control or 
the sound it makes 

Changing a navigation control’s graphic 
or sound

Provide a key that a user can press instead 
of clicking a navigation control

Assigning a shortcut key to a button

Make a navigation control active only under 
certain conditions

Limiting when a button is active

Hide or dim a navigation control when 
it’s not active

Hiding or dimming an inactive button

Make a navigation control the default Making one button the default
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Navigation links—jumping from place to 
place
To create a navigation link in Authorware, use a navigate icon.

Remember, you can place a navigate icon anywhere on the flowline or use it anywhere 
you’d use any other icon—inside a map icon, attached to a decision or interaction 
icon, or inside a framework—but its destination must be attached to a framework.

Anywhere—going to a specific page

The simplest and most straightforward type of navigation link is a link connected 
with a specific page. Unlike the Next and Previous links, whose destinations 
change each time Authorware moves to a different page, the destination of a 
navigate icon linked to a specific page never varies.

You’ll use Anywhere links most often for things such as menus—where you know 
you want a link to go to exactly the same place each time. 

Recent—backtracking

Many times it’s important to give users an easy way to get back to places they’ve 
been before. Say you’re creating an electronic travel guide. After paging through 
descriptions of dozens of hotels, a user is likely to want to return to one or two 
and find out more about them. Another user who’s searching for something 
specific in the guide—jumping around, rather than going from one page to the 
next—is occasionally going to want to return to the last entry before jumping 
forward to the next.

The Recent navigation link makes two sorts of backtracking possible:

• Go Back takes a user back to the last page Authorware displayed. It has nothing 
to do with physical proximity—that’s handled by the Previous and Next 
navigation links. Go Back goes to the page the user last visited, regardless of 
where it is.

Add or delete a default navigation control Adding or deleting a default navigation 
control

Create custom navigation controls Creating custom navigation controls

Save navigation controls as a model Saving navigation controls as a model

Replace the default navigation controls 
with a model

Replacing the default navigation controls 
with a model

What you can do In Authorware Help, see
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• List Recent Pages displays a list of the pages where Authorware has been 
most recently.

The most recent page is at the top of the list. The user can select any page from 
the list and return to it. Authorware displays the icon title of each page, so it’s a 
good idea to give icons clear, descriptive names.

It’s important not to confuse backtracking with a call (see “One-way trips and 
round trips” on page 292). A call is an automatic round trip: Authorware goes to a 
destination, and when it’s finished there, it snaps back to its point of departure as 
if it were at the end of a tightly stretched rubber band. Backtracking isn’t 
automatic. It allows users to choose to return to places they’ve already been. 

Nearby—paging  

The Nearby options in a Navigation icons properties are best suited for setting up 
navigation links between pages in a navigation framework. They’re designed to 
automatically keep track of where you are and to take you to the places where you’re 
most likely to want to go—to the next or previous page or to the first or last page.

One of the Nearby options—Exit Framework/Return—also takes care of the 
tricky task of getting you back to where you started when you jump from one 
framework to another. 

Calculate—using an expression to go to a page

Sometimes it’s convenient to use a variable or expression to define the destination 
of a navigation link rather than selecting a specific icon as the link’s destination.

For example, suppose you’ve created a piece on first aid that includes a glossary 
of terms. The word angina might appear in a dozen different places in the text. 
One way to link each instance of angina with its definition in the glossary is to 
manually set up a separate link for each instance of the word. That’s not very 
efficient. You’d have to repeat the same process not only for every instance of the 
word angina, but for every instance of every word that appears in the glossary.

A more efficient way to approach the task is first to assign the keyword angina to 
the page that contains the definition of angina. When a user clicks angina to find 
out what it means, Authorware automatically saves the word the user has clicked 
in a system variable. You can then use the variable to search for the keyword and 
find the page you’ve assigned it to. This approach is especially efficient because 
you need to set up the expression only once. You can actually make the expression 
part of the definition of the hot-text style you apply to glossary terms, and you can 
use the same expression to find any word in the glossary. 
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Search—allowing users to search for a page

The Search navigation link lets users search for a word and go to any of the pages 
where the word appears. The Search navigation link is typically used for a Find 
button, like the one on the Authorware default navigation controls panel.

When a user clicks the Find button, the Find dialog box appears.

You can set up the Find dialog box to search either an entire file or just the current 
framework. You can also search not only for the text in text objects that are inside 
display and interaction icons but also for the keywords you’ve assigned to icons. 
Searching for keywords makes it possible for users to locate icons that don’t 
display text, such as digital movie or sound icons.

Users can also set up sophisticated searches based on Boolean logic. For example, 
they can set up a search to find:

• All the pages that contain two or more words, either in any order (Cairo & 
Paris & Moscow) or in a particular sequence (Cairo, Paris, Moscow)

• All the pages that contain any of several words (Cairo | Paris | Moscow)

• All the pages that contain certain words but not others (Cairo & Paris ! 
Moscow)

You can preset the search text in the Find dialog box with either literal text or a 
variable. Presetting the search text gives you a way to automate the search process 
for users. For example, Authorware has a system variable called WordClicked, in 
which it stores any word the user clicks. By using WordClicked as the preset text 
and selecting the Search Immediately option, you can allow users to start a search 
by clicking any word on the screen.

You can also set up the Find dialog box to show not just the name of the page 
where the search text has been found but also part of the line where the 
word appears.

The context can help users identify which page they want to go to.

One-way trips and round trips
Several of the navigation links give you two ways to travel. You can take users 
either on a one-way trip, known as a jump, or on a round trip, known as a call. 

A jump is a simple, straightforward trip from a current location to a destination. A 
call keeps track of the current location so that after it arrives at its destination, it 
can return to the spot it came from.

Let’s say you’ve built a help system into the course you’ve created. You want to 
structure the course’s navigation so that users can get to the help system from 
anywhere in the course and return automatically to the place they came from when 
they’re finished. To do that, you’d call the help system rather than jump to it.
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The navigate icon where a call starts (and to which it eventually returns) can be 
either inside a framework or on the flowline outside. However, the destination of 
the outbound leg of the round trip must be a page attached to a framework icon. 
There’s also one restriction on using a call that doesn’t apply to a jump. You can 
jump between pages within the same framework, but you can call a page only if 
it’s in a different framework.

A call requires two navigate icons: one to take Authorware to the destination and 
another at the destination to take Authorware back where it came from. (Either 
navigate icon can also be replaced with a hot-text hypertext link.) At the 
destination, the navigate icon that sends Authorware on its return trip must be 
set to Exit Framework/Return.

When Authorware returns, it doesn’t go back to the exact place it came from. If it 
did, it would return to the navigate icon where it started its journey and start the 
trip all over again. Instead it goes to the point on the flowline immediately 
following the place it departed from. If you attach a map icon to a framework and 
then set up a navigate icon inside it to call another page, when Authorware returns 
to the map, it returns not to the beginning of the map, but to the place in the map 
immediately following where it left from.

All the different types of links allow you to set up a jump. The following three also 
let you set up a call:

• Anywhere links to a specific page.

• Calculate links to a page that’s identified by an expression you’ve created.

• Search allows users to search for the page where they want to go.

Nesting calls
When you set up a call, you don’t have to return immediately. For example, you 
can call one page, and from the first page call a second, and from the second page 
call a third. That’s known as nesting calls.

First call

Second call
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When you nest calls, it’s important to remember that when it’s time to return, the 
navigate icon that sends Authorware back has no idea where Authorware came 
from. It just tells Authorware to return and assumes that Authorware knows where 
to go. Authorware does. It keeps track of where it came from by keeping a list. 
Every time you call a page, Authorware records its current location on the list and 
then goes to the new destination. When a navigate icon tells it to return, it goes 
back to the last place on its list, then deletes that location from the list.

Don’t confuse Authorware by trying to use a navigate icon linked to a specific 
destination to send it back to its previous location. If you do, Authorware won’t 
look at its list, and it won’t delete the location at the bottom. The next time a 
navigate icon tells it to return, it will check the location at the bottom of the list—
and end up someplace you don’t expect. 

Navigation links—step-by-step procedures

What you can do In Authorware Help, see

Set up a navigation link to a page attached 
to a framework icon

Setting up a navigation link

Go to the next, previous, first, or last page Going to the next, previous, first, or last page

Go directly to a specific page Going to a specific page

Go to a page, then return to the place where 
the user started

Going to a page and returning

Use the value of a variable or an expression 
to determine the page to go to

Using an expression to go to a page

Let users search for a page Allowing users to search for a page

Let users search for a topic discussed on a 
page instead of the text that’s on the page

Allowing users to search for a topic

Assign a topic to a page Assigning a keyword to a page

Copy topics from one page to another Copying keywords from one icon to another

Change a topic Editing a keyword

Delete a topic Removing a keyword

Customize the Find dialog box Setting up the Find dialog box

Let users go back to pages they’ve 
already visited

Allowing users to backtrack
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Navigating with hypertext
When you attach a navigation link to hot text—text that users can click like a 
button—you’re creating hypertext.

Creating hypertext links in Authorware Authorware has a uniquely easy method 
for creating hypertext links. You first create a text style with interactivity built into 
it. You then apply the style to any text you want to turn into a hypertext link and 
select the destination Authorware goes to when a user clicks the text.

The hypertext style is really a style with a navigate icon embedded in it. Setting up 
hypertext navigation is just like setting up a navigation link once you have the 
style defined.

Hypertext—step-by-step procedures

Jumping to another file
Often your project is big enough that you need to create several Authorware files 
to encompass the whole thing. If you’re creating an electronic how-to guide, for 
example, you may want to make each chapter, along with its graphics, animations, 
and digital movies, a separate file.

As mentioned earlier, directing the flow from one file to another is different from 
directing the flow from one icon to another within a single file. You can’t use a 
navigate icon to jump from one file to another. Instead you need to use one of two 
system functions: JumpFile or JumpFileReturn (see System functions in 
Authorware Help). JumpFileReturn allows Authorware to return to the file it 
came from automatically; JumpFile doesn’t.

Customize the dialog box that displays the 
list of recent pages

Setting up the Recent Pages dialog box

Nest one navigation framework 
inside another

Nesting navigation frameworks

What you can do In Authorware Help, see

Create hypertext Navigating with hot text

Create a hot text style Creating a hot text style

Apply the hot text style to text Applying a hot text style

What you can do In Authorware Help, see
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You can attach the JumpFile and JumpFileReturn functions to a navigation 
control just as easily as you attach a navigate icon. In effect, the two functions 
work so much like a navigate icon that users may never know whether they’re 
jumping from one place in a file to another or from one file to another.

If you’re designing an Authorware piece to run over the Internet, keep the 
following things in mind when you’re setting up jumps from one file to another:

• Think small—avoid long downloads. Internet access is slower and takes longer 
than local access. Make each file as efficient as possible.

• Orchestrate downloads. Because it takes longer to download a file over the 
Internet than to read the same file from a local hard disk, download files when 
it’s least noticeable. Don’t make users wait. Otherwise the piece will seem slow 
and unresponsive.

• Think about security. Authorware lets users choose to trust or not trust sites 
they’re downloading from; it displays a dialog box at the beginning of each file 
it downloads to let them make the choice. If you avoid using certain functions 
and variables that have the potential to violate the security of a user’s system, 
you can turn the Security dialog box off. 

Subroutines
If you find yourself using the same sequence of icons over and over again in the 
same piece, consider setting them up as a subroutine. A subroutine is any single 
sequence of icons you’ve set up so that Authorware can use it in many different 
places. Online help systems and glossaries are examples of large subroutines. The 
essential characteristic of a subroutine is that Authorware can go to it and then 
return to the exact spot it came from.

For example, suppose you want to use the same three sounds over and over in a 
piece. You could set up a separate sound icon for each sound each time you 
wanted to use it. A more efficient approach is to attach the sounds to a framework 
icon at the end of the piece, like this:
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Each page in the framework is a map icon that contains one of the sounds and a 
navigate icon that’s set to exit the framework. Wherever you want to use one of 
the sounds, you’d set up a navigation link—a navigate icon or hot text with the 
Call and Return option set—to go to the page in the framework that contains the 
appropriate sound icon.

The subroutine works like this: When Authorware encounters one of the 
navigation links you’ve set up, it goes to the subroutine, plays the sound, and then 
continues down the flowline to the navigate icon. The navigate icon directs the 
flow to exit the framework. Because you set the Call and Return option for the 
navigation link that directed Authorware to the sound, Authorware exits the 
framework and automatically returns to where it came from.

The basics for creating a subroutine are simple. The subroutine must be attached 
to a framework icon. The navigation link that exits the subroutine must be set to 
Exit Framework/Return. The navigation link that directs Authorware to the 
subroutine must have the Call and Return option selected.
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CHAPTER 8
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Transitions, Positioning, and Motion

Transitions and motion create visual interest in a piece. Transitions are special 
effects that occur when Authorware displays or erases objects on the screen. 
Television and movies often use transitions between scenes—scenes softly fade 
away or dramatically spiral from one to the next. 

Objects that move can draw attention to content; they can be part of an interaction, 
or they can simulate the behavior of real-world objects. Keep in mind that 
transitions and moving objects alone won’t make a piece interesting. Interactions 
and high-quality content should take priority over motion and special effects.

Positioning has to do with changing an object’s position in response to conditions 
that you set. Positioning is a helpful way to give visual feedback to users. For 
example, as a student finishes certain sections of an educational piece, a marker 
might move along a progress bar or a map of the course.

This chapter describes the following topics:

• Using transitions to achieve special effects

• Positioning objects

• Moving objects on the screen

• Letting users move objects by dragging
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Using transitions for special effects
Transitions in Authorware are special effects applied to the Presentation window 
as you either display or erase objects. For example, the Push transition might slide 
a new screen over an old one; the Dissolve transition might slowly reveal a test 
answer or a graphic.

Skillful use of transitions can dramatize information, give greater impact, and 
enhance the overall aesthetics. Transitions can also help the rhythm and pacing of the 
piece and orient a user. For example, you can use a subtle transition when moving 
from page to page and a dramatic transition when moving from section to section.

Transition settings

You select transitions and the settings associated with them in the Transitions 
dialog box (choose Modify > Icon > Transition). 

You can vary the duration and smoothness of a transition and choose whether a 
transition affects the entire Presentation window or just the area in the window 
where new objects appear. You can use a variable or an expression to set duration 
and smoothness. For example, you can create a custom variable for the duration of 
a transition used frequently in a piece and assign its value in a calculation icon at 
the beginning. Later, if you decide the transition should run slightly faster or 
slower throughout the piece, just change the value of the custom variable.

Some transitions have other options corresponding to the effects they create. 
For example, The Byte (SharkByte Transitions) lets you control such elements 
as the number of teeth, their length and jaggedness, and whether a sound plays 
with the transition.

Transition Xtras

Transition Xtras supplement Authorware built-in transitions and are listed 
along with the built-in transitions in the Transitions dialog box. The Director 
Transitions Xtra—which provides the complete set of more than 50 transitions 
from Macromedia Director—as well as transitions from g/matter, Xaos Tools, 
and Zeus Productions are installed with Authorware.

The total number of transitions available for use with a piece depends on the 
Transition Xtras available in the Authorware Xtras folder. In addition to the 
transition Xtras installed with Authorware, you can install transition Xtras from 
independent developers.

When you distribute a piece, remember to provide users with the Xtras that you’ve 
used. These Xtras must be installed in the Xtras folder within the folder that 
contains the Authorware run-time application. See “Determining which files you 
need to distribute” on page 180.
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Positioning objects 
Positioning an object is different from moving an object. Moving an object means 
changing an object’s position on the screen as a user watches. Positioning an object 
means defining where it appears on the screen. An object may appear in different 
places at different times or for different users. But it simply appears at the position 
you designate; it doesn’t move there.

Objects normally appear exactly where you position them in the Presentation 
window. However, sometimes you might want the position of an object to depend 
on an event or a changing condition in the piece—for example, a value users 
enter, the amount of time that has passed, or the position of other objects. At 
other times you might want users to be able to drag objects wherever they want.

You can position text, graphics, sprites, buttons, or digital movies at varying 
points in several different ways:

• By positioning an object anywhere on the screen (see Positioning objects on the 
screen in Authorware Help)

• By positioning an object on a path (see Positioning objects on a path in 
Authorware Help)

• By positioning an object within an area (see Positioning objects within an area 
in Authorware Help)

• By letting users drag objects wherever they want (see Dragging an object in 
Authorware Help)

Positioning objects on a path
You might want to position an object at different points along a path. A path can 
contain straight or curved line segments. You can specify the path and the base 
and end values for the path’s ends, and then insert a variable or expression that 
determines the object’s position.

For example, if you want to show users their progress through a series of training 
courses, create a screen that lists the various sections in the series along a line. 
As users complete each section, set the value of a variable to correspond to the 
section’s position on the line. At the beginning and end of each section, use the 
variable to position a marker on the line—and show users how far they’ve gone.

Use the On Path display icon property to position an object at different points  
along a path—for example, to create a gauge or slider that moves to a specific 
point on the path depending on the value of a variable.
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Positioning objects within an area
You might want to position an object at various points within a specific area. 
To do so, specify the area, assign horizontal and vertical values to the area’s 
corners, and define variables or expressions that set the object’s horizontal 
and vertical position.

For example, suppose you’re creating a series of lessons on chess strategies. At the 
beginning of each lesson, you want to display a chessboard with the pieces set up 
to illustrate a particular strategy. To do that, position the pieces by setting the 
value of the variables assigned to them. Once you have the pieces positioned, use 
motion icons to move the pieces to their final positions to demonstrate the 
strategy that the lesson is about.

The In Area display icon property lets you specify the area, assign horizontal and 
vertical values to the area’s corners, and define variables or expressions that set the 
object’s horizontal (X) and vertical (Y) position.

Positioning objects on the screen
You can position an object anywhere on (or off ) the screen using both X and Y 
coordinates. Either use numeric values for the coordinates to place the object in a 
set location, or use variables for the coordinates to place the object in varying 
locations depending on the value of the variables. For example, if you want to let 
users see the definition of a term by clicking it, use the ClickX and ClickY 
variables to display a pop-up window containing the definition at the location 
where the user clicked.

The On Screen display icon property places objects anywhere on the screen.

Making objects move
Use the motion icon to move objects around the screen. The motion icon moves 
objects either directly to a point (on a line, a grid, or anywhere in the presentation 
window) or along a straight or curved path.

You can vary the speed or distance an object moves along a path in response 
to certain conditions in the piece. For example, you could simulate a steel ball 
rolling within a magnetic field or a ball thrown straight up into the air. The 
objects could move varying distances, depending on the strength of the 
magnetic or gravitational field. 

You can also set the scale of grids and paths by using constants, variables, or 
expressions. The scale is 0 to 100 by default, but you might want to change the 
scale, say for a timeline or for a Kelvin-scale thermometer.

You can move more than one object at a time. For example, in a demonstration of 
the solar system each planet could move independently, controlled by a different 
motion icon.
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Using the motion icon
Motion has two components—the motion icon and the icon containing the 
object you want to move. The motion icon moves everything that’s contained in 
the icon you select—text as well as graphics. Place objects that you don’t want 
moved, such as backgrounds and text, in separate icons.

The motion icon gives you a choice of five motion types:

• Direct to Point

• Direct to Line

• Direct to Grid

• Path to End

• Path to Point

Moving objects directly to a point Direct to Point moves an object to the same final 
destination no matter where it currently is on the screen. For example, you might 
want to show the correct place for an object after you’ve allowed the user to move it.

The Direct to Point motion icon moves objects from any position on the screen to 
the location you choose. 

Moving objects to a point on a line Direct to Line motion moves an object from 
anywhere in the Presentation window to a specific point on a line. When the 
object is already on the line, it appears to slide along the line; when the object isn’t 
on the line, it moves toward the specified point. For example, if you want to show 
the relationship of historical events to each other on a timeline, you can move a 
marker from a description of the event to its proper place on the timeline.

You can tailor the range and scale of the line to your needs.

Moving objects to a point on a grid Sometimes, rather than moving an object to a 
point on a line, you may want to move an object to a point on a grid. For example, 
you might want to move pieces vertically and horizontally on a chess board.

The Direct to Grid option moves an object to specific horizontal and vertical 
coordinates on a grid that you define. 

Moving objects along an entire path In some situations you’ll always want an 
object to move along the same path from beginning to end. For example, you 
might want to show the orbit of a planet or a bird’s flight path. 

The Path to End motion icon moves an object from beginning to end along a path 
that you define.
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Moving objects to a point on a path You may want to move an object along a path 
to some point that varies depending on some condition that you’re tracking—for 
example, if you’re creating a thermometer or a gauge in a simulation. 

The Path to Point motion icon moves an object along a path until it reaches some 
specific value. To track a condition that may change while the piece is running, set 
the value with a variable.

Letting users drag objects
You can let users move objects by dragging them around the Presentation window, 
within a specific area, or along a specific path. Dragging objects is a common form 
of interactivity. You can let users assemble equipment, match two items by 
dragging one to the other, control some process in a simulation by dragging a 
slider, and so on.

Making an object movable Authorware freezes everything in place when you 
package a piece so users don’t accidentally move things around the screen. If you 
want to let users move an object, you must make the object movable, either with 
the Movable setting for the icon that contains the object (Modify > Icon > 
Properties) or with the variable Movable. Using the Movable variable is more 
flexible than using the Movable setting because you can turn the variable on and 
off to control precisely when users are able to move an object.

Allowing users to interact There are two ways to let users move an object once 
you’ve made it movable. One is to set up a target area interaction (see “Letting 
users drag objects” on page 304). Target area interactions are ideal if there’s some 
specific spot you want users to drag an object to—for example, if you’re letting 
users assemble equipment or match two items by dragging one to the other. But 
they’re not so effective if you’re, say, setting up a slider to control a process in a 
simulation. The slider can be anywhere along the scale—there’s no one position 
that’s its target.

The second way to let users to move an object works for things such as sliders. 
It involves using the Positioning setting for the icon that contains the object 
(Modify > Icon > Properties) to define where the object can be moved and 
using the variable.

PathPosition tracks the location of the object. For an example and a description of 
how the approach works, see the Show Me: “Slider (Slider.a6p)” on page 391.
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Variables for tracking an object’s motion 
and position
Authorware has a set of variables designed specifically for tracking an object’s 
motion and position. The variables are listed in the following table along with a 
brief description. For more information about them, see Chapter 15, System 
Variables in Authorware Help.  

Variable Description

Animating Indicates whether an object is being moved by a 
motion icon.

DisplayHeight Contains the height of an object.

DisplayLeft Contains the distance between the left end of an 
object and the left edge of the Presentation window.

DisplayTop Contains the distance between the top of the object 
and the top edge of the Presentation window.

DisplayWidth Contains the width of an object.

DisplayX Contains the distance from the center of the object to 
the left edge of the Presentation window.

DisplayY Contains the distance from the center of the object to 
the top of the Presentation window.

Dragging Indicates whether a user is dragging an object.

Movable* Indicates whether the user can move an object.

Moving Indicates whether an object is being moved by a 
motion icon or dragged by a user.

PathPosition Contains the position of the object on a path.

PositionX
PositionY

Contains the vertical and horizontal position of an 
object in an area.
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Making objects move—step-by-step 
procedures
The following table lists the tasks you can accomplish and where you’ll find the 
steps to do so.

What you can do In Authorware Help, see

Move an object from anywhere to a 
specific position

Moving objects direct to a point

Move an object from anywhere to a 
specific point on a line

Moving objects to a point on a line

Set the base and end points of a line Moving objects to a point on a line

Move an object from anywhere to a 
specific point on a grid

Moving objects to a point on a grid

Create a grid Moving objects to a point on a grid

Move an object along a path from 
beginning to end

Moving objects along an entire path

Move an object along a path to a 
specific point

Moving objects to a point on a path

Create a path Creating paths, Making circular paths
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and More

The Authorware variables and functions give you a level of control that’s much 
greater than what you can achieve by manipulating icons on the flowline. You can 
collect and manipulate data, get detailed information about interactions, make 
decisions based on specific conditions, and set up Authorware to do just about 
anything a computer is capable of. 

You don’t need to be a programmer to take advantage of variables and functions—
in many cases, Authorware makes it as easy as copying and pasting. 

Variables represent values that can change. As the word implies, a variable’s value 
varies. Authorware contains over 250 variables that are ready to use. For example, 
the system variable PercentCorrect automatically keeps track of the percentage 
of questions a user has answered correctly. You can easily create your own custom 
variables to store any information you need to keep track of.

Functions perform specific tasks. Authorware has over 300 functions to choose 
from. For example, the system function JumpFile lets you jump from one 
Authorware file to another. WriteExtFile lets you save information in a text file.

You can combine variables and functions in expressions. An expression is any part 
of an Authorware statement, meant to be taken as a whole. For example, 2 + 2 is 
an expression but not a valid statement all by itself. A statement is a valid 
Authorware instruction that produces a result by performing a calculation or 
carrying out an operation. For example, UserName := "John Smith" is a 
statement that assigns a value to a variable.

Combining variables, functions, and expressions—along with if...then 
statements and repeat loops—to tell Authorware exactly what you want it to 
do is called scripting.
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What each variable and function does
Each variable and function has a specific purpose. To use a variable or function 
properly, you need to know exactly what it’s designed to do. There are three places 
you can find out:

• In Authorware Help System variables and System functions, describe each 
variable and function in detail.

• You can download PDF versions of System variables overview and System 
functions overview from www.macromedia.com/support/authorware/ .

• The Variables dialog box gives a brief description of each variable. The 
Functions dialog box lists the syntax and gives a brief description of each 
function.

Where you can use variables, functions, 
expressions, and scripts
In a calculation icon Opening a calculation icon displays a Calculation window. 
Calculation windows can contain variables, functions, expressions, and scripts. 
For example, you might put a calculation icon at the very beginning of a file and 
use it to set the value of a variable that controls how long wait icons pause 
throughout the file. 

In a Calculation window attached to an icon You can also use variables, functions, 
expressions, and scripts in Calculation windows attached directly to icons.
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You attach a Calculation window directly to an icon to make sure Authorware 
executes the calculation whenever it encounters the icon. For example, you’ve 
created a target area interaction and you want to make sure that the objects users 
are supposed to move are tagged as movable at the moment they enter the 
interaction. The best way to accomplish this is to attach a Calculation window to 
the interaction icon (Modify > Icon > Calculation) and set it up like this:

When you attach a Calculation window to an icon, a small equal sign appears just 
above and to the left of the icon.

In dialog boxes You can use variables, functions, and expressions—but not 
scripts—in most editable fields in dialog boxes. For example, you might want to 
position an object at the last spot where the user clicked. To do that, you’d use the 
ClickX and ClickY variables in the Position fields of the Display Icon Properties 
dialog box, like this:

Equal sign indicating
an attached

calculation
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In a few editable fields you can’t use a variable, function, or expression: fields 
where you name things (such as icons, text styles, or keywords) or where 
you provide descriptions (such as the description of a button state in the 
Button editor).

Embedded in display text You can display the contents of a variable or the value of 
an expression on the screen by embedding it in a text object or an RTF document. 
Embedding the content of a variable in text objects makes it possible to display 
information that changes from moment to moment or from user to user. 
Embedding an expression in a text object makes it possible to display the result 
of a calculation without having to add a calculation icon to the flowline. A text 
object with embedded variables and expressions looks like this:

When Authorware displays the text object, it displays the value of the variable or 
expression, not the variable or expression itself.  

Using the Calculation window
You can use the Calculation window to do the following tasks:

• Paste in a function or variable.

• View the ASCII value of the selected character in the Calculation window. 
“Displaying the ASCII value of selected text” on page 312.

• Change calculation preferences for defaults in the Calculation window. For 
example, you can set up your calculation preferences so that case-sensitive 
functions or variables are automatically converted to the correct case. For more 
information, see “Changing calculation defaults in the Calculation window” on 
page 311.
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• Insert a symbol, divider line, or message box into a calculation. See “Inserting a 
symbol, divider line, or message box into a calculation” on page 311.

Changing calculation defaults in the Calculation window

You can change several preferences in the Calculation window. Once you change 
the preferences, they become the defaults. For example, you can set up your 
calculation preferences so that case-sensitive functions or variables are 
automatically converted to the correct case.

Inserting a symbol, divider line, or message box 
into a calculation

A context menu has been added to the Calculation window. You can access this 
menu by right-clicking from the Calculation window.

You can select any toolbar option from this menu, as well as insert a symbol, 
divider line, or message box into the calculation.
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Displaying the ASCII value of selected text

You can view the ASCII value of selected text in the  Status bar in the 
Calculation window.

Calculation window keyboard shortcuts

You can use the following keyboard shortcuts in the Calculation window.

Keyboard Shortcut Result

Up arrow Move up one row

Shift+Up arrow Select the row above

Down arrow Move down one row

Shift+Down Select the row below

Left arrow Move one character to the left

Shift+Left arrow Select characters to the left of the insertion point

Control+Left arrow Move to the word to the left

Shift+Control+Left arrow Select the word to the left

Right arrow Move the insertion point one character to the right

Shift+Right arrow Select characters to the right of the insertion point.

Control+Right arrow Move to the word to the right

Shift+Control+Right arrow Select the word to the right

PgDn Move one page down

Shift+PgDn Select from the insertion point to the bottom of the page

Control+PgDn Move to the bottom of the page

Shift+Control+PgDn Select from the insertion point to the bottom of the page

PgUp Move one page up

Shift+PgUp Select from the insertion point to the top of the page

Control+PgUp Move to the top of the page

Shift+Control+PgUp Select from the insertion point to the top of the page

Home Move to the beginning of the line

Shift+Home Select from the insertion point to the beginning of the line

Control+Home Move to the top of the Calculation window
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Shift+Control+Home Select from the insertion point to the top of the 
Calculation window

End Move to the end of the line

Shift+End Select from the insertion point to the end of the line 

Control+End Move to the bottom of the Calculation window 

Shift+Control+End Select from the insertion point to the bottom of the 
Calculation window 

Ins Toggle between insert and overwrite mode

Delete Delete selected text

BkSp Delete last character

Control+BkSp Delete last word

Enter Line break

Control+A Select all

Control+C Copy

Control+V Paste

Control+X Cut

Control+Y Delete line

Control+Z Undo

Shift+Control+Z Redo

Tab Tab forward four characters

Shift+Tab Move backward four characters

Shift+Control+B Find matching bracket in an expression

Alt+Enter Create a continuation character

Control+Shift+123 Go to line number 123

Control+Shift+Alt+I Block indent

Control+Shift+Alt+U Block unindent

Control+Alt+C Mark line as a comment

Control+Alt+X Unmark line as a comment

Keyboard Shortcut Result
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Creating a Quit button

To create a Quit button, for example, you attach a calculation icon to an 
interaction icon, select the button response type, then set up the Quit function 
in the Calculation window, like this: 

Variables and Functions dialog boxes
You can also browse the Functions and Variables dialog boxes. Choose Window > 
Variables or Window > Functions, then choose the category and the variable or 
function you’re interested in. Information about the variable or function appears 
in the Description text box.

Using comments
Commenting your work is always good authoring practice. It’s especially 
important when you’re dealing with variables, functions, expressions, and 
scripts. When you go back to your work after a week or two to modify or debug it, 
you may find that the purpose of a variable or an expression isn’t immediately 
apparent. If you comment your work thoroughly as you create it, you won’t have 
to waste time deciphering it when you want to make changes later.

You can use comments anywhere in a Calculation window. To add a comment, 
type two hyphens (--) and then the text of the comment. For example:

total := score1 + bonus --calculates raw score

Authorware ignores everything after the two hyphens when it evaluates 
the expression.
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Variable and function basics—step-by-step 
procedures

Using system and custom variables
A variable represents a value that can change—such as the amount of time a user 
has spent in an interaction, the percentage of questions in a test that a student has 
answered correctly, or whether a digital movie is currently playing. Think of a 
variable as the address on a mailbox: The address (variable name) is always the 
same, but the contents (variable value) can change at any time. 

There are two types of variables: system variables, which are built into 
Authorware, and custom variables, which you create yourself.

System variables
The Authorware built-in variables, called system variables, track a wide range of 
information and are grouped into 11 categories: CMI, Decision, File, Framework, 
General, Graphics, Icons, Interaction, Network, Time, and Video. Authorware 
updates the information in the system variables automatically.

System variable names in Authorware always begin with an uppercase letter and 
consist of one or more words with no spaces between them—for example, Tries 
and VideoDone. Some system variable names can be followed by the @ and the 
title of an icon. They’re called icon variables, and you can use them to find out a 
variable’s value at a specific icon within a file.

What you can do In Authorware Help, see

Use a variable Using a variable

Display the content of a variable on 
the screen

Displaying variable information onscreen

Create an expression Expressions and operators

Display the value of an expression on 
the screen

Displaying expression values on the screen

Use a system function System functions

Use a custom function Custom functions in DLLs

Use the functions in a scripting Xtra Scripting Xtras

Attach a Calculation window to an icon Calculation Icon
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Some variables that complement each other, such as ClickX and ClickY, come in 
sets. Some variables work in tandem with functions, such as the variable 
FileLocation and the function ReadExtFile. You can assign values to some 
system variables to provide Authorware with information.

For example, you can make the variable Movable true or false to tell Authorware 
whether or not you want users to be able to move a particular object. The values of 
other system variables, such as TimeRemaining, are assigned to them by 
Authorware, and you can only extract the information they contain.

Before you start working with system variables, decide what you want to do with 
the variable. Do you want to provide Authorware with information (for example, 
by setting Movable to true to tell Authorware to allow a user to move an object)? 
Or do you want to use the variable to extract from Authorware information you 
need (for example, information that a user has entered and that Authorware has 
stored in EntryText)? Once you’ve decided what you want to do with a variable, 
finding it and putting it to use is easy. 

Custom variables
If you want to keep track of information that Authorware isn’t recording in a 
system variable, you can create a custom variable. Custom variables reflect the 
value you assign to them. The value changes only when you explicitly change it. 
For instance, you might keep track of how many times Authorware has passed 
through a decision structure with a variable named Counter. You’d use the 
expression Counter := Counter + 1 to add 1 to the value of Counter each time 
Authorware passes through the decision structure.

Custom variable names can be followed by an at symbol (@) and the title of an 
icon. They’re called custom icon variables, and you can use them to find out the 
custom variable’s value at a specific icon within a file.

Types of variables
Authorware automatically interprets a variable’s type based on how you used it. 

Numerical variables store numbers. The numbers can be whole numbers (6), real 
numbers (0.006), or negative numbers (–33). The numbers stored in a variable 
can range from –1.7*10308 to +1.7*10308.

When you add two variables, Authorware treats them as numbers because 
arithmetic operators can be used only with numbers. Numerical variables might 
contain a user’s score, a topic number, or the result of a mathematical calculation.

Character variables store character strings. A string is a sequence of one or more 
characters consisting of letters ("Mary Wagner"), numbers ("49931"), special 
characters ("*/"), or a combination of any of them ("Total is $5.00"). A 
character variable can contain up to 30,000 characters. 
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Character variables might store a user’s name, a list of spelling words, or a URL to 
a Web site. When you concatenate two variables, Authorware treats them as 
character strings because the concatenation operator joins only strings. 

Logical variables store a value of true or false. They’re like a light switch, 
alternating between two states: on and off. The number zero equals false, and any 
nonzero number (usually 1) equals true.

Logical variables are particularly useful for activating or deactivating options. 
For example, inserting a logical variable in a button’s Active If field is a good 
way to activate and deactivate the button. Logical variables are also useful for 
synchronizing events. For instance, you could use the system variable Animating 
to play a digital movie and move it across the screen at the same time.

When you use a variable in a place where Authorware expects a logical variable 
(in the Condition field of the Conditional Response Properties dialog box, for 
instance), Authorware interprets it as a logical variable. If the variable contains a 
numerical value, Authorware treats the variable as true when the value is anything 
other than zero. If the variable contains a character string, Authorware treats 
the variable as true only if the string is TRUE, T, Yes, or On (capitalization isn’t 
important). All other characters are false.

List Variables store an array of constant or variable values. Authorware supports 
two types of lists:

• Linear lists, in which each element is a single value, such as [1, 2, 
3,"a","b","c"]

• Property lists, in which each element consists of a property and a value 
separated by a colon, such as 
[#firstname:"Harry",#lastname:"Smith",#phone:5551212]

Both types of lists can be unsorted or sorted in alphabetic order.

List variables are particularly useful for keeping track of and updating an 
array of data.

Symbol Variables A symbol is a type of data like a string or other value that 
begins with the pound sign (#). Symbols are useful because Authorware can 
handle symbols more quickly than strings.

For example, the symbol #Josephine in the statement:

MyVariable := #Josephine

runs more quickly than the string "Josephine" in the statement:

MyVariable := "Josephine"

Variables assigned symbols behave differently than other variables. 

For example, after the statement MyVariable := #Josephine, embedding 
MyVariable in a display icon will show the result #Josephine, because 
#Josephine is the actual value of the variable.
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However, the statement MyVariable + 1 returns a number because in this case, 
Authorware is performing an arithmetic operation and treats UserName as a 
numerical value. For information about how Authorware handles hierarchies in 
calculations, see How Authorware evaluates expressions in Authorware Help.

Rect Variables A rect is a type of data returned by the Authorware Rect system 
function. Rects are useful for defining rectangular pixel regions. For more 
information, see Rect in Authorware Help.

Point Variables A point is a type of data returned by the Authorware Point system 
function. Points are useful for setting pixel locations. For more information, see  
Point in Authorware Help.

Variables—step-by-step procedures

Functions
A function performs a specific task. The task can be as simple as capitalizing the 
first letter of every word in a line of text or as complex as creating an array. 

There are two types of functions: system functions, which are built into 
Authorware, and custom functions, which include scripting Xtras and DLLs. 
Macromedia supplies a small set of custom functions with Authorware; many 
more are available from other developers.

The only real difference between system and custom functions is where they come 
from. They all have the same purpose: to increase the flexibility of Authorware 
and to extend the range of things you can accomplish.

What you can do In Authorware Help, see

Use a variable Using a variable

Display the content of a variable on 
the screen

Displaying variable information onscreen

Create a custom variable Creating a variable

Set the initial value of a variable Creating a variable

Make changes to a custom variable Changing a custom variable

Delete a custom variable Deleting a custom variable

Rename a custom variable Changing a custom variable

Refer to a variable’s value at a specific icon Variable values at a specific icon

Use a variable in a library Variables, functions, and expressions 
in libraries
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System functions
You can use Authorware system functions to do such things as manipulate text 
and files, control and respond to what’s going on in navigation structures, play 
and synchronize media, draw objects and manipulate graphics, jump between 
files, launch other applications, and perform mathematical functions.

Some functions that complement each other, such as ArraySet and ArrayGet, 
come in sets. Some functions work in tandem with variables, such as the 
ReadExtFile function and the system variable FileLocation. You can use 
functions such as IconNext and Keywords to get information; others such as 
CreateFolder, DeleteLine, and Quit to carry out tasks; and others such as 
Random and Round to perform operations.

System functions in Authorware follow certain naming conventions: They always 
begin with an uppercase letter and consist of one or more words with no spaces 
(for example, Beep and VideoSpeed).

Each system function is described in detail in  System Functions in Authorware 
Help.

Getting the syntax right
A function will work right only if you use the correct syntax. The syntax of a 
function includes the function’s arguments. Almost every system function requires 
arguments, which supply the function with the information it needs to carry out 
its task. For example, when you use the SQRT function, you need to supply the 
function with the number you want the square root of. 

The most detailed description of a function’s syntax appears in System functions 
in Authorware Help.  Authorware also displays the syntax of each function in the 
first line of the description in the Functions dialog box.

There are two types of arguments: required and optional. Optional arguments are 
enclosed in brackets ([ ]).

The best way to get the syntax right is to select a function in the Functions dialog 
box and then paste where you want to use it. Then replace the argument names in 
the template syntax with the values you actually want to use. For example, if you 
want to make sure that the name you’re storing in the variable UserName is 
capitalized, first type:

UserName :=

Then paste in the Capitalize function, like this:

UserName := Capitalize(string [,1])

Replace string with the name of the variable that contains the text the user 
has entered:

UserName := Capitalize(EntryText [,1])
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And finally, delete the optional argument:

UserName := Capitalize(EntryText)

If you are entering a function or variable in a Calculation window, you can make 
sure that the capitalization is correct for case-sensitive functions by setting the 
properties in the Calculation window to automatically correct the system 
functions and variables case. For details, see “Changing calculation defaults in the 
Calculation window” on page 311.

Custom functions in DLLs 
Windows dynamic link libraries (DLLs) provide a way of linking to external 
functions that you call from within calculation icons. Authorware must have the 
following information about a function in a DLL before it can load it:

• Where the function resides

• The function’s name

• How many and which type of arguments the function takes

• The type of arguments the function returns

User code documents (UCDs)

Windows DLLs weren’t created for non programmers. Standard DLL format and 
calling conventions often require you to refer to programmer documentation and 
cope with API calls to Windows. To get around that, Authorware supports a 
transparent extension to the conventional DLL, called a UCD (for user code 
document). C programmers who create DLLs for use with Authorware can use a 
UCD to preload the information Authorware needs to recognize and link to 
functions within the DLL, including function names, arguments, return types, 
syntax templates, and online descriptions. The additional resources can be stored 
either with the DLL or separately, and they remain transparent to other programs 
that have access to the DLL.

When you load a UCD, Authorware lists the functions it contains in the Functions 
dialog box. You can select the functions and paste them into a Calculation window 
just as you would a system function. That makes it possible to load and call DLLs 
without having to cope with low-level programming conventions.

Conventional DLLs

Authorware also supports conventional DLLs by presenting a dialog box in which 
you can enter the specific calling parameters. Such conventional support makes it 
possible to link to DLLs that have not been written to be specifically loadable by 
Authorware. 
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DLLs and the search path

Because files for DLLs are separate from the files that call them, they must be in the 
folders specified in the search path. If Authorware can’t locate the custom function 
in any of these folders, it ignores the function and continues running the piece. 
Always make sure that the folder containing DLLs is included in the search path.

Loading a DLL custom function
Before Authorware can use a custom function, the function needs to be in 
memory. Loading a custom function is like opening an Authorware file: 
Authorware reads the function from the disk where it’s stored into the computer’s 
memory. Once the function is there, Authorware can exchange information with 
the function and tell it when to start. Loading a function connects Authorware 
with the function and allows the two to communicate. You can start the process of 
loading a custom function from the Functions dialog box, a Calculation window, 
or a text object. 

When a function is loaded, it takes up space in memory. If you’re not using a 
function in the piece you’re working on, you can remove it from memory and free 
up the space it occupies. 

* Void signifies that the function accepts no arguments. Void must appear by itself 
in an argument list.

Using functions—step-by-step procedures

What you can do In Authorware Help, see

Use a system function System functions

Use scripting Xtra functions Using scripting Xtra functions

Use a custom function Loading a DLL custom function

Unload a custom function Unloading a DLL custom function

Use DLLs Custom functions in DLLs

Use a DLL that doesn’t follow 
Authorware conventions

Loading DLLs that don’t follow 
Authorware conventions

Use functions in libraries Variables, functions, and expressions 
in libraries
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Expressions and operators
To achieve the results you want with a variable or function, you often need to 
make the variable or function part of an expression. An expression is a statement 
that produces a result by performing a calculation or carrying out an operation 
such as placing a value in a variable. You can use expressions in Calculation 
windows and dialog boxes, and you can embed them in text objects. In addition 
to variables and functions, you can use operators, numbers, character strings, 
constants, and comments in an expression.

For example, this expression increases the value of the variable Counter by 1:

Counter := Counter + 1

This expression uses the GetLine function to get the phone number that’s stored 
on the fifth line of the variable ContactInfo and put it in the variable 
PhoneNumber:

PhoneNumber := GetLine(ContactInfo,5)

To tell Authorware what you want it to do with the variables and functions in an 
expression, you use operators.

Types of operators
An operator is a symbol that stands for the action you want Authorware to perform 
on one or more values. For example, a plus sign (+) tells Authorware to add two 
values together. The concatenation operator (^) tells Authorware to fuse two 
strings of text into one: car^pet becomes carpet. Authorware has five different 
types of operators: assignment, relational, logical, arithmetic, and concatenation. 
The operators you can use in Authorware are summarized in the table below.

All the operators are described in detail in System Functions in Authorware Help. 
The Language category in the Functions dialog box also contains a complete list 
of the operators you can use.

Category Operator What it means

Assignment operator := Assign the value on the right 
of the operator to the 
variable on the left

Relational operators = Equal to

<> Not equal to 

< Less than

> Greater than

<= Less than or equal to
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Expressions—step-by-step procedures

Scripting
Scripting is the combining of variables, functions, and expressions—along with 
if...then statements and repeat loops—to tell Authorware exactly what you want 
it to do.

Here’s an example of a simple script:

If StudentScore > 90 then StudentLevel := "expert"

The script says, “If the student’s score is greater than 90, then set the student’s 
level to expert.” It’s constructed of two expressions, StudentScore > 90 and 
StudentLevel := "expert", used as the components of an if...then statement.

>= Greater than or equal to 

Logical operators ~ Not

& And

| Or

Arithmetic operators + Add

- Subtract

* Multiply

/ Divide

Concatenation operator ^ Join (combines two strings 
into one)

What you can do Instructions in Authorware Help

Use numbers in expressions Using numbers in an expression

Use text in an expression Using character strings in an expression

Use constants in an expression Using constants in an expression

Use operators in an expression Using operators in an expression

Add comments to an expression Using comments in an expression

Display the value of an expression on 
the screen

Displaying expression values on the screen

Category Operator What it means
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You can create scripts that are quite complex as well. The following script uses 
if...then statements nested inside repeat loops to carry out a task over and over in 
many different places:

BranchList := IconID@RootIcon^Return
repeat while LineCount(BranchList) > 0

SetIcon := IconFirstChild(GetLine(BranchList, 1))
if IconType(SetIcon) = 4 |=5 |=6 |=12 then

BranchList := BranchList^SetIcon^Return
end if

Movable@SetIcon := FALSE
repeat with x := 1 to IconNumChildren(GetLine(BranchList, 1))
SetIcon := IconNext(SetIcon)
if IconType(SetIcon) = 4 |=5 |=6 |=12 then

BranchList := BranchList^SetIcon^Return
end if
Movable@SetIcon := FALSE

end repeat
BranchList := DeleteLine(BranchList, 1)

end repeat

Two of the most common ways to control what happens in Authorware—as the 
foregoing examples show—are if...then statements and repeat loops. Both are 
simple enough to master easily, but they’re also flexible enough to achieve 
sophisticated results.

If...then statements
Use an if...then statement to set up a condition and provide Authorware with a 
specific set of instructions to follow if the condition is true.

In everyday life, you use the equivalent of if...then scripts all the time. You might 
say, for example, “If it snows, then I’ll go skiing; otherwise, I’ll clean the garage.” 
Depending on how much you want to go skiing, you could set up additional 
conditions, such as “If it snows and I finish my taxes, then I’ll go skiing.”

You can use similar statements to determine what Authorware does, checking for 
one or more conditions.

Checking for a condition

The simplest form of an if...then script states, “If this condition is true, then do 
this action.” The syntax for a simple script looks like this:

if condition then statement

For example, the following script says, “If the user is new, go to the beginning of 
the video”:

if NewUser then VideoSeek(0)
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Providing an alternative

You can also provide an alternative if the condition is false, telling Authorware, 
“If this condition is true, then do this action; otherwise, do this action instead.” 
The syntax looks like this:

if condition then statement else statement

For example, the following script says, “If the user is new, go to the beginning of 
the video; otherwise, go to frame 1500”:

if NewUser then VideoSeek(0) else VideoSeek(1500)

Checking for more than one condition

You can also check for two different conditions and have Authorware do 
something based on the one that’s true. The syntax looks like this:

If condition 1 then
statement

else if condition 2 then
statement

else
statement

end if

This syntax tells Authorware, “If this first condition is true, do this action. If this 
second condition is true, do this action instead. Otherwise, do this third action.”

For example, the following example counts the number of students with scores 
falling in the high, middle, and low ranges:

If PercentCorrect < 66 then
LowScore := LowScore + 1

else if PercentCorrect < 90 then
MidScore := MidScore + 1

else
HighScore := HighScore + 1

end if
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Repeat loops
Use a repeat loop to repeat an action either for as long as a condition is true or for 
a given number of times.

Using a counter

The simplest type of repeat loop uses a counter to repeat an action a set number of 
times. The repeat loop can count either up or down, and you can set the starting 
and ending values of the count with a constant, a variable, or an expression. 

In the following example, Authorware adds 1 to Count, beeps, and then returns to 
the beginning of the loop. When the value of Count reaches 5, Authorware beeps, 
then exits the loop.

repeat with Count := 1 to 5
Beep()

end repeat

Using a list

You can also set up a repeat loop so that each of the statements in the loop is 
repeated with an element in a list. For example, the following repeat loop adds the 
values in List together. The value of X at the end is 60.

List := [10,20,30]
Total := 0
repeat with X in List

Total := Total + X
end repeat

Instead of using a counter, the repeat loop uses the number of elements in the list 
to determine how many times to repeat the loop.

Using a condition

You can also use a repeat loop to repeat an action as long as a condition is true. 
Each time Authorware repeats the loop, it checks the condition. When the 
condition changes, Authorware exits the loop.

For example, the following statements find an empty line in the string 
TestString:

LineNumber := 1
repeat while GetLine(TestString,LineNumber)<>""

LineNumber := LineNumber + 1
end repeat
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Authorware first sets the value of the variable LineNumber to 1. It then gets the 
first line in TestString and checks to make sure it isn’t empty (<>"" means “is 
not equal to empty”). If the line isn’t empty, it adds 1 to LineNumber, then returns 
to the top of the loop and starts over.

Scripting—step-by-step procedures

Xtras
The multimedia features of Authorware take creativity in many directions. As you 
think of new uses for Authorware, you may want to add features to Authorware 
that aren’t part of the standard Authorware application. To give you flexibility, 
Authorware supports the use of Xtras—extensions that add new capabilities. 

Macromedia produces a few Xtras, such as the Director transitions Xtra and the 
QuickDraw 3D Xtra, but most are produced by independent developers. The 
Authorware CD contains a few Xtras from independent developers, such as the 
Zeus Productions transitions Xtras. For information on other Xtras, visit the 
Authorware Support Center by choosing Help > Support.

What you can do In Authorware Help, see

Use a variable Using a variable

Create a custom variable Creating a variable

Refer to a variable’s value at 
a specific icon

Variable values at a specific icon

Create an expression Expressions and operators

Use numbers in expressions Using numbers in an expression

Use text in an expression Using character strings in an expression

Use constants in an expression Using constants in an expression

Use operators in an expression Using operators in an expression

Use system functions System functions

Use custom functions Custom functions in DLLs

Use the functions in a scripting Xtra Xtras

Use DLLs Using a DLL custom function, “Custom 
functions in DLLs” on page 320
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Types of Xtras
There are five types of Xtras in Authorware.

Transition Xtras create special effects when Authorware displays or erases graphics. 
For example, you can dissolve from one graphic to another or have one page slide 
over another. Transition Xtras supplement Authorware built-in transitions and are 
listed along with the built-in transitions in the Transitions dialog box. The 
Director transitions as well as transitions from g/matter and Zeus Productions are 
installed with Authorware. For more information, see “Using transitions for 
special effects” on page 300.

Sprite Xtras add functional elements to the Presentation window. For example, 
use the QuickDraw 3D Xtra to display a 3D object that users can rotate, resize, 
and interact with in other ways. With the Macromedia Control Xtra for ActiveX, 
you can add a wide variety of ActiveX controls—such as Macromedia Flash 
animations, interactive charts, HTML browser windows, and pop-up menus. For 
more information, see “Sprite Xtras” on page 328.

Scripting Xtras provide custom functions you can use just like Authorware built-in 
system functions. For example, Yamaha’s MidXtra, available from the Authorware 
Support Center, contains functions you can use to control input and output from 
MIDI devices. For more information, see “Scripting Xtras” on page 332.

MIX, service, and viewer Xtras provide core components of Authorware 
functionality; you’ll find many of them in the Xtras folder. They’re installed at the 
same time you install Authorware so that you can use them during development.

Tool Xtras provide you with additional functionality. They appear on the 
Authorware Xtra menu. For example, the Convert WAV to SWA Xtra is a tool 
Xtra that converts WAV files to SWA files.

Sprite Xtras
A sprite is a functional element such as a 3D object, a Macromedia Flash 
animation, an HTML browser window, or a pop-up menu. Sprite Xtras make it 
possible to incorporate such sprites into an Authorware piece.

When you place a sprite Xtra file in the Xtras folder and then start Authorware, 
the Xtra file adds a command to the Insert menu. For example, the QuickDraw 
3D Xtra adds the command ThreeD to the Insert menu.

Remember that an Xtra file can contain more than one Xtra. So the command the 
Xtra adds to the Insert menu has a submenu that lists all the Xtras in the Xtra file. 
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To incorporate a sprite into an Authorware piece, position the Paste Hand on the 
flowline where you want the sprite to appear, then choose the Xtra you want from 
the submenu it’s on. Authorware inserts a sprite icon on the flowline. (Some Xtras 
first display a dialog box that lets you choose the sprite you want.) When you run 
the piece, the sprite appears in the Presentation window.

Sprite icon properties

Like all icons, sprite icons have properties that you can set in the icon’s Properties 
dialog box.

The general properties of a sprite icon—which all sprite icons share—are similar 
to those of a display icon: where it’s positioned in the Presentation window, 
whether users can move it, the transition you’ve applied to it, and so on. For more 
information about the general properties of a sprite icon, see “Sprite properties” 
on page 330. 

Sprite properties, events, and methods
In addition to the general properties that all sprite icons share, each sprite icon can 
also have a set of unique features. Those features fall into three categories: 
properties, events, and methods. Not all sprite icons have features in all three 
categories. For example, a QuickDraw 3D sprite icon has properties but neither 
events nor methods.

Click the Options button in the Properties dialog box to see the properties, 
events, and methods available for a sprite icon. The appearance of the options 
dialog boxes varies considerably. ActiveX controls have their properties, events, 
and methods organized on separate tabs.

The QuickDraw 3D sprite icon—because it has only properties—has separate 
tabs devoted to different types of properties.
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Details about properties, events, and methods

For specific information about the properties, events, and methods available for a 
sprite Xtra, check the documentation that the developer has provided. The 
documentation may be available through the help system (click the Help button 
in the sprite icon’s options dialog box to display it), or it may be a Read Me file.

Sprite properties

Properties are characteristics or values. For example, the QuickDraw 3D sprite 
icon has dozens of properties that affect the rotation and position of the model, 
how it’s rendered to the screen, the direction and quality of the lighting, and the 
position and orientation of the camera.

Properties can affect things other than a sprite’s appearance. For example, the 
QuickDraw 3D sprite has properties that control the user’s ability to manipulate 
the model. A button sprite might have a property that determines whether it 
works like a push button or a radio button.

In some cases, both a sprite icon and the sprite it displays in the Presentation 
window have properties. For example, the properties of the QuickDraw 3D sprite 
icon act as defaults for the properties of the sprite itself. You can, however, change 
the properties of the sprite directly—using the SetSpriteProperty function—
without changing the properties of the sprite icon.

Authorware has four functions you can use to manipulate sprite icons and 
sprite properties.

When you’re working with ActiveX controls, use the GetSpriteProperty and 
SetSpriteProperty functions.

Sprite events

Events are exactly what they sound like: things that happen. Some events are 
produced by users. For example, the Microsoft Calendar control tracks where a 
user clicks on the calendar. Other events are produced by a sprite on its own. The 
Microsoft Web Browser control, for example, sends an event when a download 
begins and another when the download is complete. Sprites that produce events 
are called senders.

Function Description

GetIconProperty Gets the value of the asset property of the sprite icon.

GetSpriteProperty Returns the value of the property for a sprite.

SetIconProperty Sets the value of the property for the sprite icon’s asset.

SetSpriteProperty Sets the value of the property for the sprite currently 
displayed by a sprite icon.
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Use the event response type to select a sender, to track the event you want to 
respond to, and to set up Authorware to respond when it happens. There’s also a 
set of variables and functions you can use to manage events. 

Sprite methods

Methods are similar to custom functions. They let you perform some action to 
or through a sprite or a sprite icon. For example, use the GoBack and GoForward 
methods in the Microsoft Web Browser control to navigate through the pages of 
a Web site.

The primary difference between a method and a custom function is that you can’t 
use a method directly in a Calculation window. Instead, use the CallIcon 
function to call a method associated with a sprite icon or the CallSprite 
function to call a method associated with a sprite. (For information about which 
function is appropriate for the method you want to use, check the documentation 
that came with the Xtra.)

For example, to use the GoBack method, set up a statement like this in a 
Calculation window:

CallSprite(IconID@"Web Browser",#GoBack).

When you’re working with ActiveX controls, always use CallSprite.

For more information about the CallIcon and CallSprite functions, see System 
Functions in Authorware Help.

Variable Description

EventLastMatched Contains a property list for the Xtra event matched at the 
last event response.

EventQueue Contains a list of all pending unprocessed external events 
sent by Xtras in order of arrival.

EventsSuspended If true, prevents all event responses from interrupting the 
current flow and saves all events in the variable 
EventQueue.

GlobalTempo Contains the rate at which sprite Xtras receive step events.

FlushEventQueue Discards all pending events from the event queue.

SendEventReply Sends a reply to an event sent by an Xtra.
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Scripting Xtras
Scripting Xtras are packages of custom functions. They’re a way of incorporating 
functionality into an Authorware piece that Authorware can’t provide on its own. 
For example, the Yamaha MidXtra lets you control MIDI devices, which you can’t 
do with any of the functions that are built into Authorware.

When you place a scripting Xtra file in the Xtras folder and start Authorware, 
Authorware adds a category for the Xtra to the Functions dialog box.

Selecting the category displays a list of the functions contained in the Xtra. The 
syntax and a description of the function that’s selected.

You can then select the function you want to use and paste it into a 
calculation window.  

Global functions, parent objects, and child 
objects
Global functions are indistinguishable from Authorware system functions. You set 
them up and use them the same way. For example, the FileIO Xtra’s 
GetOSDirectory function—which gets the path to the Windows directory—
is as straightforward as using the Authorware GetLine function.

Parent objects are analogous to the icons on the icon palette. Each has some well-
defined task like displaying images or playing digital movies. When you drag an 
icon to the flowline, you’re creating a child of the parent icon. The child icon is an 
instance of the parent, with its own unique attributes and behaviors: For example, 
it plays a specific digital movie at a specific frame and at a specific rate. Likewise, a 
child object is a self-contained, independent instance of a parent object.

Using parent and child objects

The tasks that a parent object can perform are defined by its methods. (A method, 
you’ll remember, is another name for a custom function.) The MidXtra can, for 
example, start, stop, and loop sounds, change harmonics, add reverb, and so on. 
But just as a specific instance of the sound icon on the flowline plays a sound file, 
a child object—not its parent—provides the specific instance of a method that 
you use to perform a specific task.

Using parent and child object methods is different from using system functions. 
You first need to use the Authorware NewObject function to create and name a 
child object before you can use a child object method to perform a specific task. 
(A parent object, on the other hand, is created automatically by the scripting Xtra; 
you can’t create more of them.)
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In the following example, the NewObject function creates a new instance of 
the MidXtra (the parent object containing the MIDI methods) and names 
it Intro Music:

Intro Music:= NewObject("MidXtra")

Once you’ve created the child object, use the Authorware CallObject function to 
call the method you want to use. In the following example, CallObject calls the 
MIDIload method to load the sound file named Intro.aif:

CallObject(Intro Music,"MIDIload","Intro.aif")

Just as you need to create a child object before you can use it, you need to use the 
DeleteObject function to get rid of it when you’re finished with it.

In most cases you need to create a child object to use a method, but a few methods 
are exclusive to the parent object. For example, the FileIO Xtra’s version method 
returns the version number of the Xtra.

To call a parent object method, use the Authorware CallParentObject function. 
For example, to call the FileIO Xtra’s version method, use this statement:

Xtra Version:= CallParentObject("fileio",#version)

CallParentObject calls the version method, which gets the version number of 
the FileIO Xtra. CallParentObject then puts the version number in the custom 
variable Xtra Version.

Note: Parent and child objects in scripting Xtras arethe Authorware implementation of 
object oriented programming. If you’re interested in finding out more about how parent 
and child objects work, take a look at one of the many books available on object oriented 
programming.

Functions for using parent and child object methods

The following table lists the functions available for working with parent and child 
object methods, along with a brief description of each one. For more information 
about them, see System functions in Authorware Help.

Function Description

CallObject Calls a child object method.

CallParentObject Calls a parent object method.

DeleteObject Deletes a child object created by NewObject.

NewObject Creates a child object.
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Identifying global functions and parent and child methods

Global functions and parent and child methods all look the same when they’re 
listed in the Functions dialog box. To figure out whether an item is a global 
function, a parent method, or a child method, select it and look at the syntax that 
appears in the Description field:

• The syntax of a child method begins with CallObject.

• The syntax of a parent method begins with CallParentObject.

• The syntax of a global function looks just like the syntax of a system function.

ActiveX controls
ActiveX is Microsoft’s new name for its OLE (object linking and embedding) 
technology. The idea behind the technology is to allow one application (say, a 
spreadsheet) to plug into another application (say, a word processor) so that the 
information you produce in one can be an integral part of the information you 
produce in the other. The result could be, for example, a spreadsheet embedded in 
a business plan.

While ActiveX is essentially the same technology as OLE, its intent is slightly 
different. ActiveX is a streamlined and simplified approach aimed at allowing 
developers to produce small applications, known as controls, with a highly 
focused purpose. For example, the Flash control for ActiveX control is designed 
just to play Flash animations, not to create them.

The Macromedia Control Xtra for ActiveX is an invaluable addition to 
Authorware. Developers have created thousands of ActiveX controls, and the uses 
of the Xtra are as limitless as the variety of ActiveX controls available. Here are just 
a few examples:

• Use the Microsoft Web Browser control to let users explore the Internet.

• Create complete Windows applications with MicroHelp’s extensive library of 
Windows controls.

• Use the Microsoft Calendar control as an interface to a project log.

• Let users explore virtual worlds with the InterVista VRML control.
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ActiveX controls—step-by-step procedures

The XMLParser Xtra
The  XML Parser Xtra allows Authorware pieces to read, parse, and make use of 
the contents of XML documents. To use the XMLParser Xtra, you must know 
something about the structure and content of the documents you are parsing. 

Note: Because some of the functionality has been changed, the XMLParser Xtra for 
Authorware is a different product from the XMLParser Xtra for Director. They cannot be 
interchanged.

About XML

Although XML and HTML appear similar in some ways, it is only their syntax 
that makes them look similar. HTML is a language for page layout, while XML is 
a language for the representation of data that is used to store and transmit text 
data. XML is a specification for how data gets marked up; it does not specify 
which names are used to tag elements. So for each application, the programmer 
can develop whatever structure and elements are appropriate. Unlike HTML, 
XML says nothing about how it should be displayed (or rendered). Although MS 
IE5+ has a plug-in to display an XML file, it merely shows the hierarchy itself in a 
TreeView format. 

One of the main differences between the languages is that XML must have both 
starting and ending tags for all elements: 

<tag attr1="blah">
  content
</tag>

What you can do In Authorware Help, see

Use an ActiveX control Using an ActiveX control

Install an ActiveX control Installing ActiveX controls

Install the Macromedia Control Xtra 
for ActiveX

Installing the Macromedia Control Xtra 
for ActiveX

Install the system files users need to run 
ActiveX

Installing ActiveX system files

Install and register an ActiveX control Installing and registering the ActiveX 
controls
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For elements that do not contain content, there is an abbreviated syntax called an 
empty element tag:

<tag attr1="blah"/>

XML has become popular because of its simplicity and flexibility. It is also 
self-documenting, because the element names (tags) and attribute names describe 
what is being stored. The redundancy of naming is considered a small price to pay 
for the ease of maintaining XML. XML files can easily represent hierarchical 
structures. Also, a given level can contain multiple elements of the same type. 

The earlier technology that XML can be best compared with is INI files. In fact, 
most modern applications now use XML files to store preference settings rather 
than INI files. See Using the XML Parser Xtra in Authorware Help.
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CHAPTER 10
Tracking Performance and Working 
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with a Learning Management System

When you create a training course, you naturally want to track how well users 
perform and keep a permanent record of their performance. Tracking users’ 
performance has several benefits: 

• You can provide users with feedback as they work through the course. 

• When they finish the course, you can assess how well they’ve done. 

• You can use information about their performance to design a more effective 
training piece. 

Authorware makes tracking performance easy because everything you need is built 
in. When you set up a target response in an interaction, you need only a single 
setting to indicate whether the response is right or wrong. Authorware tracks 
users’ performance automatically—and in some detail—with a wide range of 
built-in variables. It keeps track of how many right and wrong target responses a 
user has made, how many tries the user took to get the right answer, how much 
time it took the user to respond to an interaction, how much time the user spent 
in an interaction, how much time remained if there was a time limit on an 
interaction, any objects the user has clicked or moved, and any words or lines the 
user has clicked.

Once you’ve collected the information you want, you can display the information 
on the screen or use it to determine what feedback the user needs. You can use 
Knowledge Track to exchange standard student performance information with a 
learning management system. Or you can use the Authorware built-in 
computer-managed instruction (CMI) functions to custom-tailor the student 
information you exchange with your learning management system. You can also 
use the ODBC capabilities of Authorware to save the information in a database 
such as Access.
337



Using Assessment Knowledge Objects
You may also want to use the Authorware Assessment Knowledge Objects to use a 
wizard procedure to set up your assessments. For a list of the Assessment 
Knowledge Objects and how they are used, see “Assessment Knowledge Objects” 
on page 52.

QTI Assessment Knowledge Objects

Several Assessment Question Knowledge Objects have been updated to allow for 
import and export of question content stored in XML files that conform to the 
IMS QTI (Question Test Interoperability) version 1.1 standard. The following 
Assessment Knowledge Objects have been updated:

• Hot Spot Question

• Hot Object Question 

• True-False Question

• Single Choice Question

• Multiple Choice Question

For details, see How to set up Assessment Knowledge Objects for QTI in 
Authorware Help.

The IMS QTI standard is still evolving. For more information about the standard, 
refer to http://www.imsglobal.org.

Also check the Macromedia Authorware Support site at www.macromedia.com/
support/authorware for updates and any late-breaking information about the IMS 
QTI support in these Knowledge Objects.

SCO Metadata Editor
The SCO Metadata Editor provides the functionality needed to meet Advanced 
Distributed Learning (ADL) Shareable Content Object Reference Model 
(SCORM) requirements to create an XML file with content metadata. 

For more information about the Metadata Editor, choose Commands > SCO 
Metadata Editor and press F1 to get specific help about how the editor is used.
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Guidelines for tracking and recording 
performance
As you plan what you want to track in a project and how you want to record 
performance, here are some things to think about:

• What activities do you need to track to assess a user’s performance?

“Tracking performance” on page 340 describes the activities you usually need 
to monitor to assess performance. This section also lists all the variables 
available in Authorware for tracking what a user is doing.

• How are you going to use the information you gather? Are you going to use it 
to provide feedback? Display it on the screen? Save it permanently in a text file 
or database?

For details, see Providing Feedback and Tracking and recording performance—
step-by-step procedures in Authorware Help.

• Where are you going to store performance information? On the user’s 
computer? On a local server? On a Web server across the Internet?

For more information, see “Recording performance” on page 345.

• Do you want to store the information you’ve gathered in a database?

For details, see “Connecting with databases” on page 356.

Marking a response right or wrong
A response—clicking a Help button, for example, or entering one’s name—
is neither right nor wrong. If you want Authorware to track a user’s performance, 
you need to mark the target responses in an interaction as correct or incorrect.

An interaction that contains a target response you’ve marked is called a 
judged interaction.

Use the Status setting 
to mark a response as 
right or wrong.
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When you choose Correct Response or Wrong Response, a symbol appears next to 
the result icon’s title to indicate that the response has been judged. 

A plus sign (+) indicates a correct answer; a minus sign (–) indicates a wrong answer.

You can mark more than one target response in an interaction correct. For 
example, if you set up an interaction in which students drag certain animals into 
an environment to create a balanced ecosystem, there might be half a dozen 
correct answers.

Marking a target response in an interaction as either right or wrong only instructs 
Authorware to keep track of how many correct target responses and how many 
wrong target responses a user matches in a single session. Authorware 
automatically stores that information in a special set of system variables. You still 
need to create appropriate feedback for the target response and select the exit 
branching option that you want to use.

Tracking performance
Authorware uses system variables to automatically track a wide range of 
information about a user’s performance. Here are some specific examples of how 
variables can provide a rich learning environment for the people you’re training. 

Tracking response time

The system variable ResponseTime tracks the length of time it takes a user to 
respond to an interaction. This variable is useful for limiting the amount of time a 
user has to respond in an interaction. For example, you could set up a calculation 
that automatically displays a warning if ResponseTime is greater than 15 seconds, 
and another calculation that exits the interaction automatically when 
ResponseTime reaches 30 seconds.

Correct answer

Wrong answer
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The value of ResponseTime is set to 0 each time a user responds, so it isn’t a good 
choice if you want to limit the total time a user spends in an interaction but also 
give the user more than one try. In that case use the system variable 
TimeInInteraction.

Tracking time spent in an interaction

The system variable TimeInInteraction tracks the total time a user spends in 
an interaction. The time is measured from the moment Authorware enters the 
interaction until the moment it exits the interaction. You can use 
TimeInInteraction to limit the amount of time users have in an interaction 
when you’re giving them more than one try or when the correct answer is made 
up of more than one response. 

Tracking time spent in a section

You can use the system variable SystemSeconds to calculate how long a user has 
spent in a section of a course. SystemSeconds contains the number of seconds 
that have elapsed since a user turned on or restarted the computer. If you use a 
custom variable to record the value of SystemSeconds at the beginning of the 
section, you can subtract that value from the value of SystemSeconds at the end 
of the section to figure out how long the user has spent in the section. 

This variable can be useful in determining how quickly a student learns. You 
might use the result to adjust the difficulty of a course to suit the learning speed 
of different students. 

You can also use SystemSeconds to limit the amount of time a user has to 
complete a section.

Tracking time remaining

The system variable TimeRemaining keeps track of how much time is left in an 
interaction that has a time limit. Use it to give users feedback at appropriate points 
as time runs out. 

Tracking the number of tries 

The system variable Tries keeps track of the number of times a user responds 
to a particular interaction. You might give increasingly specific hints as the value 
gets bigger.
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Tracking the choices made

You can use the system variable ChoicesMatched to keep track of how many 
different responses a user has tried in an interaction. This is a good diagnostic tool 
for determining how well a user knows the material and it’s also useful for 
tailoring feedback to a user who’s having particular trouble with a question.

Identifying objects clicked, moved, or matched

The ObjectClicked, ObjectMatched, and ObjectMoved system variables keep 
track of objects that a user has interacted with.

When a user clicks an object in the Presentation window, Authorware puts the 
name of the display icon that contains the object in the system variable 
ObjectClicked. Use ObjectClicked to give users feedback before they move the 
selected object. For instance, display a message such as “Now drag the part to its 
proper position.”

ObjectMatched contains the name of the last object a user moved to the correct 
target area in an interaction. ObjectMoved contains the name of the last object a 
user moved, whether or not it was moved to the correct target area. You can use 
both in a target area interaction where you’ve selected the Match Any Object 
option to accept any object that a user drags to the target area. For example, use 
ObjectMatched to check which object the user moved into the target area, and 
then provide appropriate feedback. Use ObjectMoved to handle cases in which the 
user moved an object but didn’t move it into the target area.

Identifying the word or line a user clicks

The system variables LineClicked and WordClicked keep track of text a user 
has clicked.

When a user clicks a line in a list or a block of text, LineClicked contains the 
number that corresponds to the line’s position in the list or text block. When 
a user clicks a word that’s part of a text object, Authorware puts the word 
in WordClicked. 

You could use both LineClicked and WordClicked to test users’ ability to 
understand the readout on the screen of a monitoring device. For example, you 
could ask them to click the line that displays the pressure in a vessel and the word 
that indicates the status of a relief valve.

Note: The system variable HotTextClicked also identifies a word that a user has clicked. 
But it’s designed to work with words you’ve set up as hypertext links—words that, when 
clicked, take a user from one part of an Authorware piece to another. For more information, 
see “Navigating with hypertext” on page 295.
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Other variables for tracking

There are several other variables you can use to track performance. They’re 
explained in detail in System Variables in Authorware Help.  

Variable Description

AllCorrectMatched TRUE if a user has matched all the target responses you’ve 
marked as correct.

ChoiceNumber Contains the number of the last response type symbol 
whose target response the user matched.

ChoicesMatched Contains the number of different response type symbols 
whose target response the user matched.

CorrectChoicesMatched
WrongChoicesMatched

Contains the number of different target responses a user 
has matched in an interaction.

FirstTryCorrect*
FirstTryWrong*

Contains the total number of judged interactions that a 
user answered right or wrong on the first try.

JudgedInteractions* Contains the total number of judged interactions a user 
encountered in a file.

JudgedResponses* Contains the total number of responses a user made to all 
the judged interactions encountered in a file.

LastLineClicked Contains the number of the line a user clicked in a 
text object.

LastObjectClicked Contains the title of the display icon that contains the last 
object a user clicked.

LastParagraphClicked Contains the paragraph number of the last paragraph a 
user has clicked.

LastWordClicked Contains the last word a user clicked in a text object.

MatchedEver TRUE if a user has previously matched the same target 
response the user has just matched.

MatchedIconTitle Contains the title of the last response type symbol whose 
target response a user has matched.

ParagraphClicked Contains the number of the paragraph a user clicked in a 
text object.

PercentCorrect
PercentWrong

Contains the percentage of all the judged responses that a 
user answered right or wrong.

PreviousMatch@¬
Icontitle

TRUE if the response type symbol named in IconTitle was 
the last one matched by a user.

ResponseStatus Contains the status of the first judged response type 
symbol that a user matched in an interaction.
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Providing feedback
Feedback is an important part of an effective course. One of the easiest ways to 
provide feedback—and one of the simplest ways to use variables—is to display the 
value of a variable on the screen.

Feedback lets users track their own performance and see their strengths and 
weaknesses. For those sections of the course that build on what users learned in 
previous sections, a performance summary can help users to prepare. For example, 
knowing that they did well in one segment prepares and motivates users for 
working with additional information.

To provide a user with a performance summary, display the value of variables 
such as these:

• PercentCorrect, PercentWrong

• TotalCorrect, TotalWrong

• FirstTryCorrect, FirstTryWrong

• JudgedInteractions

• JudgedResponses

Say that at the end of a course you want to display a summary that looks like this:

TimesMatched Contains the number of times a user matched the current 
response type symbol during the current session.

TotalCorrect*
TotalWrong*

Contains the total number of right or wrong responses a user 
made to all the judged interactions encountered in a file.

Variable Description
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To create this summary, set up a text object like this:

Recording performance
Authorware keeps track of information about a user’s performance automatically, 
and it also collects information that you ask the user to enter, such as the 
user’s name or password. However, Authorware doesn’t store this information 
indefinitely, and it doesn’t save the information permanently before it quits 
unless you tell it to. 

It’s good practice to store information, as soon as Authorware has collected it, 
in a custom variable where it won’t be overwritten as Authorware continues to 
gather information.

If you want to keep the information permanently, save it in an external file—
a data file saved on a disk.

Storing information in Authorware

Whenever a user enters something in a text-entry field, Authorware automatically 
stores the information. It stores text in the system variable EntryText and 
numerical values in the system variables NumEntry, NumEntry2, and NumEntry3. 
But because Authorware stores the information automatically, it also automatically 
overwrites the information as soon as the user enters new information.

Suppose you ask a user to enter her name and then her password. When she enters 
her name, Authorware stores it in EntryText. Then, as soon as she enters her 
password, Authorware stores it in EntryText, overwriting her name. Fortunately 
it’s very easy to transfer the user’s name to a different variable before she enters her 
password. You can do that with a simple assignment statement, in this case:

UserName := EntryText

To keep a permanent record of information a user has entered—rather than just 
storing it temporarily while Authorware is running—save the information in an 
external file or database. See “Saving information in an external file” on page 346 
and “Connecting with databases” on page 356.
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Saving information in an external file

You can save information that users have entered by transferring it from the 
variable where Authorware has stored it to an external file. 

Usually you’ll want to use a variable to name the file where you’re storing user 
information so you can change the file name for each user. One of the simplest 
approaches is to ask a user to enter his or her name at the beginning of a piece, 
store the name in the system variable UserName, and then use UserName as the 
name of the file where you store information about a user’s performance. For more 
information, see the UserName function.

Saving information on a local hard disk or server

To save information on the user’s hard disk or on a local server, use the 
Authorware WriteExtFile and AppendExtFile functions. It’s best to save files 
either in the records folder or in the folder containing the Authorware file the user 
is running. Authorware creates the records folder automatically to give you a 
convenient place to save information. The records folder is named A6w_data, and 
it’s located inside the Windows or Winnt folder, depending on which operating 
system you are using. You can change the location of the records folder with the 
JumpFile and JumpFileReturn functions. You can also set the location of the 
records folder in the Aw6.ini file.

There’s a good reason to save files either in the records folder or in the folder 
containing the Authorware file the user is running: Authorware keeps track of the 
paths to those folders and stores them in the system variables RecordsLocation 
and FileLocation. When you use either variable, all you need to specify is the 
location inside the records folder or the Authorware file folder where you want to 
save a file—Authorware fills in the rest of the path automatically. 

Saving information over the Internet

Transferring information over the Internet—or over a corporate, government, or 
educational intranet—differs in two significant ways from saving information on 
a user’s hard disk or on a local server:

• You can’t use the Authorware WriteExtFile and AppendExtFile functions. 
Instead you use the equivalent functions FtpStore and FtpAppend that are 
part of the FTP UCD.

• You can transfer information with a Web-packaged piece only if a user has 
chosen trusting mode. Users can choose nontrusting mode to protect their 
system from Web-packaged pieces that might read confidential files from their 
hard disk and transmit them back to the server.  
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Managing information with a database

An external file and the Authorware records folder are fine for simple record 
keeping, but if you want to manage information with any sophistication, 
you need a database.

For example, if you’re creating training for a company that requires employees to 
complete regular training courses, you probably need to set up a system that 
constantly updates the records at the end of courses and provides an accurate list 
of who has completed which courses. 

Tracking and recording performance—step-
by-step procedures

What you can do In  Authorware Help, see

Mark a response right or wrong Marking a response right or wrong

Display a user’s score on the screen Displaying a user’s score

Store information a user enters Recording information a user enters

Save information a user enters permanently Saving user information

Store text and values Storing text and values

Use WriteExtFile to save information Setting up WriteExtFile to save user 
information

Set the path for the file you’re saving 
information in

Setting up WriteExtFile to save user 
information

Name the file you’re saving information in Setting up WriteExtFile to save user 
information

Save the content of a variable in a file Setting up WriteExtFile to save user 
information

Retrieve information from a file Retrieving information

Display information from a file on the screen Retrieving information

Use ReadExtFile to retrieve 
information from a file

Retrieving information
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Using Knowledge Track to set up a course
The best way to keep track of student performance is to use an AICC-compliant 
computer-managed instruction (CMI) system. This type of management server is 
also known as a learning management system (LMS).

Authorware makes it easy for you to pass student performance data to a CMI 
system with:

• Knowledge Track settings for files, interactions, and responses

• A comprehensive set of tracking variables and functions

Use the Knowledge Track settings in the File Properties, Interaction Properties, 
and Response Properties dialog boxes to track basic student performance data. If 
you need to do more sophisticated tracking, use the Authorware learning 
management system variables and functions to customize the way Authorware 
gathers data and passes it to your learning management system.

Knowledge Track settings
The Knowledge Track settings in the File Properties, Interaction Properties, and 
Response Properties dialog boxes make it easy to gather basic student performance 
data such as scores, the amount of time students spend in both individual 
interactions and entire courses, and the specific answers each student gives (not 
just whether a student’s answers are right or wrong).

The following tables provide an overview of the information you can gather with 
the Knowledge Track settings.

CMI tab (File Properties dialog box)

Setting What it does

All Interactions Turns on tracking for all the interactions in the file.

Score Tracks and adds up a student’s score.

Time Tracks how long a student takes to complete all the interactions 
in the file.

Timeout Tracks a student’s inactivity. If too long a period passes during 
which a student does nothing, Authorware takes special action.

Logout Upon Exit Logs students out of the learning management system when they 
quit Authorware.
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CMI tab (Interaction Properties dialog box)

In addition to the information you enter in the dialog box, Authorware sends the 
date and time the student exited the interaction and the number of seconds the 
student spent in the interaction. Authorware also sends whether or not the 
student answered correctly and the answer the student chose or entered.

Response Properties dialog box

CMI variables and functions
The Authorware computer-managed instruction (CMI) variables and functions 
are listed in the following tables.

Variables

For detailed information about the following variables see System variables 
overview in Authorware Help.

Setting What it does

Interaction Turns on tracking for the interaction (as long as All Interactions is 
checked in the File Properties dialog box).

Interaction ID Specifies the interactions’s unique identifier in the learning 
management system. 

Objective ID Specifies the objective ID the interaction is tied to in the learning 
management system.

Weight Indicates the relative importance of the interaction.

Type Indicates the type of interaction, multiple choice or fill-in.

Setting What it does

Score Sets the value associated with the response. 

Variable Description

CMIAttemptCount Contains the number of times a student has visited 
the activity.

CMIAttempts Contains a list of property lists to store attempt 
information.

CMICompleted* Indicates whether a student has completed as activity.
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CMIConfig Contains configuration information entered in the learning 
management system.

CMICourseID Contains the course number entered in the learning 
management system.

CMIData* Exchanges miscellaneous activity data with the learning 
management system.

CMIFailed* Indicates whether a student has failed an activity.

CMILoggedOut* Logs the student out from the learning management 
system immediately after exiting the activity.

CMIMasteryScore Contains the required mastery score for the activity.

CMIObjCount Contains the number of objectives related to the activity.

CMIObjectives Contains a list of property lists to store objective 
information.

CMIPassed* Indicates whether the student has passed the activity.

CMIPath Contains the full path to the private data directory for 
the student.

CMIReadComplete* Deletes temporary data files immediately after the data is 
transferred between the learning management system and 
Authorware.

CMIScore* Contains the score for the activity. 

CMIStarted* Indicates whether the student has started the activity.

CMIStatus* Indicates the status of the activity, “Completed,” 
“Incomplete,” or “Not Attempted.”

CMITime* Contains the number of seconds a student has spent on 
the activity.

CMITimedOut* Logs the student out of the learning management system 
if too much inactive time has passed during the activity.

CMITrackAll
Interactions*

Setting CMITrackAllInteractions to TRUE allows a learning 
management system to track the interactions in a file. 

CMITrackInteraction* Applies to a specific interaction icon.

CMIUserID Contains the student’s unique identification string.

CMIUserName Contains the user name that the student used to log in to 
the learning management system.

TotalScore Contains the sum of the scores of all the student’s 
responses.

Variable Description
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Functions

For detailed information about the following functions see System functions 
overview in Authorware Help.

Function Description

CMIAddComment Adds an activity-specific comment to the CMI course. 

CMIAddInteraction Transfers specific information about an interaction to the 
learning management system.

CMIAddInteractionEx Transfers specific custom data about an interaction to the 
learning management system.

CMIFinish Sends all finalized tracking data to the server.  Sends 
ExitAU.

CMIFlush Sends all current tracking data to the server. 

CMIGetAICCVersion Returns the current AICC version. The version can be set to any 
string. For details, see “CMISetAICCVersion” on page 353.

CMIGetAttempt Returns from the learning management system the number 
of times the student has attempted the activity. 

CMIGetAttemptScore Returns the score for an activity attempt given an attempt 
number between 1 and the value of the CMIAttemptCount.

CMIGetAttemptStatus Returns a status for an attempt given an attempt 
number between 1 and the value of the CMIAttemptCount 
system variable.

CMIGetConfig Returns activity configuration data specified in the learning 
management system. 

CMIGetCourseID Returns the course number specified in the learning 
management system.

CMIGetCustomField Returns the value stored in the custom field indicated by 
the table and field names.

CMIGetData Returns activity data specified in the learning 
management system. 

CMIGetDemographics Returns the student demographics information indicated 
by the specified field name. 

CMIGetLastError Use to determine whether an error occurred in the last 
CMI operation.

CMIGetLocation Returns from the learning management system the last place 
the user left off in the activity. 

CMIGetMasteryScore Returns the required mastery score for the activity as set in 
the learning management system. 
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CMIGetObjCount Returns the number of objectives related to the 
current activity. 

CMIGetObjID Returns the unique identifier for an activity objective 
specified by an index number between zero and the value of 
the CMIObjCount system variable. 

CMIGetObjScore Returns the current score for the activity objective specified 
by an index number between 1 and the value of the 
CMIObjCount system variable. 

CMIGetObjStatus Returns the status of the activity objective specified by an 
index number between 1 and the value of the CMIObjCount 
system variable. 

CMIGetPath Returns from the learning management system the path to 
the private student directory. 

CMIGetScore Returns from the learning management system the numeric 
score for the activity. 

CMIGetStatus Returns from the learning management system the status of 
the current activity as the user last left it. 

CMIGetTime Returns from the learning management system the total time 
in seconds that the user has spent in the activity. 

CMIGetUserID Returns the student's unique identification string as set in the 
learning management system. 

CMIGetUserName Returns the user name that the student used to log in to the 
learning management system. 

CMIInitialize Allows the learning management system to perform any 
initialization necessary before running the activity. 

CMIIsAttempt¬
Completed

Returns whether the student completed the specified 
attempt. 

CMIIsAttemptFailed Returns whether the student failed the specified attempt. 

CMIIsAttemptPassed Returns whether the student passed the specified attempt. 

CMIIsAttemptStarted Returns whether an attempt is started given an attempt 
number between 1 and the value of the CMIAttemptCount 
system variable. 

CMIIsCompleted Returns TRUE if the learning management system indicates 
that the current activity is complete, FALSE otherwise. 

CMIIsFailed Determines whether or not the student failed the 
current activity. 

CMIIsObjCompleted Returns whether an objective is completed given an 
objective index between 1 and the value of the CMIObjCount 
system variable. 

Function Description
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CMIIsObjFailed Returns whether an objective is failed given an objective 
index between 1 and the value of the CMIObjCount 
system variable. 

CMIIsObjPassed Returns whether an objective is passed given an objective 
index between 1 and the value of the CMIObjCount 
system variable. 

CMIIsObjStarted Returns whether an objective is started given an objective 
index between 1 and the value of the CMIObjCount 
system variable. 

CMIIsPassed Determines whether or not the student passed the 
current activity. 

CMIIsStarted Returns TRUE if the learning management system 
indicates that student has started but not completed 
the current activity. 

CMILogin Logs the student specified by the sign-on name and 
password into the CMI server. May not work with all Learning 
Management Systems.

CMILogout Logs the student out of the current activity. May not work 
with all Learning Management Systems.

CMIReadComplete Should be called after obtaining all the information from the 
learning management system.

CMISetAICCVersion Sets the client AICC version number for compatibility with 
different CMI systems. The version can be set to any string. 
The default is version 2.0.

CMISetCompleted Sets the current activity as completed. 

CMISetCustomField Sets a value in the custom field indicated by the table and 
field names. 

CMISetData Passes miscellaneous activity data to the learning 
management system. 

CMISetFailed Sets the current activity as failed. 

CMISetLocation Sets where the student last left off in the current activity. 
Accepts up to 255 characters.

CMISetLoggedOut Sets the current activity as logged out.

CMISetObj Transfers specific information about an objective to the 
learning management system given an objective index 
between 1 and the value of the CMIObjCount. 

CMISetPassed Sets the current activity as passed. 

CMISetScore Passes the numeric activity score to the learning 
management system. 

Function Description
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Learning Management System (LMS) 
Examples
In the Authorware program file Goodies folder is a another folder called LMS 
examples. These examples show you how you can use Authorware to work with an 
LMS product.

These examples are intended only to provide sample code that may be copied and 
modified. Some changes may be required to work with any given LMS product. 
There are many comments within the examples to help you better understand them.

There are four types of Authorware examples in this folder that demonstrate 
tracking over the Web. Three of these are in the AICC folder and one is in the  
ADL folder.

AICC

All of the AICC examples should be published to the Web using the Data 
Tracking publishing template that is included with Authorware 6. For detailed 
information on the AICC, visit the AICC website at http://www.aicc.org.

AICC/CMI

The AICC /CMI folder contains an example that uses the CMI functions that are 
built-in to Authorware. These functions are mapped to AICC data elements. The 
functions automatically detect when the file is running as a Web-based or file/
LAN-based piece and switch to the appropriate AICC communication means 
(either INI-like text files or HTTP POST commands).

The other two examples in the AICC folder both use the low-level mechanism of 
HTTP GET’s and PUT’s to send data to the server via AICC HACP and do not 
support LAN-based LMS products.

AICC/POST

The AICC/POST folder contains an example that uses the PostURL function.  
This function only appears in Authorware 4.0.3 or later. PWInt (SMI functions) 
for the Web also requires the Authorware Web Player version 5.2 or later.

CMISetStarted Sets the current activity as started. 

CMISetStatus Passes the current activity status to the learning 
management system. 

CMISetTime Sets the total number of seconds the student has spent 
in the activity. 

CMISetTimedOut Sets the activity as timed out. 

Function Description
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AICC/GET

The AICC/GET folder contains examples that uses ReadExtFile to generate 
HTTP GET requests.  These examples will work with earlier versions of the 
Authorware Web Player and may be helpful for debugging communication with 
some LMS products.

ADL

The ADL sample file should be published using the template named AICC 
API - ADL SCORM. End-users must install this template by copying the 
template file  AICC API - ADL SCORM.htm  from the  ADL/HTML folder 
to the publishing template folder for Authorware.

The default location for the Authorware publishing template folder is:  
C:\Program Files\Macromedia\Authorware 6\HTML.

ADL/Testbed

This is a sample Authorware 6 file that uses the ReadURL function of Authorware 
to communicate with an ADL SCORM compatible LMS. For example, the file 
uses this command to initialize communication:

  ReadURL("javascript:API.LMSInitialize(\"\")", 30)

The sample file relies on the  AICC API - ADL SCORM  publishing template 
which includes JavaScript code to locate the LMS-provided API object. If you 
publish files intended for use with an ADL-type system and do not use this 
template, you will need to include your own code to locate the API object and 
create a handle to it named API.

ADL/HTML

This sample contains a small HTML file that is a publishing template to be used 
with the Authorware 6 one-button publishing feature. Make sure the template file 
AICC API - ADL SCORM.htm is copied to your local Authorware publishing 
template folder, as described above.
Tracking Performance and Working with a Learning Management System 355



Connecting with databases
Combining the interactivity of Authorware with the power and flexibility of a 
database gives users a powerful tool for retrieving and managing data quickly 
and effectively.

Using Authorware, a company that requires employees to complete regular 
training courses could constantly update its records when employees complete an 
online course and provide an accurate list of who has completed which courses. 
For a retail outlet or a group of restaurant owners, Authorware connected to a 
database could support an electronic product kiosk that’s updated daily with 
current information about price and product availability. A referral agency for 
carpenters and plumbers could use Authorware to create a simple interface to its 
listing of members, their specialties, and their current availability. There are many 
ways for Authorware and databases to work together. You’ll probably think of 
many more as you work with them.

Authorware makes connecting with databases relatively simple by using two 
industry standards:

• Open Database Connectivity (ODBC), a common standard for connecting 
to a database

• Structured Query Language (SQL), a standard language for sending commands 
to and receiving information from a database

ODBC enables Authorware to communicate with a variety of commonly used 
databases such as Access, dBase, FoxPro, and Paradox.

To see an example of how the ODBC functions are actually used in an 
Authorware piece, choose Help > Show Me and then launch “Using ODBC.”
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Streaming, Intranets, and the Web

Networks—local area networks (LANs); corporate, government, and educational 
intranets; and the Internet—offer flexible and convenient access to information. They 
provide an efficient and effective way to distribute the kinds of projects you create 
with Authorware, such as interactive multimedia, training applications, human 
resource information, kiosks, hypermedia reference titles, and online magazines.

Take training courses, for example. Authorware and a corporate intranet are the 
ideal combination for developing “distance learning” applications. Anyone who 
has access to the intranet—whether at a company site or by a modem—can work 
through a training course at any time without needing to go anywhere. If the 
course needs updating, you make the changes once, on the server, and everyone 
throughout the company has instant access to the new version. 

Using a local area network is easy: Authorware treats a server attached to the 
network the same as the hard disk of the computer it’s running on. It also provides 
two elegant ways of using intranets and the Internet:

• Streaming technology, which lets you download and run Authorware pieces in 
Netscape Navigator, Internet Explorer, and other compatible browsers

• Internet services, which let you link to external content through uniform 
resource locators (URLs) and give you access to a complete set of file transfer 
protocol (FTP) functions even when you’re not using streaming technology
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Speed
Computers keep getting faster and faster. But no matter how fast a computer can 
process information, the information needs to be in memory before the computer 
can do anything with it. Getting information to the computer and into memory 
over a network takes time. 

There are three basic ways to use Authorware with a network, and network speed 
affects all of them:

• You can run an Authorware piece across a LAN. 

When you launch the piece, your computer loads the Authorware run-time 
application into memory across the network. If the piece itself or the libraries 
it’s linked to are also on the server, Authorware downloads information across 
the network as it needs it.

• You can download a piece across the Internet or an intranet and use 
Authorware Web Player to play it in a Web browser.

The player downloads the segments of the Web-packaged piece and any 
external content across the network as it needs them.

• You can run a piece that’s located on your computer’s hard disk but that’s 
linked to a library or external content that’s elsewhere. 

You can link to a library only across a LAN. You can link to external content 
over a LAN, over an intranet, or over the Internet.

The speed at which you can play a piece across a network, download it, or 
download linked external content always depends on the same things: the speed of 
data transmission across the network and the amount of information being 
transferred. On all types of networks—LANs, intranets, and the Internet—
network speed varies depending on the specific network configuration and the 
amount of activity on the network. 

Intranets that use T1 or T3 servers can be quite fast, but if users are dialing into 
the intranet from a modem, the connection will be only as fast as their modem.

The Internet is typically slower than an intranet, primarily because unless users 
have DSL or other high-speed connections, users dial in at relatively slow 
speeds—28,800 or 33,600 bits per second (bps). At 28,800 bps, a user receives 
only about 2800 data bytes per second. At 33,600 bps, the rate increases to 
approximately 3300 bytes per second. At those speeds, it takes 20 to 30 seconds to 
download a 60K file. If traffic is heavy at the Internet access point or on the 
Internet host, or if there’s network congestion, the rate drops even lower—to as 
low as a few hundred bytes per second. Although 56,000 Kbps and faster modems 
are becoming more common, for now it’s a good idea to assume a file will 
download at a rate of about 1500 bytes per second.
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Streaming technology for the Web
Streaming technology lets you package an Authorware piece especially for the 
Web, download it over the Internet or an intranet, and run it in a compatible 
browser such as Netscape Navigator or Internet Explorer.

Streaming involves the use of two components:

• The publish for Web Player options (part of one-button publishing), which 
you use to prepare the piece and segment it for downloading over the Web. The 
one-button publishing process creates a map file, which tells Authorware Web 
Player what to download, when to download it, and where to put the 
downloaded segments.

• Authorware Web Player, which manages the downloading according to the 
map file and runs the piece.

One of the big advantages of Web-packaging a piece is that it’s divided into 
segments. Authorware Web Player can start running the piece as soon as the first 
segment is downloaded—it doesn’t have to wait for the entire piece. Furthermore, 
the player downloads segments only as they’re needed. This makes it possible to 
produce large applications—20 or 30 MB and larger—that run efficiently and 
continuously. If you design a piece cleverly, users won’t realize that portions of it 
are being downloaded as the piece is running. If you’ve installed Authorware 
Advanced Streamer on a Web server, Authorware Web Player will even attempt to 
download in advance the segments users are most likely to want next.

Using streaming, you can deliver full-fidelity, cross-platform interactive pieces. 
You can deliver interactive multimedia training anywhere in your company, 
tracking user information, offering online help, and exchanging information 
between users and the file server.

You can create a central library of interactive documents for use by employees—
such things as job listings, benefits information, phone directories, and 
performance—support aids-that can be updated at any time.

You can use virtually all the features of Authorware. You can include text, 
graphics, audio, animations, and movies, as well as all response types, data 
tracking, and database management. You can embed your piece within a Web 
page or have it take over the full screen. Your piece can retrieve information from 
the intranet and send information back to the server. You can jump to other URLs 
and make calls to JavaScript from your piece.

The main limitation on just about everything you do is the data transmission speed 
of the intranet that carries your piece. The slower the transmission speed, the less 
ambitious you can be with using multimedia in your piece. For tips on what you can 
do to optimize your piece for delivery over low bandwidth, see “Tips for optimizing 
Web-packaged pieces for low-bandwidth (28.8 Kbps) delivery” on page 361.
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Designing a piece for the Web
An Authorware piece that is downloaded over the Web must be designed 
differently from a piece that runs from the user’s hard disk. The two environments 
have different strengths and constraints: the major strength of streaming 
technology is its flexibility; its major constraint is network speed.

Orchestrating downloads

People are sophisticated viewers. To keep them engaged, you need to avoid dead 
spots during downloading. Design a project so that long downloads and data 
transfers aren’t necessary. Orchestrate the flow of information so there’s always 
something to engage a user’s attention during downloads and data transfers.

Here are a few suggestions:

• Keep in mind the network speed the user will experience. What may be fine 
over a T1 line may be unbearably slow over a 28,800 bps modem.

• Emphasize interactivity rather than big graphics and lengthy sounds. The 
interactivity in Authorware doesn’t require a lot of bandwidth; it works well at 
standard modem speeds. 

• Try using a small Presentation window. It’s easier to keep the file size small if you 
use small bitmaps, and it’s easier to use small bitmaps if your Presentation window 
is small. Nonstandard Presentation windows can look great on Web pages. 

• Experiment with really small bitmaps. See how creative you can be with 4-bit 
images, which are half as big as 8-bit images. Try using 1-bit images; they’re 
black and white, but you can add two colors (one foreground and one 
background) with the colors palette in Authorware. Line art (in which the 
entire image is either solid black or white) can be scanned to produce attractive 
1-bit images.

• Save graphics in JPEG and GIF formats, which are smaller than their 
BMP counterparts. Macromedia Fireworks is an excellent tool both for 
determining which format produces a more compact file and for saving the file 
in the format that’s best.

• Save voice audio files in Voxware (VOX) format. Save other audio files in 
Shockwave Audio (SWA) or MP3 format.

• Make the most of the NetDownload, NetPreload, and Preload functions. (See 
“Web-related variables and functions” on page 363.)

• When you use one-button publishing to package a piece for Authorware Web 
Player, experiment with different size segments.
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• Consider distributing large media files on CD, if that’s a possibility. (See “CD–
Web hybrids” on page 371.)

• Test your work at the speed the user will experience. Ask yourself: Will the user 
be willing to wait for the file to download?

For suggestions on improving performance, see Performance tips for 
Web-packaged pieces and Tips for optimizing web-packaged pieces for 
low-bandwidth (28.8 Kbps) delivery in Authorware help.

Tips for optimizing Web-packaged pieces for low-bandwidth 
(28.8 Kbps) delivery

The following tips are useful for delivering pieces over low bandwidth.

• For voice-overs and narration that is “clean voice” with no echoes or background 
noise or music, use VOX compression. It will produce very small files.

• Use the Export Media command to export internal sounds and images to 
compress them into a smaller size (for example, SWA, MP3, VOX, and GIF). 
This is particularly useful if you no longer have the original source material for 
the sounds and images that are now internal to the piece.

• Use internal media whenever possible because it works better with the 
Advanced Streamer. External media (including references to URL-based media) 
are not predictively downloaded with the Knowledge Stream technology.  You 
can use the Package External Media Internally option in one-button publishing 
to facilitate this.

• Avoid using AVI or QuickTime 2 movies at 28.8 Kbps.  If you must use a 
movie, use a tool such as Adobe Premiere to save it as an FLC/FLI and import 
it into Authorware as an internal movie, and use a VOX, SWA, or MP3 file in a 
sound icon as the soundtrack.

• Avoid using large external UCD libraries and custom Xtras if you can. If you 
do use these, use recycle so it doesn’t have to be downloaded each time. UCD 
and Xtras are not part of what the Knowledge Stream technology knows about 
and are not predictively downloaded. 

• Use a single replicated tiled graphic (stored in a library) instead of a large screen.

• In general, store graphics that are shared among pieces in external libraries.

• A single large AAM file (i.e., from a single A6P file) works better than multiple 
AAM files. If you don’t share libraries between multiple AAM files, package the 
libraries internally.

• If you are having bandwidth problems, first try compressing the graphic or 
sound being displayed just after the hiccup. If that doesn’t work, try inserting 
wait icons at opportune places in the course to get delays at predictable times 
rather than randomly. If you insert a wait icon, the Authorware Web Player will 
continue preloading (predictively) the next segments to load and will “get ahead” 
so that it can overcome any temporary higher-bandwidth parts of the course.
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• For computer-generated animation style graphics, use RLE or GIF.

• For natural photographic style images use JPEG. Don’t use internal bitmaps.

• Put in “Loading...” animation at the very beginning of the piece, followed by a 
wait icon.  This will give the first parts of the course a chance to preload so they 
flow smoothly and the user gets feedback that the piece is still running.

• To compress graphics, use File > Export Media to export them and then import 
them into Macromedia Fireworks, or another program such as Adobe 
Photoshop or Debabelizer.  Fireworks will let you try out different compression 
formats (for example, GIF versus JPEG) side-by-side to see which produces 
better results.  Then re-import them into Authorware.

• For sounds, export these, if necessary, using File > Export Media. Then use the 
SWA Xtra to convert these to SWA. Use 8 Kbits/high compression. Record the 
WAV files at the best sample rate you can. Usually 22 kHz/16-bit will suffice, 
though. The better the input, the better sounding the compressed sounds will 
be, and the size of the SWA files doesn’t depend on the size of the input files.  
For voice sounds which have no background music or noise and no echo (for 
example, just “clean” speech), use the Voxware Encoder that Authorware 
installs in your Windows Start program menu. 

• Set the calculation variable GlobalPreroll to 15000 bytes or so. You can also 
change the preroll on a per-sound-icon basis.  Prerolls make sure that sound is 
loaded before it is needed and acts as a buffer to allow for hiccups in network 
bandwidth.  The sound won’t start playing until the preroll number of bytes is 
downloaded.

• Put a wait icon at the beginning of your piece to give the Advanced Streamer a 
chance to act.

• If you are using NetDownload(), consider converting it to 
NetDownloadBackground() to make the download happen in the 
background.

• To see if you are “in the ballpark” as to whether your piece is the right size to 
work at a speed over 28.8 Kbps, Web-package it to an empty folder and use 
Windows File Properties to see the overall size of the folder contents. Estimate 
how long you expect your course to take in real time (i.e., does it encompass 5 
minutes of online training of a student sitting in front of the machine). Take 
the overall size of the Web-packaged piece (e.g., 500K) and divide by the real 
time length of the piece (e.g., 5 minutes). For 28.8, realistically you get about 
2 Kbytes/sec or 120 Kbytes/minute bandwidth.  For this example, 500 K/5 
minutes is 100K/minute, which should work well at 28.8. If your speed is more 
than 120 Kbytes/minute you may have trouble.

• You don’t have to convert every sound and graphic to a compressed format, but 
graphics bigger than about  8K may cause stuttering in the playback (remember 
you get about 2K/second at 28.8 modem speed).

• Create icon size report to find bandwidth hogging icons.
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• Reduce the bit-depth of graphics.

• Decompose large area graphics into smaller pieces if the area can be reduced 
(for example, break a picture frame down into four separate pieces-left, top, 
right, bottom when the center portion is not important).  Macromedia 
Fireworks can do much of this work for you automatically.

• If multiple graphics share some portion of an image in common, break the 
images into component pieces and place in a library. Build the full graphic 
using display links to the component pieces (e.g. a software training piece may 
have several screenshots where the contents of the file windows differ, but the 
toolbar remains the same).

• If a background is repeating, place one small tile in a library, and build up the 
background with multiple display icon links to the tile.

• Use built-in tool box patterns instead of large complex image backgrounds.

• Break down video into narration (sound icon) and flip through a few static 
frames (using transitions to spice it up).

• Use native toolbox objects instead of images whenever possible (e.g. text object 
instead of an image containing text).

• Avoid using Preload() because it blocks (i.e. it doesn't work in the background).  
The KnowledgeStream technology does much of this preloading.  If you have 
to, use NetPreload() instead, but use it sparingly because it will do manually 
what the predictive downloading tries to do automatically.

Web-related variables and functions
A special set of variables and functions has been designed for use with 
Web-packaged Authorware pieces. They appear in the Network category in 
the Functions dialog box.

Variables

Variable Description

GlobalPreroll Contains the number of bytes to download before any 
network-based sounds used by your piece begin to play. 

NetBrowserName Contains the name of the browser running the current piece.

NetBrowserVendor Contains the name of the vendor of the browser running the 
current piece.

NetBrowserVersion Contains the version number of the browser running the 
current piece.
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Functions

NetConnected Indicates whether Authorware Web Player is running 
a piece. 
If you create two different versions of the same piece—one 
Web-packaged, one not—you can use NetConnected to 
determine which is running. You might use that information 
to display a 1-bit line drawing for the Web-packaged version 
and an 8-bit image for the other.

NetLocation Contains the server location where the Web-packaged 
piece is located.
With NetLocation you don’t have to keep track of the 
URL yourself. It’s an easy way to find other things, such as 
external content files, stored at the same location.

Preroll Contains the number of bytes to download before the sound 
contained in the specified icon begins to play. 

SoundBytes Contains the size (number of bytes) of the sound contained 
in the specified sound icon.

Function Description

Bandwidth Returns the rate of previous reads or downloads in bytes 
per second. 

FTP UCD functions Add FTP capabilities to Authorware. See “The Authorware 
FTP functions” on page 370.

JumpFile Jumps to a URL-specified Authorware piece. (URLs work 
only in Web-packaged pieces.)

JumpFileReturn Jumps to a URL-specified Authorware piece and then 
returns. (URLs work only in Web-packaged pieces.)

GoToNetPage Opens a new Web page identified by a URL in the browser. 
Use GoToNetPage to go from a Web-packaged piece 
either to a Web page or to another Web-packaged piece.

NetAbort Attempts to terminate a download given a NetID returned by 
NetDownloadBackground. 

NetDownload Downloads a file identified by a URL to the user’s hard disk. 
Use NetDownLoad to download content, such as text or 
graphics, or files Authorware Web Player may need, such as 
sprite or scripting Xtras.

NetDownload
Background

Attempts a background download of the file specified in 
URL to the given local filename. 
NetDownloadBackground is similar to NetDownload, 
but doesn’t wait for a download to complete.

Variable Description
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If you use the GoToNetPage and NetDownload functions in an Authorware piece 
that hasn’t been packaged for the Web, Authorware ignores them. 

If you use NetPreload in a piece that hasn’t been packaged for the Web, it works 
just like PreLoad. The Preload and the NetPreload functions are related but do 
different things:

Preload loads information into memory so that it’s immediately accessible when 
Authorware is ready to use it. Preload is usually used with large files, such as 
embedded digital movies, which can produce a noticeable lag if Authorware needs 
to load them into memory before it can run them. You can download external 
graphics and sounds directly into memory by using a URL with Preload; this 
works only with external graphics and sound.

NetPreload downloads a segment of a Web-packaged piece to the user’s 
computer (it won’t, however, download external sounds or graphics files). Use it to 
download a segment behind the scenes so it’s at hand when Authorware needs it. 
Unlike Preload, NetPreload doesn’t load the segment into memory. 

NetDownloadName Returns a destination filename given a netID as returned by 
NetDownloadBackground. 

NetError Returns an error code for a download given a NetID as 
returned by NetDownloadBackground. 

NetFileSize Returns the content size in bytes of the specified URL. 

NetLastModDate Returns the most recent modification date of the 
specified URL.

NetPercentDone Reports the progress of a download given a NetID as 
returned by NetDownloadBackground. Progress ranges 
from 0 to 100.

NetPreload Downloads a segment of a Web-packaged piece.
Use NetPreload to download segments when it will be 
least noticeable to the user; don’t use NetPreload, 
however, if you’re using Authorware Advanced Streamer. 
To preload external content linked to a piece, use the 
Preload function.

ReadExtFile Reads an external file identified by a URL.

ReadURL Reads the specified URL and returns the file's contents, or 
the javascript result, as a character string.

ResetBandwidth Clears the bandwidth statistics for the specified selector. 

Function Description
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Managing content in Web-packaged pieces
Content can be embedded in or external to a Web-packaged piece, just as it can in 
any Authorware piece. A consideration to keep in mind when designing a piece is 
to avoid delays when content is downloading.

If you’re using Authorware Advanced Streamer, avoid using external content 
whenever possible. It’s less efficient than embedded content.

Embedded content Authorware one-button publishing includes embedded 
content in one of the segments that it creates when you package the piece 
for the Web. 

• If you’re using Authorware Advanced Streamer, avoid using the NetPreload 
function. NetPreload does manually what Authorware Advanced Streamer 
attempts to do automatically: download segments when the transfer is least 
noticeable.

• If you’re not using Authorware Advanced Streamer, use the onDemand option 
and NetPreload to control when Authorware Web Player downloads the 
segments that contain content.

External content Authorware handles external content differently depending on 
how you’ve set up the content:

• If the path to an external media file points to your local hard disk or your local 
server, one-button publishing adds a path that points to the folder on the user’s 
computer where the player will download the file.

Use the onDemand option to download the file only if and when it’s actually 
needed: the player first checks for the file in the folder on the user’s computer; if 
it finds a copy there, it uses it rather than downloading the file again.

• If the path to an external media file is a URL, one-button publishing leaves the 
path as it is.

Use Preload to load an external sound or graphics file directly from a URL 
into memory.

• If you use NetDownload to download an external media file, Authorware Web 
Packager leaves the path to the file as it is.

Use the onDemand option in the map file to control precisely when the player 
downloads the file.

Note: Custom fonts are difficult to handle because they need to be installed after they’re 
downloaded (see Using custom fonts in Web-packaged pieces).
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Configuring your server
You need to set up the Web server where you place the HTML page and the 
Web-packaged Authorware piece so that it recognizes the Multipurpose Internet 
Mail Extensions (MIME) type that identifies a Web-packaged Authorware file. 
It’s a matter of adding a few lines to the server’s configuration settings.

Providing the Authorware Web Player
Users need the correct version of Authorware Web Player to run a Web-packaged 
piece you’ve created in Authorware 6.

If you aren’t working in an environment where you can distribute the player to 
users directly, have them download it from the Macromedia Web site (it’s free). 
For information about setting up a link to the Macromedia Web site, visit the 
Authorware Support Center. (Choose Help > Support Center or visit 
www.macromedia.com/support/authorware.)

Streaming—step-by-step procedures

What you can do In Authorware Help, see

Package a piece for the Web Getting a piece ready for the Web, Publishing 
for the Authorware Web Player, Publishing to 
a Web page, Using one-button publishing to 
package a piece

Edit a map file Editing a map file with the Authorware Web 
Packager editor

Combine map files for different 
player versions

Combining map files for different player 
versions

Add a line to a map file Adding a new external content line

Edit map segment lines Adding a new external content line

Edit library lines Adding a new external content line

Add a line for external content Adding a new external content line

Edit an external content line Adding a new external content line

Use Xtras in Web-packaged pieces Web-packaged pieces and external files

Play a Director movie in 
a Web-packaged piece

Playing Director movies in Web-packaged 
pieces

Use multiple get and put entries Using multiple get and put entries
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Authorware Advanced Streamer
Authorware Advanced Streamer improves downloading performance for a 
Web-packaged piece. Authorware Advanced Streamer records the general file 
access patterns that users make when running a piece. It uses that information 
to predictively download file segments in the background when subsequent 
users run the piece. 

Authorware Advanced Streamer uses probability calculations to determine how 
future users will navigate through the piece based on past users. As a user spends 
time reading information or interacting with the current segment of a piece, 
Authorware Advanced Streamer downloads the next segments that it predicts will 
be requested by the user. By productively using this idle time, Authorware 
Advanced Streamer reduces the amount of time users spend waiting for material 
to download.

For detailed information about Authorware Advanced Streamer, see Authorware 
Help.

Using Internet services
Your use of the Web isn’t limited to what you can do in Web-packaged pieces. In 
standard Authorware pieces—and without a Web browser—you can:

• Link to external content files on a Web server

For example, on a corporate intranet you could provide brief QuickTime 
reports on company events and update them daily.

Tune the performance of a 
Web-packaged piece

Performance tips for Web-packaged pieces

Bypass the Security dialog box Bypassing the Security dialog box in trusting 
mode, Bypassing the Security dialog box in 
nontrusting mode

Check whether a user is running in trusting 
or nontrusting mode

Querying a network security variable

Create a piece that won’t be affected by 
any browser’s palette

Creating a Web-packaged piece with a Web-
safe palette

Configure the Web server Configuring your server

Add a Web-packaged piece to a 
Web page

Publishing to a Web page, Using one-button 
publishing to package a piece

Set up a Web page for 
non-streaming browsers

Working with non-streaming browsers

What you can do In Authorware Help, see
Chapter 11368



• Use the FTP functions in the Authorware FTP UCD. 

Whenever a user completes a section of a training course, you can use the 
FTPStore function to transfer the results to a central Web server.

• Use ReadURL to call JavaScript.

You can also use the Macromedia Control Xtra for ActiveX to embed Internet 
Explorer in an Authorware piece and use it to display HTML pages or to connect 
with the Web. For example, if you’re developing a training piece on the Internet, you 
could launch Internet Explorer and respond to actions users take in the browser.

Designing for Internet services
Many of the issues you have to deal with when you’re creating a Web-packaged 
piece also apply to a standard Authorware piece that uses Internet services:

• Keep in mind the network speed the user will experience.

• Avoid delays during downloading.

• Link to external content over the Web only when you must, and then keep 
graphics, sounds, and movies as small and efficient as possible. 

• Remember that your content needs to be compatible with the computer it’s 
running on.

• Make the most of the FTP functions that Authorware can use (see “The 
Authorware FTP functions” on page 370).

• Test your work at the speed the user will experience.

There are differences too. Some variables, functions, and features are available 
only to Web-packaged pieces:

• Of the Authorware Web-related variables, only GlobalPreroll, Preroll, 
and SoundBytes can be used in both standard and Web-packaged pieces. 
NetConnected and NetLocation work only in connection 
with Web-packaged pieces. NetBrowserName, NetBrowserVendor, 
and NetBrowserVersion work only in Web-packed pieces.

• Of the Authorware Web-related functions, only Bandwidth, Jumpfile, 
JumpFileReturn, ReadExtFile, and ResetBandwidth can be used in both 
standard and Web-packaged pieces. (For a complete list of Web-related 
functions, see “Web-related variables and functions” on page 363.)

• You can use URLs with JumpFile and JumpFileReturn only in Web-packaged 
pieces. So you can’t jump from a local Authorware file to an Authorware file on 
a Web server. 

• You can use the Preload function to preload an internal sound or graphic or 
an external sound or graphic linked to a URL into memory.
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• With a standard Authorware piece, there are no download options that 
let you download on demand or preempt or recycle a file that’s already 
been downloaded.

• The Internet services available to an standard piece have no built-in security 
features. Xtras, UCDs, and DLLs can be downloaded freely; the FTP functions 
can read and write files. Xtras, UCDs, and DLLs can be downloaded freely; the 
FTP functions can read and write files.

The Authorware FTP functions
The Authorware FTP UCD contains 19 functions that you can use to manage the 
transfer of information over the Internet or an intranet. The following table gives 
a brief description of each function. For more information, see the Read Me file 
that accompanies the UCD. The Authorware FTP UCD contains 19 functions 
that you can use to manage the transfer of information over the Internet or an 
intranet. The following table gives a brief description of each function. For more 
information, see the Read Me file that accompanies the UCD. 

Function What it does

FtpAbort Aborts the current asynchronous function.

FtpAppend Transfers a file from the local file system to a Web server. If 
the file doesn’t exist, FtpAppend creates it. If the file does 
exist, FtpAppend appends the transferred file to the 
existing file.

FtpChangeParentDir Simplifies dealing with different server syntaxes for naming 
the parent directory (this is a special case of 
FtpChangeWorkingDir).

FtpChangeWorkingDir Allows the calling application to use a different directory for 
file storage or retrieval.

FtpClose Closes the FTP session.

FtpConnect Establishes an FTP connection to a server.

FtpDelete Deletes a file from a Web server.

FtpDisconnect Disconnects the FTP connection from the server.

FtpGetWorkingDir Gets the full path of the current working directory.

FtpList Instructs a Web server to send a list of files.

FtpMakeDir Causes the directory specified by the remote path to be 
created as a directory.

FtpNameList Instructs a Web server to send a directory listing.

FtpOpen Allocates and initializes resources for the FTP session.
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CD–Web hybrids
The main constraint on delivering multimedia over a network is always network 
speed. Productions with a lot of audio, video, and graphics are especially restricted 
because these types of media take up the most disk space. CD–Web hybrids 
overcome this limitation by combining the media-rich content of CD technology 
with the immediacy and resources of the Internet. 

For example, a CD-based travel guide could download the most up-to-date 
information about hotel prices, entertainment, and exchange rates from the 
Internet. You could either package such a piece for the Web and run it in a 
browser from the CD—at about 100 times the speed of downloading it from the 
Web over a 28,800 bps modem—or you could package it and use the Authorware 
Internet services to download information from the Web.

Whichever method you choose, the combination of a CD and the Web can be an 
ideal solution for many projects.

FtpRemoveDir Causes the directory specified by the remote path to be 
removed as a directory as long as it’s empty.

FtpRename Renames a file on a Web server.

FtpResult Returns the result string of the completed FTP operation.

FtpRetrieve Retrieves a file from a Web server.

FtpStatus Returns the status of the last function.

FtpStore Stores a file on a Web server.

Function What it does
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Creating Knowledge Objects

A Knowledge Object is a packet of logic—encapsulated in a model—that you insert 
into an Authorware piece. A Knowledge Object is different from a simple model in 
that it’s connected to a wizard. A wizard is an Authorware piece that provides an 
interface for setting up, making changes to, or even adding new content and logic 
to the Authorware piece where you’ve inserted the Knowledge Object.

Knowledge Objects are powerful productivity tools that make inexperienced 
members of a development team productive by enabling them to do common 
tasks easily and efficiently. Knowledge Objects also make you more productive if 
you’re an experienced developer by giving you a way to automate repetitive tasks. 
Knowledge Objects, in fact, fundamentally revolutionize the authoring practice.

Here are examples of some of the things you can do with Knowledge Objects:

• You’re creating a psychological evaluation with hundreds of multiple-choice 
questions. After the content of the questions has been developed by experts, 
you create a Knowledge Object that allows a low-level Authorware specialist to 
import each question from a text file and set up an interaction for it—without 
using any of the detailed Authorware dialog boxes.

• You recognize that there’s a need for templates that help trainers construct 
courses that embody good instructional design principles. You create 
Knowledge Objects that embody such templates. You package and sell them.

• You’re creating a huge project in Authorware that has thousands of framework 
pages. You discover well into the project that you need to add a prefix to the 
name of every page. You can create a Knowledge Object that changes the title 
of every page icon automatically.
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• You discover that you need to create a set of Knowledge Objects that all do very 
much the same thing. You can create a Knowledge Object that helps you build 
the other Knowledge Objects.

• You’re a consultant, and after you deliver a project you’ve created in Authorware 
to your client, the client discovers a few minor bugs in it. You can create a 
Knowledge Object the client can run to fix the bugs.

A Knowledge Object works like this: A user drags a Knowledge Object from the 
Knowledge Objects window to the flowline. The Knowledge Object launches the 
wizard connected to it. Doing so launches another instance of Authorware in 
which the wizard runs. The wizard leads the user through the process of setting up 
content in the Knowledge Object or configuring the code it contains. As the user 
makes choices in the wizard, the wizard makes the appropriate changes in the 
“target” Authorware piece (the piece where the user has inserted the Knowledge 
Object). When the user quits the wizard and runs the file that contains the 
Knowledge Object, Authorware, instead of launching the wizard when it 
encounters the Knowledge Object icon, executes the logic inside the icon.

The simplest Knowledge Objects consist of a Knowledge Object icon and the 
wizard it launches. You save a Knowledge Object icon as a model. Knowledge 
Objects—as long as you save them in the proper folder—appear in the Knowledge 
Objects window, where they’re easily accessible to users. They can be used over 
and over again.

Displaying Knowledge Objects in the 
Knowledge Objects window
The Knowledge Objects window provides access to the Knowledge Objects and 
models that are located in the Knowledge Objects folder in the Authorware 6 folder.

The Category drop-down list at the top of the Knowledge Objects window lists the 
name of each of the subfolders inside the Knowledge Objects folder. “All” also 
appears on the drop-down list. Choosing All lists all the Knowledge Objects and 
models in all of the subfolders and any Knowledge Objects and models in the 
Knowledge Objects folder itself. Choosing any other category lists the Knowledge 
Objects and models in the subfolder it represents. Knowledge Objects and models in 
subfolders nested inside subfolders aren’t listed in the Knowledge Objects window.

The Category drop-down list shows shortcuts to folders outside the Knowledge 
Objects folder; likewise, the Knowledge Objects window shows shortcuts to 
Knowledge Objects that are stored in folders outside the Knowledge Objects 
folder (as long as the shortcuts are in the Knowledge Objects folder or one of its 
subfolders). Shortcuts appear in italics.

If you add Knowledge Objects to the Knowledge Objects folder or any of its 
subfolders after you’ve launched Authorware, click the Refresh button in the 
Knowledge Objects window.
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Wizards and targets
A wizard and its target are two separate Authorware pieces in two separate 
instances of Authorware that are running simultaneously. The wizard is an 
interface for setting up content or for configuring or constructing logic in 
the target Authorware piece. It contains logic that manipulates the target 
Authorware piece.

Launching a wizard

When you launch a wizard from a Knowledge Object, it automatically starts 
another instance of Authorware. The instance of Authorware running the wizard 
takes focus so that it’s impossible for a user to make changes in the target piece 
while the wizard is running, except through the wizard. A wizard can make 
changes not just inside the Knowledge Object that launched it but to any part of 
the target Authorware piece.

A wizard communicates with the target Authorware piece through the Knowledge 
Object that launched it. A wizard can, of course, be launched by different 
instances of the same Knowledge Object in the same Authorware piece or by the 
same Knowledge Object in different Authorware pieces—but only one wizard can 
be running in an Authorware piece at a time.

When you pause an unpackaged wizard (which you may do when you’re testing or 
debugging a wizard), you can make changes to the wizard and then resume 
running it or restart it from the beginning. 

Quitting a wizard

When you quit a packaged wizard, the instance of Authorware running it quits 
automatically. 

When you quit an unpackaged wizard, the wizard file closes, but the instance of 
Authorware running it remains open. You can either close it or switch focus to 
return to the instance of Authorware containing the target file.

Variables and functions for Knowledge 
Objects
The variables and functions for Authorware Knowledge Objects are described in 
the following sections.

You can use all of these functions and variables from a wizard, just as they are used 
in commands. However, if you open a new file, you will lose the Knowledge 
Object icon reference point into the piece. You’ll need to reference icons in the 
target through some other means, such as the RootIcon function. Also, if you 
package the piece, the icon IDs in the target piece may change in the process.
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Variables

For detailed information about the following variables, see System Variables in 
Authorware Help.

Functions

For detailed information about the following functions, see System Functions in 
Authorware Help. 

Variable Description

Knowledge¬
ObjectID

KnowledgeObjectID@"IconTitle" contains the Knowledge 
Object ID string from the icon specified in IconTitle.

TargetIcon TargetIcon contains the icon ID of the Knowledge Object 
icon from the target piece responsible for launching the 
current wizard file.

Function Description

CallTarget Executes a function in a target piece. Use CallTarget only in 
calculation icons in a wizard (see “Communicating with a 
Knowledge Object” on page 382).

ClearIcons Deletes the selected icons without copying them to the Clipboard.

CopyIcons Copies the selected icons to the Clipboard.

CutIcons Cuts the selected icons and places them on the Clipboard.

DisplayResponse Displays the response associated with the specified icon.

EraseResponse Erases the response associated with the specified icon.

GetCalc Returns the contents of the specified calculation icon (or the 
calculation attached to any specified icon) as a string.

GetExternalMedia Returns a full list of external media associated with the node 
or the library. This function returns an empty list when used on 
packaged files.

GetFileProperty Gets the file property for the indicated property. This function only 
operates on unpackaged files. Supported properties include: 
#awTitleBar, #awTaskBar, #awCenterOnScreen, 
#awMenuBar, #awOverlayMenu, #awMatchWindowColor, 
#awStandardAppearance, #awWindows31Metrics, 
#awDesktopPattern, #awTrackAllInteractions, 
#awTrackScore, #awTrackTime, #awTrackTimeout, 
#awLogoutUponExit.

GetFunctionList Returns a property list with information about the functions within 
the specified category. Use 0 to retrieve the list of functions in U32 
and Script Xtras loaded by your course. This function only 
operates on unpackaged files.
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GetIconContents Returns a property list of content contained within the 
specified icon. 

GetInitialValue Retrieves the initial value of a variable.

GetLibraryInfo Returns a linear list of all libraries currently associated with the 
current course file.

GetPasteHand Returns the IconID of the icon closest to the paste hand. If the 
IconID is positive, then the paste hand is before that icon. If the 
iconID is negative, then the paste hand is after that icon. If the 
value returned is 0, then the paste hand is on the tool palette. This 
function only operates on unpackaged files.

GetPostPoint Returns the post point for the icon you specify. The post point is 
the upper left corner of the bounding box for objects in a display or 
response. The return value looks like this: point(x, y).

GetPostSize Returns the post size for the icon you specify. The size is returned 
like this: size(width, height).

GetSelectedIcons Returns a linear list describing the selected icons in the front map. 
Values are the IconTitle, IconID, and IconType. This 
function only operates on unpackaged files.

GetVariable Retrieves the value of the named variable.

IconID Returns the unique numeric identifier of the icon in which it 
appears. Use IconID("IconTitle") to get the ID of a 
specific icon.

ImportMedia Imports media into the specified display, interaction, movie, or 
sound icon.

InsertIcon Inserts an icon of the specified IconType on the Authorware 
flowline at the current location of the Paste Hand.

IsCourseChanged Returns TRUE if the Course files has been changed and not saved. 
This function only operates on unpackaged files.

IsLibraryChanged Returns TRUE if the Content Library file specified by LibraryID 
has been changed and not saved. Use GetLibraryInfo to 
obtain a list of libraries containing the ID for each file. This function 
only operates on unpackaged files.

NewVariable Creates a new user variable. Use an IconID to create a local 
variable. Sets EvalStatus. This function only operates on 
unpackaged files.

OpenFile Opens the specified course file. If the file name is omitted, a new 
untitled file is created.

OpenLibrary Opens the specified content library file. Returns the value of 
IOStatus. This function only operates on unpackaged files.

Function Description
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PackageFile Packages the currently open course file. Returns the value of 
IOStatus. This function does nothing unless called via the 
CallTarget function on an unpackaged target file.

PackageLibrary Packages the specified library file. The file specified must be 
connected with the current course. Returns the value of 
IOStatus. This function does nothing unless called via the 
CallTarget function on an unpackaged target file.

PasteIcons Pastes icons from the Clipboard to the point on the flowline 
indicated by the Paste Hand.

PasteModel Inserts the specified model into a piece at the point on the flowline 
indicated the Paste Hand.

SaveFile Saves the current course file. Untitled files are not saved if the file 
name is omitted or the path is relative. Sets IOStatus and 
IOMessage. Returns the value of IOStatus. This function only 
operates on unpackaged files.

SaveLibrary Saves the specified content library file. If a new file name is given, 
the library is saved to the new file and the original file is left intact. 
The course file will be marked as "Changed" during this action. 
Returns the value of IOStatus. This function only operates on 
unpackaged files.

SelectIcon Clears, sets, or adds to the selection in the piece.

SetCalc Sets the string of a specified calculation icon (or of a calculation 
attached to any specified icon).

SetEmpty Sets the state of the Empty property of the specified Knowledge 
Object icon.

SetFileProperty Sets the file property for the indicated property to the indicated 
value. This function only operates on unpackaged files. Returns 
TRUE if successful, FALSE otherwise. Supported properties 
include: #awTitleBar, #awTaskBar, #awCenterOnScreen, 
#awMenuBar, #awOverlayMenu, #awMatchWindowColor, 
#awStandardAppearance, #awWindows31Metrics, 
#awDesktopPattern, #awTrackAllInteractions, 
#awTrackScore, #awTrackTime, #awTrackTimeout, 
#awLogoutUponExit.

SetIconTitle Sets the title of the specified icon.

SetInitialValue Sets the initial value of the named variable.

SetPasteHand Sets the location of the Paste Hand.

SetPostPoint Sets the post point for the icon you specify. The post point is the 
upper left corner of the bounding box for objects in a display or 
response.

SetPostSize Sets the post size for the icon you specify. 

Function Description
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Knowledge Objects—step-by-step 
procedures 

SetVariable Sets the value of the named variable.

ShowWindow Opens or closes the Presentation window.

What you can do In Authorware Help, see

Create a Knowledge Object and the wizard 
that provides its interface

Creating a Knowledge Object, Creating 
a good wizard interface

Add a Knowledge Object icon to the 
flowline and set it up

The Knowledge Object icon, Setting up 
a Knowledge Object icon

Connect a Knowledge Object icon and the 
wizard that provides its interface

Connecting a Knowledge Object icon 
to a wizard

Create a unique ID for a Knowledge 
Object icon

Creating a unique ID for a Knowledge 
Object icon

Use the CallTarget function to execute a 
function in a wizard.

CallTarget function, Communicating with 
a Knowledge Object

Get and set variable values with a wizard GetCalc function, SetCalc function, Getting 
and setting variables with a wizard

Use a wizard to position the Paste Hand in 
the target piece

SetPasteHand function, Positioning the 
Paste Hand with a wizard

Use a wizard to select icons in the 
target piece

SelectIcon function, Selecting an icon with 
a wizard

Use a wizard to insert and delete icons in 
the target piece

CutIcons function, CopyIcons function, 
PasteIcons function, ClearIcons function, 
Inserting and deleting icons with a wizard, 
Building logic on the fly with models

Use a wizard to insert a model in the 
target piece

PasteModel function, Inserting and deleting 
icons with a wizard

Use a wizard to get and set icon properties 
in the target piece

Getting and setting icon properties with 
a wizard

Use a wizard to get and set the string in a 
calculation in the target piece

GetCalc function, SetCalc function, Setting 
a calculation with a wizard

Use a wizard to import images, movies, and 
sounds into the target piece

ImportMedia function, Importing media with 
a wizard

Give users the ability to change the settings 
they’ve selected in the wizard

Making Knowledge Objects re-entrant

Function Description
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The Knowledge Object icon
The Knowledge Object icon doesn’t appear in the icon palette. It’s accessible 
through Insert > Icon > Knowledge Object Icon.

You can think of a Knowledge Object icon as a map icon that has a 
communication link with another Authorware piece running in a separate 
instance of Authorware. The Knowledge Object icon launches the wizard and 
provides the link between the wizard and the target Authorware piece where the 
icon is located.

Knowledge Object icons, unlike other Authorware icons, behave differently 
depending on whether or not you’ve saved them in a model:

• You can lock a Knowledge Object icon so that after you’ve saved it in a model, 
no one can open the icon and cut or copy its contents.

• You can set up a Knowledge Object icon so that after you’ve saved it in a 
model, when users drag the model from the Knowledge Objects window to the 
flowline, Authorware launches the Knowledge Object’s wizard automatically.

Anticipate error conditions Handing error conditions in Knowledge 
Objects

Test and debug a Knowledge Object Testing and debugging Knowledge Objects

Create a preferences file for a 
Knowledge Object

Creating a preferences file for a 
Knowledge Object

Turn a Knowledge Object icon into a 
Knowledge Object

Turning a Knowledge Object icon into 
a Knowledge Object

Distribute Knowledge Objects Distributing Knowledge Objects

Make the Knowledge Object accessible 
from the Knowledge Objects window

Displaying Knowledge Objects in the 
Knowledge Objects window

What you can do In Authorware Help, see
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Knowledge Object icon options
Every Knowledge Object icon has three options:

Lock Icon: When Saved in Model has two benefits. It protects proprietary code 
from unauthorized use. It also prevents people from unintentionally making 
changes to the logic in the Knowledge Object icon that might cause the 
Knowledge Object to stop working properly.

Run Wizard: Immediately When Inserted From Model launches the wizard 
associated with a Knowledge Object automatically when a user drags the 
Knowledge Object from the Knowledge Objects window to the flowline.

Empty: Run Wizard When Icon Encountered launches the wizard associated with a 
Knowledge Object when the Knowledge Object icon is encountered on the 
flowline. When a wizard needs information from the user, set the Empty property 
with the SetEmpty function. Make sure you clear the Empty property once your 
wizard has the information it needs. If you don’t clear this setting, the Knowledge 
Object will launch the wizard every time the user tries to run the piece. When in 
doubt, clear this setting.

Creating a good wizard user interface
How good a Knowledge Object is depends not only on how well coded and well 
tested it is but on how successful users are in getting it to do what they want it to 
do. That requires a well-designed user interface. 

A good design provides:

• A map. Users should be able to tell from the interface what functions are part 
of the wizard and where they’re located in the wizard.

• Clear choices. Users should understand what they’re being asked and should 
have enough information to make the choices they want. Provide defaults that 
are logical and intuitive.

• Predictable outcomes. Users need to understand the implications of the choices 
they make so they get the results they expect.

• Context. If a wizard completes only part of a larger task, the wizard should 
make clear how its function fits into the larger task.

• Re-entrancy. Users should be able to run a wizard more than once to modify 
their work. They shouldn’t have to delete their work and run the wizard again 
to change the results.
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Communicating with a Knowledge Object
Use the CallTarget function to control the target Authorware piece from the 
wizard. The CallTarget function lets you call a function and have it affect the 
target piece that contains the Knowledge Object that launched the wizard.

Here are some of the things you can do with the CallTarget function:

• Get the ID of an icon in the target piece:

BackgroundID := CallTarget("IconID","Background")

• Select an icon in the target piece:

CallTarget("SelectIcon",BackgroundID)

• Copy the selected icon or icons in the target piece:

CallTarget("CopyIcons")

• Set the position of the Paste Hand in the target piece:

IntroTextID := CallTarget("IconID","Intro Text")
CallTarget("SetPasteHand",IntroTextID,#before)

• Paste the contents of the Clipboard at the place marked by the Paste Hand:

CallTarget("PasteIcons")

• Change the title of an icon:

TextResponseID := CallTarget("IconID","Text Response")
CallTarget("SetIconTitle",TextResponseID,"Marie Curie")
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Show Me Examples

Each Show Me example is a capsule computer-based training (CBT) course that 
explains and demonstrates a valuable technique. All the Show Me examples 
contain flowline logic that you can paste into your course to give you a head start 
with your work. 

Accessing Show Me examples

You can access Show Me examples in three ways:

• Select Help > Show Me from the Authorware menu. A list of Show Me 
examples is displayed in Authorware Help. You can select a Show Me from the 
Help Contents, look for it in the Index, or search for it.

• You can open the Show Me folder in the Authorware program folder and click 
on a Show Me A6P file to open it in Authorware.

• New Show Me examples are continually added to the Authorware support site 
at www.macomedia.com/support/authorware/.
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24 Points (24points.a6p)

Uses Authorware’s target area interaction to create a drag-and-drop math game.

Administration (Admin.a6p)

Provides a simple application to read the data written by the Logon and Content 
Show Me files.

Altimeter (Altimeter.a6p)

Simulates an altimeter by using the Line function and Authorware’s capability to 
update displayed variables.

Animated Buttons (anibutt.a6p)

Demonstrates how to set up an animated button.

A/V Synchronization (Avsync.a6p) 

Illustrates synchronizing text or graphics with audio and video.

Bar Graph (Bargraph.a6p)

Demonstrates how to create a simple bar graph.

Button Interaction (Q_button.a6p)

Provides a simple demonstration of a push button interaction.

Calculator (Calculator.a6p)

Demonstrates how to build a simple calculator.

Catch It (CatchIt.a6p)

Demonstrates how to use Authorware’s Overlapping function to build a simple 
game called Catch It.

CD-ROM Drive Letter (FindCD.a6p)

Demonstrates how to determine the drive letter assigned to the CD-ROM drive.

Clock (Clock.a6p)

Demonstrates how to create an analog clock using Authorware’s Line function.
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Content Application (Content.a6p)

Provides a simple application that demonstrates how to integrate smaller pieces 
into a complete application.

Creating a Subroutine (Subrout.a6p)

Shows how to create a subroutine and some uses for subroutines, such as 
recording student scores.

Cubes (Cubes.a6p)

Show how to represent 3D cubes using Authorware’s line tool.

Displaying Variables (Variable.a6p)

Provides a simple demonstration of variables embedded in a display. Shows how to 
use the Update Displayed Variables setting to display the current icon title, time, 
and other user information.

Double Click Selection (Dblclick.a6p)

Shows how to set up double-click and single-click responses in one interaction.

Drag and Drop Interactions (Drag.a6p)

Demonstrates how to use Authorware’s system functions and variables to simplify 
the setup for target area interactions.

Encryption-Decryption (Encrypt.a6p)

Demonstrates how to build a simple encryption system in Authorware.

External Content (External.a6p)

Provides an example of displaying external graphics based on a variable and 
displaying a graphic from a URL.

Flash Asset Xtra(Flash.a6p)

Demonstrates how to use the Flash Asset Xtra in Authorware.

Flash in ActiveX (flash_ax\FlashAx.a6p)

Demonstrates messaging from a Flash 5 movie into an Authorware piece, using 
the ActiveX control.
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Forms (Forms.a6p)

Shows how to use a framework; includes a list to create a multifield form.

Forms with WinCtrls (Forms_Win.a6p)

Demonstrates how to set up a multi-field form using the Windows Control 
Knowledge Objects.

Free Form Text (Q_txt_l.a6p)

Illustrates simple methods for evaluating text responses that may not have an 
easily defined answer.

Generic Question Model (Q_model.a6p)

Shows how to create a generic multiple-choice interaction that can be used as a 
model for rapid development.

Glossary (Glossary.a6p)

Demonstrates a simple glossary structure. Demonstrates the use of external data 
files, WordClicked, LineClicked, and string manipulation. The glossary functions 
include a scrolling list of terms and the ability to click on any word on the screen 
to search for its definition.

Graphing (Graph.a6p)

Demonstrates graphing simple data points using the Line function. The user can 
enter values for the data points either by clicking on the grid or keying in numbers 
for x and y.

Hangman (Hangman.a6p)

Shows you how to create a hangman game.

Help System (Help.a6p)

Demonstrates a simple help system using Frameworks.From the help screen, the 
user can select a topic by clicking on it in the list, or use the framework Find 
function to navigate to a help topic.

Hot Object Interaction (Q_hotobj.a6p)

Discusses clickable object interactions and how to set them up with a catchall.
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Hot Spot Interaction (Q_hotspt.a6p)

Demonstrates the use of hot spots, how to layer hot spots, and catchall hot spots.

Hot Text (Hottext.a6p)

Demonstrates the use of hot text links.

Jigsaw Puzzle (Jigsaw.a6p)

Shows how to create a jigsaw puzzle in Authorware.

Judging and Tracking (Judge.a6p)

Shows how to judge and track a student’s response at an interaction.

Keyboard (Keyboard.a6p)

Shows how to create an onscreen keyboard.

Keypress Interactions (Keypress.a6p)

Demonstrates setting up a keypress interaction and how to check for special keys. 
The example shows how to capture each keystroke and display a bullet character. 
The Logon piece uses this same interaction for the password entry.

Logon (Logon.a6p)

Shows how to prompt the user for a name and password. The example checks for 
existing records and resumes any previous file. If the logon doesn’t find any 
records, the user can sign in, retype the name, or quit.

Magnify (Magnify.a6p)

Uses Authorware’s graphic scaling ability and external content support to create a 
graphic zooming function.

Making Icons Immovable (Lockdown.a6p)

Shows how to lock down the contents of an icon.

Marching Ants (Marchant.a6p)

Demonstrates using the Line function to simulate a “marching ants” marquee. It 
also demonstrates how to select an object with the marquee.
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Memory Game (Memgame.a6p)

Demonstrates how to build a memory game.

Morse Code (Morse.a6p)

Demonstrates how to build a Morse code generator. The user can convert text to 
Morse code or create tones by holding down the mouse button.

Movie Controls (Movctrls.a6p)

Illustrates how to create controls for any digital movie.

Moving Objects (Move.a6p)

Shows how to animate and position graphics. Includes a rotating gauge, a progress 
bar, and a scrolling graphic.

Mr. ASCII Pseudo (Ascii.a6p)

Demonstrates how to create an animation using character strings.

Navigating & Expressions (Nav_page.a6p)

Shows how to use an expression in a navigation icon to navigate to a page. The 
user can click on a list of icon titles to navigate to an icon.

Navigating with Flash (flash_nav\Nav_Flash.a6p)

Show how to use a Flash file as a navigation bar within an Authorware file.

Notepad (Notepad.a6p)

Illustrates a combination of functions such as reading/writing files and working 
with strings. Functionally, the notepad lets a user enter, view, and delete notes.

Orbit (Orbit.a6p)

Shows how to animate an object so that it goes behind and in front of the same 
object it travels around.

Paging (Paging.a6p)

Provides a simple paging structure setup. In addition to simple paging, the 
example illustrates preventing wraparound paging.
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Picture Box (Pic-box.a6p)

Demonstrates a game in which a picture is divided into nine pieces. Eight of the 
pieces are displayed in random order on a 3 x 3 grid. The user can slide one piece 
at a time into the empty space. The objective is to rearrange the pieces into their 
proper order.

Pie Chart (PieChart.a6p)

Uses the Line function to draw many single lines. Together, the lines look like a 
colored pie chart.

Piston (Piston.a6p)

Demonstrates how to create motion similar to that of a piston.

Pop-up Glossary (Popup.a6p)

Shows how to create a pop-up window to display text.

Pull-down Menus (Pulldown.a6p)

Shows how to create menu separators, create accelerator keys, and remove the 
File menu.

Radio Buttons (Radiob.a6p)

Shows how to set up radio button logic.

Rat Maze (Ratmaze.a6p)

Demonstrates how to build a maze game.

RealNetworks (Real.a6p)

Shows how to use the RealPlayer Control for ActiveX in Authorware.

Referring to Icons (Refer.a6p)

Shows how to refer to the value of a variable at an icon.

RGB (RGB.a6p)

Shows how to use RGB to change the color for the drawing functions.
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Right and Left Clicks (Rightclk.a6p)

Demonstrates how to create a hot spot that responds to left and right 
mouse clicks.

Rotating Graphic (Rotate.a6p)

Demonstrates how to rotate a graphic based on the position of a slider or a 
value that the user enters.

RTF Objects Editor (RTF.a6p)

Shows how to use the RTF Objects Editor to create a media rich RTF file within 
Authorware with graphics, variables, expressions, and hyperlinks.

Screen Capture (screencp\Screencp.a6p)

Shows how to capture screens from within Authorware.

Screen Saver (Ssaver.a6p)

Demonstrates how to create a screen saver in Authorware.

Screening Text or Numbers (Screen.a6p)

Provides methods for extracting the characters desired from a string. In the 
example, the user keys in text and it is split into numeric and nonnumeric strings.

Scripting & Expressions (Script.a6p)

Provides basic examples of if...then statements, repeat loops, and the Test function.

Scrollable Lists (Scrllist.a6p)

Demonstrates how to create a scrollable, highlighting list box.

Scrolling Checklist (Scrollck.a6p)

Demonstrates a scrolling checklist: lines of scrolling text with each line preceded 
by a field that you can click to cycle through two or more values.

Set Motion Object (setmotionobject.a6p)

Demonstrates how you can use one motion icon to move a number of 
separate objects.
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Short Text Interaction (Q_txt_s.a6p)

Shows how to create short text interactions so that they anticipate all 
possible responses.

Show Me Credits (Credits.a6p)

Shows how to set up names of the people who contributed to the development 
of the Show Me files.

Slider (Slider.a6p)

Shows how to set up a simple slider.

Smart Glossary (Smart.a6p)

Shows how to set up a general hypertext style that jumps from any term to 
the appropriate definition, using Authorware’s FindText and PageFoundID 
functions.

Snake (Snake.a6p)

Demonstrates how to create a “snake” game.

Storing/Retrieving Information (Write.a6p)

How to read, write, and append text to a file. The user enters text in a text 
response and then can choose a button to write, append, or read the text from 
the text file.

Tab Buttons (Tabs.a6p)

Tabs are a popular metaphor for organizing information. This Show Me 
demonstrates how to create that effect.

Target Area Interaction (Q_target.a6p)

How to set up drag and drop for multiple objects, and the use of a catchall.

Ticker Tape (Ticker.a6p)

Demonstrates how to have a line of text move in a horizontal cycle, like a 
ticker tape.
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Time Limit Interaction (Q_time.a6p)

Setting up a time limit at an interaction.

Tool Palette (Toolpal.a6p)

Shows how to create a movable tool palette.

Tool Tips (Tooltips.a6p)

Shows how to create tooltips—those little yellow reminders that pop up when 
you move the pointer over a button.

Tries Limit Interaction (Q_tries.a6p)

This example uses a musical quiz to demonstrate how to limit the number of 
chances for a user to select an option.

Using ActiveX (activex\Activex.a6p)

Shows how to insert and use ActiveX controls in Authorware. Includes 
demonstrations of a Web browser, a calendar, and Macromedia’s Flash control 
for ActiveX.

Using Lists (Lists.a6p)

Shows how to create and use lists in Authorware. Also shows how to sort lists.

Using ODBC (Odbc\Odbc.a6p)

Shows how to connect to a data source through ODBC. This piece includes 
sample SQL statements to store, retrieve, open, and close a data source.

Using Scripting Xtras (Xtraio.a6p)

Shows how to create a child instance of the File IO Xtra for reading and 
writing a file.

Variable Branching (Decision.a6p)

Shows how to determine a decision path with a variable or expression.

Variable Button Labels (vaributt.a6p)

Demonstrates how to place variable text over a button.
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Window Resize (Winsize.a6p)

Demonstrates how to create a presentation window that the user can resize at 
run time.

XML Parser (XMLParser.a6p)

Shows how to use the XML Parser scripting Xtra (which must be installed in 
your Xtras folder.)
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Objects and WinCtrls.u32

The WinCtrls.u32 file lets you display common Windows controls in your 
Authorware piece. Windows controls are standard interface elements (widgets) 
with which the user can interact. Using a control is a matter of selecting a control 
type and then setting or retrieving properties for that control. 

You can include controls in an Authorware piece either by using the supplied 
Knowledge Objects or by hand-coding. 

About WinCtrls.u32

The Windows operating system already has the capability to display standard 
controls such as buttons, list boxes, and check boxes. Before WinCtrls.u32, you 
had to use a tedious process to simulate these controls in Authorware. Now the 
WinCtrls.u32 file provides a simple interface to these controls. 

When you distribute an Authorware piece that includes a Windows control, you 
must include the WinCtrls.u32 file with the Authorware piece.

Here are some of the features of WinCtrls.u32:

• Support for multiple instances 

• Internal tab order and tab handling 

• Support for the Authorware erase icon 

• Support for the Authorware motion icon 

• Open, flexible architecture (new controls can be added in the future)

• Keypress interactions that remain active when a control has the focus 
(controls don’t “trap” any key presses) 
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• Easy event handling (no need to initialize the event variable after an event 
has occurred) 

• Optional use of the Authorware internal Paste Hand

• Control over colors, fonts, visibility, and appearance 

• Support for standard Windows tooltips 

• Authorware Web Player support 

• Clipboard support

• Right mouse button support 

• Small file size and low memory overhead 

Windows controls offer some advantages over ActiveX controls, including 
the following:

• Unlike an ActiveX control, if you put a Windows control in a Web piece, 
you can run it in Netscape Navigator. 

• ActiveX controls must be registered, but you do not need to register 
Windows controls.

• You cannot redistribute Microsoft Forms 2.0 ActiveX controls unless you are a 
registered Microsoft developer, but anyone can distribute Windows controls.

• You can redistribute one file (WinCtrls.u32) instead of multiple OCXs.

• You don’t have to worry about version conflicts with Windows controls.

• The WinCtrls.u32 file returns data types that Authorware can handle.

• WinCtrls.u32 supports internal tab order automatically.

Before you begin

Before you use WinCtrls.u32, you should know how to use the Authorware 
flowline and icons. Make sure you understand the difference between an icon’s 
title and its ID. You should also know how to create basic scripts in Authorware, 
load custom functions, and create user variables. 

When you use WinCtrls.u32, you can create a carriage return by using \r within a 
text string. This is equivalent to the Authorware variable Return. For example,

"Line 1\rLine 2\rLine 3" 

and 

"Line 1" ^ Return ^ "Line 2" ^ Return ^ "Line 3" 
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are equivalent, and both result in the following display:

Line 1 
Line 2 
Line 3 

In addition, be aware of the following limitations:

• You cannot have a transparent control.

• You cannot layer a control in Authorware. A control is always drawn direct 
to screen.

About Windows Control Knowledge Objects 
You use Windows Control Knowledge Objects to display controls in your 
Authorware piece. The WinCtrls.u32 file provides three Knowledge Objects:

Windows Control Knowledge Object This Knowledge Object creates a single 
instance of a control. (If you want multiple instances, you must use multiple 
Knowledge Objects.) You use this Knowledge Object to create a control before 
you attempt to get or set properties.

For more information, see “Using a Windows Control Knowledge Object to 
create a Windows control” on page 398.

Set Property Knowledge Object After you have created a control, you use this 
Knowledge Object to set the various attributes (called properties) for that control.

For more information, see “Setting a control’s properties with the Set Property 
Knowledge Object” on page 401.

Get Property Knowledge Object You use this Knowledge Object to retrieve the 
current value of a control’s property. The value is placed in a user variable that you 
create or select. Each Knowledge Object can retrieve only one value. 

For more information, see “Retrieving a control’s properties with the Get Property 
Knowledge Object” on page 403.
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Using a Windows Control Knowledge Object to create a 
Windows control

You use the Windows Control Knowledge Object to create a control. After 
creating the control, you’ll use the Set Property Knowledge Object to set the value 
of the control’s properties.

To use a Windows Control Knowledge Object to create a Windows control: 

1 Drag a Windows Control Knowledge Object from the Knowledge Objects 
window onto the flowline at the point where you want to display a control. 

The Windows Control: Introduction screen is displayed. 

2 Click Next, or select Id and Erase Issues, to display the Windows Control: ID 
and Erase Issues screen, then enter the name of the user variable that will be 
used when displaying the control. (ID variables are used by Authorware to 
identify controls.) 

Authorware automatically erases content in many situations. For example, 
exiting the branch of a decision icon that has been set to Erase Contents: Upon 
Exit will erase any content displayed in the branch. Windows controls will also 
be automatically erased. To prevent a control from automatically erasing, select 
Prevent Automatic Erase. 
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3 Click Next, or choose Select Windows Control, to display the Windows 
Control: Select Windows Control screen, then select the type of control you 
want to display. 

For information about each control, see Types of controls in Authorware Help.

4 Click Next, or select Set Size and Position, to display the Windows Control: Set 
Size and Position screen. 

This screen, which appears in front of the Presentation window for your 
Authorware piece, lets you set the size and the position of the control. (The 
height of some controls—for example, ComboBox—is fixed in proportion to 
the font size used.) In the Presentation window you will see a box whose color 
matches the color in the Size/Position Indicator Box Color list. This box 
indicates the current size and position of the control. 
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5 If you want to change the size and position settings, drag within the 
Presentation window to redraw the box. 

The changes are reflected in the settings of the Windows Control: Set Size and 
Position screen. 

6 Click Next, or select Change event variable, to display the Windows Control: 
Change Event Variable screen, then enter the name of a user variable that will 
be triggered when a change event occurs.

A change event occurs when the status of the control changes; see “Using the 
change event variable name” on page 415. 

The use of a change event variable is optional. 

7 Click Next, or select Finish, to display the Windows Control: Finish screen, 
which displays the name of the control that you specified. Click Done to apply 
your settings, or click Back to edit your settings. 
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Setting a control’s properties with the Set Property 
Knowledge Object 

Once you have created a control to display, you can modify (or set) its properties. 
If you do not set a control’s property, the property’s default value is used. 

Some properties depend on the values of other properties. For example, setting 
Enabled to TRUE will appear to have no effect if Visible is set to FALSE.

To set property values: 

1 Drag a Windows Control—Set Property Knowledge Object from the 
Knowledge Objects window onto the flowline at the point where you want to 
set property values. 

The Windows Control—Set Property: Introduction screen is displayed. 
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2 Click Next, or select Id variable, to display the Windows Control—Set 
Property: ID Variable screen, then enter the user variable that you used to 
display the control. (ID variables are used by Authorware to identify controls.) 

If you know the type of control, you can select it from the Windows Control 
Type list. This restricts the properties that display in the following screen to 
those that are relevant to the selected control type. 

3 Click Next, or choose Select properties, to display the Windows Control—
Set Property: Select Properties screen, then select a property in the Available 
Properties list. Then click the right arrow to move it to the Selected 
Properties list. 

4 In the Selected Properties list, click the property once to highlight it. In the 
Property value text box, select or enter a value. 
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5 Click Next, or select Finish, to display the Windows Control—Set Property: 
Finish screen, which displays a summary of the property values that will be 
applied to the control. Click Done to apply these values, or click Back to edit 
the values. 

Retrieving a control’s properties with the Get Property 
Knowledge Object 

Your Authorware piece may need to retrieve the current value of a Windows 
control property. For example, you may need to retrieve the item that is currently 
selected in a list. The Get Property Knowledge Object places the retrieved 
property value into a user variable. 

You can retrieve the value of a control’s property only while that control currently 
exists. This means that although the control doesn’t necessarily need to be visible, 
it must not have been erased before you attempt to retrieve the property value. 

After you’ve decided which property value you want to retrieve, you must 
determine where in the Authorware flowline you want it retrieved. For example, 
you might want to retrieve the value within an interaction icon’s response if that 
response was triggered by a user event such as a mouse click.
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To retrieve a property value: 

1 Drag a Windows Control—Get Property Knowledge Object from the 
Knowledge Objects window onto the flowline at the point where you want 
to retrieve the value. 

The Windows Control—Get Property: Introduction screen is displayed. 

2 Click Next, or select Id variable, to display the Windows Control—Get 
Property: ID Variable screen, then enter the name of the user variable you 
used to display the control. (ID variables are used by Authorware to identify 
controls.)

If you know the type of control, you can select it from the Windows Control 
Type list. This restricts the properties that display in the following screen to 
those that are relevant to the selected control type. 
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3 Click Next, or select Property name, to display the Windows Control—Get 
Property: Property Name screen, then select the property whose value you want 
to retrieve. 

You can retrieve only one property’s value. To retrieve more than one value, you 
must use a separate Knowledge Object for each value. 

4 Click Next, or select Property variable, to display the Windows Control—
Get Property: Property Variable screen, then enter the name of an Authorware 
user variable.

In your Authorware piece, when this Knowledge Object is encountered, this 
user variable will be updated to reflect the retrieved value. 
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5 Click Next, or select Finish, to display the Windows Control—Get Property: 
Finish screen, which displays a summary of the changes that will be made to 
the Knowledge Object. Click Done to apply these changes, or click Back to 
edit the changes. 

Example: Building a list box

The steps for building Windows controls using Knowledge Objects follow the 
same basic procedure: you create a control, set its properties, and check the state 
of the properties.

Following are the basic steps for using Knowledge Objects to build a Windows 
list box. 

To display the ListBox control:

1 Drag a Windows Control Knowledge Object to the flowline. 

The Windows Control: Introduction screen is displayed. 

Note: You will be prompted to save your file if you have not previously saved it.

2 Click Select Windows Control. 

The Windows Control: Select Windows Control screen is displayed. 

3 Select ListBox for the type of control.

4 Click Next to display the Windows Control: Set Size and Position screen. Set 
the dimensions for the list box, and leave all other settings at their defaults. 

5 Click Done.

The following message appears: “The wizard is now configuring the Knowledge 
Object. Please wait.” When wizard is finished, the Knowledge Object is 
displayed on the flowline.
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6 On the flowline, name the Knowledge Object My ListBox. 

To set the control’s properties:

1 Drag a Windows Control—Set Property Knowledge Object to the flowline, 
after My ListBox.

The Windows Control—Set Property: Introduction screen is displayed. 

2 Click Select Properties to display the Windows Control—Set Property: Select 
Properties screen. In the Available Properties section, select the Items property, 
then click the right arrow to move it to the Selected Properties section. 

3 In the Property Value text box, type green\rblue\rorange\rred\rpurple.

4 Click Done.

5 On the flowline, name the Knowledge Object Set List Items. 
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To retrieve the ListBox control’s property value:

1 Drag an interaction icon to the flowline and name it Get Clicked Item.

2 Attach a map icon as a conditional response and name it wcChangeEvent (the 
default name of the wizard variable). 

3 In the Conditional tab of the Properties window, set the conditional response 
to Automatic: On False to True. 

4 Open the Map and drag a Windows Control—Get Property Knowledge 
Object to the flowline. 

The Windows Control—Get Property: Introduction screen is displayed.

5 Click Property Name to display the Windows Control—Get Property: Name 
screen. From the pop-up menu, select Value. 

6 Click Next to display the Windows Control—Get Property: Property Variable 
screen. Make sure the value of the variable is =wcPropertyValue. 

7 Click Done. If a message appears alerting you that the wcPropertyValue 
variable will be created, click Yes.

When the Knowledge Object is created, it is displayed on the flowline.

8 On the flowline, name the Knowledge Object Get Value. 

9 Drag a calculation icon to the flowline. Title it myitems. Open it and type 
something like the following to define a new user variable that returns a 
delimited list called myitems:

myitems:=”item1\ritem2\ritem3\ritem4”

10 Directly under Get Value, drag a calculation icon to the flowline. Open it and 
type the following: 

clicked := GetLine(myItems, (wcPropertyValue + 1) ) 
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Note: The list item numbering is zero-based—that is, the first item is 0, the second is 1, 
the next is 2, and so on.

11 Drag a display icon to the flowline, name it Show Values, and open it. Use the 
Text tool to type the following: 

value: {wcPropertyValue} list item: {clicked}

When you are finished, your flowline should look like the one below.

12 Save your Authorware piece. 

You’re done! You’ve used Windows controls to display a list box and to retrieve 
the text of the selected ListBox item.
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Available Windows controls and properties 
There are a number of different Windows controls, each of which has a number of 
valid properties that can be read or set. The following table displays all of the 
currently available controls and properties. An X indicates that the property is 
valid for that control type.

For more information, see Types of controls and Windows control properties in 
Authorware Help.
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For information about the types of controls, variables, and functions available, see 
Using Windows controls Knowledge Objects and WinCtrls.u32 overview in 
Authorware Help.
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Using Authorware Windows controls 
variables
In general, the only types of Authorware user variables that you can use with 
Windows Control Knowledge Objects are regular and list variables. User icon 
variables are not currently supported, although you can use them if your controls 
are hand-coded. For more information, see “Using user icon variables” on page 418.

To use a variable, precede the name with an equal sign (=), except in the Property 
Value field for VariableName where you do not precede the name with an equal 
sign if the name is the actual name of the variable to use.

Note: The normal rules for valid user variable names still apply. For example, variable 
names must begin with a letter.

Using variables in a Windows Control Knowledge Object 

In a Windows Controls Knowledge Object, a user variable is needed for the 
control ID. Similarly, user variables can be used to position a control and they are 
used to indicate Change Events. 

These variable names are always preceded with an equal sign (=). You can use an 
existing variable, or you can create a new variable. If the name you enter for the 
variable refers to a user variable that does not exist, it is created.

Using variables in a Set Property Knowledge Object 

In the Windows Control Set Property Knowledge Object, variables are used to set 
properties for a control. User variables can also be used for any property (except 
read-only properties). You enter the name of the variable in the Property Value field.

If you are setting the VariableName property and are entering the actual name of 
the user variable, do not precede the variable name with an equal sign. The 
variable will not be created if it does not already exist—you must create the 
variable in your Authorware piece. You can still use a user variable, whose value is 
the name of the actual user variable, by preceding it with an equal sign in the 
normal manner. 

Using variables in a Get Property Knowledge Object 

You must include user variables to get properties from a control. Add the user 
variable name (this variable is the one that was originally used when the control 
was created) immediately after the equal sign without any leading spaces. If the 
variable does not already exist, it is created. On some screens, the equal sign is 
preset and cannot be removed. Add the variable name immediately after the equal 
sign without any leading spaces. If the variable does not already exist, it is created.
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Using the change event variable name

The variable ChangeEventVarName (or change event variable name) is a type of 
event—for example, a single click on an item in a control. The change event 
variable changes from 0 (FALSE) to 1 (TRUE) and then immediately back to 0. 
You can use this user variable in a conditional response (set to On False to True) so 
that Authorware can respond to the event of the user clicking a button. 

When the user double-clicks a control (for example, an item in a list box), the 
change event variable changes from 0 to 2. While a value of 2 is still TRUE (any 
positive number is TRUE), it will allow you to distinguish between a single click 
and a double click. 

The use of a change event variable name is optional. Use it when necessary; it does 
have a small effect on performance.

You should not explicitly set the change event variable to 0 immediately after it 
has been triggered. Doing so may result in WinCtrls.u32 resetting the variable to 
1. In general, you should not have to explicitly set the change event variable’s 
value, because WinCtrls.u32 will control its value.

Using List Variables

If you are using list variables with Windows controls, the list variables must be 
given the appropriate initial value, otherwise Windows controls may not be able 
to update the variable’s value correctly. You can select the variable name in the 
Variables dialog box and edit the Initial value field. Linear list variables should be 
initialized as [] and property list variables should be initialized as [:].

About the control ID number 

Each time a control is created, it can be given a unique ID number that is usually 
assigned to an Authorware user variable. If you use the wcDisplayControl 
function in a calculation icon, you aren’t required to assign the ID to a variable; 
however, if it isn’t assigned, you won’t be able to reference the control—for 
example, to set a property. 

The number is actually the return value from the function that creates the control. 
Authorware can communicate with a control: it does so by referencing the 
control’s ID number (by means of the variable). 
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Here is a simplified representation of a typical communication between 
Authorware and WinCtrls.u32:

Authorware: WinCtrls, display an edit control that I’ll call foo. 

WinCtrls: OK, I’ve done it and I’ve called it 1234. (That is, foo is 1234.) 

Authorware: WinCtrls, tell "foo" to change its font to Arial. 

or 

foo := wcDisplayControl( 400, 120, 300, 20, "Edit" ) 
wcSetPropertyValue( foo, "FontName", "Arial" ) 

You need to create the control before you can set any of its properties. Also, you 
must not set two current controls to the same Authorware user variable. 

Coding a control 

Before you start, check that the WinCtrls.u32 functions wcDisplayControl(), 
wcGetPropertyValue(), and wcSetPropertyValue() have been loaded into 
your Authorware piece.

Creating a control

In general, use code like this to create a control within a calculation icon:

control Var := wcDisplayControl( x1, y1, width, height, control
name[, change event variable name] ) 

This code uses the following arguments: 

• control Var is the Authorware user variable that will contain the ID number 
of the control after it has been created. 

• x1 is the x coordinate of the upper left corner.

• y1 is the y coordinate of the upper left corner. 

• width is the pixel width. 

• height is the pixel height. 

• control name is the type of control. 

• change event variable name is name of the Authorware user variable that is 
to change from 0 (FALSE) to 1 (TRUE) each time a change event occurs. 

Here is an example of creating a control:

ctrl_ID := wcDisplayControl( 125, 60, 325, 150, "Memo",
"ctrl01Change") 
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Displaying a control

To display a control, use code like this within a calculation icon:

control Var := wcDisplayControl( x1, y1, width, height, control 
name, [ change event variable name] ) 

Here is an example of displaying a control:

ctrl_ID := wcDisplayControl( 125, 60, 325, 150, "Memo",
"ctrl01Change") 

Setting the property of a control

To set or change a control’s property, make sure you have already created the 
control and used an Authorware variable to capture the resulting return value. 
This return value is the control’s ID number. Typically, the code to change a 
property looks like this: 

Result := wcSetPropertyValue( ID number, property name, Value ) 

For more information, see the function wcSetPropertyValue in Authorware Help.

Here is an example of changing a control’s property: 

ctrl_ID := wcSetPropertyValue( ctrl_ID, "MaxLength", "100") 

WinCtrls.u32 should typecast property values for you. For example, each of the 
following lines shows two equivalent values:

1, "1"

"True", TRUE

Similarly, each of the following lines shows two equivalent values:

0, "0"
"False", FALSE
100, "100"

Reading a property’s current value

To get a property’s value, the control must currently exist. Typically, your query 
would look like this: 

Value := wcGetPropertyValue( ID number, property name ) 

Here is an example of reading a property’s value:

myFont := wcGetPropertyValue( ctrl_ID, "FontName" ) 

For more information, see the function wcGetProperty value in Authorware Help.
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Using user icon variables 

If you are an experienced authors who is familiar with scripting in Authorware, 
you can hand-code a control. When hand-coding a control, you can use user icon 
variables for both the control ID and the change event variable name. 

For example, if there is an icon titled "My Settings", a variable bar@"My 
Settings" could be used as the control ID like this: 

bar@"My Settings" := wcDisplayControl(100, 100, 200, 120, "Memo")
wcSetPropertyValue(bar@"My Settings", "FontName", "Arial") 

If the user icon variable is also a list variable, it could be used like this: 

bar@"My Settings"[1] := wcDisplayControl(100, 100, 200, 
120,"Memo")
wcSetPropertyValue(bar@"My Settings"[1], "FontName", "Arial") 

For the variable foo@"My Settings" to be used as the change event variable 
name, the variable needs to be in a form that will be evaluated correctly. That is, 
the double quotation marks need to be preserved. 

For example, the following variables are all invalid: 

newCtrl := wcDisplayControl(100, 100, 200, 120, "Memo", 
"foo@""My Settings"")
newCtrl := wcDisplayControl(100, 100, 200, 120, "Memo", 
"foo@\"My Settings") 
newCtrl := wcDisplayControl(100, 100, 200, 120, "Memo", "foo@My 
Settings") 
newCtrl := wcDisplayControl(100, 100, 200, 120, "Memo", foo@"My 
Settings") 

Authorware will incorrectly see My Settings as a user variable, return syntax 
errors, or simply not work. 

You must “escape” the double quotation marks so that Authorware recognizes 
them as part of the variable name and not as the ends of text strings; you must also 
add double quotation marks to redefine the text strings. One way is to use 
Char(34), the Authorware equivalent of the double quotation mark, in place of 
the user variable’s quotation marks: 

"foo@" ^ Char(34) ^ "My Settings" ^ Char(34) 

If the variable is also a list variable, you could use code like this: 

"foo@" ^ Char(34) ^ "My Settings" ^ Char(34) ^ "[1]" 

A simpler way is to precede the double quotation marks that need to be preserved 
with a backslash: 

"foo@\""My Settings\"" 

If the variable is also a list variable, you could use code like this: 

"foo@\""My Settings\"[1]" 
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For example, the following two code samples show the two methods of using the 
name of the user icon variable foo@"My Settings" for the change event variable: 

newCtrl := wcDisplayControl(100, 100, 200, 120, "Memo", 
"foo@"^Char(34)^"My Settings"^Char(34)) 

newCtrl := wcDisplayControl(100, 100, 200, 120, "Memo", "foo@\""My 
Settings\"" ) 

Note: The normal rules for valid user variable names still apply. For example, variable 
names must begin with a letter. 
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controlling text with  190
CharCount variable

controlling text with  189
check boxes

setting up  256
Checkboxes Knowledge Object  53
child objects

description of  332
functions for  333
functions for using  333
identifying  334
using  332

ChoiceNumber variable  343
ChoicesMatched variable  342,  343
Index422



chroma key, for video effects  234
Circle function  222
CMI

functions for  351
variables for  349

CMI system
setting up courses for  348

CMI tab  348
Knowledge track settings and  348

Code function
controlling text with  190

Coloring icons  48
commands

on pull-down menuscommands
See also individual commands

Commands menu
adding a command  182

comments
in authoring practice  164
uses for  314

compacting files  165
compressing files

for distribution  174
sound files  226

conditional expressions, branching based on  281
conditional interactions  267
conditional user responses

Automatic setting for  268
step-by-step instructions for  270

conditions
alternatives for  325
multiple, checking for  325
using  326

conditions in scripts
If...Then statements  324
repeat loops  326

content
creating  184
embedding  184
incorporating  184
linking  184
linking to pieces  47
management advantages  237
management tools  238

See also specific types
managing  237
media libraries  239

content, (continued)
OLE used for  184
Web-packaged pieces and  366
Xtras used for  184

Continue branching option, 
in conditional response  270

Control Panel window, troubleshooting with  167
Control Panel, for running pieces  34,  50
conventional DLLs  320
Copy File Knowledge Object  53
copying files  53
correct responses, indicating  339
CorrectChoicesMatched variable  343
counter, using  326
courses

setting up for CMI systems  348
Create RTF Object Knowledge Object  54
creating digital movies  230
creating graphics  219
creating sounds  225
creating text  187
creating video  234
cross-platform conversion  229
custom functions

in DLLs, loading  321
in DLLs, using  320
methods vs.  331
step-by-step instructions for  321

custom variables
overview of  316
saving performance information with  345
using  315

Customizing icons  48

D

data variables, in authoring development stage  35
databases

connecting with  356
managing information with  347
text from  186

decision icons
branching and  277
dragging files onto  48
role of  38
troubleshooting  166

decision structures
description of  274,  277
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decompression program, in distribution package  180
DeleteLine function

controlling text with  190
DeleteObject function

for child object  333
design

as authoring stage  34
for Internet services  369
Web-packaged piece  360

Design window
flowline in  34

development
models used in  245
using External Media Browser in  241

diagonal line tool
using  219

DIB file support  229
digital movie functions  232

See also specific functions
digital movie icons

in libraries  243
role of  39,  230

digital movie variables
listed  231
See also specific variables

Direct to Grid motion type  303
Direct to Line motion type  303
Direct to Point motion type  303
directing flow

automatically  277
overview of  273

Director movies
importing  230
in distribution package  180
retaining interactivity of  230
saving as QuickTime movies  231
support for  229

Director Shockwave movies, Shockwave ActiveX 
control for  229

DirectToScreen variable
for images  222

discussion group, Authorware  16
disk space

distribution options and  165
disk, as distribution option  173
disk-and-network delivery, 

as distribution option  173,  174

display icons
in libraries  243
rearranging order with  221
role of  38,  218
troubleshooting  166

DisplayHeight variable
for images  222

DisplayLeft variable  222
DisplayTop variable  222
DisplayWidth variable  222
distribution

basics of  172
digital movie issues  229
external content issues  238
intranet options for  357
libraries and  243
media for  173
network options for  357
of Authorware Web Player  367
of files with Authorware pieces  180
optimizing file size for  174
World Wide Web options for  357

DLLs
as custom functions  321
conventional DLLs  320
custom functions in  320
search path and  321

downloading
design considerations for  360
functions for  364
non-web-packaged pieces  369
onDemand option  366

downloads
Internet considerations for  296

Drag and Drop exercises  52
Drag and Drop Question Knowledge Object  52
drag-and-drop feature

for importing content  47
for importing digital movies  230
for importing sound files  226
for importing text  188
for linking content  47
to target area  264

dragging objects
letting users drag objects  304

DrawBox function  222
DrawCircle function  222
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drawing
creating graphics  219

DrawLine function  222
drivers

in distribution package  180

E

editing
links  185
text  186

educational applications
database connectivity for  356
Internet access with  368

Embedding and linking content
description of  184

embedding content
description of  184
linking content vs.  184
step-by-step instructions for  185
to flowline  47

Empty option  381
EntryText variable

controlling text with  189
in text-entry user response  263
user responses recorded in  345

erase icons
role of  38

Eval function
controlling text with  190

EvalAssign function
controlling text with  190

evaluation, as authoring stage  35
EventLastMatched variable  331
EventQueue variable  331
events

defined  330
limiting use of  272
overview of  270
sprite  329,  330
variables for managing  330

EventSuspended variable  331
exercises, types of  52
Exit Framework/Return option  291
Explorer (Windows), 

dragging or dropping content from  47

expressions
as External Media Browser pathnames  238,  241
branching based on  280
defining links with  185
displaying values onscreen  323
in scripts  323
overview of  307,  322
step-by-step guide to  323
using  322
using to go to pages  291
where used  308

external content
features  238
naming scheme for  164
rhythm and pace concerns  164
using  241
Web-packaged pieces and  366

external images, linking to  220
External Media Browser

development uses  241
distribution uses  241
features  242
managing content with  238
role of  184,  238
step-by-step instructions for  242
using  241

external software modules, in distribution package  181
external sounds, in distribution package  180

F

feedback
providing  344
with conditional responses  269

File command (Modify menu), 
for setting up file properties  163

File Knowledge Objects  53
file names

naming scheme for  164
file properties

setting up  163
File Properties dialog box

CMI tab in  348
options, listed  163

File Transfer Protocol (FTP) functions  346
FileIO scripting Xtra

GetOSDirectory function  332
version method in  333
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FileLocation variable
paths to folders stored in  346

files
compacting  165
dragging onto flowline  47
external content  238,  242
jumping to  295
linking to  47,  220
media libraries vs.  239
naming scheme for  164
network download speed  358
optimizing size of  174
saving  165
saving user responses in  346
selecting for distribution  180

Find CD Drive Knowledge Object  53
Find command (Edit menu)

for text  189
Find function

controlling text with  190
finding text  189
FirstTryCorrect variable

in performance summary  344
tracking and  343

FirstTryWrong variable
in performance summary  344
tracking and  343

FLC/FLI movies
support for  229

flow
directing  273
directing automatically  277
Internet and  275

flowline
breaking into sections  164
comments on  164
dragging files onto  48
embedding or linking content to  47
importing digital movies to  230
importing sound files to  226
in icon-based authoring  33
inserting sprites on  329
interaction  252
models  240,  245
troubleshooting methods  166

FlushEventQueue function  331

Font Resources
Knowledge objects for  53

fonts
in distribution package  180

ForceCaps variable
controlling text with  189

formatting, imported text and  187
framework environment

how it works  286
framework icons

dragging files onto  48
overview of  285
role of  38

framework window  285
frameworks

description of  284
navigation controls for  287
nesting navigation frameworks  287

FTP functions
as distribution option  368
listed  370

FTP UCD  370
FTP UCD (Windows)

storing user responses with  346
FtpAbort function  370
FtpAppend function  370
FtpChangeParentDir function  370
FtpChangeWorkingDir function  370
FtpClose function  370
FtpConnect function  370
FtpDelete function  370
FtpDisconnect function  370
FtpGetWorkingDir function  370
FtpList function  370
FtpMakeDir function  370
FtpNameList function  370
FtpOpen function  370
FtpRemoveDir function  371
FtpRename function  371
FtpResult function  371
FtpRetrieve function  371
FtpStatus function  371
FtpStore function  371
functions

CMI functions  351
controlling images with  222
controlling sound with  227
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functions, (continued)
controlling video with  235
custom, methods vs.  331
digital movie  232
for event management  330
for Knowledge Objects  376
for movies  231
for parent and child objects  333
for sprite icons and properties  330
for Web-packaged pieces  364
image, listed  222
in scripts  323
Internet-related  363,  364
JumpFileReturn function  296
overview of  307,  318
purpose of  308
sound, listed  228
step-by-step instructions for  315,  321
syntax of  319
system, overview of  319
text, listed  190
troubleshooting  167
video, listed  235
where used  308

functions, listed  370

G

Get RTF Object Text Range Knowledge Object  55
GetIconProperty function

for sprite icons  330
GetLine function

controlling text with  190
GetMovieInstance function  232
GetNumber function

controlling text with  190
GetSpriteProperty function  330
GetWord function

controlling text with  190
global functions

identifying  334
using  332

GlobalPreroll variable  363
GlobalTempo variable  331
Go Back links  290
GoToNetPage function  364

graphics
as content  183
controlling with functions  222
controlling with variables  222
creating  219
embedding and linking  185
integrating  219
positioning  220
step-by-step instructions for  223
synchronizing with audio and video  226
working with  218

graphics file formats, Internet delivery and  360
graphics files, in distribution package  180
graphics functions

listed  222
See also specific functions

graphics variables
listed  222
See also specific variables

grid, displaying images on  220
Group command

for selected icons  47
Grouping icons  48
grouping images  220
Guidelines for using sound  224

H

hard disk capacity, distribution options and  165
hard disk, saving user responses on  346
hardware requirements

bitmap resolution and  218
distribution options and  172
fonts and  186

help features
Authorware Attain Help Pages  15
for sprite Xtras  330
step-by-step guide  36

Hot Area exercises  52
Hot Object exercises  52
Hot Object Question Knowledge Object  52
hot objects

limiting use of  272
overview of  261
step-by-step instructions for  261

Hot Spot Question Knowledge Object  52
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hot spots
limiting use of  272
overview of  260
response type symbols and  252
step-by-step instructions for  260
working with  260

hot text
attaching navigation links to  295
role of  186

HotTextClicked variable  342
controlling text with  189

hypertext
creating  295
creating links  295
HotTextClicked variable and  342
navigating with  295
role of  186
step-by-step instructions for  295

I

Icon color palette
role of  39

icon palette
description of  34

icon properties
troubleshooting  167

icon titles
comments in  164

icon-based authoring  36
icons

coloring  48
comments with  164
customizing  48
embedding or linking content to  47
framework icons  285
grouping in a map  48
in library files  239
Knowledge Object icons  380
motion icons  303
naming  47
naming scheme for  164
navigate icons  284
rearranging  47
result icons  251
selecting multiple  47
troubleshooting methods  166,  167,  168
working with on flowline  164

See also Knowledge Object icon
If...Then statements

in scripts  324
image file formats, Internet delivery and  360
image functions

listed  222
See also specific functions

Image Properties command
authoring and  48

image variables
listed  222
See also specific variables

images
bit-depth considerations  218
bitmap resolution for  218
combining sound with  226
controlling with functions  222
controlling with variables  222
creating  219
dragging onto display icon  47–48
importing, platform and  220
integrating  219
Internet delivery issues  360
linking to  220
positioning  220
properties of  48
step-by-step instructions for  223
synchronizing sound with  226
working with  218

implementation, as authoring stage  36
Import command

in icon-based authoring  47
importing graphics

bitmap resolution and  218
types of images  220

importing movies
quick method for  230

importing sounds
description of  226

importing text
uses for  187

In Area property  302
incorrect responses, indicating  339
Insert RTF Object Hot Text Interaction Knowledge 

Object  55
InsertLine function

controlling text with  190
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Inspectors command (Windows menu), 
for images  220

installation instructions, distribution options and  173
installer program

distribution options and  173
in distribution package  180

installing
Authorware  15

interaction flowline  252
interaction icons  249

dragging files onto  48
graphics in  218
how they work  249
in libraries  243
role of  38

Interaction Properties dialog box  349
interactions

advantages of  247
components of  248
conditional  267
in authoring development stage  35
Internet delivery issues  360
judging  339
limiting  272
methods  255

See also specific methods
overview of  247
results of  248
saving as models  240
step-by-step instructions for  255
structure of  249
text entry by users  263,  264
time limits and  267
tracing flow through  251
using  247

Interface Components Knowledge Objects  53
Internet

as distribution option  173–174,  357
bit-depth considerations  218
CD-Web hybrid solutions  360,  371
flow and  275
functions for  363,  364
jumping to other files and  296
navigation structures and  288
preparing a piece for  177
saving user responses over  346
speed considerations  358
variables for  363

Internet applications, packaging and distributing  36
Internet Knowledge Objects  54
Internet services

designing for  369
using  368

intranet applications
packaging and distributing  36
speed considerations  358
Web access and  368

intranets
as distribution option  ??–174
Authorware Web Player and  357

J

JudgedInteractions variable
in performance summary  344
tracking and  343

JudgedResponses variable
in performance summary  344
tracking and  343

judging interactions  339
Jump to Authorware File Knowledge Object  53
JumpFile function  296,  364

URLs with  369
JumpFileReturn function  296,  364

URLs with  369
jumps

as one-way navigation structures  292
Internet considerations for  296
navigation links and  290
to files  295
to specific pages  290

K

keypress responses
limiting use of  272
overview of  262
using  262

keywords
naming scheme for  164
using  164

Knowledge Object icons
description of  380
options for  381
properties for  381
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Knowledge Objects  51
communicating with  382
displaying  374
for a new file  50
functions for  376
introduction to  50
launching wizards from  375
overview for developers  373
step-by-step instructions for  379
uses for  373
using  51
variables for  376
wizard user interface and  381

Knowledge Objects window  374
Knowledge Track

overview of  348
settings for  348

L

LastLineClicked variable  343
LastObjectClicked variable  343
LastParagraphClick variable  343
LastWordClicked variable  343
LastX/LastY variables  222
Launch Default Browser Knowledge Object  54
Layer setting

for digital movies  231
for display icon  221

Layer variable  222
layering text and graphics  221
libraries

adding icons to  243
button  257
in Authorware  239
packaging  176
step-by-step instructions for  244
using  243

library search path, as distribution requirement  173
limiting user responses  272
Line function  222
LineClicked variable  342
LineCount function  190

controlling text with  190
Link to File option

for linking images  220
linked files, in distribution package  180

linking content  185
digital movies  230
embedding content vs.  184
external content files  238
external images  220
External Media Browser for  238
media libraries  239
models  240
step-by-step instructions for  185
video  234

linking content to flowline
dragging from browser and  48
File menu, Import command, 

in icon-based authoring  47
links

editing  185
navigation links  290

List Recent Pages links  291
lists

using  326
local area network (LAN)

as distribution medium  173,  174
saving user responses on  346
speed considerations  358

Lock Icon option  381
logical variables

for conditional responses  268
Login for an assessment  53
Login Knowledge Object  53
LowerCase function

controlling text with  190

M

Macromedia Press  17
Macromedia Web site, providing link to  367
map icons

as result icon  249,  251
role of  38

MapChars function
controlling text with  190

MatchedEver variable  343
MatchedIconTitle variable  343
media

available types of  183
distribution options  173
See also external media

media editors  184
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media libraries  239
as design tool  35
button libraries vs.  243
features  244
step-by-step instructions for  244
using  243

Media Sychronization  48
media synchronization  227
MediaLength variable

for digital movie  231
for video  235

MediaPause function
for digital movie  232
for sound  228
for video  235

MediaPlay function
for digital movie  232
for sound  228
for video  235

MediaPlaying variable
for digital movie  231
for sound  227
for video  235

MediaPosition variable
for digital movie  231
for sound  227
for video  235

MediaRate variable
for digital movie  231
for sound  227
for video  235

MediaSeek function
for digital movie  232
for sound  228
for video  235

menus
pull-down  258
pull-down, limiting use of  272

Message Box Knowledge Object  53
methods

custom functions vs.  331
defined  331
parent and child objects and  332
sprite  331
sprite, properties  329

Microsoft Calendar ActiveX control, 
events sent by  330

Microsoft Web Browser, events sent by  330
Microsoft Word, RTF text in  187
MidXtra, child object created from  332
minus sign (-)

as incorrect response indicator  340
models

defined  245
features  246
sharing  245
step-by-step instructions for  246
uses for  240
using  245

motion effects
description of  299
in authoring development stage  35
tracking for objects  305
with digital movies  230
working with  302

motion icons
role of  38
using  303

motion types
Direct to Grid  303
Direct to Line  303
Direct to Point  303
Path to End  303
Path to Point  304

Move Cursor Knowledge Object  53
Movie Controller Knowledge Object  54
Movie Icon Properties dialog box, settings in  230
movie sychronization with display icons  227
movies

as content  183
combining sound and graphics in  226
creating  230
distribution issues  229
embedding and linking  185
formats for  229
functions for  231
integrating  230
media synchronization  227
on asset list  35
playing range of frames from  230
positioning  220
step-by-step instructions for  232
using efficiently  230
using functions with  232
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movies, (continued)
using motion with  230
using variables with
variables for  231
working with  228

moving objects
with motion icon  302

MPEG file support, for movies  229
multimedia pieces

authoring help guide  36
authoring practice tips  163
authoring stages  34
creating content for  184
icons in  33,  38–39
interaction for. See interactions
packaging  180
troubleshooting  166

Multiple Choice exercises  52
Multiple Choice Question Knowledge Object  53
multiple icons, selecting  47

N

naming icons  47
naming scheme, creating  164
navigate icons

description of  284
role of  38

navigating
with hypertext  295

navigation controls
for frameworks  287

navigation frameworks
nesting  287

navigation links
attaching to hot text  295
step-by-step instructions for  294
using navigate icons for  290
working with  290

navigation structures
considerations for  288
description of  274,  284
in authoring development stage  35
Internet and  288
overview  284
step-by-step instructions for  289

Nearby links  291

nested repeat loops
in scripts  323

nesting calls  293
nesting navigation frameworks  287
NetAbort function  364
NetBrowserName variable  363
NetBrowserVendor variable  363
NetBrowserVersion variable  363
NetConnected variable  364
NetDownload function  364
NetDownloadBackground function  364
NetDownloadName function  365
NetError function  365
NetFileSize function  365
NetLastModDate function  365
NetLocation variable  364
NetPercentDone function  365
NetPreload function  365
network

as distribution option  173,  174,  357
disk delivery combined with  173,  174
saving user responses on  346
speed issues  358

New File Knowledge Objects  52
NewObject function

for child object  332,  333
NumCount function

controlling text with  190
NumCount variable

for conditional response  268
NumEntry/NumEntry2/NumEntry3 variables

user responses recorded in  345
numerical variables  317

O

object type, icon type and  33
ObjectClicked variable  342
ObjectMatched variable  342
ObjectMoved variable  342
object-oriented programming, 

parent and child objects  332
objects

hot  261
layering  221
letting users drag  304
moving  302
on asset list  35
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objects, (continued)
positioning  301
positioning on a path  301
positioning on the screen  302
positioning within an area  302
tracking motion of  305
tracking position of  305

OLE objects
as content  184

On Path property  301
onDemand download option

content management with  366
One-button publishing

purpose of  359
settings  179
using to package a piece  178

one-way trips. See jumps
online help  15
Open Database Connectivity (ODBC) capabilities

advantages of  356
sample uses for  186

Open File Dialog Box Knowledge Object  54
Open File Dialog Knowledge Object  54
operating system

distribution options and  172
testing with  172

operators
overview of  322
types of  322

optimizing file size  174
oval tool  219
Overlapping function  222

P

pace, in authoring practice  164
packaging

basics of  175
files included in  175
in distribution stage  36
libraries  176
process for  175
step-by-step instructions for  177

pages
backtracking to  290
jumping to  290
searching for  292
using expressions to go to  291

paging structures
description of  282
for text  188
RTF files and  282

paragraph ruler  187
ParagraphClicked variable  343
parent objects

description of  332
functions for using  333
identifying  334
using  332

parsing XML files  335
pasting text  188
path

for Web-packaged piece  366
in External Media Browser  238,  241
to records folder  346

Path to End motion type  303
Path to Point motion type  304
paths

positioning objects on  301
Peachpit Press  17
PercentCorrect variable

in performance summary  344
tracking and  343

PercentWrong variable
in performance summary  344
tracking and  343

performance
bit depth and  218

performance summary, providing  344
performance, tracking and recording  337

providing feedback  344
step-by-step instructions for  347
storing information  345
system variables for  340

perpetual interactions
pull-down menus as  258
step-by-step instructions for  271

PICS movies
as external files  229
See also movies

plus sign (+)
as correct response indicator  340

pointer tool
for positioning graphics  220
using  219
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polygon tool
using  219

position, tracking for objects  305
positioning objects

description of  299,  301
on a path  301
on the screen  302
within an area  302

Preload function  365,  369
Preroll variable  364
Presentation window

hot spots on  260
in icon-based authoring  34
Internet delivery and  360
layering graphic objects in  221
sprite Xtras for  329
using Text tool in  187
using toolbox in  219

PresetEntry variable
controlling text with  189

PreviousMatch@IconTitle variable  343
properties

defined  330
In Area property  302
Knowledge Object icons  381
of sprite icons  330
of sprite icons vs. sprites  330
On Path property  301

Properties dialog box
for positioning graphics  220

prototypes, as authoring stage  35
pull-down menus

overview of  258
setting up  258
step-by-step instructions for  259

Q

QuickDraw 3D sprite icon, properties of  329,  330
QuickTime for Windows drivers, 

in distribution package  180
QuickTime movies and QuickTime for Windows

drivers  180
in distribution package  180
saving Director movies as  231
support for  229
See also movies

quitting
wizards  375

Quiz Knowledge Object  52

R

radio buttons
description of  256
uses for  256

Radio Buttons Knowledge Object  54
RAM requirements

distribution and  172
random branching

overview of  279
Randomly To Unused Path option  279
Read INI Value Knowledge Object  53
Read Me files, distribution options and  173
ReadExtFile function  365

URLs with  369
ReadURL function  365
rearranging icons  47
Recent navigation link  290
recording performance

in Authorware  345
in database  347
in external files  346
providing feedback  344
step-by-step instructions for  347
system variables for  340

records folder, saving user responses in  346
RecordsLocation variable

paths to folders stored in  346
rectangle tool

using  219
Reduce function

controlling text with  190
referral applications, database connectivity for  356
relative path

advantages of  241
removable disk, as distribution option  173
repeat loops

in scripts  326
RepeatString function

controlling text with  190
Replace function

controlling text with  190
ReplaceLine function

controlling text with  190
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ReplaceString function
controlling text with  190

ReplaceWord function
controlling text with  191

Reset Path On Entry option  279
ResetBandwidth function  365
Response Properties Dialog Box  349
response type symbol

in interaction  249,  250
responses. See user responses
ResponseStatus variable  343
ResponseTime variable  340
result icons

content of  251
interactions and  249
response type symbols and  251

result path  249,  251
results, in interactions  248,  249
RFind function

controlling text with  191
RGB function  223
rich text format (RTF) files

importing text in  187
paging structure and  282

right responses, indicating  339
round trips. See calls
rounded rectangle tool  219
RTF files

paging structure and  282
RTF functions  214
RTF Knowledge Objects

Create RTF Object 
Knowledge Object  211,  212

Get RTF Object Text Range 
Knowledge Object  211,  213

Insert RTF Object Hot Text Interaction 
Knowledge Object  212

RTF Object Hot Text Interaction 
Knowledge Object  213

Save RTF Object Knowledge Object  211
Search RTF Object Knowledge Object  212,  213
Show or Hide RTF Object 

Knowledge Object  211,  212
using with RTF document  211

RTF Objects
publishing for the web  218

RTF Objects Editor  192

RTF Objects Knowledge Objects  54
RTFObj.u32  214
Run Wizard option  381
run-time applications  175

S

sampling rate, for sounds  224
Save and Compact command

File menu  165
Save As command

File menu  165
Save command

File menu  165
Save File Dialog Box Knowledge Object  54
Save RTF Object Knowledge Object  54
saving

performance information  345
your work  165

Scoring for an assessment  53
Scoring Knowledge Object  53
screen

displaying text on  186
positioning objects on  302

scripting  323
defined  323
If...Then statements  324
overview of  323
repeat loops  326
step-by-step instructions for  327

scripting Xtras
overview of  332
parent and child objects with  332

scrolling structure for text  188
Search navigation links, searching for words and  292
search path

DLLs and  321
Search RTF Object Knowledge Object  55
searches

for pages  292
searching

for text  189
security features

non-web-packaged pieces and  370
saving user responses and  346

selecting multiple icons  47
Send Mail Knowledge Object  54
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Send to Back command
for layering objects  221

senders
overview of  270
sprite events and  330
sprite methods and  331

SendEventReply function  331
sequential branching

overview of  278
server

configuring for web-packaged files  367
Set File Attribute Knowledge Object  53
Set Window Caption Knowledge Object  54
SetFill function  223
SetFrame function  223
SetIconProperty function

for sprite icon  330
SetLine function  223
SetMode function  223
SetPalette function  223
SetSpriteProperty function  330
Shockwave ActiveX control, 

for Director Shockwave movies  229
Short Answer Question Knowledge Object  53
Short Text exercises  52
Show Me examples  16
Show or Hide RTF Object Knowledge Object  55
Single Choice Question Knowledge Object  53
Slider Knowledge Object  54
software modules, in distribution package  181
sound capabilities, distribution options and  173
sound files

compressing  226
creating  225
editing before importing  224
embedding and linking  185

sound functions
listed  228
See also specific functions

sound icons
in libraries  243
role of  39

sound synchronization with display icons  227
sound variables

listed  227
See also specific variables

SoundBytes variable  364

SoundPlaying variable  227
sounds

as content  183
combining with other media  226
considerations for using  224
controlling with functions  227
controlling with variables  227
creating  225
file formats for  225
integrating  225
media synchronization  227
sampling rate issues  224
step-by-step instructions for  228
working with  224

special effects, using transitions for  300
speed issues on networks

CD-Web hybrids and  371
description of  358

sprite icons
properties of  329,  330

sprite Xtras
overview of  328
properties, events, and methods of  329

sprites
properties of  330
senders  330

start and stop flags
in troubleshooting  166
role of  39

storing information, on user performance  345
straight line tool

using  219
Streaming

Authorware Web Player  359
streaming

content management with  366
design considerations for  360
providing Authorware Web Player for  367

Streaming technology
overview of  359

String function
controlling text with  191

Strip function
controlling text with  191

Structured Query Language (SQL)
advantages of  356
sample use for  186
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structures
decision structures  277
navigation structures  284
paging structures  282

styles, text  188
subroutines

overview  296
SubStr function

controlling text with  191
synchronizing sound, movies, and display icons  227
syntax

in Functions dialog box  319
of functions  319

system functions
overview of  319
parent and child object methods vs.  332

system variables
for conditional responses  268,  269
for tracking performance  340
overview of  315
using  315

system-level drivers, in distribution package  180
SystemSeconds variable  341

T

target areas
limiting use of  272
step-by-step instructions for  265
using  264

target responses
checking for match with  252,  339
definition of  248

targets
controlling with wizards  382
description of  375

TechNotes  16
testing pieces

by running  165
for Internet delivery  360
in authoring development stage  35,  165
in authoring evaluation stage  35
on different computers  172

text
as content  183
combining sound with  226
creating within Authorware  187
database, sending to or importing from  186

text, (continued)
displaying on screen  186
dragging onto display icon  47–48
editing  186
embedding and linking  185
font issues  186,  187
hypertext  186
importing, uses for  187
integrating into Authorware piece  187
issues concerning  186
overview of  186
paging or scrolling structure for  188
pasting  188
searching for  189
step-by-step instructions for  191
style attributes  188
synchronizing sound with  226
user entry of  264
working with  186

text functions
listed  190
See also specific functions

Text menu
using  186

text styles
sharing as models  245

text tool
using  219

text variables
listed  189
See also specific variables

text-entry fields
conditional responses for  268
creating  263
providing feedback for  269
response type symbols and  252
step-by-step instructions for  263

text-entry interactions
overview of  263

time limits for responses  267
limiting use of  272
step-by-step instructions for  267

TimeInInteraction variable
for user response  267,  340,  341

TimeRemaining variable  341
for user response  267

TimesMatched variable  344
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toolbar
description of  37
illustration of  34
showing or hiding  37

toolbox
using  219

TotalCorrect variable  344
in performance summary  344

TotalWrong variable  344
in performance summary  344

Trace function
in troubleshooting variables  167

tracking performance
providing feedback  344
step-by-step instructions for  347
storing information  345
system variables for  340

transition settings  300
transition Xtras

description of  300
transitions

description of  299
using for special effects  300
working with  300

Transitions dialog box  300
tries limit response

description of  265
step-by-step instructions for  266

Tries variable  341
troubleshooting

authoring methods  166
interactions  251
links  185
step-by-step instructions for  168

True/False exercises  52
True/False Question Knowledge Object  53
Tutorial  57

U

UCDs
DLLs and  320

UpperCase function
controlling text with  191

user groups, Authorware  17

user responses
buttons for  256
catch-all areas for  260
conditional  270
hot objects for  261
hot spots for  260
in interactions  248,  249
limiting  272
marking right or wrong  339
pull-down menus for  258
response type symbols  249,  250
target areas for  264
text-entry fields for  263
time limits for  267
tries limits for  266

UserName variable
saving user responses with  346

users
feedback for  344
letting users drag objects  304
text entry by  264

V

variables
as External Media Browser pathnames  238,  241
branching based on  280
character  317
CMI variables  349
controlling images with  222
controlling sound with  227
controlling video with  235
custom variables  315
digital movie
for event management  330
for Knowledge Objects  376
for movies  231
for tracking object’s motion  305
for tracking object’s position  305
for tracking performance  340
image, listed  222
in scripts  323
Internet-related  363
naming scheme for  164
numerical  317
overview of  307
providing feedback with  344
purpose of  308
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variables, (continued)
sound, listed
step-by-step instructions for  315
system, using  315
text, listed  189
troubleshooting  167
types of  316
video, listed  235
where used  308

video
as content  183
combining sound with  226
controlling with functions  235
controlling with variables  235
creating  234
integrating  234
playback options  234
requirements for  233
step-by-step instructions for  236
synchronizing with audio and graphics  226
using variables with  235
working with  233

Video for Windows drivers, 
in distribution package  180

Video for Windows movies
in distribution package  180
support for  229
See also movies

video functions
listed  235
See also specific functions

Video Icon Properties dialog box
options in  234

video icons
role of  39

video overlay card, using chroma key with  234
video overlay drivers, in distribution package  180
video variables

listed  235
See also specific variables

VideoChromaKey function  236
videodisc distribution and  173
videodisc drivers, in distribution package  180
VideoDisplay function  236
VideoDone variable  235
VideoFrame variable  235
VideoPause function  236

VideoPlay function  236
VideoResponding variable  235
VideoSeek function  236
VideoSend function  236
VideoSound function  236
VideoSpeed function  236
VideoStep function  236
VideoText function  236
View menu

for showing or hiding toolbar  37
voice-overs  226

See also sound

W

wait icons
role of  38

Web server, configuring for web-packaged files  367
Web sites

See also Internet
Web-packaged pieces

step-by-step instructions for creating  178
WinCtrls.u32  395
Windows applications

run-time applications  175
text fonts and  186

Windows Control Get Property Knowledge Object  54
Windows Control Knowledge Object  54

creating a control  398
Windows Control Knowledge Objects  397

Get Property Knowledge Object  397
Set Property Knowledge Object  397
Windows Control Knowledge Object  397

Windows Control Set Property Knowledge Object  54
Windows controls and properties  410
Windows Controls Knowledge Object

using variables in  414
wizards

controlling targets with  382
description of  375
Knowledge Objects and  15
launching from Knowledge Objects  375
quitting  375
wizard user interface  381

Word, RTF text in  187
WordClicked variable

controlling text with  189
for tracking performance  342
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WordCount function
controlling text with  191

WordCount variable  189,  268
controlling text with  189

workspace, in icon-based authoring  34
World Wide Web. See Internet
Write INI Value Knowledge Object  53
WriteExitFile function

sample use for  186
WriteExtFile function

for saving user responses  346
wrong responses, indicating  339
WrongChoicesMatched variable  343

X

XML parsed files  335
XML Parser Xtra  335
Xtras

in distribution package  180,  181
role of  184
scripting Xtras  332
sprite Xtras  328
transition Xtras  300
types of  328
using  327

Y

Yamaha MidXtra, child object created from  332
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	To display the content of more than one icon:
	1 Double-click the first icon to open it.
	2 Shift-double-click subsequent icons.

	To open a set of neighboring icons:
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	To choose a Knowledge Object for a new file:
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	Adding a Knowledge Object to a file
	To add a Knowledge Object to a file:
	1 Choose File > Save to save your file.
	2 If the Knowledge Object window isn’t open, choose Window > Knowledge�Objects.
	3 Drag a Knowledge Object icon from the Knowledge Objects window to�the�flowline.
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	Tutorial
	Tutorial structure
	What you should know

	Analyze the completed tutorial
	Objectives
	View the completed tutorial
	1 Start Authorware. In the New Project dialog box, click None.
	2 Choose File > Open > File and select Camera6.a6p from the Tutorial folder within your Authorwar...
	Navigate through the finished file
	1 Click the Continue button in the lower right corner.
	2 Select each choice from the Main Menu. You are first introduced to camera terminology. You can ...
	3 In general, notice the order in which things happen. Pay attention to the various types of cont...
	4 In the Design window, double-click the Introduction map icon to view the icons contained within.

	Restart the completed tutorial
	1 When you finish viewing the file, you can either keep it open for reference, or close it by cho...


	Add graphics, sound, and a button to a new piece
	Objectives
	Create a new piece
	1 Choose File > New > File.
	2 Click None; you’ll use Knowledge Objects later in the tutorial.
	3 To save and name the piece, select File > Save. In the File Name text box, type�Camera.
	4 Browse to your Authorware 6 application folder and save the file in the Tutorial�folder.

	Set properties for the Presentation window
	Size the Presentation window
	1 Select Modify > File > Properties.
	2 In the Size pop-up menu, verify that 640 x 480 (VGA, Mac13”) is selected.

	Specify window options
	1 Deselect Title Bar and Menu Bar.
	2 Select Center on Screen, then click OK.


	Create a title page
	1 To create the title page, drag a display icon, used to display text and graphics, from the icon...
	2 To name the icon, type the word Title while the icon is still selected.
	3 Double-click the Title display icon.
	Create text using the toolbox
	1 In the toolbox, select the Text tool.
	2 To change the default font, choose Text > Font. Select Arial if it appears on a list of fonts; ...
	3 In the Presentation window, click toward the upper left corner (exact placement isn’t necessary...
	4 To change the size of the text, select the entire line of text and choose Text�>�Size > 14.
	5 To make the text margin narrower, click the small square margin handle (not the dark triangle) ...
	6 To make the text stand out against any color background, verify that it’s still selected and ch...
	7 Close the modes palette and choose Control > Restart to play the piece from the beginning of th...


	Add a graphic background
	Open a library
	1 Choose File > Open > Library. Within your Authorware application folder, browse to the Tutorial...
	2 If the Design window is not visible, choose Window > Design > Camera.a6p.
	3 Drag the Title Background display icon from the library to the flowline above the Title icon.
	4 To view the piece in the Presentation window, choose Control > Restart. Then choose Control > P...
	5 In the Presentation window, drag the text that you typed to align it under the Title Background...
	6 When you finish viewing the piece, choose File > Save.

	Import graphics
	1 Return to the flowline.
	2 On the flowline, Shift-double-click the Title display icon to open it.
	3 Choose File > Import.
	4 In the Import Which File dialog box, browse within your Authorware 6 application folder to Tuto...
	5 Select Link To File, and then click Import.
	6 Drag the camera to the approximate location shown in the following illustration:
	7 With the graphic still selected, choose Window > Inspectors > Modes and select�Alpha.


	Add Sound
	1 Drag a sound icon from the icon palette to the flowline, placing it below the Title display icon.
	2 Name the sound icon Camera Sound, and double-click it.
	3 In the Sound Icon Properties dialog box, click Import and browse within your�Authorware 6 appli...
	4 In the Sound Icon Properties dialog box, click the Timing tab. In the Concurrency pop-up menu, ...
	5 In the Play pop-up menu, verify that Fixed Number of Times appears.
	6 In the text box below, type 2 for the number of times the sound will play.
	7 Click the Play button to hear the sound based on the settings that you specified, and then clic...
	8 Restart and pause the piece by choosing Control > Restart and then Control�>�Pause.

	Add a Continue button
	1 Add a wait icon after the Camera Sound icon on the flowline, and name the icon Continue.
	2 Double-click the icon to open the Wait Icon Properties dialog box.
	3 Deselect Key Press, verify that Show Button is selected, and click OK.
	4 Restart the piece. When the Continue button appears, click it.
	Position the Continue button
	1 Choose Control > Restart. You can also press 1 on the numeric keypad.
	2 Pause the piece by choosing Control > Pause, or press 2 on the numeric keypad.
	3 Drag the Continue button to the lower right corner of the Presentation�window.
	4 Close the Presentation window by choosing Control > Stop, or press 0 on the numeric keypad.


	Erase content and add transitions
	1 Drag an erase icon to the flowline and place it below the wait icon.
	2 Name the erase icon Erase Title Page.
	3 Double-click the Erase icon.
	4 On the Erase tab, select the Ellipsis (...) button to the right of the Transition�text box.
	5 In the Erase Transition dialog box, verify that [Internal] is selected in the Categories column.
	6 In the Transitions column, scroll up and select Fade Out.
	7 Verify that .5 appears in the Duration text box and click OK.
	8 To select what you want to erase, click the Icons tab in the Erase Icon Properties dialog box a...
	9 In the Presentation window, click the camera graphic.
	10 To preview the transition, click the Preview button in the Erase Icon Properties dialog box. W...
	Test your work
	1 Choose Control > Restart to restart the piece, and click the Continue button to�see the entire ...
	2 Choose Control > Stop.


	Group icons into a map icon
	1 Click slightly above and to the left of the first icon on the flowline and drag the pointer to ...
	2 In the flowline, name the resulting map icon Introduction.

	Color icons
	1 Verify that the Introduction map icon is still selected.
	2 On the icon panel, select orange from the icon color boxes.

	Add a main menu and navigation
	Objectives
	Add graphics to the segment
	1 If the Design window is not open, choose Window > Design, and then choose�the name of the file ...
	2 On the flowline, add a map icon after the Introduction icon and name it Main�Menu.
	3 Double-click the Main Menu map icon to open it.
	4 Drag the Lesson Title Background icon from the library to the Main�Menu�flowline.
	5 On the Main Menu flowline, add a display icon below Lesson Title Background and name it Lesson ...
	6 To import the camera graphic for this segment, choose File > Import and Browse within your Auth...
	7 Select Camera2.png, and then select Link to File and click Import.
	8 With the graphic still selected, use the modes palette to select Alpha. (If the modes palette i...

	Align objects in the Presentation window
	Use flags to view segments of your piece
	1 From the icon palette, drag a start flag to the beginning of the Main Menu flowline.
	2 To restart the piece from the start flag, do one of the following:

	Align the graphics
	1 Pause the piece.
	2 In the Presentation window, verify that the Lesson Title Background dark rectangle appears in t...


	Add menu items
	1 On the Main Menu flowline, add an interaction icon below Lesson Title and name it Select a Topic.
	2 Double-click the Select a Topic icon to open it, and select the Text tool from the toolbox.
	3 In an earlier section, you changed the default text to Arial. Use the Text menu to verify that ...
	4 If the modes palette isn’t open, choose Window > Inspectors > Modes. Select Inverse and close t...
	5 Click near the upper left corner of the Presentation window and type Main Menu, then press Ente...
	6 Choose Text > Size and select 10 point.
	7 In the Presentation window, type 1. Photographic Terminology, then press Enter twice.
	8 Type 2. Parts of a Camera, and again press Enter twice.
	9 Type 3. Take Some Pictures, and press Enter twice.
	10 Type 4. Camera Quiz.
	11 Click the square text margin handle (not the dark triangle) at the right end of the margin lin...

	Set the navigational structure
	1 On the Main Menu flowline, place a navigate icon to the right of the Select a Topic icon.
	2 In the Response Type dialog box, select Hot Spot, and click OK.
	3 On the Main Menu flowline, name the unlinked navigate icon Navigate to Terminology.
	4 On the Main Menu flowline, double-click the response symbol above the Navigate to Terminology i...
	5 On the Hot Spot tab of the Response Properties dialog box, in the Size text boxes, specify 196 ...
	6 In the Keys text box, type 1.
	7 Select Highlight on Match.
	8 To display a pointing finger when the user rolls over the hot spot, click the Ellipsis (...) bu...
	9 On the Response Properties dialog box, click OK.
	Add and configure the remaining navigation icons
	1 Place another navigation icon on the Main Menu flowline to the right of the Navigate to Termino...
	2 Double-click the response symbol above the Navigate to Parts of Camera icon. On the Hot Spot ta...
	3 Place two more navigation icons to the right of the others, and name them Navigate to Take Pict...
	4 Double-click the response symbol for Navigate to Take Pictures, type 3 in the Keys text box, th...
	5 Double-click the response symbol for Navigate to Quiz, type 4 in the Keys text box, then click OK.

	Place hot spots on the Main Menu
	1 Choose Control > Restart from Flag, then choose Control > Pause.
	2 Taking care to avoid dragging the sizing handles, drag the menu text within the Lesson Title Ba...
	3 Drag each of the four hot spots to their corresponding menu selections.


	Create a master framework
	1 Drag a framework icon to the Level 1 flowline, below the Introduction icon, and name it Master ...
	2 Drag the Main Menu icon to the right of the Master Framework icon.
	3 Double-click the Master Framework icon to open its flowline.
	4 To delete the default icons, select the Gray Navigation Panel icon and Shift- Click the Navigat...
	5 When the alert appears, click Select All Attached Icons.
	6 Drag the Title Background icon from the library to the Master Framework flowline.
	7 Drag an interaction icon from the icon palette to the Master Framework flowline, place it below...

	Add a Menu button
	1 Drag a map icon to the right of the Global Navigation icon on the Master Framework flowline.
	2 In the Response Type dialog box, verify that Button is selected, and click OK.
	3 On the Master Framework flowline, name the map icon Menu.
	4 Double-click the Menu response symbol. Click Buttons and verify that the button with the descri...
	5 In the Response Properties dialog box, click the Ellipsis (...) button to the right of the Curs...
	6 In the Response Properties dialog box, click OK.
	Add the navigation for the Menu button
	1 On the Master Framework flowline, double-click the Menu map icon.
	2 Drag a navigate icon to the Menu flowline, and name it Navigate to Main Menu.
	3 Double-click the Navigate to Main Menu icon. In the Navigate Icon Properties dialog box, verify...
	4 In the Page list, select Main Menu, and then click OK to link the Menu button to the Main Menu.
	5 Close the Menu flowline.


	Add a Quit button
	1 On the Master Framework flowline, add a map icon to the right of the Menu icon, and name it Quit.
	2 Double-click the Quit icon. Add an interaction icon to the Quit flowline and name it Exit the P...
	3 Double-click the Exit the Program icon. Select the Text tool in the toolbox and type, anywhere ...
	4 If the modes palette is not open, choose Window > Inspectors > Modes. Verify that Inverse is se...
	5 Choose Control > Stop or press 0 on the numeric keypad to close the Presentation window.
	Add a Yes response
	1 On the Quit flowline, place a map icon to the right of the interaction icon. In the Response Ty...
	2 Name the map icon Yes, and double-click its response symbol.
	3 On the Button tab of the Response Properties dialog box, click the Ellipsis (...) button to the...
	4 In the Response Properties dialog box, again click OK.
	5 On the Quit flowline, double-click the Yes icon. Add a calculation icon to the Yes flowline and...
	6 Double-click the Quit icon to display the Calculation window.
	7 To specify the function to add to the Quit icon, choose Window > Functions. Verify that All app...
	8 In the scrolling list below the Category pop-up menu, scroll down and click�Quit. Read the desc...
	9 Click the Paste button, then click Done.
	10 In the calculation window, select the text within the parentheses that says option and type 1.
	11 Close the calculation window. When the alert appears, press Enter.
	12 Close the Yes flowline.

	Add a No response
	1 On the Quit flowline, place a map icon to the right of the Yes map icon and name it No.
	2 Double-click the No icon to open the No Flowline. Add a navigate icon to the No flowline and na...


	Place the buttons
	1 On the Master Framework flowline, double-click the Global Navigation interaction icon. Drag and...
	2 Choose Control > Restart from Flag.
	3 Click the Quit button and pause the piece.
	4 Drag the Yes and No buttons to the lower edge of the Lesson Title Background�rectangle.
	5 Double-click the text Are you sure you want to exit the Camera Tutorial? In the toolbox, select...
	6 In the toolbox, select the Pointer tool. Drag the text and place it above the Yes and No buttons.
	7 Choose Control > Play to start the piece from where you left off, and click No.
	8 In the Navigation Properties dialog box, under Page, select Main Menu, which is where you want ...
	9 Authorware takes you to the Main Menu. Pause the piece and close the Master Framework flowline.

	Import an RTF File
	Objectives
	Create a terminology segment
	1 On the Level 1 flowline, add a map icon to the right of the Main Menu icon, and name it Termino...
	2 Double-click the Terminology map icon and drag the Lesson Title Background icon from the librar...
	3 Place a display icon below the Lesson Title Background icon and name it Camera.
	4 Double-click the Camera icon. Choose File > Import and browse to the Tutorial/Assets folder wit...
	5 To view the alpha transparency in the image, choose Window > Inspectors > Modes, and select Alpha.
	6 Drag the camera graphic to the lower right area of the Presentation window, as shown in the fol...
	7 In the toolbox, select the Text tool. Click toward the upper left corner in the�Presentation wi...
	8 In the Presentation window, select the text. Use the Text menu to verify that the text is Arial...
	9 In the modes palette, select Inverse.

	Edit an external file with the RTF Objects Editor
	1 Choose Commands > RTF Objects Editor.
	2 In the RTF Objects Editor, choose File > Open Document.
	3 Browse to the Tutorial/Assets folder within your Authorware 6 application folder and open Termi...
	Change text formats
	1 Select the Lens heading text and click the Bold button.
	2 Repeat step 1 to add boldface to the Aperture ring heading and the Shutter Release heading.
	3 To save your changes to the RTF file, in the RTF Objects Editor choose File > Save As. Name the...


	Import the RTF file
	1 On the Terminology flowline, add a display icon below the Camera display icon, and name it Term.
	2 Double-click the Term icon and choose File > Import. Browse to the Tutorial/ Assets folder with...
	3 Select Link to File and click Import.
	4 In the RTF Import dialog box, verify that Create New Display Icon and Standard are selected, an...
	Rename the terms
	1 On the Terminology flowline, select the Term icon and rename it Lens.
	2 Select the Term 2 icon and rename it Aperture Ring.
	3 Rename the Term 3 icon Shutter Release.
	4 Rename the Term 4 icon Shutter Speed Indicator.
	5 Rename the Term 5 icon Film Advance Lever.


	Align the text
	1 On the Terminology flowline, double-click the Lens icon.
	2 In the toolbox, select the Text tool.
	3 Click the text in the Presentation window and slide the right square margin handle to the left ...
	4 Select the Pointer tool in the toolbox, and use it to drag the text to the approximate location...
	5 If the modes palette is not open, choose Windows > Inspectors > Modes. Select�Inverse.
	6 Return to the Terminology flowline and double-click the Aperture Ring icon.
	7 In the Presentation window, again use the Text tool to decrease the margin size, and use the Po...
	8 In the modes palette, select Inverse.
	9 On the Terminology flowline, double-click the Shutter Release icon, and repeat steps 7 and 8 to...
	10 On the Terminology flowline, double-click the Shutter Speed Indicator icon, and again repeat s...
	11 On the Terminology flowline, double-click the Film Advance Lever icon, and (you guessed correc...
	Add wait and erase icons
	1 On the Terminology flowline, add a wait icon after the Lens icon and name it�Continue.
	2 Double-click the Continue icon. In the Wait Icon Properties dialog box, verify that Key Press a...
	3 On the Terminology flowline, add an erase icon after the Continue icon and name it Erase Term.
	4 Click the Continue icon, and Shift-click the Erase Term icon to add it to the�selection.
	5 Choose Edit > Copy.
	6 On the Terminology flowline, click after the Aperture Ring icon to move the Paste Hand to that ...
	7 Paste copies of the Continue and Erase Term icons after the Shutter Release icon and the Shutte...


	Align and erase objects
	1 Add a start flag to the beginning of the Terminology flowline and choose Control > Restart from...
	2 Move the objects in the Presentation window, as necessary, to better align them.
	3 Double-click the lens text to display its toolbox. Select the Rectangle tool.
	4 If the modes palette is not open, choose Window > Inspectors > Modes. Select�Inverse.
	5 In the Presentation window, drag the mouse pointer to draw a rectangle around the camera lens.
	6 Choose Control > Play and click the Continue button.
	7 In the Icons tab of the Erase Icon Properties dialog box, verify that Icons to Erase is selecte...
	8 Choose Control > Pause and align the objects on the screen, as necessary.
	9 Double-click the Aperture Ring text to display its toolbox. Select the Rectangle tool and draw ...
	10 Choose Control > Play and click the Continue button.
	11 In the Presentation window, click the Aperture Ring text so that the Aperture Ring icon appear...
	Configure the Shutter Release page
	1 Choose Control > Pause and align the objects on the screen, as necessary.
	2 Double-click the Shutter Release text to display its toolbox. Select the Rectangle tool and dra...
	3 In the modes palette, verify that Inverse is selected.
	4 Choose Control > Play and click the Continue button.
	5 In the Presentation window, click the Shutter Release text so that the Shutter Release icon app...

	Configure the Shutter speed indicator page
	1 Choose Control > Pause and align the objects on the screen, as necessary.
	2 Double-click the Shutter Speed Indicator text to display its toolbox. Select the Rectangle tool...
	3 In the modes palette, verify that Inverse is selected.
	4 Choose Control > Play and click the Continue button.
	5 In the Presentation window, click the Shutter Speed Indicator text so that the Shutter Speed In...

	Configure the Film Advance Lever Page
	1 Choose Control > Pause and align the objects on the screen, as necessary.
	2 Double-click the Film Advance Lever text to display its toolbox. Select the Rectangle tool and ...


	Add a Flash movie
	1 On the Terminology flowline, click below the Lens icon so that the Paste Hand appears there.
	2 Choose Insert > Media > Flash.
	3 In the Flash Asset Properties dialog box, click Browse. In the Open Shockwave Flash Movie dialo...
	4 In the Flash Asset Properties dialog box, verify that Linked, Image, Sound, and Loop are select...
	5 In the Scale text box, type 75 for the movie to appear 75 percent of its original size. Click OK.
	6 On the Terminology flowline, double-click the Flash icon to open the Sprite Icon Properties dia...
	7 Choose Control > Restart from Flag, then pause the piece. In the Presentation window, drag the ...
	Erase the Flash movie by modifying properties
	1 On the Terminology flowline, double-click the first Erase Term icon that appears after the Flas...
	2 In the Presentation window, click the Flash movie.
	3 Click OK to close the dialog box.


	Organize the flowline
	1 Drag to select the Lens and Flash icons as well as the Continue and Erase Term icons that appea...
	2 Choose Modify > Group and name the map icon Lens Term.
	3 Select the Aperture Ring icon as well as the wait and erase icons that are next on the flowline...
	4 Select the Shutter Release icon as well as the wait and erase icons that are next on the flowli...
	5 Select the Shutter Speed Indicator icon as well as the wait and erase icons that are next on th...
	6 The Film Advance Lever icon does not require a wait or erase icon, since it�displays the last o...

	Link the photographic terminology to the Main Menu
	1 Choose Control > Restart and click the Continue button.
	2 When the Main Menu appears, click 1. Photographic Terminology.
	3 The Page field includes a list of icons to which you can navigate: the Main Menu and the Termin...
	4 Close the Terminology flowline.
	5 Click the Continue button to view all the terms.

	Use models to streamline authoring
	Objectives
	Add models
	1 Go to the Level 1 flowline.
	2 If the Knowledge Objects window is not open, choose Window > Knowledge�Objects.
	3 In the Category pop-up menu, select Tutorial.
	4 Select the CameraParts map icon and drag it to the flowline to the right of the Terminology map...
	5 Select the TakePictures map icon and drag it to the flowline to the right of the CameraParts ma...

	Link models to the Main Menu
	1 Choose Control > Restart. In the Introductory segment, click the Continue�button.
	2 On the Main Menu page, click 2. Parts of a Camera.
	3 In the Navigate Icon Properties dialog box, click Parts of a Camera in the list of pages, to li...
	4 Authorware takes you to the Parts of a Camera page. Click the Menu button.
	5 When you return to the Main Menu, click 3. Take Some Pictures.
	6 In the Navigate Icon Properties dialog box, select Take Some Pictures to link and navigate to t...
	Test the Models
	1 Restart your piece. After the Introductory segment, click Continue.
	2 On the Main Menu, click 2. Parts of a Camera, then test each question by answering it.
	3 When you finish testing the Parts of a Camera segment, click the Menu button to return to the M...
	4 Click 3. Take Some Pictures.
	5 Follow the instructions in the Presentation window to adjust the aperture and shutter speed ind...
	6 When you’ve finished taking pictures, choose Control > Stop.
	7 On the Level 1 flowline, double-click the Parts of a Camera icon to open its�flowline.
	8 Examine the flowline to understand more about the authoring involved in�creating this model. Wh...


	Use Knowledge Objects to create a quiz
	Objectives
	Add icons and graphics for the quiz
	1 On the level 1 flowline, add a map icon to the right of the Take Some Pictures icon and name it...
	2 Double-click the Camera Quiz map icon. Add a display icon to the Camera Quiz flowline and name ...
	3 Double-click the Quiz Text icon. Select the Text tool and type Camera Quiz toward the upper lef...
	4 In the Presentation window, select the text. Use the Text menu to verify that the text is Arial...
	5 If the modes palette is not open, select Window > Inspectors > Modes. Select Inverse if it’s no...
	6 Place a start flag at the beginning of the Camera Quiz flowline. Restart the piece from the fla...

	Specify Knowledge Object Settings
	1 If the Knowledge Objects window is not open, choose Window > Knowledge Objects. In the Category...
	2 In the list of Knowledge Objects, scroll down to the Quiz Knowledge Object. Drag the Quiz Knowl...
	Specify the Screen size and quiz media path
	1 Read the first page of the wizard, then click Next.
	2 For screen size, verify that 640 x 480 is selected.
	3 Along the bottom of the window, you see a text box that displays where Authorware will store th...

	Determine the layout style
	1 In the Select a Layout list, click each selection to preview it.
	2 Select 3 Educational as the layout, then click Next.

	Create default quiz options
	1 Review the default settings.
	2 When you finish reviewing the settings, click Next.

	Set login options
	1 Select Show Login Screen at Start.
	2 Deselect the following options:
	3 To determine where Authorware will store the quiz results, refer to the path in the Records Dir...

	Specify data tracking options
	Add scoring options for questions
	1 Select Judge User Response Immediately.
	2 Verify that User Must Answer Question to Continue and Show Feedback After Question Is Judged ar...
	3 Verify that 70 is in the Passing Score % text box, and click Next.

	Specify generic feedback
	1 To specify positive feedback, verify that Positive is selected.
	2 Click the Delete Feedback button twice, so that the only positive feedback text that remains is...
	3 To specify the text that should appear when a user incorrectly answers a question, select Negat...
	4 Click the Delete Feedback button twice, so that the only negative feedback text that remains is...


	Add a question to the quiz
	Add a single-choice question
	1 In the Quiz Knowledge Object: Add Questions window, click Single Choice.
	2 In the Enter or Modify Question Title text box, type Question 1. Then click Run Wizard.

	Import graphics for a quiz question
	1 In the Preview Window, click the sample question text so that it appears in the Edit Window.
	2 Click Import Media. In the Import Media dialog box, browse to the Tutorial/ Assets folder withi...
	3 If a message appears asking for permission to copy the file, click Yes.


	Use the set up wizard
	1 In the Edit Window, replace the sample text with What is the name of the adjustable diaphragm t...
	2 In the Preview Window, click the word distractor. Use the Edit Window to replace it with the wo...
	3 In the Preview Window, click the definition text under Shutter. Use the Edit Window to change t...
	4 In the Preview Window, click the word hint and select Right Answer.
	5 Use the Edit Window to change the word hint to Aperture, and press Enter.
	6 In the Preview Window, click the text under Aperture. Use the Edit Window to change the text to...
	Finish adding choices and responses
	1 In the Preview Window, select the word feedback. Select Wrong Answer.
	2 Use the Edit Window to change the text to Shutter Release, and press Enter.
	3 In the Preview Window, click the text under Shutter Release. Use the edit window to change the ...
	4 To add a final answer, verify that Wrong Answer is selected, and click Add�Choice.
	5 In the Preview Window, click <Place choice here>. Use the Edit Window to change the text to Len...
	6 In the Preview Window, click <generic feedback>. Use the Edit Window to change the text to No. ...
	7 To exit the wizard for the first quiz question, click Done.


	Add a true/false question
	1 Click True/False.
	2 In the Enter or Modify Question Title text box, type Question 2. Then click Run Wizard.
	3 To import a graphic for this question, click the first line of text in the Preview window, then...
	4 In the Import Media dialog box, browse to Tutorial/Assets within your Authorware 6 application ...
	5 Use the Edit Window to change the sample question text to The higher the aperture setting, the ...
	6 In the Preview Window, click True and select Right Answer.
	7 Click the text under True. Use the Edit Window to replace the text with Yes. The higher you set...
	8 In the Preview Window, click the text under False. Use the Edit Window to replace the text with...
	9 To complete the question and exit the wizard, click Done.

	Add a hot spot question
	1 Click Hot Spot.
	2 In the Enter or Modify Question Title text box, type Question 3. Then click Run Wizard.
	3 To import a graphic for this question, click the first line of text in the Preview window and c...
	4 If a message appears asking permission to copy the file, click Yes.
	5 Use the Edit Window to change the sample question text to Click the part of the camera you woul...
	6 Click the Add Hotspot button three times, so that five hot spot responses appear in the Preview...
	Modify the hot spot response text
	1 In the Preview Window, click the text in the second line of hot spot 1. Use the Edit Window to ...
	2 In the Preview Window, click the text in the second line of hot spot 2. Use the Edit Window to ...
	3 In the Preview Window, click the text in the second line of hot spot 3. Use the Edit Window to ...
	4 In the Preview Window, click the text in the second line of hot spot 4. Use the Edit Window to ...
	5 In the Preview Window, click the text in the second line of hot spot 5. Use the Edit Window to ...
	6 When you finish changing the hot spot text, the window should look like the following illustrat...

	Modify hot spots
	1 Click Modify Hotspot.
	2 If necessary, drag the camera graphic up and toward the right edge of the window, as shown in t...
	3 Drag hot spot 1 to place it over the shutter release button on the camera, as shown in the foll...
	4 Drag hot spot 2 to the lens, and use the sizing handles to enlarge the hot spot so that it cove...
	5 Drag hot spot 3 to the aperture ring, and resize it to cover the aperture ring.
	6 Drag and resize hot spots number 4 and 5, so they appear as in the following illustration:
	7 Click Done to complete placing the hot spots, then click Done again to complete Question 3.


	Add a multiple-choice question
	1 In the Quiz window, click Multiple Choice.
	2 In the Enter or Modify a Question Title text box, type Question 4. Click�Run�Wizard.
	3 In the Preview Window, click the sample question text. Use the Edit Window to change it to What...
	4 In the Preview Window, click Auckland. The minus sign indicates this is an incorrect choice. Cl...
	5 Use the Edit Window to change Auckland to Shutter speed, and press Enter.
	6 In the Preview Window, click the text under Shutter speed and use the Edit Window to change it ...
	7 In the Preview Window, click Perth. Then click Wrong Answer.
	8 Use the Edit Window to change Perth to Film advance lever, and press Enter.
	9 In the Preview Window, click the text under Film advance lever and use the Edit Window to chang...
	Complete the question
	1 Verify that the third choice is a right answer, as indicated by the plus sign. Change Sydney to...
	2 Verify that the fourth choice is an incorrect answer, as indicated by the minus sign. Change Vi...
	3 To complete the question, click Done.


	Finish using the Knowledge Object
	1 In the Click an Item in the List to Modify It pane, click Question 2. Click the Move Question u...
	2 Click Question 3, and then click the Move Question up arrow once, to place the question before ...
	3 To finish using the Knowledge Object, click Done. Then refer to the Camera Quiz flowline to vie...

	Link the quiz
	1 Restart the piece, and click Continue to go to the Main Menu.
	2 In the Main Menu, click Camera Quiz. In the Navigate Icon Properties dialog box, select Camera ...

	Change quiz graphic objects
	1 Pause the piece and double-click toward the edge of the Presentation window to see the Quiz Bac...
	2 In the Presentation window, double-click the logon dialog box so that it is the only object sel...
	Import a graphic for the Quiz Background display icon
	1 On the Camera Quiz flowline, double-click the Quiz framework icon.
	2 On the Quiz flowline, double-click the Quiz Background display icon.
	3 Choose File > Import. Browse to the Tutorial/Assets folder within your Authorware 6 application...
	4 In the modes palette, select Alpha.
	5 Place a start flag at the top of the Quiz flowline, and choose Control > Restart from Flag. Pau...
	6 Press the Up Arrow key six times to move the background up 6 pixels. Press the Right Arrow key ...

	Import the camera graphic
	1 On the Quiz flowline, double-click the Login display icon.
	2 On the Login flowline, double-click the first display icon, named Display. On the Display flowl...
	3 In the Presentation window, all of the objects on the page are selected. Press Delete.
	4 Choose File > Import and import Camera1.png from your Tutorial/Assets folder within your Author...
	5 If the modes palette is not open, choose Window > Inspectors > Modes. Select Alpha from the mod...
	6 Drag the camera toward the lower right edge of the window.
	7 Close the Display flowline.


	Modify Styles
	1 Choose Text > Define Styles.
	2 In the Define Styles dialog box, select General Text Heading - edu from the list of styles. In ...
	3 In the Font Size pop-up menu, select 9 as the point size.
	4 Verify that Text Color is selected. Click the Text Color box. In the Text Color palette, select...
	5 Change each of the following styles to Arial text. Additionally, repeat steps 3 and 4 to change...
	6 Change the wzDistractorHilite style to 9 point yellow Arial text.
	7 When you’ve finished changing the styles in the Define Styles dialog box, click�Done.

	Delete login objects
	1 On the Quiz flowline, go to the Login flowline.
	2 On the Login flowline, select the Middle Name map icon, then press Delete.
	3 On the Login flowline, double-click the First Name map icon.
	4 On the First Name flowline, double-click the First Name interaction icon. In the Presentation w...
	Align objects to enter a first name
	1 In the Presentation window, double-click the First Name text entry field. In the Interaction Te...
	2 Choose Control > Restart from flag, then pause the piece.
	3 In the Presentation window, double-click the text Enter you First Name and press Enter.
	4 Choose Text > Alignment > Left to change the alignment from centered.
	5 Use the Pointer tool in the toolbox to make the text margins narrower and to place the text wit...
	6 Select the First Name text entry field and drag it under the Enter your First Name...text. Use ...
	7 Choose Control > Play and type your first name in the text field. Press Enter, and then pause t...
	8 Close the First Name flowline.

	Align objects to enter a last name
	1 On the Login flowline, double-click the Last Name map icon.
	2 On the Last Name flowline, double-click the Last Name interaction icon.
	3 In the Presentation window, select the Last Name text, verify that no other objects are selecte...
	4 Double-click the Last Name text entry field. On the Text tab of the Interaction Text Field Prop...
	5 Choose Control > Restart from Flag. Again type your first name in the text entry field and pres...
	6 Pause the piece and drag the Last Name text entry field over the First Name text entry field. R...
	7 Double-click the text that reads Enter your Last Name and press Enter.
	8 Choose Text > Alignment > Left. Use the Pointer tool in the toolbox to drag the text above the ...
	9 Choose Control > Play and type your last name in the text field, then press Enter. Pause the pi...

	Align objects to submit your name data
	1 In the Presentation window, double-click the text that reads, Your name is not in the roster. W...
	2 Use the Pointer tool to resize the text margin and place it to the lower portion of the Quiz Ba...

	Replace buttons
	1 Double-click the Retype Name button. In the Response Properties dialog box, rename the button R...
	2 Click Buttons. Scroll down the list and select the Standard Windows 3.1 System button.
	3 Click OK to close the Buttons dialog box, then click OK again in the Response Properties dialog...
	4 In the Presentation window, double-click the Quit button. In the top text box, select the Quit ...
	5 Click Buttons and select the Standard Windows 3.1 System button.
	6 Click OK to close the Buttons dialog box, then click OK again on the Response Properties dialog...
	7 In the Presentation window, double-click the Sign-on button and repeat steps 5 and 6 to select ...
	8 Drag the buttons to the lower left area of the Presentation window, in the order shown in the f...
	9 Play the piece. In the Presentation window, click Sign-on, then pause the piece.


	Modify the Quiz design
	Design Question 1
	1 In the Presentation window, select only the text that reads Quiz, Question 1 and�delete it.
	2 Select the Quiz Navigation object and delete it.
	3 Drag the Previous Page and Next Page buttons to the lower right area of the Quiz Background.
	4 Move the Question 1 of 4 text to the lower right area of the Quiz Background, above the Previou...
	5 In the Presentation window, double-click the orange Quit button. In the Response Properties dia...
	6 In the Presentation window, drag the sizing handles on the Finish button to make the button lar...
	7 Drag the Finish button to the lower left edge of the quiz background.
	8 Select the lens graphic. Go to the modes palette and select Alpha. Drag the lens�graphic to rep...
	9 Double-click the question text. Using the Pointer tool, decrease the size of the margins and mo...

	Arrange choices and responses
	1 In the Presentation window, double-click the text A. Shutter.
	2 Control-Shift-click to select the three remaining choices. Drag the choices under the question,...
	3 Choose Control > Play and click the first choice in the Presentation window. Pause the piece.
	4 Double-click the feedback text that appears.
	5 Use the Pointer tool in the toolbox to decrease the margin size and to move the feedback text t...
	6 Choose Control > Play and click the second choice in the Presentation window.
	7 Verify that the positive feedback appears in the same area as the negative feedback, and click ...

	Design Question 2
	1 Double-click the camera lens graphic and select Alpha from the modes palette.�If necessary, rep...
	2 Double-click the question text. Use the Pointer tool to decrease the size of the margin and mov...
	3 Double-click True, then use Control-Shift-click to add the second False choice to the selection...
	4 Play the piece and click the second False choice. Double-click the response text and use the Po...
	5 Play the piece and click True. Verify that the response text appears in the correct location an...

	Design Question 3
	1 In the Presentation window, double-click the camera graphic. In the modes palette, select Alpha.
	2 Double-click the question text. Use the Pointer tool to decrease the size of the margin and to ...
	3 Choose Control > Play, and click the left side of the camera to click a hot spot that displays ...
	4 Taking care to not click over a hot spot, double-click the response text. Use the Pointer tool ...
	5 Play the piece and click the shutter release on the camera to verify that the positive response...

	Design Question 4
	1 In the Presentation window, double-click the question text. Use the Pointer tool to decrease th...
	2 Double-click A. Shutter speed, then use Control-Shift-click to select the remaining choices. Dr...
	3 Double-click the Check Answer button. In the Response Properties dialog box, click Buttons. In ...
	4 In the Presentation window, select just the Check Answer button and drag it underneath the choi...
	5 Choose Control > Play and click any of the choices to view the response text.
	6 Pause the piece, then double-click the response text to open the toolbox.
	7 Use the Pointer tool to resize the response text margin, and move the response text underneath ...
	8 Play the piece again, then select another choice. Click the Check Answer button, then pause the...

	Design the Finish response
	1 On the Quiz flowline, double-click the Finish map icon.
	2 On the Finish flowline, double-click the Are You Sure interaction icon.
	3 In the Presentation window, select the Finish background, then delete it.
	4 Place a start flag at the top of the Finish flowline, and restart the piece from�the�flag.
	5 Pause the piece. Select and delete the small black text that reads Finish (not the larger white...
	6 Double-click the Yes button. In the Response Properties dialog box, click Buttons and Choose th...
	7 Repeat step 6 to change the No button to a Standard Windows 3.1 System button.
	8 Choose Control > Play, and click No.

	Complete the quiz
	1 Restart your piece. After the introductory sequence, click Continue. On the Main Menu, click Ca...
	2 Log in, using the same name that you used before. You should bypass the sign�on message.
	3 Answer the four questions, then click the Next Page button to view the quiz�results.
	4 Choose Control > Pause and double-click the Quit button.
	5 In the Response Properties dialog box, click Buttons. Select the Standard Windows 3.1 System bu...
	6 Choose Control > Play and click Quit.


	Limit when a button is active
	Use an Active If condition
	1 On the level 1 flowline, double-click the Master Framework icon.
	2 On the Master Framework flowline, double-click the Menu response symbol.
	3 In the Response Properties dialog box, go to the Response tab. In the Active If text box, type ...

	Hide an inactive button
	1 In the Response properties dialog box, click the Button tab.
	2 Click Hide When Inactive, then click OK.


	View quiz data
	Publish your piece with one-button publishing
	Objectives
	View publish settings
	1 After saving your file, choose File > Publish > Publish Settings.
	2 The Publish for CD, LAN, Local HDD, and Publish for Web text boxes indicate where Authorware wi...
	3 Click the Package tab to see that Authorware, by default, packages external libraries and media...
	4 Click the Files tab to see the files Authorware will include in the published package, along wi...
	5 When you finish viewing the publish settings, click OK.

	Use one-button publishing
	1 Choose File > Publish > Publish.
	2 When the One Button Publishing Completed dialog box appears, click OK.
	3 To view your piece in a Web page, browse to your Tutorial folder within your Authorware 6 appli...
	4 Open the HTM file in a Web browser to play your published piece.

	The next steps

	Working with Authorware
	Good authoring practice
	Good authoring practice—step-by-step procedures
	What you can do
	In Authorware Help, see

	Troubleshooting methods
	Determine which section has the problem
	Think through the problem section
	Check the icon settings
	Figure out where the flow goes
	Check variables and functions
	Make changes one at a time
	Re-create the section

	Troubleshooting—step-by-step procedures
	What you can do
	In Authorware Help, see

	Setting up file structures
	File structures
	Default search path
	Specifying file locations
	See also

	User records
	Location of user records
	Changing the records folder
	Specifying where Authorware searches for files
	To specify where Authorware searches for files:
	1 Choose Modify > File > Properties.
	2 Click the Interaction tab.
	3 In the Search Path field, specify the location of external files.



	Distributing your piece
	Choosing a distribution medium
	Delivering on CD or disk
	Delivering across networks
	Using a combination of disk and network delivery
	Optimizing file size

	Packaging an Authorware piece
	Options for packaging a piece
	The Authorware run-time application
	Do two things before you package a piece:
	1 Make a copy of the piece. Once a piece is packaged, its structure can’t be examined and its med...
	2 Make sure you have all the additional files that the piece requires, such as Xtras and DLLs, an...


	Packaging libraries

	Packaging a piece—step-by-step procedures
	What you can do
	In Authorware 6 Help, see

	Getting a piece ready for the Web
	Getting ready for the Web—step-by-step procedures
	What you can do
	In Authorware Help, see


	Using one-button publishing to package a piece
	Setting up one-button publishing settings

	Determining which files you need to distribute
	Commands menu
	Adding your own commands to the Commands menu

	Working with Content
	Creating and incorporating content
	Using Xtras and OLE to include content

	Embedding and linking content
	Embedding and linking content—step-by- step procedures
	What you can do
	In Authorware Help, see

	Working with text
	Guidelines for creating and integrating text
	Creating and integrating text
	Making the most of text
	Controlling text with variables and functions
	Variable
	Description
	Function
	Description

	Text—step-by-step procedures
	What you can do
	In Authorware Help, see

	Using the RTF Objects Editor
	Definitions
	Features
	Opening the RTF Objects Editor
	To open the RTF Objects Editor:

	The RTF Objects Editor toolbar

	Managing files with the RTF Objects Editor
	Opening a new RTF document
	To open a new RTF document:
	1 Choose Commands > RTF Objects Editor.
	2 In the RTF Objects Editor, do one of the following:


	Opening an existing RTF document
	To open an existing RTF document:
	1 In the RTF Objects Editor, do one of the following:
	2 Select the file you want to open.


	Opening a database
	To open a Microsoft Access database:
	1 In the RTF Objects Editor, do one of the following:
	2 Select the MS Access Database MDB file you want to open.
	3 Highlight a table to select it.
	4 Select a reference field from the Reference Field section.
	5 Do one of the following:


	Opening a previously opened RTF document
	To open a previously opened RTF document:
	1 In the RTF Objects Editor, choose File > Reopen.
	2 Select the file you want to open.


	Saving an RTF document
	To save an RTF document, do one of the following in the RTF Objects Editor:

	Printing an RTF document
	To print an RTF document:
	1 In the RTF Objects Editor, do one of the following:
	2 Set the print options as desired.
	3 Click OK.


	Exiting the RTF Objects Editor
	To exit the RTF Objects Editor:
	1 In the RTF Objects Editor, do one of the following:
	2 If you have not previously saved your file, you are prompted to do so. Click Yes to save your f...



	Editing files with the RTF Objects Editor
	Undoing the last action
	To undo the last action, do one of the following in the RTF Objects Editor:

	Redoing the last action
	To redo the last action that you undid, do one of the following in the RTF Objects Editor:

	Deleting text or graphics
	To delete text or a graphic and save a copy to the Clipboard:
	1 In the RTF Objects Editor, select the text or graphic.
	2 Do one of the following:


	Copying text or graphics
	To copy text or a graphic to the Clipboard:
	1 In the RTF Objects Editor, select the text or graphic.
	2 Do one of the following:


	Pasting text or graphics
	To paste material on the Clipboard to a new location:
	1 In the RTF Objects Editor, select and cut or copy the text or graphic.
	2 Place the insertion point in the new location.
	3 Do one of the following:


	Using the Paste Special command
	To paste special text or formats:
	1 Select and cut or copy the text or graphic.
	2 Place the insertion point in the new location.
	3 In the RTF Objects Editor, choose Edit > Paste Special.
	4 Select one of the special options (depending on the source):
	5 Select other options as needed:
	6 Click OK.



	Searching for and replacing text in the RTF Objects Editor
	Searching for text
	To locate text in a document:
	1 In the RTF Objects Editor, place the insertion point at the place in the file where you want to...
	2 Select the text you want to find.
	3 Do one of the following:
	4 If you did not select text or want to find other text, type it in the text box.
	5 If you want, select the following options:
	6 Click Find Next to locate the next occurrence of the text in the direction you�selected.
	7 Continue clicking Find Next until you have found all the text you want, then click Cancel.
	8 To repeat the last Find or Search operation, choose Search > Search Again.


	Replacing text
	To replace text in a document:
	1 In the RTF Objects Editor, place the insertion point at the place in the file you want to begin...
	2 If you want, select the text you want to replace.
	3 Choose Search > Replace.
	4 If you did not select text or you want to find other text, type it in the text box.
	5 In the Replace With text box, enter the text you want to substitute for the found text.
	6 If you want, select the following options:
	7 Do one of the following:
	8 Continue clicking the desired buttons until you have replaced all the text you want, then click...
	9 To repeat the last Find or Search operation, choose Search > Search Again.



	Changing view options in the RTF Objects Editor
	To change the display of toolbars:
	1 In the RTF Objects Editor, choose View.
	2 Click each toolbar to select or deselect it, until you have selected the toolbars you want to d...


	Inserting files and graphics using the RTF Objects Editor
	Inserting a file or image into an RTF document
	To insert a file or image in an RTF document:
	1 Use the RTF Objects Editor to open a file.
	2 In the open RTF document, place the insertion point at the location where you want to insert th...
	3 If you are inserting a file, choose Insert > File or click the Insert File button on the toolbar.
	4 Select the type of file you want to insert.
	5 Select the path and name of the file.
	6 Select one of the following options:
	7 If you selected Link File in step 5, select a path option:
	8 If you are inserting an image, select the Image Preview option you want to use to review the file:
	9 Click OK to insert the file or image.


	Inserting a shape in an RTF document
	To insert a shape in an RTF document:
	1 Use the RTF Objects Editor to open an RTF document, or start a new file.
	2 Place the insertion point at the location where you want to insert the shape.
	3 Choose Insert > Shape or click the Insert Shape button on the toolbar.
	4 Select the shape you want to insert.
	5 Change the Inside Brush settings as needed to determine the fill for the shape.
	6 Change the Outside Border settings as needed to determine the color, line width, and line style...
	7 Click OK.


	Inserting a symbol in an RTF document
	To insert a symbol in an RTF document:
	1 Use the RTF Objects Editor to open an RTF document.
	2 Place the insertion point at the location where you want to insert the symbol.
	3 Choose Insert > Symbol or click the Insert Symbol button on the toolbar.
	4 Change the font as needed.
	5 Click the symbol, then click OK to insert it.


	Inserting a hyperlink (hot text) in an RTF document
	To insert a hyperlink in an RTF document:
	1 Use the RTF Objects Editor to open an RTF document.
	2 Place the insertion point at the location where you want to insert the hyperlink.
	3 Choose Insert > Hot Text or click the Insert Hot Text button on the toolbar.
	4 In the LinkText field, enter the text for the hyperlink. For example, if you want the user to c...
	5 In the Link Code field, enter the link code or icon title. For example, if you want to link to ...
	6 Select Underline Hot Text if you would like the hot text underlined.
	7 Click OK.
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